knetworkmanager "no network device found" if wired connection plugged in before starting

Bug #50770 reported by Kenny Duffus on 2006-06-23
20
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Medium
Unassigned

Bug Description

knetworkmanager complains "no network device found" if you already have a wired connection before it starts

/etc/network/interfaces is empty apart from lo

Please see also bug #77557.

Jonathan Jesse (jjesse) wrote :

I was not able to reproduce this bug. What version of knetworkmanager are you using? Are you still having this problem?

More information would be great.

Thanks,

Jonathan

Kenny Duffus (kduffus) wrote :

this appears fixed in current edgy (was originally detected in dapper)

Changed in knetworkmanager:
importance: Untriaged → Medium
status: Unconfirmed → Fix Released
Kenny Duffus (kduffus) wrote :

ok, not fixed I still get it on a laptop, but it seems to make a difference whether knetworkmanager was started automatically in the seesion or run later

Changed in knetworkmanager:
status: Fix Released → Unconfirmed
GeekSmith (lixo-geeksmith) wrote :

I've seen this inconsistently in both Dapper and Edgy when I ran knetworkmanager as a normal user. It always worked when I ran it using kdesu. When started as a normal user from the command line it shows this error:
Error requesting name, org.freedesktop.DBus.Error.AccessDenied: Connection ":1.6" is not allowed to own the service "org.freedesktop.NetworkManagerInfo" due to security policies in the configuration file

So, I added this:
<policy user="|my_username|">
   <allow own="org.freedesktop.NetworkManagerInfo"/>
   <allow send_destination="org.freedesktop.NetworkManagerInfo"/>
   <allow send_interface="org.freedesktop.NetworkManagerInfo"/>
</policy>

to the following files:
/etc/dbus-1/system.d/knetworkmanager.conf
/etc/dbus-1/system.d/NetworkManager.conf

and it works every time now. A less restrictive default policy might clear this up for everybody.

@@ron Smith
http://geeksmith.blogspot.com/

Jonathan Jesse (jjesse) wrote :

Hello,

I have knetworkmanager running on my laptop w/o any problems installed on an Edgy box. I did not have to make the suggested changes, in fact I didn't make any changes.

Jonathan

GeekSmith (lixo-geeksmith) wrote :

Don't know if this makes a difference, but I'm running fluxbox instead of a full KDE environment.

Veysel Harun Sahin (harunsahin) wrote :

Hi,

I too live the same problem on Feisty Fawn Herd 4 box. But my problem does not related to user permissions. I also have some problems with the default gateway setting. It sometimes defaults to 0.0.0 and gives error. I am still trying to understand what causes the problem.

Terrenius (terrenius) wrote :

I have the same problem. In fact it can't detect my wireless or my network card. I'm running herd 5 and the install is almost completely pristine. I did do a update & upgrade, but the problem existed before. It doesn't detect my adapters, even though when I go into the network settings, they're both there and functioning fine. What's really bizarre is that it used to work completely and now doesn't work completely. I say nix this package and find something else.

I can confirm this bug after a fresh Kubuntu Feisty beta install. Although I saw the security error mentioned above when starting KNetworkManager from the console, fixing the permissions in the security policy files didn't help.

KNetworkManager works when it is started as root with kdesu.

Richard Johnson (nixternal) wrote :

Confirming due to responses.

Changed in knetworkmanager:
status: Unconfirmed → Confirmed
Jonathan Jesse (jjesse) wrote :

Good mroning,

When I start my laptop up with a cable connected to it, I have no problems with KnetworkManager. I am running the latest version of Fiesty completly up to date as of this molrning.

Are others still having a problem or am I mis understaind it?

GeekSmith (lixo-geeksmith) wrote :

I am now running Feisty, a fresh install on 3 systems, and I have not had this problem. I only saw the problem on one system: a Dell D610 with the Intel 2915 ABG WLAN adapter.

Jonathan Jesse (jjesse) wrote :

Can others that are running on Feisty confirm this bug is solved?

i think so.

Changed in knetworkmanager:
status: Confirmed → Fix Released

I'm seeing this again on Gutsy. Replugging the LAN cable makes my Broadcom Corporation NetXtreme BCM5755M Gigabit Ethernet PCI Express (rev 02) appear, before that, knetworkmanager only sees my IPW3945 (with which it deals just fine). After replugging I can hit select the wired device and will get connected via it.

Happens again, in Gutsy (that is knetworkmanager 0.2).

Changed in knetworkmanager:
status: Fix Released → Confirmed

I see the same problem with Gutsy, running on an Thinkpad T61p.

I was wrong, it still happens, but for some reason it doesn't seem to happen
each and every time, just upon most boots.

Tyler Mitchell (fission) wrote :

I'm seeing this as well on Feisty. Adding my username to:
 /etc/dbus-1/system.d/knetworkmanager.conf
 /etc/dbus-1/system.d/NetworkManager.conf
did correct the problem.

However, this was all working before. In bug #77557, someone mentioned that using knetworkconf could have caused the problem, but my /etc/network/interfaces file is the same as my working computer.

I assume that the line
        <policy at_console="true">
should permit me to connect. My guess is that dbus (or whatever) can't tell that I'm at the console, which is why I'm being refused access. Does that sound reasonable?

Tyler Mitchell (fission) on 2007-10-08
description: updated
Tyler Mitchell (fission) wrote :

To answer my own question: yes, dbus couldn't tell that I was at the console, due to incorrect permissions on
    /var/run/console
It should look like:
    % ls -ld /var/run/console
    drwxr-xr-x 2 root fission 60 2007-10-08 14:17 /var/run/console

Looks like it's fixed in Gutsy now?

It works for me in gutsy now.

Changed in knetworkmanager:
status: Confirmed → Fix Released
Marius Groenewald (groenem) wrote :

I did a upgrade from Feisty to Gutsy, but it was interrupted just before it reached the final stages, and now my knetworkmanager also is not working, giving me the "No network device found" message. Are there any files I can download manually and install to rectify this problem? I can't use Adept Manager, of course, so I have to download the file from a different PC connected to the internet.

In the KDE Control Module, under the Network Interfaces tab, I Disabled my network interface and then Enabled it, but it just hangs while trying to Enable.

Jamie (solowinter) wrote :

Same issue as Marius in upgrading a laptop for a friend. I don't recall having anything remotely like this problem with I upgraded to Gusty during beta release. When I try to run "/etc/init.d/networking restart" I get:

"Ignoring unknown interface eth0=eth0..."

Benjamin Tayehanpour (konaya) wrote :

The workaround posted by GeekSmith works. However, I think this is a more elegant (and, possibly, _the_) solution:

One of the two files mentioned contains this section:
<policy group="netdev">
   <allow own="org.freedesktop.NetworkManagerInfo"/>
   <allow send_destination="org.freedesktop.NetworkManager"/>
   <allow send_interface="org.freedesktop.NetworkManager"/>
</policy>

However, the equivalent in the other file is:
<policy group="netdev">
   <allow send_destination="org.freedesktop.NetworkManager"/>
   <allow send_interface="org.freedesktop.NetworkManager"/>
</policy>

Adding the missing line to the second file, and of course adding my user name to the netdev group, solved the problem for me. Group policies are "better" than individual user policies, right?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers