Change log for knights package in Ubuntu

124 of 24 results
Published in disco-release on 2019-03-07
Deleted in disco-proposed (Reason: moved to release)
knights (18.12.3-0ubuntu1) disco; urgency=medium

  * New upstream release (18.12.3)

 -- Rik Mills <email address hidden>  Thu, 07 Mar 2019 13:30:45 +0000
Superseded in disco-release on 2019-03-07
Deleted in disco-proposed on 2019-03-08 (Reason: moved to release)
knights (18.12.2-0ubuntu1) disco; urgency=medium

  * New upstream release (18.12.1)
  * New upstream release (18.12.2)

 -- Rik Mills <email address hidden>  Thu, 21 Feb 2019 12:11:49 +0000
Superseded in disco-release on 2019-02-21
Deleted in disco-proposed on 2019-02-22 (Reason: moved to release)
knights (18.12.0-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Switch the watch file to stable releases, now that there are.

 -- Pino Toscano <email address hidden>  Mon, 17 Dec 2018 13:30:39 +0100

Available diffs

Superseded in disco-release on 2018-12-17
Deleted in disco-proposed on 2018-12-18 (Reason: moved to release)
knights (18.11.90-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Make sure to use the kf5 buildsystem when invoking dh_auto_configure.

 -- Pino Toscano <email address hidden>  Fri, 30 Nov 2018 22:38:19 +0100

Available diffs

Superseded in disco-release on 2018-12-01
Deleted in disco-proposed on 2018-12-02 (Reason: moved to release)
knights (18.11.80-1) unstable; urgency=medium

  * Team upload.
  * New upstream development release: (Closes: #874962) (LP: #1757703)
    - now part of KDE Applications, so adopt its versioning
  * Switch Vcs-* fields to salsa.debian.org.
  * Remove knights-dbg in favour of the -dbgsym package
    - stop forcing --destdir for dh_auto_install, as there is only one binary
      now
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
    - remove --parallel for dh, as now done by default
  * Drop the Debian-provided knights man page, as knights does not really have
    command line options.
  * Remove trailing whitespaces in changelog, and control.
  * Remove empty line at the end of changelog.
  * Bump Standards-Version to 4.2.1, no changes required.
  * Add a watch file.
  * Add the upstream GPG signing key.
  * Update the build dependencies following the port to Frameworks:
    - remove kdelibs5-dev, and libkdegames-dev
    - add extra-cmake-modules, qtbase5-dev, libqt5svg5-dev,
      libqt5texttospeech5-dev, libkf5configwidgets-dev, libkf5crash-dev,
      libkf5dbusaddons-dev, libkf5doctools-dev, libkf5kio-dev, libkf5plasma-dev,
      libkf5plotting-dev, libkf5textwidgets-dev, libkf5xmlgui-dev,
      libkf5wallet-dev, and libkf5kdegames-dev
  * Use the right dh addon:
    - switch from kde to kf5 dh addon
    - bump the pkg-kde-tools build dependency to >= 0.15.16
  * Switch cmake parameter BIN_INSTALL_DIR to KDE_INSTALL_BINDIR, as the former
    is deprecated.
  * Switch the Homepage to kde.org.
  * Switch Maintainer to Debian Qt/KDE Maintainers.
  * Bump the cmake build dependency to >= 3.2.0, as indicated by the upstream
    build system.

 -- Pino Toscano <email address hidden>  Fri, 23 Nov 2018 22:20:19 +0100
Superseded in disco-release on 2018-11-24
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-04
Deleted in bionic-proposed (Reason: moved to release)
knights (2.5.0-2build1) bionic; urgency=high

  * No change rebuild to pick up -fPIE compiler default

 -- Balint Reczey <email address hidden>  Tue, 03 Apr 2018 12:31:13 +0000
Superseded in bionic-release on 2018-04-04
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-11-29
Deleted in xenial-proposed (Reason: moved to release)
knights (2.5.0-2) unstable; urgency=medium

  * Team upload.
  * Fix typo in the description of knights-dbg. (Closes: #724819)
  * Remove menu file and its pixmap, as knights already provides a desktop
    file.
  * Migrate to the dh sequencer:
    - use the dh sequencer in rules, using the kde addon, with parallel build,
      and in as-needed mode
    - drop the cdbs build dependency
  * Bump Standards-Version to 3.9.6, no changes required.
  * Explicitly install to debian/knights, instead of the default debian/tmp
    followed by moves by dh_install.

 -- Pino Toscano <email address hidden>  Sun, 29 Nov 2015 12:45:20 +0100
Superseded in xenial-release on 2015-11-29
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
knights (2.5.0-1build1) utopic; urgency=medium

  * No change rebuild for libkdegames transition
 -- Scott Kitterman <email address hidden>   Tue, 24 Jun 2014 00:10:07 -0400
Superseded in utopic-release on 2014-06-24
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
knights (2.5.0-1) unstable; urgency=low


  * Team upload.
  * New upstream release.
  * Update knights.xpm.
  * Bump the kdelibs5-dev and libkdegames-dev build dependencies to 4.9,
    as required upstream.
  * Update Vcs-* headers.
  * Bump Standards-Version to 3.9.4, no changes required.

 -- Pino Toscano <email address hidden>  Sat, 20 Jul 2013 16:35:21 +0200
Superseded in saucy-release on 2013-07-23
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
knights (2.5.0-0ubuntu1) quantal; urgency=low

  * New upstream release:
    - Drop load_right_default_theme.diff, superceeded by upstream
    - Bump build-depend version of libkdegames-dev to >> 4.9
 -- Jonathan Thomas <email address hidden>   Wed, 15 Aug 2012 20:31:40 -0400

Available diffs

Superseded in quantal-release on 2012-08-16
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
knights (2.3.2-1build1) oneiric; urgency=low

  * Rebuild for libkdegames5a transition.
 -- Felix Geyer <email address hidden>   Wed, 08 Jun 2011 12:49:48 +0200

Available diffs

Superseded in oneiric-release on 2011-06-08
knights (2.3.2-1) unstable; urgency=low

  * New upstream release.
  * Add load_right_default_theme.diff to prevent issues when you have configured
    a theme that doesn't exist (may happen easily with obsolete themes).

Available diffs

Superseded in oneiric-release on 2011-05-31
knights (2.3.1-1) unstable; urgency=low

  * New upstream release.
  * Update patches:
    - Remove 03_dont_crash_fics.diff, no longer needed.
    - Remove 04_stop_clock_game_over.diff, no longer needed.
  * Add sjeng to Suggests.
  * Add crafty to Suggests.

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
knights (2.0.1-2) unstable; urgency=low

  * Upload to unstable. (Closes: #604334, #591562, #528348, #366183)
  * Point debian/control Vcs fields to the new Git repository.
  * Bump Standards-Version to 3.9.1, no changes needed.
  * Move manpage to section 6 since this software is a game.

Available diffs

Deleted in jaunty-release on 2013-02-27 (Reason: needs KDE 3)
Obsolete in intrepid-release on 2013-02-20
knights (0.6-8.2ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/kubuntu_01_fix_castle.diff
    - Changed homepage and redid for new Debian spec.
    - Added Original-Maintainer as per Ubuntu spec.
    - debian/rules: Removed config.{sub,guess}.
    - debian/rules: added dh_icons.

 -- Andreas Wenning <email address hidden>   Tue, 03 Jun 2008 21:43:51 +0200

Available diffs

Superseded in intrepid-release on 2008-06-03
Obsolete in hardy-release on 2015-04-24
knights (0.6-8ubuntu3) hardy; urgency=low

  * debian/rules: changed dh_iconcache to dh_icons - fixes build.

 -- Jonathan Patrick Davies <email address hidden>   Thu, 6 Dec 2007 23:36:10 +0100
Superseded in hardy-release on 2007-12-06
knights (0.6-8ubuntu2) hardy; urgency=low

  * Correct maintainer email.

 -- Jonathan Patrick Davies <email address hidden>   Fri, 26 Oct 2007 20:36:30 +0200
Superseded in hardy-release on 2007-10-26
knights (0.6-8ubuntu1) hardy; urgency=low

  * Merge from debian unstable. Remaining Ubuntu changes:
    - debian/kubuntu_01_fix_castle.diff
    - Changed homepage and redid for new Debian spec.
    - Added Original-Maintainer as per Ubuntu spec.
  * debian/rules: Removed config.{sub,guess}.

Superseded in hardy-release on 2007-10-26
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
knights (0.6-7.1ubuntu2) feisty; urgency=low

  * Automated backport by prevu. No source changes
  * Fixed if in rules to work properly

 -- Martin Meredith <email address hidden>   Wed,  8 Nov 2006 18:12:43 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
knights (0.6-7.1ubuntu1) edgy; urgency=low

  * Sync from debian unstable
  * Added dh_iconcache

Superseded in edgy-release on 2006-08-30
knights (0.6-7ubuntu1) edgy; urgency=low

  * Merge from debian unstable.

Superseded in edgy-release on 2006-07-06
Obsolete in dapper-release on 2011-09-06
knights (0.6-6ubuntu1) dapper; urgency=low

  * Added dh_iconcache

 -- Sarah Hobbs <email address hidden>   Sat, 13 May 2006 21:43:18 +1000
Superseded in dapper-release on 2006-05-13
Superseded in dapper-release on 2006-02-03
knights (0.6-6) unstable; urgency=low


  * Rebuild against kdelibs4c2a. (Closes: #338269)
  * debian/control: build-depends on specific libraries instead of xlibs-dev.

 -- Tommaso Moroni <email address hidden>  Sun,  4 Dec 2005 11:55:42 +0100
Obsolete in breezy-release on 2008-03-25
knights (0.6-3build1) breezy; urgency=low


  * Rebuild for new C++ ABI

 -- Matthias Klose <email address hidden>  Mon,  6 Jun 2005 16:36:59 +0000
124 of 24 results