Kopete 0.12.3 can't log in to ICQ anymore

Bug #69494 reported by Robert Penz on 2006-10-31
12
Affects Status Importance Assigned to Milestone
Kopete
Fix Released
Medium
kopete (Ubuntu)
Undecided
Frode M. Døving

Bug Description

Binary package hint: kopete

I'm reporting this for Kubuntu 6.06 KDE 3.5.5 packages.

Since today Kopete 0.12.3 can't log in to ICQ anymore. The problem occurs not for all distributions. According to discussions in the kopete irc channel it happens sofar only for Kubuntu and Geentoo, but not Debian SID/FC6. Maybe that changes

In the debug log you see following:

kutils (KSettings::Dispatcher): [static KSettings::Dispatcher* KSettings::Dispatcher::self()]
kutils (KSettings::Dispatcher): [void KSettings::Dispatcher::registerInstance(KInstance*, QObject*, const char*)] kopete
kdecore (KNetwork resolver): shouldResInit: /etc/resolv.conf updated
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline

See http://bugs.kde.org/show_bug.cgi?id=136566 for more information.

The StableReleaseUpdates request is in bug 69583.

Robert Penz (robert-penz-name) wrote :

A fix has been provided is reported to work.

SVN commit 600778 by rjarosz:

Fix bug 136566: Connecting to ICQ doesn't work anymore.

OSCAR server stops sending own user info at logon, we have to send own user info request like ICQ5.

BUG: 136566

 M +1 -0 client.cpp

--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/client.cpp #600777:600778
 @ -340,6 +340,7 @
                //we've finished logging in. start the services setup
                kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
                initializeStaticTasks();
+ d->ownStatusTask->go();
                ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
                connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
                ssTask->go( true ); //fire and forget

Frode M. Døving (frode) wrote :

Confirmed on edgy.

Changed in kopete:
status: Unconfirmed → Confirmed
Robert Penz (robert-penz-name) wrote :

As Info:

Frode M. Doeving is working on new packages and says he will have someone upload it to edgy-updates once it's opened. (just got the info from him)

I asked him also about the kde 3.5.5 dapper packages and he said following: they are much about the same. I'll try to get kubuntu.org updated too. I'll tell you when I have something you can test.

Robert Penz (robert-penz-name) wrote :

Fixed Dapper are available under:

http://ubuntu.lnix.net/misc/kopete-fix/

(the edgy ones are just being compiled)

BIG thx to Frode M. Doeving !!!

Robert Penz (robert-penz-name) wrote :

ah the above Dapper package is for KDE 3.5.5

strangely enough, i cant reproduce this, which is why i didnt research into it last night.

it seems a different fix to usual too.

Glad it's fixed though

Changed in kopete:
status: Unknown → Fix Released
Frode M. Døving (frode) wrote :

Dapper 3.5.2 packages available at: http://ubuntu.lnix.net/misc/kopete-fix/kdenetwork-dapper/

You will only need the kopete package.
Please test and give me feedback on this.

Robert Penz (robert-penz-name) wrote :

According to this SVN patch the above fix works only if you set kopete to online but not if you choose e.g.away.

SVN commit 600976 by rjarosz:

Fix bug when going online with any other status than online i.e. away, n/a... Kopete indicates the account as online.
The status on a server is correct.

Reported by Jan Ritzerfeld, thanks.
Please test it.

CCBUG: 136566

 M +4 -2 liboscar/client.cpp
 M +1 -1 oscaraccount.cpp

--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/client.cpp #600975:600976
 @ -340,7 +340,6 @
                //we've finished logging in. start the services setup
                kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "stage two done. setting up services" << endl;
                initializeStaticTasks();
- d->ownStatusTask->go();
                ServiceSetupTask* ssTask = new ServiceSetupTask( d->connections.defaultConnection()->rootTask() );
                connect( ssTask, SIGNAL( finished() ), this, SLOT( serviceSetupFinished() ) );
                ssTask->go( true ); //fire and forget
 @ -398,9 +397,12 @
        d->active = true;

        if ( isIcq() )
- {
                setStatus( d->connectAsStatus, d->connectWithMessage );

+ d->ownStatusTask->go();
+
+ if ( isIcq() )
+ {
                //retrieve offline messages
                Connection* c = d->connections.connectionForFamily( 0x0015 );
                if ( !c )
--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/oscaraccount.cpp #600975:600976
 @ -560,7 +560,7 @
        /* We're not even online or connecting
         * (when getting server contacts), so don't bother
         */
- if ( !myself()->isOnline() )
+ if ( !engine()->isActive() )
        {
                kdDebug(OSCAR_GEN_DEBUG) << k_funcinfo << "Can't add contact, we are offline!" << endl;
                return false;

Frode M. Døving (frode) wrote :

New fix added to packages.
Packages for testing can be found at: http://ubuntu.lnix.net/misc/kopete-fix/

Please give me feedback.
Especially if you can test the kdenetwork-dapper ones.
(Also test other protocols if you can, it's a old kopete).

Robert Penz (robert-penz-name) wrote :

The dapper kde 3.5.5 package works.

Kurt Huwig (k-huwig) wrote :

The edgy package works.

Juho Lehto (keeperb5) wrote :

Edgy fix works here too.

ma2412ma (ma2412ma) wrote :

When can we expect that the corrected version of Kopete gets into some official repository? It's pretty annoying not being able to use ICQ although there is a solution available - see also http://bugs.kde.org/show_bug.cgi?id=136566.

Timm (gummibaerchen) wrote :

Please put it in the official Repo.

Seems like my Kwallet doesn't like the "new" Kopete!

Thanks

Timm (gummibaerchen) wrote :

> Seems like my Kwallet doesn't like the "new" Kopete!

That was a problem with KWallet (you must close it befor shutting down).

Changed in kopete:
status: Confirmed → Fix Committed
Simon Law (sfllaw) wrote :

In order for this fix to get into Edgy, you must follow the https://wiki.ubuntu.com/StableReleaseUpdates policy. Please start by proposing this change properly:

1. Propose

All proposals for stable release updates must be approved by Matt Zimmerman or Colin Watson. A convenient way to do this is to attach all of the information to the existing bug report, use Backport fix to releases to mark the bug for backporting, then subscribe the ubuntu-sru team. If more than one bug is being addressed, it is better to file a bug to track the SRU itself and refer to all of the relevant bugs. SRU proposals must be accompanied by the following information for each bug to be addressed:

- A bug number referring to a complete bug report describing the problem and its effect

- A statement explaining the impact of the bug on users and justification for backporting the fix to the stable release

- An explanation of how the bug has been addressed in the development branch, including the relevant version numbers of packages modified in order to implement the fix

- A patch applicable to the stable version of the package. If preparing a patch is likely to be time-consuming, it may be preferable to discuss the first three items before preparing a patch.

- A copy of this proposal and a hyperlink to any prior discussion thread should be added to the bug report as a comment, usually by CCing <email address hidden>.

Thanks.

the debdiff was in fdoving's repository.

Simon Law (sfllaw) on 2006-11-30
description: updated
Frode M. Døving (frode) wrote :

SRU bug report for this is https://launchpad.net/distros/ubuntu/+source/kopete/+bug/69583

In the future the 'Backport Fix To Releases' feature of launchpad should be used.

Ref: https://launchpad.net/distros/ubuntu/+source/kdepim/+bug/73225/comments/3

- Frode

Changed in kopete:
assignee: nobody → frode
Frode M. Døving (frode) wrote :

Fix accepted into edgy-updates.
Already fixed in feisty.

Changed in kopete:
status: Fix Committed → Fix Released
Changed in kopete:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.