Ubuntu

SRU: kopete can't connect to ICQ.

Reported by Frode M. Døving on 2006-10-31
18
Affects Status Importance Assigned to Milestone
kopete (Ubuntu)
Low
Frode M. Døving

Bug Description

Binary package hint: kopete

Since today (2006-10-31) Kopete 0.12.3 can't log in to ICQ anymore.

Original Bug: https://launchpad.net/distros/ubuntu/+source/kopete/+bug/69494
KDE Bug: http://bugs.kde.org/show_bug.cgi?id=136566

Requesting SRU as this affects many Kubuntu users.
I consider not beeing able to login to ICQ a severe regression if not updated.

Frode M. Døving (frode) wrote :

Patch applied to package.

Frode M. Døving (frode) wrote :

Fixed packages for edgy available at: http://ubuntu.lnix.net/misc/kopete-fix/kopete-edgy/

Matt Zimmerman (mdz) wrote :

Patch is OK for -proposed, please include a more appropriate changelog entry as requested on IRC (describe what the patch does)

Frode M. Døving (frode) wrote :

New debdiff with edited changelog entry.

Matt Zimmerman (mdz) wrote :

Thank you; upload approved for -proposed

Brandon Holtsclaw (imbrandon) wrote :

Sponsoring this upload to -proposed and subscribing to the package

Changed in kopete:
importance: Undecided → Low
status: Unconfirmed → Fix Committed
Frode M. Døving (frode) wrote :

DAPPER:
I've prepared a patch and a debdiff to the kdenetwork packages.
patch and debdiff attached.

Matt Zimmerman (mdz) wrote :

changelog needs to target -proposed, not -updates

Frode M. Døving (frode) wrote :

Sorry about that.
Fixed in proposed.debdiff

Frode M. Døving (frode) wrote :

Upstream has changed the fix.
The implemented fix only allows you to connect with status 'Online'. (You can however change to any status after the initial connection.)

The new revision allows you to make the initial connection with for example 'Away' status too.

More info: http://bugs.kde.org/show_bug.cgi?id=136566#c37

Will add debdiff as soon as I've tested the new fix myself.

Frode M. Døving (frode) wrote :

We will have to open a new SRU for dapper, as fixing the kopete in dapper-main is not as stright forward. (icq has been broken for some time, needs more fixes)
Backporting this fix to dapper-backports will be stright forward though.

I'm running edgy-eft (kopete 0.12.3) and I'm unable to use ICQ for about a week! Will there be a fix available soon?

Andres Mujica (andres.mujica) wrote :

Hi there,

why this bug is not marked as duplicate of 69494

https://launchpad.net/distros/ubuntu/+source/kopete/+bug/69494

can we mark it as dup??

Frode M. Døving (frode) on 2006-11-15
description: updated
Jonathan Riddell (jr) wrote :

Debdiff in comment of Frode M. Døving at 2006-11-01 23:23:04 GMT looks good. Will upload when approved by ubuntu-sru

Matt Zimmerman (mdz) wrote :

It was already approved for -proposed; see earlier comments

Colin Watson (cjwatson) wrote :

Rejected kopete 4:3.5.5+kopete0.12.3-0ubuntu3; please reupload with a version number that doesn't clash with uploads to other Ubuntu releases.

Frode M. Døving (frode) wrote :

4:3.5.5+kopete0.12.3-0ubuntu2.1 uploaded.

Frode M. Døving (frode) on 2006-11-30
Changed in kopete:
assignee: nobody → frode
Frode M. Døving (frode) wrote :

Latest debdiff.
Changes from:
kopete_3.5.5+kopete0.12.3-0ubuntu1 (edgy)
to:
kopete_3.5.5+kopete0.12.3-0ubuntu2.1 (proposed update)

Changed in kopete:
status: Fix Committed → In Progress
Colin Watson (cjwatson) wrote :

Latest debdiff also approved for edgy-proposed.

Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed, please notify Simon Law and solicit testing as per https://wiki.ubuntu.com/StableReleaseUpdates

Changed in kopete:
status: In Progress → Fix Committed
Frode M. Døving (frode) wrote :
Tom Shaw (firephoto) wrote :

Updated from edgy-proposed, kopete_3.5.5+kopete0.12.3-0ubuntu2.1_i386, icq logs on/off fine and logs on as any status ok.

Martin Böhm (martin.bohm) wrote :

Tested on i386, ICQ login works fine with "Online". However, when I try logging in with a different status, for instance "Invisible" and "Away", it first informs me in the chat window that I'm "Online" and only after that it reports that I'm "Away" and "Invisible". It seems though that it's not a big problem as the friend who watched my status on the other end reported that I was "Invisible" all the time.

Simon Law (sfllaw) wrote :

I was able to reproduce the bug and confirm that ICQ now works with the latest patch.

I only tested for regressions in ICQ messaging and not in any of the other plugins.

Approved for upload to edgy-updates on the 11th.

Jonathan Riddell (jr) wrote :

Uploaded to edgy-updates.

Frode M. Døving (frode) wrote :

I'm already a kopete bug contact.
Monitoring for bugs related to the update.

Tollef Fog Heen (tfheen) wrote :

Fix accepted into -updates.

Changed in kopete:
status: Fix Committed → Fix Released
Frode M. Døving (frode) wrote :

7 days since release.
No bugs related to this fix reported to launchpad.

SRU completed.

To post a comment you must log in.