krb5 1.13.2+dfsg-2ubuntu0.1 source package in Ubuntu

Changelog

krb5 (1.13.2+dfsg-2ubuntu0.1) wily-security; urgency=medium

  * SECURITY UPDATE: SPNEGO context aliasing bugs
    - d/p/u/0011-Fix-SPNEGO-context-aliasing-bugs-CVE-2015-2695.patch:
      improve logic in src/lib/gssapi/spnego/gssapiP_spnego.h,
      src/lib/gssapi/spnego/spnego_mech.c.
    - d/p/u/0016-Fix-SPNEGO-context-import.patch: fix SPNEGO context import
      in src/lib/gssapi/spnego/spnego_mech.c.
    - CVE-2015-2695
  * SECURITY UPDATE: IAKERB context aliasing bugs
    - d/p/u/0012-Fix-IAKERB-context-aliasing-bugs-CVE-2015-2696.patch:
      improve logic in src/lib/gssapi/krb5/gssapiP_krb5.h,
      src/lib/gssapi/krb5/gssapi_krb5.c, src/lib/gssapi/krb5/iakerb.c.
    - d/p/u/0014-Fix-two-IAKERB-comments.patch: fix comments in
      src/lib/gssapi/krb5/iakerb.c.
    - CVE-2015-2696
  * SECURITY UPDATE: KDC crash via invalid string processing
    - d/p/u/0013-Fix-build_principal-memory-bug-CVE-2015-2697.patch:
      use k5memdup0() instead of strdup() in src/lib/krb5/krb/bld_princ.c.
    - CVE-2015-2697
  * SECURITY UPDATE: memory corruption in IAKERB context export/import
    - d/p/u/0015-Fix-IAKERB-context-export-import-CVE-2015-2698.patch:
      dereferencing the context_handle pointer before casting it in
      and implement implement an IAKERB gss_import_sec_context() function
      in src/lib/gssapi/krb5/gssapiP_krb5.h,
      src/lib/gssapi/krb5/gssapi_krb5.c, src/lib/gssapi/krb5/iakerb.c.
    - CVE-2015-2698

 -- Marc Deslauriers <email address hidden>  Wed, 11 Nov 2015 08:36:55 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2015-11-11
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
krb5_1.13.2+dfsg.orig.tar.gz 11.3 MiB a7af3953e4ab52b17f80bdfc2fc7471b66b512b128520796e2b993554543873a
krb5_1.13.2+dfsg-2ubuntu0.1.debian.tar.xz 96.9 KiB 4cfa67cf186ebd5d1c3efcd0bf11402ad13568a74193c72f1301191fdb7c870f
krb5_1.13.2+dfsg-2ubuntu0.1.dsc 3.4 KiB 096a6480f7df337a2311c86cc96afdf620eae0b0415ddbbf10d1abf35da715d2

View changes file

Binary packages built by this source

krb5-admin-server: No summary available for krb5-admin-server in ubuntu wily.

No description available for krb5-admin-server in ubuntu wily.

krb5-admin-server-dbgsym: No summary available for krb5-admin-server-dbgsym in ubuntu wily.

No description available for krb5-admin-server-dbgsym in ubuntu wily.

krb5-doc: No summary available for krb5-doc in ubuntu wily.

No description available for krb5-doc in ubuntu wily.

krb5-gss-samples: No summary available for krb5-gss-samples in ubuntu wily.

No description available for krb5-gss-samples in ubuntu wily.

krb5-gss-samples-dbgsym: No summary available for krb5-gss-samples-dbgsym in ubuntu wily.

No description available for krb5-gss-samples-dbgsym in ubuntu wily.

krb5-k5tls: No summary available for krb5-k5tls in ubuntu wily.

No description available for krb5-k5tls in ubuntu wily.

krb5-k5tls-dbgsym: No summary available for krb5-k5tls-dbgsym in ubuntu wily.

No description available for krb5-k5tls-dbgsym in ubuntu wily.

krb5-kdc: No summary available for krb5-kdc in ubuntu wily.

No description available for krb5-kdc in ubuntu wily.

krb5-kdc-dbgsym: No summary available for krb5-kdc-dbgsym in ubuntu wily.

No description available for krb5-kdc-dbgsym in ubuntu wily.

krb5-kdc-ldap: No summary available for krb5-kdc-ldap in ubuntu wily.

No description available for krb5-kdc-ldap in ubuntu wily.

krb5-kdc-ldap-dbgsym: No summary available for krb5-kdc-ldap-dbgsym in ubuntu wily.

No description available for krb5-kdc-ldap-dbgsym in ubuntu wily.

krb5-locales: No summary available for krb5-locales in ubuntu wily.

No description available for krb5-locales in ubuntu wily.

krb5-multidev: No summary available for krb5-multidev in ubuntu wily.

No description available for krb5-multidev in ubuntu wily.

krb5-multidev-dbgsym: No summary available for krb5-multidev-dbgsym in ubuntu wily.

No description available for krb5-multidev-dbgsym in ubuntu wily.

krb5-otp: No summary available for krb5-otp in ubuntu wily.

No description available for krb5-otp in ubuntu wily.

krb5-otp-dbgsym: No summary available for krb5-otp-dbgsym in ubuntu wily.

No description available for krb5-otp-dbgsym in ubuntu wily.

krb5-pkinit: No summary available for krb5-pkinit in ubuntu wily.

No description available for krb5-pkinit in ubuntu wily.

krb5-pkinit-dbgsym: No summary available for krb5-pkinit-dbgsym in ubuntu wily.

No description available for krb5-pkinit-dbgsym in ubuntu wily.

krb5-user: No summary available for krb5-user in ubuntu wily.

No description available for krb5-user in ubuntu wily.

krb5-user-dbgsym: No summary available for krb5-user-dbgsym in ubuntu wily.

No description available for krb5-user-dbgsym in ubuntu wily.

libgssapi-krb5-2: No summary available for libgssapi-krb5-2 in ubuntu wily.

No description available for libgssapi-krb5-2 in ubuntu wily.

libgssapi-krb5-2-dbgsym: No summary available for libgssapi-krb5-2-dbgsym in ubuntu wily.

No description available for libgssapi-krb5-2-dbgsym in ubuntu wily.

libgssrpc4: No summary available for libgssrpc4 in ubuntu wily.

No description available for libgssrpc4 in ubuntu wily.

libgssrpc4-dbgsym: No summary available for libgssrpc4-dbgsym in ubuntu wily.

No description available for libgssrpc4-dbgsym in ubuntu wily.

libk5crypto3: No summary available for libk5crypto3 in ubuntu wily.

No description available for libk5crypto3 in ubuntu wily.

libk5crypto3-dbgsym: No summary available for libk5crypto3-dbgsym in ubuntu wily.

No description available for libk5crypto3-dbgsym in ubuntu wily.

libkadm5clnt-mit9: No summary available for libkadm5clnt-mit9 in ubuntu wily.

No description available for libkadm5clnt-mit9 in ubuntu wily.

libkadm5clnt-mit9-dbgsym: No summary available for libkadm5clnt-mit9-dbgsym in ubuntu wily.

No description available for libkadm5clnt-mit9-dbgsym in ubuntu wily.

libkadm5srv-mit9: No summary available for libkadm5srv-mit9 in ubuntu wily.

No description available for libkadm5srv-mit9 in ubuntu wily.

libkadm5srv-mit9-dbgsym: No summary available for libkadm5srv-mit9-dbgsym in ubuntu wily.

No description available for libkadm5srv-mit9-dbgsym in ubuntu wily.

libkdb5-8: No summary available for libkdb5-8 in ubuntu wily.

No description available for libkdb5-8 in ubuntu wily.

libkdb5-8-dbgsym: No summary available for libkdb5-8-dbgsym in ubuntu wily.

No description available for libkdb5-8-dbgsym in ubuntu wily.

libkrad-dev: No summary available for libkrad-dev in ubuntu wily.

No description available for libkrad-dev in ubuntu wily.

libkrad-dev-dbgsym: No summary available for libkrad-dev-dbgsym in ubuntu wily.

No description available for libkrad-dev-dbgsym in ubuntu wily.

libkrad0: No summary available for libkrad0 in ubuntu wily.

No description available for libkrad0 in ubuntu wily.

libkrad0-dbgsym: No summary available for libkrad0-dbgsym in ubuntu wily.

No description available for libkrad0-dbgsym in ubuntu wily.

libkrb5-3: No summary available for libkrb5-3 in ubuntu wily.

No description available for libkrb5-3 in ubuntu wily.

libkrb5-3-dbgsym: No summary available for libkrb5-3-dbgsym in ubuntu wily.

No description available for libkrb5-3-dbgsym in ubuntu wily.

libkrb5-dbg: No summary available for libkrb5-dbg in ubuntu wily.

No description available for libkrb5-dbg in ubuntu wily.

libkrb5-dev: No summary available for libkrb5-dev in ubuntu wily.

No description available for libkrb5-dev in ubuntu wily.

libkrb5-dev-dbgsym: No summary available for libkrb5-dev-dbgsym in ubuntu wily.

No description available for libkrb5-dev-dbgsym in ubuntu wily.

libkrb5support0: No summary available for libkrb5support0 in ubuntu wily.

No description available for libkrb5support0 in ubuntu wily.

libkrb5support0-dbgsym: No summary available for libkrb5support0-dbgsym in ubuntu wily.

No description available for libkrb5support0-dbgsym in ubuntu wily.