Change log for lablgtk3 package in Ubuntu

111 of 11 results
Published in hirsute-release on 2020-11-19
Deleted in hirsute-proposed (Reason: moved to Release)
lablgtk3 (3.1.1+official-1build1) hirsute; urgency=medium

  * No-change rebuild for ocaml abi changes.

 -- Matthias Klose <email address hidden>  Tue, 03 Nov 2020 15:28:50 +0100
Superseded in hirsute-release on 2020-11-19
Published in groovy-release on 2020-10-06
Deleted in groovy-proposed (Reason: moved to Release)
lablgtk3 (3.1.1+official-1) unstable; urgency=medium

  * Use an official upstream tarball, instead of a tag on the upstream git.
  * d/rules: give explicit list of packages to dune (closes: #971439)
  * Change debian/watch to download official tarballs, instead of tagged
    releases from git.

 -- Ralf Treinen <email address hidden>  Thu, 01 Oct 2020 21:47:51 +0200
Superseded in groovy-release on 2020-10-06
Deleted in groovy-proposed on 2020-10-07 (Reason: moved to Release)
lablgtk3 (3.1.1-1build2) groovy; urgency=medium

  * Rebuild against new OCAML ABI.

 -- Gianfranco Costamagna <email address hidden>  Mon, 24 Aug 2020 12:52:51 +0200

Available diffs

Superseded in groovy-release on 2020-08-24
Deleted in groovy-proposed on 2020-08-25 (Reason: moved to Release)
lablgtk3 (3.1.1-1build1) groovy; urgency=medium

  * Rebuild against new OCAML ABI.

 -- Gianfranco Costamagna <email address hidden>  Thu, 20 Aug 2020 08:38:24 +0200
Superseded in groovy-release on 2020-08-20
Deleted in groovy-proposed on 2020-08-21 (Reason: moved to Release)
lablgtk3 (3.1.1-1) unstable; urgency=medium

  * Team upload
  * New upstream release
  * Fix dependency on libgtkspell3-3-dev (Closes: #967893)
  * Bump debhelper compat level to 13
  * Add Rules-Requires-Root: no

 -- St├ęphane Glondu <email address hidden>  Wed, 12 Aug 2020 11:06:07 +0200
Superseded in groovy-release on 2020-08-12
Deleted in groovy-proposed on 2020-08-14 (Reason: moved to Release)
lablgtk3 (3.1.0-3build1) groovy; urgency=medium

  * Rebuild against new OCAML ABI.

 -- Gianfranco Costamagna <email address hidden>  Wed, 13 May 2020 13:45:14 +0200
Superseded in groovy-proposed on 2020-05-13
lablgtk3 (3.1.0-3) unstable; urgency=medium

  * Patch gcc10: fix compilation with gcc10 (closes: #957414)

 -- Ralf Treinen <email address hidden>  Fri, 17 Apr 2020 21:39:33 +0200
Superseded in groovy-release on 2020-05-13
Published in focal-release on 2020-02-28
Deleted in focal-proposed (Reason: moved to Release)
lablgtk3 (3.0~beta6-2build1) focal; urgency=medium

  * No-change rebuild against ocaml-nox-4.08.1

 -- Steve Langasek <email address hidden>  Fri, 21 Feb 2020 07:23:01 +0000
Superseded in focal-release on 2020-02-28
Published in eoan-release on 2019-09-03
Deleted in eoan-proposed (Reason: moved to release)
lablgtk3 (3.0~beta6-2) unstable; urgency=medium

  * Package liblablgtk3-ocaml-dev: add breaks/replaces with
    liblablgtk3-ocaml (<< 3.0~beta6-1) since the META file was
    moved from the latter to the first (closes: Bug#935611)
  * Add to override dh_ocaml more units that are also exported by
    lablgtk2-ocaml-dev: GPointer, Glib
  * Fix a typo in long description of liblablgtk3-ocaml

 -- Ralf Treinen <email address hidden>  Mon, 26 Aug 2019 09:44:41 +0200

Available diffs

Superseded in eoan-release on 2019-09-03
Deleted in eoan-proposed on 2019-09-04 (Reason: moved to release)
lablgtk3 (3.0~beta6-1) unstable; urgency=medium

  * New upstream beta release
  * New binary packages liblablgtkspell3-ocaml-dev, liblablgtkspell3-ocaml
  * d/watch:
    - point to release tags on github
    - set uversionmangle to handle correctly ".beta" versions
  * Build-dependencies:
    - add libcairo2-ocaml-dev
    - add ocaml-dune and libdune-ocaml-dev
    - change ocaml-nox to ocaml
    - change debhelper(=11) to debhelper-compat(=12), drop file debian/compat
  * Drop build-conflict on liblablgtk2-ocaml-dev
  * Improve package descriptions
  * Installation into binary packages:
    - change debian/*install.in files to follow the new file layout created
      by "dune install"
    - install useful upstream docs into liblablgtk-ocaml-dev
    - do not install binaries lablgladecc3 and gdk_pixbuf_mlsource3
  * debian/rules:
    - build: call dune -p ... (thanks to @ejgallego for the hint)
    - clean: call dune
    - install: call dune
    - configure: do nothing, since dune does its own configuration.
    - drop unused variable settings from d/rules
    - dh_missing: switch to --fail-missing
    - override dh_ocaml to avoid conflicts on units that are also
      exported by lablgtk2-ocaml-dev
  * debian/copyright:
    - drop a spurious blank line
  * Package tests:
    - update compilation option for lablgtk3-dev
  * Add Homepage
  * Standards-Version 4.4.0 (no change)

 -- Ralf Treinen <email address hidden>  Tue, 13 Aug 2019 09:18:16 +0200

Available diffs

Superseded in eoan-release on 2019-08-29
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-07-14 (Reason: moved to release)
lablgtk3 (3.0~beta3-1) unstable; urgency=medium

  * Initial packaging (closes: #916645)

 -- Ralf Treinen <email address hidden>  Sun, 23 Dec 2018 20:00:19 +0100
111 of 11 results