Ubuntu

Change log for “language-selector” package in Ubuntu

175 of 233 results
Published in trusty-release on 2014-04-10
Deleted in trusty-proposed (Reason: moved to release)
language-selector (0.129) trusty; urgency=medium

  * Update translations from launchpad
 -- Sebastien Bacher <email address hidden>   Thu, 10 Apr 2014 20:05:44 +0200

Available diffs

Superseded in trusty-release on 2014-04-10
Deleted in trusty-proposed on 2014-04-12 (Reason: moved to release)
language-selector (0.128) trusty; urgency=medium

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - set a minimal height for the details (lp: #1165626)
 -- Sebastien Bacher <email address hidden>   Wed, 09 Apr 2014 18:15:26 +0200

Available diffs

Superseded in trusty-release on 2014-04-09
Deleted in trusty-proposed on 2014-04-10 (Reason: moved to release)
language-selector (0.126) trusty; urgency=medium

  * LanguageSelector/ImConfig.py:
    Make fcitx the system default if installed (LP: #1297831).
 -- Gunnar Hjalmarsson <email address hidden>   Thu, 27 Mar 2014 15:09:00 +0100

Available diffs

Superseded in trusty-proposed on 2014-03-27
language-selector (0.125) trusty; urgency=medium

  * fontconfig/69-language-selector-zh-*.conf:
    Added 'binding="strong"' when missing (LP: #1227034).
 -- Gunnar Hjalmarsson <email address hidden>   Thu, 27 Mar 2014 11:38:00 +0100

Available diffs

Superseded in trusty-release on 2014-03-27
Deleted in trusty-proposed on 2014-03-29 (Reason: moved to release)
language-selector (0.124) trusty; urgency=medium

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    PyGTKDeprecationWarning fixes.
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 19 Mar 2014 02:07:00 +0100

Available diffs

Superseded in trusty-release on 2014-03-19
Deleted in trusty-proposed on 2014-03-20 (Reason: moved to release)
language-selector (0.123) trusty; urgency=medium

  * Rewrite the python shebang path to /usr/bin/python3.
 -- Matthias Klose <email address hidden>   Thu, 20 Feb 2014 13:10:24 +0100

Available diffs

Superseded in trusty-release on 2014-02-20
Deleted in trusty-proposed on 2014-02-21 (Reason: moved to release)
language-selector (0.122) trusty; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    Enabled grouping in currency format example.
 -- Gunnar Hjalmarsson <email address hidden>   Thu, 13 Feb 2014 23:44:00 +0100

Available diffs

Superseded in trusty-release on 2014-02-13
Deleted in trusty-proposed on 2014-02-15 (Reason: moved to release)
language-selector (0.121) trusty; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py,
    LanguageSelector/ImConfig.py:
    - Dropped the ambiguous 'default' option in the IM selector.
  * debian/control:
    - Bump version of the im-config dependency.
    - Bump Standards-Version to 3.9.5.
  * help/C/index.docbook:
    - Language Support Help updated.
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 05 Feb 2014 08:19:00 +0100

Available diffs

Superseded in trusty-release on 2014-02-05
Deleted in trusty-proposed on 2014-02-06 (Reason: moved to release)
language-selector (0.120) trusty; urgency=low

  * fontconfig/69-language-selector-zh-hk.conf, -zh-mo.conf:
    WenQuanYi Zen Hei fonts dropped (LP: #1270647).
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 21 Jan 2014 22:37:00 +0100

Available diffs

Superseded in trusty-release on 2014-01-23
Deleted in trusty-proposed on 2014-01-24 (Reason: moved to release)
language-selector (0.119) trusty; urgency=medium

  * data/language-selector.desktop.in:
    - Show in both unity-control-center and gnome-control-center (LP: #1257505)
 -- Robert Ancell <email address hidden>   Wed, 15 Jan 2014 15:07:58 +1300

Available diffs

Superseded in trusty-release on 2014-01-15
Deleted in trusty-proposed on 2014-01-16 (Reason: moved to release)
language-selector (0.118) trusty; urgency=low

  * data/pkg_depends:
    ttf-wqy-zenhei replaced with fonts-droid for Chinese (LP: #1173571).
  * fontconfig/69-language-selector-zh-hk.conf, -zh-cn.conf, -zh-sg.conf:
    Droid Sans Fallback moved to top.
  * fontconfig/69-language-selector-zh-tw.conf:
    Outdated DejaVu bindings removed (LP: #1173571).
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 06 Nov 2013 14:58:00 +0100

Available diffs

Superseded in trusty-release on 2013-11-06
Deleted in trusty-proposed on 2013-11-08 (Reason: moved to release)
language-selector (0.117) trusty; urgency=low

  * LanguageSelector/LocaleInfo.py:
    Fix TypeError (LP: #1194985).
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 05 Nov 2013 02:34:00 +0100

Available diffs

Superseded in trusty-release on 2013-11-05
Published in saucy-release on 2013-10-04
Deleted in saucy-proposed (Reason: moved to release)
language-selector (0.116) saucy; urgency=low

  * Update translations from launchpad
 -- Sebastien Bacher <email address hidden>   Fri, 04 Oct 2013 11:17:41 +0200

Available diffs

Superseded in saucy-release on 2013-10-04
Deleted in saucy-proposed on 2013-10-05 (Reason: moved to release)
language-selector (0.115) saucy; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - dbus_backend/ls-dbus-backend: pass system-bus-name as a subject
      instead of pid so policykit can get the information from the system
      bus.
    - CVE-2013-1066
 -- Marc Deslauriers <email address hidden>   Wed, 18 Sep 2013 12:45:13 -0400

Available diffs

Published in precise-updates on 2013-09-18
Published in precise-security on 2013-09-18
language-selector (0.79.4) precise-security; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - dbus_backend/ls-dbus-backend: pass system-bus-name as a subject
      instead of pid so policykit can get the information from the system
      bus.
    - CVE-2013-1066
 -- Marc Deslauriers <email address hidden>   Fri, 13 Sep 2013 12:35:48 -0400
Published in quantal-updates on 2013-09-18
Published in quantal-security on 2013-09-18
language-selector (0.90.1) quantal-security; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - dbus_backend/ls-dbus-backend: pass system-bus-name as a subject
      instead of pid so policykit can get the information from the system
      bus.
    - CVE-2013-1066
 -- Marc Deslauriers <email address hidden>   Fri, 13 Sep 2013 12:34:31 -0400

Available diffs

Published in raring-updates on 2013-09-18
Published in raring-security on 2013-09-18
language-selector (0.110.1) raring-security; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - dbus_backend/ls-dbus-backend: pass system-bus-name as a subject
      instead of pid so policykit can get the information from the system
      bus.
    - CVE-2013-1066
 -- Marc Deslauriers <email address hidden>   Fri, 13 Sep 2013 12:06:55 -0400

Available diffs

Superseded in saucy-release on 2013-09-18
Deleted in saucy-proposed on 2013-09-20 (Reason: moved to release)
language-selector (0.114) saucy; urgency=low

  * Update for python-distutils-extra changes to help handling
 -- Jeremy Bicha <email address hidden>   Tue, 23 Jul 2013 12:45:09 -0400

Available diffs

Superseded in saucy-release on 2013-07-25
Deleted in saucy-proposed on 2013-07-26 (Reason: moved to release)
language-selector (0.113) saucy; urgency=low

  * fontconfig/30-cjk-aliases.conf:
    Stop fontconfig warnings (LP: #1191450).
 -- Gunnar Hjalmarsson <email address hidden>   Sun, 16 Jun 2013 07:41:00 +0200

Available diffs

Superseded in saucy-release on 2013-06-16
Deleted in saucy-proposed on 2013-06-17 (Reason: moved to release)
language-selector (0.112) saucy; urgency=low

  * debian/language-selector-common.links:
    Missing symlinks added.
  * fontconfig/99-language-selector-zh.conf:
    Get rid of fontconfig warnings (LP: #1189152).
  * fontconfig/none:
    Removed.
  * fontconfig/README:
    Cleanup.
 -- Gunnar Hjalmarsson <email address hidden>   Sat, 15 Jun 2013 00:20:00 +0200

Available diffs

Superseded in saucy-release on 2013-06-14
Deleted in saucy-proposed on 2013-06-16 (Reason: moved to release)
language-selector (0.111) saucy; urgency=low

  * data/pkg_depends:
    - Replace ttf-thai-tlwg with fonts-thai-tlwg.
    - Replace ttf-arphic-ukai with fonts-arphic-ukai.
 -- Colin Watson <email address hidden>   Sun, 09 Jun 2013 23:54:04 +0100

Available diffs

Superseded in saucy-release on 2013-06-10
Published in raring-release on 2013-04-17
Deleted in raring-proposed (Reason: moved to release)
language-selector (0.110) raring; urgency=low

  * Updated translations for raring
 -- Sebastien Bacher <email address hidden>   Wed, 17 Apr 2013 12:28:24 +0200

Available diffs

Superseded in precise-updates on 2013-09-18
Deleted in precise-proposed on 2013-09-19 (Reason: moved to -updates)
language-selector (0.79.3) precise-proposed; urgency=low

  * language_support_pkgs.py:
    Fix of TypeError in _expand_pkg_pattern() (LP: #1161953).
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 09 Apr 2013 13:11:25 +0100

Available diffs

Superseded in raring-release on 2013-04-17
Deleted in raring-proposed on 2013-04-18 (Reason: moved to release)
language-selector (0.109) raring; urgency=low

  * data/LanguageSelector.ui:
    Make the "Drag languages..." sentence bold (LP: #362204).
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 02 Apr 2013 16:10:00 +0100

Available diffs

Superseded in raring-release on 2013-04-09
Deleted in raring-proposed on 2013-04-10 (Reason: moved to release)
language-selector (0.108) raring; urgency=low

  * language_support_pkgs.py:
    Fix of TypeError in _expand_pkg_pattern() (LP: #1161953).
 -- Gunnar Hjalmarsson <email address hidden>   Fri, 29 Mar 2013 18:40:00 +0100

Available diffs

Superseded in raring-release on 2013-04-02
Deleted in raring-proposed on 2013-04-03 (Reason: moved to release)
language-selector (0.107) raring; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    Prevent crashes like the one in LP: #1154243.
 -- Gunnar Hjalmarsson <email address hidden>   Mon, 18 Mar 2013 05:16:00 +0100

Available diffs

Superseded in raring-release on 2013-03-22
Deleted in raring-proposed on 2013-03-23 (Reason: moved to release)
language-selector (0.106) raring; urgency=low

  * language_support_pkgs.py:
    Changes in available_languages() to avoid that users are prompted
    to install language support for non-installed languages. That
    could happen if there were other locales on the system but the
    locales representing the installed languages.
  * dbus_backend/ls-dbus-backend:
    Update /etc/papersize when regional formats are applied system
    wide (LP: #1130690).
  * debian/control:
    Bump the accountsservice dependency.
  * LanguageSelector/LocaleInfo.py:
    Don't display the @variant portion of a language or locale name
    as b'variant'.
 -- Gunnar Hjalmarsson <email address hidden>   Fri, 22 Feb 2013 07:05:00 +0100

Available diffs

Superseded in precise-updates on 2013-04-18
Deleted in precise-proposed on 2013-04-20 (Reason: moved to -updates)
language-selector (0.79.2) precise-proposed; urgency=low

  * LanguageSelector/LanguageSelector.py:
    Call missing() in language_support_pkgs.py instead of
    by_locale(), so the check for missing language support packages
    is carried out for all the installed languages, not only for the
    current system language (LP: #1134364).
  * language_support_pkgs.py:
    - Hack to prevent that users are prompted to install hunspell-de-xx
      when the enhanced (and conflicting) hunspell-de-xx-frami is
      installed (LP: #1103547).
    - Changes in available_languages() to avoid that users are prompted
      to install language support for non-installed languages. That
      could happen if there were other locales on the system but the
      locales representing the installed languages (LP: #1134364).
  * LanguageSelector/LangCache.py:
    When a language is removed, don't remove packages that are not
    language specific (LP: #37707).
  * debian/control:
    Bump the accountsservice dependency.
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 27 Feb 2013 16:44:00 +0100

Available diffs

Superseded in raring-release on 2013-03-01
Deleted in raring-proposed on 2013-03-02 (Reason: moved to release)
language-selector (0.105) raring; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    Prevent crashes like the one in LP: #1112706.
 -- Gunnar Hjalmarsson <email address hidden>   Thu, 21 Feb 2013 15:15:04 +0100

Available diffs

Superseded in precise-updates on 2013-03-25
Deleted in precise-proposed on 2013-03-26 (Reason: moved to -updates)
language-selector (0.79.1) precise; urgency=low

  * check-language-support: De-duplicate output for a single target language
    (LP: #1056689).
 -- Colin Watson <email address hidden>   Wed, 13 Feb 2013 16:44:55 +0000

Available diffs

Superseded in raring-release on 2013-02-21
Deleted in raring-proposed on 2013-02-27 (Reason: moved to release)
language-selector (0.104) raring; urgency=low

  * data/pkg_depends:
    List of input methods for traditional Chinese modified. Thanks to
    Ma Xiaojun for the proposal (LP: #1120833).
  * LanguageSelector/LangCache.py:
    When a language is removed, don't remove packages that are not
    language specific (LP: #37707).
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 12 Feb 2013 05:25:22 +0100

Available diffs

Superseded in raring-release on 2013-02-12
Deleted in raring-proposed on 2013-02-13 (Reason: moved to release)
language-selector (0.103) raring; urgency=low

  * LanguageSelector/LanguageSelector.py:
    Make getMissingLangPacks() return a list instead of a set -
    fixes regression issue from version 0.102 (LP: #1103547).
 -- Gunnar Hjalmarsson <email address hidden>   Fri, 08 Feb 2013 17:12:00 +0100

Available diffs

Superseded in raring-release on 2013-02-08
Deleted in raring-proposed on 2013-02-10 (Reason: moved to release)
language-selector (0.102) raring; urgency=low

  [ Martin Pitt ]
  * tests/test_language_support_pkgs.py: Fix unstable test due to Python's
    current hash randomization.
  * Add test case for LP #1103547.

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/LanguageSelector.py:
    Call missing() in language_support_pkgs.py instead of
    by_locale(), so the check for missing language support packages
    is carried out for all the installed languages, not only for the
    current system language.
  * language_support_pkgs.py:
    Hack to prevent that users are prompted to install hunspell-de-xx
    when the enhanced (and conflicting) hunspell-de-xx-frami is
    installed (LP: #1103547).
 -- Martin Pitt <email address hidden>   Fri, 08 Feb 2013 11:55:28 +0100

Available diffs

Superseded in raring-release on 2013-02-08
Deleted in raring-proposed on 2013-02-09 (Reason: moved to release)
language-selector (0.101) raring; urgency=low

  * This upload is about fixing LP: #1043031. Namely the use of LANG guards
    introduced in 0.86 was possibly not an entirely correct solution because
    there is a significant class of users who do not use the 'native' locale
    of these fonts, yet this is what a LANG guards tests for. We need the
    fontconfig configurations to apply correctly in these cases too.
  * Remove Japanese fontconfig file; these have been moved to the individual
    font packages which will be pulled in by l-s if appropriate.
  * Switch to using .maintscript file for removing conffiles; version
    debhelper BD as appropriate.
  * 69_zh* - remove wqy-microhei versions. This package now has its own
    fontconfig configuration.
  * fontconfig/README: Update to reflect reality of the 69_* files
  * Remove 'strong' binding and unnecessary fonts from zh_* configuration.
 -- Iain Lane <email address hidden>   Wed, 06 Feb 2013 15:37:33 +0000

Available diffs

Superseded in raring-proposed on 2013-02-06
language-selector (0.100) raring; urgency=low

  * help/C/language-selector.xml:
    Update due to the transition from im-switch to im-config.
  * LanguageSelector/LanguageSelector.py,
    LanguageSelector/gtk/GtkLanguageSelector.py:
    Do not let the LANGUAGE priority list contain non-English items
    after an English item, since the resulting display language would
    not likely meet the user's expectations (LP: #1084745).
  * data/LanguageSelector.ui:
    Title added to the "Checking available language support" progress
    dialog (LP: #1113093).
  * Removal of stuff related to language-selector-kde, since Kubuntu
    isn't using it any longer.
  * debian/control:
    Bump Standards-Version to 3.9.4.
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 29 Jan 2013 21:29:00 +0100

Available diffs

Superseded in raring-release on 2013-02-07
Deleted in raring-proposed on 2013-02-08 (Reason: moved to release)
language-selector (0.99) raring; urgency=low

  * LanguageSelector/ImConfig.py,
    LanguageSelector/gtk/GtkLanguageSelector.py:
    - Get available input methods from im-config (LP: #1090754).
  * debian/control:
    - Bump version of the im-config dependency.
    - yelp added to the Recommends field, since it's needed for the
      "Help" button to work.
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 18 Dec 2012 21:32:00 +0100

Available diffs

Superseded in raring-release on 2013-01-10
Deleted in raring-proposed on 2013-01-11 (Reason: moved to release)
language-selector (0.98) raring; urgency=low

  * debian/control:
    - Bump version of the im-config dependency.
 -- Gunnar Hjalmarsson <email address hidden>   Mon, 10 Dec 2012 17:29:00 +0100

Available diffs

Superseded in raring-release on 2012-12-10
Deleted in raring-proposed on 2012-12-12 (Reason: moved to release)
language-selector (0.97) raring; urgency=low

  * Restore to version 0.95, now that the im-config MIR is sorted.
 -- Adam Conrad <email address hidden>   Sun, 09 Dec 2012 10:47:01 -0700

Available diffs

Superseded in raring-release on 2012-12-09
Deleted in raring-proposed on 2012-12-11 (Reason: moved to release)
language-selector (0.96) raring; urgency=low

  * Revert to 0.94, as the im-switch transition needs MIR approval.
 -- Adam Conrad <email address hidden>   Fri, 07 Dec 2012 15:28:29 -0700

Available diffs

Superseded in raring-release on 2012-12-07
Deleted in raring-proposed on 2012-12-09 (Reason: moved to release)
language-selector (0.95) raring; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    - Deprecated keyword "type" in Gtk.MessageDialog constructors
      replaced by "message_type".
  * debian/control, LanguageSelector/gtk/GtkLanguageSelector.py,
    LanguageSelector/ImConfig.py, data/LanguageSelector.ui:
    - Transition from the im-switch framework for handling input
      method systems to im-config (LP: #1076975).
 -- Gunnar Hjalmarsson <email address hidden>   Fri, 30 Nov 2012 05:36:00 +0100

Available diffs

Superseded in raring-release on 2012-12-07
Deleted in raring-proposed on 2012-12-09 (Reason: moved to release)
language-selector (0.94) raring; urgency=low

  * data/language-selector.desktop.in:
    - Use equivalent 'preferences-desktop-locale' icon instead of
      'config-language' since the High Contrast theme is missing a symlink
 -- Jeremy Bicha <email address hidden>   Tue, 27 Nov 2012 15:20:11 +0100

Available diffs

Superseded in raring-release on 2012-11-27
Deleted in raring-proposed on 2012-11-28 (Reason: moved to release)
language-selector (0.93) raring; urgency=low

  * LanguageSelector/LocaleInfo.py:
    Look first for a common_name field when grabbing a language name
    (LP: #991002).
 -- Gunnar Hjalmarsson <email address hidden>   Fri, 16 Nov 2012 16:55:39 +0000

Available diffs

Superseded in raring-release on 2012-11-16
Deleted in raring-proposed on 2012-11-17 (Reason: moved to release)
language-selector (0.92) raring; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py,
  gnome-language-selector: Add single instance support for gnome-language-selector
  and fix the Escape key malfunction when num lock is on.
 -- Shih-Yuan Lee (FourDollars) <email address hidden>   Mon, 12 Nov 2012 09:55:43 +0100

Available diffs

Superseded in raring-release on 2012-11-12
Deleted in raring-proposed on 2012-11-13 (Reason: moved to release)
language-selector (0.91) raring; urgency=low

  * Build depend on python3-all.
 -- Dmitrijs Ledkovs <email address hidden>   Fri, 26 Oct 2012 11:56:42 +0100

Available diffs

Superseded in raring-release on 2012-10-26
Published in quantal-release on 2012-10-09
language-selector (0.90) quantal; urgency=low

  * Updated launchpad translations
 -- Sebastien Bacher <email address hidden>   Tue, 09 Oct 2012 15:59:39 +0200

Available diffs

Superseded in quantal-release on 2012-10-09
language-selector (0.89) quantal; urgency=low

  * check-language-support: De-duplicate output for a single target language
    (LP: #1056689).
 -- Colin Watson <email address hidden>   Thu, 27 Sep 2012 13:04:24 +0100

Available diffs

Superseded in quantal-release on 2012-09-27
language-selector (0.87) quantal; urgency=low

  * Fix bad testing sections. LP: #1034928
    - fontconfig/69-language-selector-ja-jp.conf: Separate matching
      patterns for non-bitmap/non-hinting sections. And remove legacy
      font lists.
    - fontconfig/69-language-selector-zh-tw.conf: Separate matching
      patterns at "Bind AR PL UMing with DejaVu Serif" section.
 -- Fumihito YOSHIDA <email address hidden>   Wed, 22 Aug 2012 11:35:26 +0900

Available diffs

Superseded in quantal-release on 2012-09-06
language-selector (0.86) quantal; urgency=low

  * Apply all (ja-jp, zh-*) fontconfig config files only when locale matches
  * Remove 69-language-selector-ka-ge.conf — it's going to its corresponding
    font package fonts-bpg-georgian.
  * Disable installation/updating of fontconfig-voodoo and remove previously
    installed symlinks on upgrade.
  * Enable all config files that might have been previously installed by
    fontconfig-voodoo now that they are all guarded by locale.
  * Standards-Version → 3.9.3, no changes required
 -- Iain Lane <email address hidden>   Mon, 13 Aug 2012 11:35:34 +0100

Available diffs

Superseded in quantal-release on 2012-08-20
language-selector (0.85) quantal; urgency=low

  * ls-dbus-backend: fix for python3 compatibility.  LP: #1014429.
  * Do not touch /etc/environment; we should be updating /etc/default/locale
    exclusively.  On upgrade, clean up any references that have been left
    behind in /etc/environment. LP: #1035498.
 -- Steve Langasek <email address hidden>   Fri, 10 Aug 2012 22:06:35 -0700

Available diffs

Superseded in quantal-release on 2012-08-11
Deleted in quantal-proposed on 2012-08-12 (Reason: moved to release)
language-selector (0.84) quantal-proposed; urgency=low

  * data/pkg_depends: Add fonts-lklug-sinhala for Sinhala.
 -- Colin Watson <email address hidden>   Thu, 28 Jun 2012 14:44:44 +0100

Available diffs

Superseded in quantal-release on 2012-06-28
language-selector (0.83) quantal; urgency=low

  * debian/rules: Override dh_auto_* commands to build with Python 3. (See
    Debian #597105)
 -- Martin Pitt <email address hidden>   Thu, 14 Jun 2012 10:13:04 +0200

Available diffs

Superseded in quantal-release on 2012-06-14
language-selector (0.82) quantal; urgency=low

  [ Colin Watson ]
  * Port to Python 3:
    - Use Python 3-style print functions.
    - Use "except Exception as e" syntax rather than the old-style "except
      Exception, e".
    - Use "raise Exception(value)" syntax rather than the old-style "raise
      Exception, value".
    - Use list comprehensions rather than filter.
    - Use new-style octal literals.
    - Use str() rather than unicode() in Python 3.
    - Open subprocesses with universal_newlines=True when expecting to read
      text from them.
    - Cope with changes in dict method return types in Python 3.

  [ Martin Pitt ]
  * tests/runner.sh: Run with $PYTHON if specified, to make it easier to run
    with a different Python version.
  * Consistent str vs. bytes handling, to work with Python 3.
  * Convert tests to current apt API.
  * Python 3 compatible import statements.
  * Properly close files, to avoid ResourceWarnings.
  * Convert all tabs to spaces.
  * LanguageSelector/gtk/GtkLanguageSelector.py: Pass a string to setlocale(),
    not bytes.
  * LanguageSelector/qt/QtLanguageSelector.py: Fix for Python 3.
  * LanguageSelector/gtk/GtkLanguageSelector.py: python3-dbus now sometimes
    calls OpProgress.update() without any argument. Support this and pulsate
    the progress bar in this case.
  * Switch all hashbangs and dependencies to Python 3.
  * debian/control: Drop now obsolete language-selector and
    language-selector-qt transitional packages.
 -- Martin Pitt <email address hidden>   Thu, 14 Jun 2012 09:50:35 +0200

Available diffs

Superseded in quantal-release on 2012-06-14
language-selector (0.81) quantal; urgency=low

  * data/pkg_depends: replace cmap-adobe- depends by poppler-data
    (lp: #1009052)
 -- Sebastien Bacher <email address hidden>   Thu, 07 Jun 2012 12:45:28 +0200

Available diffs

Superseded in quantal-release on 2012-06-07
language-selector (0.80) quantal; urgency=low

  * Add gcompris to pkg_depends (for gcompris-sound-* in Edubuntu)
 -- Stephane Graber <email address hidden>   Mon, 14 May 2012 17:14:12 -0400

Available diffs

Superseded in quantal-release on 2012-05-14
Published in precise-release on 2012-04-18
language-selector (0.79) precise; urgency=low

  * Update of help document (LP: #983951).
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 18 Apr 2012 08:09:49 +0200

Available diffs

Superseded in precise-release on 2012-04-18
language-selector (0.78) precise; urgency=low

  * Updated translations from launchpad (lp: #980842)
 -- Sebastien Bacher <email address hidden>   Fri, 13 Apr 2012 16:21:24 +0200

Available diffs

Superseded in precise-release on 2012-04-13
language-selector (0.77) precise; urgency=low

  * dbus_backend/ls-dbus-backend: Set LC_IDENTIFICATION as well, to comply
    with what Ubiquity does. (LP: #926207)
  * tests/test_language_support_pkgs.py: Fix
    test_by_package_and_locale_noinstalled() for current pkg_depends: gedit
    does not need aspell any more, use abiword as trigger package.
  * language_support_pkgs.py, _expand_pkg_pattern(): Special-case "zh-han[st]"
    values for the locale. These are not actual locales, but e. g. Ubiquity
    assumes this works. So let these mean "zh_CN" and "zh_TW" respectively.
    Add a test case to tests/test_language_support_pkgs.py. (LP: #963460)
 -- Martin Pitt <email address hidden>   Fri, 30 Mar 2012 12:42:15 +0200

Available diffs

Superseded in precise-release on 2012-03-30
language-selector (0.76) precise; urgency=low

  * Add conffile upgrade handling for ko-kr conffiles dropped since lucid.
 -- Steve Langasek <email address hidden>   Mon, 26 Mar 2012 22:20:17 -0700

Available diffs

Superseded in precise-release on 2012-03-28
language-selector (0.75) precise; urgency=low

  [ Jinkyu Yi ]
  * data/pkg_depends:
    - Add fonts-unfonts-core for fonts-nanum's fallback
    - Remove ttf-alee, fonts-nanum-extra to reduce ko-related packages
      (refer to task-korean-desktop at Debian)
    - remove nabi, Unity can't support it
 -- Martin Pitt <email address hidden>   Fri, 16 Mar 2012 11:27:49 +0100

Available diffs

Superseded in precise-release on 2012-03-16
language-selector (0.74) precise; urgency=low

  * data/pkg_depends: Add fonts-ukij-uyghur for Uyghur. Thanks to Eagle
    Burkut for pointing this out.
 -- Martin Pitt <email address hidden>   Thu, 15 Mar 2012 15:22:54 +0100

Available diffs

Superseded in precise-release on 2012-03-15
language-selector (0.73) precise; urgency=low

  * data/pkg_depends: Add support for translated documentation of amarok
    and calligra.
 -- Felix Geyer <email address hidden>   Mon, 12 Mar 2012 11:39:45 -0400

Available diffs

Superseded in precise-release on 2012-03-12
language-selector (0.72) precise; urgency=low

  [ Sebastien Bacher ]
  * data/language-selector.desktop.in:
    - use official "Keywords" rather than "X-GNOME-Keywords" (LP: #949849)

  [ Martin Pitt ]
  * LanguageSelector/qt/QtLanguageSelector.py: Kubuntu's package manager is
    "Muon", not "Adept". Also update all messages in po/*.po to avoid breaking
    existing translations. (LP: #628653)
  * LanguageSelector/gtk/GtkLanguageSelector.py: Fix crash in
    updateLocaleChooserCombo() if tree model is not yet set. (LP: #945494)
  * debian/language-selector-common.postinst: Do not fail configuring if D-BUS
    does not give us the PID of a running ls-dbus-backend. (LP: #766672)
 -- Martin Pitt <email address hidden>   Fri, 09 Mar 2012 16:34:49 +0100

Available diffs

Superseded in precise-release on 2012-03-09
language-selector (0.71) precise; urgency=low

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/gtk/GtkLanguageSelector.py:
    Modified wording of the error message shown if the example box
    fails to apply the current locale (LP: #930785).

  [ Martin Pitt ]
  * data/pkg_depends: Drop myspell-ru, we have hunspell-ru now.
  * data/pkg_depends: Add cmap-adobe-* packages for ghostscript. (LP: #496012)
 -- Martin Pitt <email address hidden>   Fri, 02 Mar 2012 06:54:37 +0100

Available diffs

Superseded in precise-release on 2012-03-02
language-selector (0.70) precise; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    Clear the example box values before trying to generate new ones.
  * LanguageSelector/qt/QtLanguageSelector.py:
    Call for the no longer existing writeSysLangSetting() function
    removed (LP: #928400). writeSysLanguageSetting() now sets LANG.
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 15 Feb 2012 07:42:06 +0100

Available diffs

Superseded in precise-release on 2012-02-15
language-selector (0.69) precise; urgency=low

  * LanguageSelector/LocaleInfo.py, getUserDefaultLanguage(): Fix crash if
    system D-BUS is not running, which happens when running fontconfig-voodoo
    from casper. (LP: #856975)
  * debian/control: "Ubuntu Linux" → "Ubuntu". (LP: #919972)
  * data/pkg_depends: Move mozvoikko to xul-ext-mozvoikko.
  * data/pkg_depends: gedit and sylpheed use libenchant now, move these from
    aspell to hunspell dictionaries.
  * Close window on "Esc". (LP: #614933)
  * LanguageSelector/gtk/GtkLanguageSelector.py: Intercept errors from
    aptdaemon transactions and stop waiting for the transaction to finish on
    an error. (LP: #863875)
 -- Martin Pitt <email address hidden>   Thu, 09 Feb 2012 14:41:43 +0100

Available diffs

Superseded in precise-release on 2012-02-09
language-selector (0.68) precise; urgency=low

  * LanguageSelector/qt/QtLanguageSelector.py: Erroneous for loops
    replaced with simple variable assignments (LP: #926824).
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 08 Feb 2012 06:15:31 +0100

Available diffs

Superseded in precise-release on 2012-02-08
language-selector (0.67) precise; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py: Remove call for the
    dropped function verify_no_unexpected_changes() (LP: #927814).
 -- Gunnar Hjalmarsson <email address hidden>   Tue, 07 Feb 2012 08:33:33 +0100

Available diffs

Superseded in precise-release on 2012-02-07
language-selector (0.66) precise; urgency=low

  * LanguageSelector/LangCache.py, tests/test_lang_cache.py: Drop some dead
    code.
  * data/pkg_depends: Install poppler-data for all languages. (LP: #893920)
  * tests/test_language_support_pkgs.py: Fix test case for a package which is
    not a pattern, but a full name ("chromium-browser-l10n").
  * language_support_pkgs.py: Also consider the pattern itself a package name.
    Fixes installation of chromium-browser-l10n and poppler-data.
  * tests/test-data/etc/apt/sources.list*: Use precise.
  * tests/test_lang_cache.py: Update the cache before the tests, so that they
    can actually succeed.
 -- Martin Pitt <email address hidden>   Mon, 06 Feb 2012 12:33:54 +0100

Available diffs

Superseded in precise-release on 2012-02-06
language-selector (0.65) precise; urgency=low

  [ Colin Watson ]
  * check-language-support: Ignore errors from locale.setlocale.  We might
    well be running from the installer before locales have been properly
    configured (LP: #925330).
  * Clean up lots of pyflakes warnings.
  * LanguageSelector/FontConfig.py, LanguageSelector/LocaleInfo.py,
    LanguageSelector/utils.py: Use string methods rather than deprecated
    string functions.

  [ Gunnar Hjalmarsson ]
  * LanguageSelector/LocaleInfo.py: Prevent makeEnvString() from
    processing the empty string (LP: #926049).
  * fontconfig/30-cjk-aliases.conf: Changes due to Korean migration to
    fonts-nanum (LP: #792471).
  * debian/control: pyqt4-dev-tools added to build-depends (the pyuic4
    program is called from LanguageSelector/qt/Makefile).

  [ Martin Pitt ]
  * debian/control: Use standard X-Python-Version field.
  * debian/control: Bump Standards-Version to 3.9.2.
  * debian/control: Move transitional packages to Priority: Extra to quiesce
    lintian.
  * debian/control: Drop Vcs-Bzr. We move to the standard
    lp:ubuntu/language-selector branch now.
 -- Martin Pitt <email address hidden>   Mon, 06 Feb 2012 07:23:43 +0100

Available diffs

Superseded in precise-release on 2012-02-06
language-selector (0.64) precise; urgency=low

  * language_support_pkgs.py: Fix raising of NotImplementedError.
 -- Martin Pitt <email address hidden>   Fri, 03 Feb 2012 08:36:57 +0100

Available diffs

Superseded in precise-release on 2012-02-03
language-selector (0.63) precise; urgency=low

  [ Martin Pitt ]
  * LanguageSelector/LanguageSelector.py: Fix KeyError crash on a nonexisting
    package. (LP: #843430)
  * language_support_pkgs.py: Add PackageKit WhatProvides() plugin for
    "locale()" search. Register it in setup.py.
  * LanguageSelector/LangCache.py, data/blacklist, setup.py: Drop support for
    data/blacklist, we haven't needed it for a long time, and don't intend to
    bring back this hack.
  * dbus_backend/ls-dbus-backend: Drop GetMissingPackages{,Async} methods. The
    current code isn't using them, and there is no need to have this in a
    D-BUS service. language_support_pkgs works fine as user in frontends.
  * Drop tests/test_dbus_backend.py. It only exercised above method, not the
    "set system-wide locale" bits.
  * Drop LanguageSelector/CheckLanguageSupport.py,
    dbus_backend/ls-dbus-backend: Not used by anything any more, obsoleted by
    language_support_pkgs.py.
  * LanguageSelector/LanguageSelector.py: Reimplement getMissingLangPacks()
    using language_support_pkgs.py. This gets rid of a lot of redundant and
    bad code.
  * Change code to use the LanguageSelector.LangCache namespace more
    explicitly, to make it easier to get rid of LangCache.
  * LanguageSelector/LangCache.py: Remove yet another copy of the pkg_depends
    evaluation logic, and some more dead code, rewrite using
    language_support_pkgs.
  * Drop tests.moved/. Unused, no automatic tests, not very useful.
  * LanguageSelector/LangCache.py, LanguageSelector/qt/QtLanguageSelector.py:
    Drop last remainders of the languageSupport* info, language-support-* were
    dropped several cycles ago.

  [ Gunnar Hjalmarsson ]
  * Make the LANG variable, which up to now has represented regional
    formats, denote the display language instead (LP: #877610).
  * Make use of accountsservice's FormatsLocale property and
    SetFormatsLocale method when selecting a user's regional formats.
    (LP: #866062)
  * When setting the system-wide language, ensure that the system
    regional formats locale is set in order to prevent surprise
    changes of the formats.
  * data/LanguageSelector.ui: Text about rebooting no longer
    applicable, so removed.
  * LanguageSelector/LocaleInfo.py: Encode @variant string in the
    translate() function as UTF-8 to avoid a UnicodeDecodeError if a
    locale with @variant is selected for regional formats.
  * debian/control: Bump accountsservice dependency to >= 0.6.15-2ubuntu3,
    to ensure that we have the new SetFormatsLocale method.
  * debian/control: Make im-switch a dependency of language-selector-gnome,
    since it's no longer a dependency of ibus (LP: #908762).
 -- Martin Pitt <email address hidden>   Fri, 03 Feb 2012 07:01:24 +0100

Available diffs

Superseded in precise-release on 2012-02-03
language-selector (0.62) precise; urgency=low

  [ Colin Watson ]
  * data/pkg_depends:
    - Replace ttf-arphic-uming with fonts-arphic-uming.

  [ Martin Pitt ]
  * data/pkg_depends: Drop usage of '|'. It unnecessarily complicates the
    logic, does not add any expressiveness, and was only used once anyway.
  * data/pkg_depends: Add generic language-pack- pattern (without a trigger
    package), so that we do not need to special-case it in the code.
  * Add language_support_pkgs.py and tests/test_language_support_pkgs.py:
    Complete rewrite of the check-language-support and
    LanguageSelector/CheckLanguageSupport.py functionality. The old code was
    terrible and hard to maintain, the new one now makes it very easy to
    integrate into installers or an aptdaemon plugin and does not have any
    dependencies to any of the old language-selector code (which will
    eventually be dropped).
  * check-language-support: Rewrite using language_support_pkgs. CLI API stays
    the same.
  * setup.py, debian/language-selector-common.install: Install
    language_support_pkgs.py.
  * language_support_pkgs.py: Add apt_cache_add_language_packs() function
    which uses LanguageSupport to mark all corresponding language support
    packages for installation for an apt.Cache() object with to-be-installed
    packages. This is a suitable function to use as an aptdaemon plugin.
  * setup.py, debian/rules: Move to python-setuptools, as we are going to need
    it for registering an aptdaemon plugin through "entry_points". Add
    python-setuptools build dependency.
  * setup.py, debian/language-selector-common.install: Register
    apt_cache_add_language_packs as aptdaemon "modify_cache_after" plugin and
    install this package's egg-info.  With this, installing a new package
    through aptdaemon (i. e.  software-center or any other desktop
    integration) will automatically install the corresponding language packs
    and support packages as well.  (LP: #396414)
 -- Martin Pitt <email address hidden>   Thu, 26 Jan 2012 16:20:53 +0100

Available diffs

Superseded in precise-release on 2012-01-26
language-selector (0.61) precise; urgency=low

  * data/pkg_depends:
    - Replace ttf-tmuni with fonts-tibetan-machine.
    - Replace ttf-sil-abyssinica with fonts-sil-abyssinica.
    - Replace ttf-arabeyes with fonts-arabeyes.
    - Replace ttf-kacst with fonts-kacst.
    - Replace ttf-mgopen with fonts-mgopen.
    - Replace ttf-farsiweb with fonts-farsiweb.
    - Replace ttf-sil-scheherazade with fonts-sil-scheherazade.
    - Replace ttf-sil-ezra with fonts-sil-ezra.
    - Replace ttf-sil-yi with fonts-sil-nuosusil.
    - Replace ttf-takao-mincho with fonts-takao-mincho.
    - Replace ttf-takao-gothic with fonts-takao-gothic.
    - Replace ttf-khmeros with fonts-khmeros.
    - Replace ttf-lao with fonts-lao.
    - Replace ttf-manchufont with fonts-manchufont.
    - Replace ttf-sil-padauk with fonts-sil-padauk.
    - Replace ttf-nafees with fonts-nafees.
 -- Colin Watson <email address hidden>   Tue, 03 Jan 2012 14:27:27 +0000

Available diffs

Published in oneiric-updates on 2012-01-18
Deleted in oneiric-proposed (Reason: moved to -updates)
language-selector (0.56.1) oneiric-proposed; urgency=low

  * LanguageSelector/gtk/GtkLanguageSelector.py:
    Work around python2.7 crash when passing a unicode value to
    locale.setlocale() (LP: #909256).
    (Same solution as the solution in Precise to bug 905429.)
 -- Gunnar Hjalmarsson <email address hidden>   Wed, 28 Dec 2011 19:00:00 +0100

Available diffs

Superseded in precise-release on 2012-01-03
language-selector (0.60) precise; urgency=low

  [ Martin Pitt ]
  * debian/control: Move from transitional python-gobject to python-gi.
  * Drop fontconfig/69-language-selector-ko-kr.conf: Obsolete now with the
    move to fonts-nanum.
  * LanguageSelector/gtk/GtkLanguageSelector.py: Work around python2.7 crash
    when passing an unicode value to setlocale(). (LP: #905429)

  [ Jinkyu Yi ]
  * data/pkg_depends: Add fonts-nanum*.
 -- Martin Pitt <email address hidden>   Mon, 19 Dec 2011 10:34:41 +0100

Available diffs

175 of 233 results