Change log for lasso package in Ubuntu

175 of 84 results
Published in jammy-proposed
lasso (2.7.0-2build1) jammy; urgency=medium

  * No-change rebuild against openssl3

 -- Simon Chopin <email address hidden>  Wed, 01 Dec 2021 16:11:56 +0000
Published in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
lasso (2.7.0-2) unstable; urgency=medium

  * debian/rules: introduce build-arch/build-indep targets.
  * debian/rules: clean perl META files.
  * debian/rules: remove cleaning of id-wsf directory, it doesn't exist
    anymore.
  * debian/liblasso3.symbols: add lasso_log symbol introduced in 2.7.0-1.

 -- Frederic Peters <email address hidden>  Sat, 06 Nov 2021 13:42:52 +0100

Available diffs

Superseded in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
lasso (2.6.1-3build3) jammy; urgency=medium

  * No-change rebuild to add python3.10.

 -- Matthias Klose <email address hidden>  Sun, 17 Oct 2021 12:21:27 +0200

Available diffs

Superseded in jammy-release
Published in impish-release
Deleted in impish-proposed (Reason: Moved to impish)
lasso (2.6.1-3build1) impish; urgency=medium

  * No-change rebuild to build packages with zstd compression.

 -- Matthias Klose <email address hidden>  Thu, 07 Oct 2021 12:13:46 +0200
Superseded in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
lasso (2.7.0-1) unstable; urgency=medium

  * New upstream release.
  * debian/patches/: remove, all patches are now upstream.

 -- Frederic Peters <email address hidden>  Mon, 16 Aug 2021 18:31:12 +0200
Published in hirsute-updates
Published in hirsute-security
lasso (2.6.1-2ubuntu0.1) hirsute-security; urgency=medium

  * SECURITY UPDATE: unsigned assertions after signed valid assertions
    are honored.
    - d/p/CVE-2021-28091.patch: Fix signature checking on unsigned
      response with multiple assertions
    - CVE-2021-28091

 -- Steve Beattie <email address hidden>  Fri, 28 May 2021 14:26:54 -0700
Published in bionic-updates
Published in bionic-security
lasso (2.5.1-0ubuntu1.2) bionic-security; urgency=medium

  * SECURITY UPDATE: unsigned assertions after signed valid assertions
    are honored.
    - d/p/CVE-2021-28091.patch: Fix signature checking on unsigned
      response with multiple assertions
    - CVE-2021-28091

 -- Steve Beattie <email address hidden>  Fri, 28 May 2021 14:56:48 -0700
Published in groovy-updates
Published in groovy-security
lasso (2.6.0-7ubuntu2.1) groovy-security; urgency=medium

  * SECURITY UPDATE: unsigned assertions after signed valid assertions
    are honored.
    - d/p/CVE-2021-28091.patch: Fix signature checking on unsigned
      response with multiple assertions
    - CVE-2021-28091

 -- Steve Beattie <email address hidden>  Fri, 28 May 2021 14:38:03 -0700
Published in focal-updates
Published in focal-security
lasso (2.6.0-7ubuntu1.2) focal-security; urgency=medium

  * SECURITY UPDATE: unsigned assertions after signed valid assertions
    are honored.
    - d/p/CVE-2021-28091.patch: Fix signature checking on unsigned
      response with multiple assertions
    - CVE-2021-28091

 -- Steve Beattie <email address hidden>  Fri, 28 May 2021 14:49:51 -0700
Superseded in impish-release
Deleted in impish-proposed (Reason: Moved to impish)
lasso (2.6.1-3) unstable; urgency=high

  * debian/patches/0001-Fix-signature-checking-on-unsigned-response-with-mul.patch,
    taken from upstream repository,
    * CVE-2021-28091: Signature checking on unsigned response with multiple
      assertions

 -- Frederic Peters <email address hidden>  Tue, 01 Jun 2021 14:43:55 +0200

Available diffs

Superseded in impish-release
Published in hirsute-release
Deleted in hirsute-proposed (Reason: moved to Release)
lasso (2.6.1-2) unstable; urgency=medium

  * debian/control: add gtk-doc-tools to build-depends, required when running
    autoreconf against autoconf 2.70. (closes: 978846)

 -- Frederic Peters <email address hidden>  Thu, 31 Dec 2020 15:41:40 +0100
Superseded in hirsute-release
Deleted in hirsute-proposed (Reason: moved to Release)
lasso (2.6.1-1build2) hirsute; urgency=medium

  * No-change rebuild to drop python3.8 extensions.

 -- Matthias Klose <email address hidden>  Mon, 07 Dec 2020 18:21:39 +0100

Available diffs

Superseded in hirsute-release
Deleted in hirsute-proposed (Reason: moved to Release)
lasso (2.6.1-1build1) hirsute; urgency=medium

  * No-change rebuild for the perl update.

 -- Matthias Klose <email address hidden>  Mon, 09 Nov 2020 12:16:19 +0100
Superseded in focal-updates
Deleted in focal-proposed (Reason: moved to -updates)
lasso (2.6.0-7ubuntu1.1) focal; urgency=medium

  * d/p/Fix-ECP-signature-not-found-error-when-only-assertion.patch:
    Cherry-picked from upstream bugfix for handling authn responses correctly
    (LP: #1897117).

 -- Chris MacNaughton <email address hidden>  Fri, 25 Sep 2020 14:29:11 +0000
Superseded in hirsute-release
Published in groovy-release
Deleted in groovy-proposed (Reason: moved to Release)
lasso (2.6.0-7ubuntu2) groovy; urgency=medium

  * d/p/Fix-ECP-signature-not-found-error-when-only-assertion.patch:
    Cherry-picked from upstream bugfix for handling authn responses correctly
    (LP: #1897117).

 -- Chris MacNaughton <email address hidden>  Fri, 25 Sep 2020 14:29:11 +0000

Available diffs

Superseded in hirsute-release
Deleted in hirsute-proposed (Reason: moved to Release)
lasso (2.6.1-1) unstable; urgency=medium

  * New upstream release.
  * debian/patches/: remove, all patches are now upstream.

 -- Frederic Peters <email address hidden>  Thu, 23 Apr 2020 20:52:51 +0200
Superseded in groovy-release
Published in focal-release
Deleted in focal-proposed (Reason: moved to Release)
lasso (2.6.0-7ubuntu1) focal; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - d/p/PAOS-Do-not-populate-Destination-attribute.patch: Do not populate
      "Destination" attribute (LP: #1833299)

 -- Corey Bryant <email address hidden>  Wed, 19 Feb 2020 09:54:35 -0500
Superseded in focal-proposed
lasso (2.6.0-2ubuntu3) focal; urgency=medium

  * No-change rebuild to drop python3.7.

 -- Matthias Klose <email address hidden>  Tue, 18 Feb 2020 10:20:19 +0100

Available diffs

Superseded in focal-release
Deleted in focal-proposed (Reason: moved to Release)
lasso (2.6.0-2ubuntu2) focal; urgency=medium

  * No-change rebuild to build with python3.8.

 -- Matthias Klose <email address hidden>  Fri, 18 Oct 2019 18:41:16 +0000

Available diffs

Obsolete in disco-updates
Deleted in disco-proposed (Reason: moved to -updates)
lasso (2.6.0-2ubuntu0.1) disco; urgency=high

  * d/p/PAOS-Do-not-populate-Destination-attribute.patch: Do not populate
    "Destination" attribute (LP: #1833299)

 -- Dmitrii Shcherbakov <email address hidden>  Thu, 04 Jul 2019 18:42:56 -0500
Superseded in bionic-updates
Deleted in bionic-proposed (Reason: moved to -updates)
lasso (2.5.1-0ubuntu1.1) bionic; urgency=high

  * d/p/PAOS-Do-not-populate-Destination-attribute.patch: Do not populate
    "Destination" attribute (LP: #1833299)

 -- Dmitrii Shcherbakov <email address hidden>  Thu, 04 Jul 2019 18:42:56 -0500
Superseded in focal-release
Obsolete in eoan-release
Deleted in eoan-proposed (Reason: moved to release)
lasso (2.6.0-2ubuntu1) eoan; urgency=high

  * d/p/PAOS-Do-not-populate-Destination-attribute.patch: Do not populate
    "Destination" attribute (LP: #1833299)

 -- Dmitrii Shcherbakov <email address hidden>  Thu, 04 Jul 2019 18:42:56 -0500

Available diffs

Superseded in eoan-release
Obsolete in disco-release
Deleted in disco-proposed (Reason: moved to release)
lasso (2.6.0-2build1) disco; urgency=medium

  * No-change rebuild to build without python3.6 support.

 -- Matthias Klose <email address hidden>  Sat, 03 Nov 2018 12:12:24 +0000
Superseded in disco-release
Obsolete in cosmic-release
Deleted in cosmic-proposed (Reason: moved to release)
lasso (2.5.1-0ubuntu2) cosmic; urgency=medium

  * No-change rebuild to build for python3.7.

 -- Matthias Klose <email address hidden>  Thu, 28 Jun 2018 12:36:06 +0000

Available diffs

Superseded in disco-proposed
lasso (2.6.0-2) unstable; urgency=medium

  * d/compat: bump do debhelper level 9.
  * d/control, d/rules: add and use dh-autoreconf.
  * d/watch: add watch file.
  * d/control: bump Standards-Version to 4.1.4 after those changes.
  * d/liblasso3.symbols: add symbols file for liblasso3, imported from Ubuntu,
    thanks to Corey Bryant <email address hidden> (closes: #894296)
  * d/liblasso3.symbols: update for 2.6.0.
  * d/control: add Multi-Arch: same to liblasso-perl.
  * d/control: use proper capitalization for ${misc:Depends}.
  * d/control: bump versions in X-Python-Version and X-Python3-Version.

 -- Frederic Peters <email address hidden>  Fri, 15 Jun 2018 21:33:58 +0200
Superseded in cosmic-release
Published in bionic-release
Superseded in bionic-release
Deleted in bionic-proposed (Reason: moved to release)
lasso (2.5.1-0ubuntu1) bionic; urgency=medium

  * New upstream stable point release.
  * d/p/0001-perl-remove-quotes-from-PERL-V-ccflags-output.patch: Dropped.
    Fixed in upstream stable point release.
  * d/liblasso3.symbols. Add symbols file for liblasso3 shared library.

 -- Corey Bryant <email address hidden>  Mon, 26 Mar 2018 16:03:00 -0400

Available diffs

Superseded in bionic-release
Deleted in bionic-proposed (Reason: moved to release)
lasso (2.5.0-5ubuntu1) bionic; urgency=medium

  * d/control, d/rules: Enable test execution during build.

 -- Corey Bryant <email address hidden>  Mon, 05 Feb 2018 16:20:28 -0500

Available diffs

Superseded in bionic-release
Deleted in bionic-proposed (Reason: moved to release)
lasso (2.5.0-5build5) bionic; urgency=medium

  * No-change rebuild against perlapi-5.26.1

 -- Steve Langasek <email address hidden>  Thu, 02 Nov 2017 05:36:19 +0000

Available diffs

Superseded in bionic-release
Obsolete in artful-release
Deleted in artful-proposed (Reason: moved to release)
lasso (2.5.0-5build4) artful; urgency=medium

  * No-change rebuild to build to drop python3.5.

 -- Matthias Klose <email address hidden>  Sat, 05 Aug 2017 18:24:55 +0000
Superseded in artful-proposed
lasso (2.5.0-5build3) artful; urgency=medium

  * No-change rebuild for perl 5.26.0.

 -- Matthias Klose <email address hidden>  Wed, 26 Jul 2017 19:52:30 +0000

Available diffs

Superseded in artful-release
Deleted in artful-proposed (Reason: moved to release)
lasso (2.5.0-5build2) artful; urgency=medium

  * No change rebuild to add Python 3.6 support.

 -- Michael Hudson-Doyle <email address hidden>  Tue, 16 May 2017 20:17:12 +1200

Available diffs

Superseded in artful-release
Obsolete in zesty-release
Deleted in zesty-proposed (Reason: moved to release)
lasso (2.5.0-5build1) zesty; urgency=medium

  * No-change rebuild for perl 5.24 transition

 -- Iain Lane <email address hidden>  Sun, 23 Oct 2016 12:09:05 +0100
Superseded in zesty-release
Obsolete in yakkety-release
Deleted in yakkety-proposed (Reason: moved to release)
lasso (2.5.0-5) unstable; urgency=medium

  * d/: disable PHP support for now. (closes: #821547, #821683)

 -- Frederic Peters <email address hidden>  Thu, 05 May 2016 11:11:01 +0200
Superseded in yakkety-release
Published in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
lasso (2.5.0-3ubuntu2) xenial; urgency=medium

  * Add build-dependency on dh-autoreconf as php-dev no longer pulls it
    in (LP: #1566404).

 -- Nishanth Aravamudan <email address hidden>  Tue, 05 Apr 2016 15:36:04 -0700
Superseded in xenial-proposed
lasso (2.5.0-3ubuntu1) xenial; urgency=medium

  * Disable PHP bindings as they only support PHP5 (LP: #1566404).

 -- Nishanth Aravamudan <email address hidden>  Tue, 05 Apr 2016 08:27:20 -0700

Available diffs

Superseded in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
lasso (2.5.0-3build1) xenial; urgency=medium

  * No-change rebuild to drop python3.4 support.

 -- Matthias Klose <email address hidden>  Tue, 19 Jan 2016 11:46:20 +0000
Superseded in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
lasso (2.5.0-3) unstable; urgency=medium

  * d/p/0001-perl-remove-quotes-from-PERL-V-ccflags-output.patch: new patch,
    make sure to remove quotes given by "perl -V::ccflags:" as they ultimately
    cause the 32bit builds to fail. (closes: #809759)
    * Thanks to Niko Tyni for the detailed diagnostic.
  * d/rules: enable verbose builds. (closes: #809760)

 -- Frederic Peters <email address hidden>  Mon, 11 Jan 2016 09:16:31 +0100

Available diffs

Superseded in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
lasso (2.5.0-2) unstable; urgency=medium

  * Build against latest Perl release.

 -- Frederic Peters <email address hidden>  Sun, 03 Jan 2016 13:33:18 +0100
Superseded in xenial-proposed
lasso (2.5.0-1build1) xenial; urgency=medium

  * Rebuild for Perl 5.22.1.

 -- Colin Watson <email address hidden>  Fri, 18 Dec 2015 00:26:50 +0000
Superseded in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
lasso (2.5.0-1) unstable; urgency=medium

  * New upstream release.
  * d/control, d/rules: add new package for Python 3 bindings.

 -- Frederic Peters <email address hidden>  Fri, 04 Sep 2015 17:48:04 +0200
Superseded in xenial-release
Obsolete in wily-release
Obsolete in vivid-release
Deleted in vivid-proposed (Reason: moved to release)
lasso (2.4.1-1build1) vivid; urgency=medium

  * No change rebuild against PHP 5.6 (phpapi-20131226).
 -- Robie Basak <email address hidden>   Tue, 27 Jan 2015 15:54:55 +0000
Superseded in vivid-release
Deleted in vivid-proposed (Reason: moved to release)
lasso (2.4.1-1) unstable; urgency=medium


  * New upstream release.
  * d/p/perl-get-required-CFLAGS-from-perl-V-ccflags.patch: merged upstream
  * d/p/Use-INSTALLDIRS-vendor-for-the-Perl-bindings-as-per-.patch: refreshed

 -- Frederic Peters <email address hidden>  Thu, 28 Aug 2014 17:27:48 +0200
Superseded in vivid-release
Obsolete in utopic-release
Deleted in utopic-proposed (Reason: moved to release)
lasso (2.4.0-4build1) utopic; urgency=medium

  * Rebuild for Perl 5.20.0.
 -- Colin Watson <email address hidden>   Wed, 20 Aug 2014 00:19:08 +0100
Superseded in utopic-release
Deleted in utopic-proposed (Reason: moved to release)
lasso (2.4.0-4) unstable; urgency=medium


  * d/p/Use-INSTALLDIRS-vendor-for-the-Perl-bindings-as-per-.patch: use
    INSTALLDIRS=vendor for the Perl bindings, as per the Debian Perl policy.
    (thanks Niko Tyni)
  * debian/rules, debian/liblasso-perl.install: don't hardcode /usr/lib/perl5
    (thanks Niko Tyni, again) (closes: #752703)

 -- Frederic Peters <email address hidden>  Wed, 25 Jun 2014 23:15:03 +0200

Available diffs

Superseded in utopic-release
Deleted in utopic-proposed (Reason: moved to release)
lasso (2.4.0-3) unstable; urgency=medium


  * d/p/perl-get-required-CFLAGS-from-perl-V-ccflags.patch (stolen from git):
    get required CFLAGS from $(perl -V::ccflags:) (closes: #742522)

 -- Frederic Peters <email address hidden>  Tue, 08 Apr 2014 09:29:11 +0200
Superseded in utopic-release
Published in trusty-release
Deleted in trusty-proposed (Reason: moved to release)
lasso (2.4.0-2build1) trusty; urgency=medium

  * No change rebuild for phpapi-20121212+lfs (LFS ABI break on 32-bit
    arches).
 -- Robie Basak <email address hidden>   Wed, 19 Feb 2014 08:20:44 +0000
Superseded in trusty-release
Deleted in trusty-proposed (Reason: moved to release)
lasso (2.4.0-2) unstable; urgency=medium


  * debian/php5-lasso.prerm: fix call to php5dismod. (closes: #734767)

 -- Frederic Peters <email address hidden>  Mon, 13 Jan 2014 11:00:16 +0100

Available diffs

Superseded in trusty-release
Deleted in trusty-proposed (Reason: moved to release)
lasso (2.4.0-1) unstable; urgency=low


  * New upstream version.
  * debian/control, debian/rules: use autoreconf
  * debian/source/version: switch to 3.0 (quilt)

 -- Frederic Peters <email address hidden>  Tue, 07 Jan 2014 13:22:21 +0100

Available diffs

Superseded in trusty-release
Deleted in trusty-proposed (Reason: moved to release)
lasso (2.3.6-3) unstable; urgency=medium


  * Remove double-free in lasso_node_build_deflated_query. (thanks Andjelko
    Horvat, closes: #732543)
  * Enable hardened build flags. (thanks Moritz Muehlenhoff, closes: #667555)
  * debian/php5-lasso.{postinst,prerm}: use php5enmod and php5dismod.
    (closes: #667766)
  * bindings/php5/lasso.ini: change comment marker. (closes: #571736)

 -- Frederic Peters <email address hidden>  Sun, 29 Dec 2013 10:06:47 +0100

Available diffs

Superseded in trusty-release
Deleted in trusty-proposed (Reason: moved to release)
lasso (2.3.6-2.2) unstable; urgency=low


  * Non-maintainer upload.
  * Apply commit a5674b48 from upstream to port to the libxml buffer API.
    Also adopt changes for the Perl binding. libxml stopped to expose the
    internals of xmlOutputBuffer in 2.9. (Closes: #713668)

 -- Sebastian Ramacher <email address hidden>  Tue, 30 Jul 2013 14:19:34 +0200
Superseded in trusty-release
Obsolete in saucy-release
Deleted in saucy-proposed (Reason: moved to release)
lasso (2.3.6-2.1ubuntu1) saucy; urgency=low

  * Resynchronise with Debian.  Remaining changes:
    - Ported to LIBXML2_NEW_BUFFER, fixing FTBFS.

Superseded in saucy-release
Deleted in saucy-proposed (Reason: moved to release)
lasso (2.3.6-2ubuntu2) saucy; urgency=low

  * Rebuild for PHP 5.5.
 -- Colin Watson <email address hidden>   Tue, 16 Jul 2013 02:01:39 +0100

Available diffs

Superseded in saucy-release
Obsolete in raring-release
Deleted in raring-proposed (Reason: moved to release)
lasso (2.3.6-2ubuntu1) raring; urgency=low

  * Ported to LIBXML2_NEW_BUFFER, fixing FTBFS.
 -- Daniel T Chen <email address hidden>   Wed, 24 Apr 2013 20:26:55 -0400

Available diffs

Superseded in raring-release
Obsolete in quantal-release
lasso (2.3.6-2build1) quantal; urgency=low

  * No-change rebuild for phpapi change
 -- Ilya Barygin <email address hidden>   Sat, 30 Jun 2012 13:03:19 +0400
Superseded in quantal-release
lasso (2.3.6-2) unstable; urgency=low


  * Fix building against glib 2.32 (closes: #665565, #666636)

 -- Frederic Peters <email address hidden>  Mon, 02 Apr 2012 17:31:31 +0200
Superseded in quantal-release
Published in precise-release
lasso (2.3.5-4build2) precise; urgency=low

  * Rebuild with fixed Perl 5.14 on amd64.
 -- Colin Watson <email address hidden>   Tue, 15 Nov 2011 17:02:49 +0000

Available diffs

Superseded in precise-release
lasso (2.3.5-4build1) precise; urgency=low

  * Rebuild for Perl 5.14.
 -- Colin Watson <email address hidden>   Tue, 15 Nov 2011 13:28:49 +0000
Superseded in precise-release
lasso (2.3.5-4) unstable; urgency=low
  * Don't force gcc 4.4 anymore; /facepalm. (closes: #635640) -- Frederic Peters <email address hidden>  Thu, 28 Jul 2011 08:16:14 +0200
Superseded in precise-release
Obsolete in oneiric-release
lasso (2.3.5-2ubuntu1) oneiric; urgency=low

  * Drop b-d ongcj.
  * Don't use gcc-4.4 as CC.
 -- Matthias Klose <email address hidden>   Fri, 06 May 2011 19:38:21 +0200

Available diffs

Superseded in oneiric-release
lasso (2.3.5-2build1) oneiric; urgency=low

  * Rebuild for Perl 5.12.
 -- Colin Watson <email address hidden>   Fri, 06 May 2011 17:01:21 +0100

Available diffs

Superseded in oneiric-release
lasso (2.3.5-2) unstable; urgency=low

  * debian/liblasso-perl.install: fixed module name (uppercase L).
    (closes: #622114)
  * debian/liblasso3-dev.install: do not install libtool archive file.
    (closes: #620909, #621560)
  * debian/control.in: add build-dependency on gcc-4.4, to match the gcj
    version that is used.
  * debian/rules:
    + force gcc 4.4, because of gcj 4.4.
    + remove rpath from Lasso.so Perl module.
    + remove obsolete call to dh_python.

Available diffs

Superseded in oneiric-release
Obsolete in natty-release
lasso (2.2.1-4build3) natty; urgency=low

  * No-change rebuild for multiarch libs
 -- Andreas Moog <email address hidden>   Tue, 05 Apr 2011 02:54:08 +0200

Available diffs

Superseded in natty-release
lasso (2.2.1-4build2) natty; urgency=low

  * Rebuild to add support for python 2.7.
 -- Matthias Klose <email address hidden>   Fri, 03 Dec 2010 00:02:41 +0000

Available diffs

Superseded in natty-release
Obsolete in maverick-release
Obsolete in lucid-release
lasso (2.2.1-4build1) lucid; urgency=low

  * No-change rebuild against php5 5.3.
 -- Michael Bienia <email address hidden>   Fri, 12 Mar 2010 16:40:27 +0100

Available diffs

Superseded in lucid-release
lasso (2.2.1-4) unstable; urgency=low

  * debian/control, debian/rules: updated build-depends for recent gcj
    changes, and to use the default gcc version. (Closes: #566895)

Available diffs

Superseded in lucid-release
Obsolete in karmic-release
Obsolete in jaunty-release
lasso (2.2.1-2build1) jaunty; urgency=low

  * No change rebuild to build with Python 2.6.

 -- Alessio Treglia <email address hidden>   Mon, 09 Mar 2009 22:18:41 +0100

Available diffs

Superseded in jaunty-release
lasso (2.2.1-2) unstable; urgency=high

  * Correctly check for signature validity (CVE-2009-0050) (Closes: #511262)

 -- Stefan Lesicnik <email address hidden>   Sun,  25 Jan 2009 01:47:16 +0000

Available diffs

Obsolete in intrepid-updates
Obsolete in intrepid-security
lasso (2.2.0-1ubuntu0.1) intrepid-security; urgency=low

  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

 -- Stefan Lesicnik <email address hidden>   Wed, 14 Jan 2009 19:56:22 +0200
Obsolete in hardy-updates
Obsolete in hardy-security
lasso (2.1.1-2ubuntu1.1) hardy-security; urgency=low

  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

 -- Stefan Lesicnik <email address hidden>   Wed, 14 Jan 2009 20:18:30 +0200
Obsolete in gutsy-updates
Obsolete in gutsy-security
lasso (2.0.0-1ubuntu1.1) gutsy-security; urgency=low

  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

 -- Stefan Lesicnik <email address hidden>   Wed, 14 Jan 2009 20:23:28 +0200
Obsolete in dapper-updates
Obsolete in dapper-security
lasso (0.6.3-4ubuntu1.1) dapper-security; urgency=low

  * SECURITY UPDATE: lasso does not properly check the return value from the
    OpenSSL DSA_verify function (LP: #317181).
    - lasso/xml/tools.c: Correctly check for signature validity.
    - CVE-2009-0050

 -- Stefan Lesicnik <email address hidden>   Wed, 14 Jan 2009 20:26:34 +0200
Superseded in jaunty-release
lasso (2.2.1-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  04 Nov 2008 21:28:35 +0000

Available diffs

Superseded in jaunty-release
Obsolete in intrepid-release
lasso (2.2.0-1) unstable; urgency=low

  * New upstream release.
    * Acknowledge NMU.
    * Fixed missing quotes in configure.in (Closes: #487816)
  * debian/control:
    * Updated package descriptions,
    * Used new Homepage field.
    * Moved liblasso-perl to perl section.
  * debian/rules:
    * remove config.log on clean.
    * remove empty id-wsf include directory.

 -- Stefan Ebner <email address hidden>   Tue,  15 Jul 2008 17:47:41 +0100

Available diffs

Superseded in intrepid-release
lasso (2.1.98-4.1ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable. (LP: #242497) Remaining Ubuntu changes:
    + debian/control:
      - Modify Maintainer value to match DebianMaintainerField spec.
    + configure{,.ac}:
      - Add missing quotes around the value for PHP[45]_LIBS.

Available diffs

Superseded in intrepid-release
Obsolete in hardy-release
lasso (2.1.1-2ubuntu1) hardy; urgency=low

  * Merge from debian unstable (LP: #134095), remaining changes:
    + debian/control:
      - Modify Maintainer value to match DebianMaintainerField spec.
    + configure{,.ac}:
      - Add missing quotes around the value for PHP[45]_LIBS.
  * Fix two lintian warnings:
    + debian/control:
      - liblasso3-dev: Replace ${Source-Version} with ${binary:Version}
    + debian/rules:
      - Don't ignore a make clean error.

175 of 84 results