Ubuntu

Change log for “libapache2-mod-fcgid” package in Ubuntu

129 of 29 results
Published in raring-updates on 2013-10-25
Published in raring-security on 2013-10-25
libapache2-mod-fcgid (1:2.3.7-0ubuntu2.13.04.1) raring-security; urgency=low

  * SECURITY UPDATE: heap buffer overwrite. (LP: #1238242)
    - Add debian/patches/20_CVE-2013-4365.dpatch, patch from upstream.
    - CVE-2013-4365
 -- Felix Geyer <email address hidden>   Fri, 11 Oct 2013 19:18:31 +0200
Published in quantal-updates on 2013-10-25
Published in quantal-security on 2013-10-25
libapache2-mod-fcgid (1:2.3.7-0ubuntu2.12.10.1) quantal-security; urgency=low

  * SECURITY UPDATE: heap buffer overwrite. (LP: #1238242)
    - Add debian/patches/20_CVE-2013-4365.dpatch, patch from upstream.
    - CVE-2013-4365
 -- Felix Geyer <email address hidden>   Fri, 11 Oct 2013 19:44:31 +0200
Published in precise-updates on 2013-10-25
Published in precise-security on 2013-10-25
libapache2-mod-fcgid (1:2.3.6-1.1ubuntu0.1) precise-security; urgency=low

  * SECURITY UPDATE: heap buffer overwrite. (LP: #1238242)
    - Add debian/patches/20_CVE-2013-4365.dpatch, patch from upstream.
    - CVE-2013-4365
 -- Felix Geyer <email address hidden>   Fri, 11 Oct 2013 19:39:49 +0200
Published in trusty-release on 2013-10-18
Published in saucy-release on 2013-10-11
Deleted in saucy-proposed (Reason: moved to release)
libapache2-mod-fcgid (1:2.3.9-1) unstable; urgency=high


  * New upstream release.
    - Fixes CVE-2013-4365: heap buffer overwrite. (Closes: #725942)
  * Further improve the long description. (Closes: #719534)

 -- Felix Geyer <email address hidden>  Thu, 10 Oct 2013 19:49:42 +0200

Available diffs

Superseded in saucy-release on 2013-10-11
Deleted in saucy-proposed on 2013-10-13 (Reason: moved to release)
libapache2-mod-fcgid (1:2.3.7-1) unstable; urgency=low


  * Adopt the package. (Closes: #713917)
  * Switch from cdbs to dh-style rules file.
  * Switch to debhelper compat level 9.
  * Bump Standards-Version to 3.9.4, no changes needed.
  * Improve the short description. (Closes: #664202)
  * Guard AddHandler option in fgcid.conf so it's only used when
    the mime module is laoded. (Closes: #711542)
  * Add Vcs-* headers.

 -- Felix Geyer <email address hidden>  Sat, 10 Aug 2013 11:15:31 +0200

Available diffs

Superseded in saucy-release on 2013-08-11
Deleted in saucy-proposed on 2013-08-12 (Reason: moved to release)
libapache2-mod-fcgid (1:2.3.7-0.1) unstable; urgency=low


  * Non-maintainer upload.
  * New upstream release. (Closes: #689149)
    - Drop 20_honor_FcgidMaxProcessesPerClass_setting.dpatch, applied upstream.
  * Switch from dpatch to source format 3.0 (quilt). (Closes: #664353)
  * Fix the watch file, thanks to Bart Martens.
  * Fix building twice in a row. (Closes: #693625)
    - Call make distclean.

 -- Felix Geyer <email address hidden>  Wed, 05 Jun 2013 22:14:50 +0200
Superseded in saucy-release on 2013-07-18
Published in raring-release on 2012-10-18
Published in quantal-release on 2012-08-20
libapache2-mod-fcgid (1:2.3.7-0ubuntu2) quantal; urgency=low

  * Pass build flags as EXTRA_$FLAGS so we don't override the default ones.
 -- Felix Geyer <email address hidden>   Mon, 20 Aug 2012 13:55:53 +0200
Superseded in quantal-release on 2012-08-20
libapache2-mod-fcgid (1:2.3.7-0ubuntu1) quantal; urgency=low

  * New upstream release. (LP: #1038877)
  * Drop 20_honor_FcgidMaxProcessesPerClass_setting.dpatch, applied upstream.
  * Pass build flags to the upstream build system.
 -- Felix Geyer <email address hidden>   Mon, 20 Aug 2012 13:41:21 +0200
Published in oneiric-updates on 2012-03-20
Published in oneiric-security on 2012-03-20
libapache2-mod-fcgid (1:2.3.6-1+squeeze1build0.11.10.1) oneiric-security; urgency=low

  * fake sync from Debian

Obsolete in natty-updates on 2013-06-04
Obsolete in natty-security on 2013-06-04
libapache2-mod-fcgid (1:2.3.6-1+squeeze1build0.11.04.1) natty-security; urgency=low

  * fake sync from Debian

Superseded in quantal-release on 2012-08-20
Published in precise-release on 2012-03-19
libapache2-mod-fcgid (1:2.3.6-1.1) unstable; urgency=low


  * Non-maintainer upload.
  * import r1037727 from upstream to fix vhost-specific process controls
     (Closes: #615814)

 -- Daniel Kahn Gillmor <email address hidden>  Wed, 07 Mar 2012 17:00:08 -0500
Published in hardy-updates on 2011-01-10
Published in hardy-security on 2011-01-10
libapache2-mod-fcgid (1:2.2-1ubuntu0.8.04.1) hardy-security; urgency=low

  * SECURITY UPDATE: possible stack buffer overwrite (LP: #698060)
    - fcgid_bucket.c: patch from upstream
    - CVE-2010-3872
 -- Felix Geyer <email address hidden>   Thu, 06 Jan 2011 12:49:03 +0100
Obsolete in karmic-updates on 2013-03-04
Obsolete in karmic-security on 2013-03-04
libapache2-mod-fcgid (1:2.2-1ubuntu0.9.10.1) karmic-security; urgency=low

  * SECURITY UPDATE: possible stack buffer overwrite (LP: #698060)
    - fcgid_bucket.c: patch from upstream
    - CVE-2010-3872
 -- Felix Geyer <email address hidden>   Thu, 06 Jan 2011 12:57:47 +0100
Obsolete in maverick-updates on 2013-03-05
Obsolete in maverick-security on 2013-03-05
libapache2-mod-fcgid (1:2.3.5-2ubuntu0.1) maverick-security; urgency=low

  * SECURITY UPDATE: possible stack buffer overwrite (LP: #698060)
    - debian/patches/CVE-2010-3872.patch: patch from upstream
    - CVE-2010-3872
 -- Felix Geyer <email address hidden>   Thu, 06 Jan 2011 13:12:50 +0100
Published in lucid-updates on 2011-01-10
Published in lucid-security on 2011-01-10
libapache2-mod-fcgid (1:2.3.4-2ubuntu0.2) lucid-security; urgency=low

  * SECURITY UPDATE: possible stack buffer overwrite (LP: #698060)
    - modules/fcgid/fcgid_bucket.c: patch from upstream
    - CVE-2010-3872
 -- Felix Geyer <email address hidden>   Thu, 06 Jan 2011 13:04:02 +0100
Superseded in precise-release on 2012-03-19
Published in oneiric-release on 2011-04-28
Obsolete in natty-release on 2013-06-04
libapache2-mod-fcgid (1:2.3.6-1) unstable; urgency=low

  * New upstream release (Closes: #595276)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  16 Nov 2010 10:05:52 +0000

Available diffs

Superseded in natty-release on 2010-11-16
Obsolete in maverick-release on 2013-03-05
libapache2-mod-fcgid (1:2.3.5-2) unstable; urgency=low

  * Fix build problem with new ash (Closes: #583025)
    Thanks Hideki Yamane and Igor Galić.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  20 Jun 2010 03:01:44 +0100

Available diffs

Superseded in lucid-updates on 2011-01-10
Deleted in lucid-proposed on 2011-01-11 (Reason: moved to -updates)
libapache2-mod-fcgid (1:2.3.4-2ubuntu0.1) lucid-proposed; urgency=low

  * Add 30_fix-request-body-truncation.dpatch to fix corruption of requests
    that exceed the FcgidMaxRequestInMem size. (LP: #573591)
 -- Felix Geyer <email address hidden>   Sun, 16 May 2010 13:07:54 +0200

Available diffs

Superseded in maverick-release on 2010-06-20
libapache2-mod-fcgid (1:2.3.5-1) unstable; urgency=medium

  * New upstream release
  * Change default shared memory path to /var/lib/apache2/fcgid/shm.
  * Update watch file.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:53:30 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Published in lucid-release on 2010-02-04
libapache2-mod-fcgid (1:2.3.4-2) unstable; urgency=medium

  * Fix segfault with empty outout from fcgi process (Closes: #468559)
  * Add -dbg package
  * Update package description from official site.

Available diffs

Superseded in lucid-release on 2010-02-04
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Published in hardy-release on 2007-10-23
libapache2-mod-fcgid (1:2.2-1) unstable; urgency=medium

  * New upstream release (Closes: #446585)
  * fixed debian/watch to new version (Closes: #446586)

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
libapache2-mod-fcgid (1:2.1-2) unstable; urgency=medium

  * Add proper dependency by shlibs:Depends (Closes: #427046, #427120)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  11 Jun 2007 18:43:39 +0100
Superseded in gutsy-release on 2007-06-11
libapache2-mod-fcgid (1:2.1-1) unstable; urgency=low

  * New upstream release (Closes: #420910)
  * Add SharememPath to default config. Thanks to Philipp Wollermann.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  15 May 2007 13:55:47 +0100
Superseded in gutsy-release on 2007-05-15
libapache2-mod-fcgid (1:1.10-2) unstable; urgency=high

  * rewind upstream version temporary for etch release. (Related: #401938)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 Apr 2007 00:15:02 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
libapache2-mod-fcgid (2.0-1) unstable; urgency=high

  * New upstream release
  * Apply NMU Update (Closes: #394473)

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
libapache2-mod-fcgid (1.10-1) unstable; urgency=low

  * New upstream release
  * Update app kill patch: Rename Directive ErrorTimeout -> ShutdownTimeout

Superseded in edgy-release on 2006-07-10
libapache2-mod-fcgid (1.09-1) unstable; urgency=low

  * New upstream release (Closes: #361975, #361579, #345752)
  * Set "IPCConnectTimeout 20" in default config file (Closes: #352498)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 14:31:57 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
libapache2-mod-fcgid (1.07-1) unstable; urgency=low


  * New upstream release (Closes: #339604)
  * Unnecessary dependency has been removed. Those provied from
    apache2-common. (Closes: #334011)

 -- Tatsuki Sugiura <email address hidden>  Mon, 21 Nov 2005 05:55:39 +0900
Obsolete in breezy-release on 2008-03-25
Obsolete in hoary-release on 2008-03-19
libapache2-mod-fcgid (1.05-1) unstable; urgency=low


  * New upstream release

 -- Tatsuki Sugiura <email address hidden>  Thu,  7 Apr 2005 16:31:07 +0900
129 of 29 results