Change log for libapt-pkg-perl package in Ubuntu

146 of 46 results
Published in eoan-release on 2019-07-04
Deleted in eoan-proposed (Reason: moved to release)
libapt-pkg-perl (0.1.36) unstable; urgency=medium

  * Switch to range-based for loops.
  * Updates for apt 1.9.0, with thanks to Julian Andres Klode for the
    detailed report (closes: #930653).
    - Remove obsolete IsOk method from PkgFileIterator.
    - Remove obsolete GetMatch method from Policy.
    - Use string and vector from namespace std explicitly (previously
      picked up through a similar declaration in an apt-pkg header).
    - Remove obsolete GetPriority(Package) method from Policy.
    - Support old ABI for AptPkg::Source->find Files attribute.

 -- Brendan O'Dea <email address hidden>  Tue, 18 Jun 2019 13:14:33 +1000
Superseded in eoan-release on 2019-07-04
Deleted in eoan-proposed on 2019-07-05 (Reason: moved to release)
libapt-pkg-perl (0.1.34ubuntu1) eoan; urgency=medium

  * Port to apt 1.9.0

 -- Julian Andres Klode <email address hidden>  Mon, 17 Jun 2019 18:42:22 +0200
Superseded in eoan-proposed on 2019-06-17
libapt-pkg-perl (0.1.34build2) eoan; urgency=high

  * No change rebuild against apt 1.9.0.

 -- Julian Andres Klode <email address hidden>  Mon, 17 Jun 2019 13:09:25 +0200

Available diffs

Superseded in eoan-release on 2019-06-26
Published in disco-release on 2018-11-08
Deleted in disco-proposed (Reason: moved to release)
libapt-pkg-perl (0.1.34build1) disco; urgency=medium

  * No-change rebuild for the perl 5.28 transition.

 -- Adam Conrad <email address hidden>  Fri, 02 Nov 2018 18:09:02 -0600

Available diffs

Superseded in disco-release on 2018-11-08
Published in cosmic-release on 2018-05-05
Deleted in cosmic-proposed (Reason: moved to release)
libapt-pkg-perl (0.1.34) unstable; urgency=medium

  * Update debhelper version in Build-Depends.
  * Move repository to salsa.debian.org and update Vcs control fields.
  * Update standards version to 4.1.4.

 -- Brendan O'Dea <email address hidden>  Tue, 17 Apr 2018 22:54:17 +1000

Available diffs

Superseded in cosmic-release on 2018-05-05
Published in bionic-release on 2017-11-22
Deleted in bionic-proposed (Reason: moved to release)
libapt-pkg-perl (0.1.33build1) bionic; urgency=medium

  * No-change rebuild against perlapi-5.26.1

 -- Steve Langasek <email address hidden>  Thu, 02 Nov 2017 05:39:35 +0000

Available diffs

Superseded in bionic-release on 2017-11-22
Published in artful-release on 2017-08-19
Deleted in artful-proposed (Reason: moved to release)
libapt-pkg-perl (0.1.33) unstable; urgency=medium

  * Fix EXTEND size for Files field of source records: was extending by
    four rather than two.  Presumably a mistake from when source records
    were added.  It seems likely that I was initally going to add Files
    and Files2 before realising that Files2 was a superset of Files.
  * Update debian policy version to 4.0.1.
  * Use debhelper v10.
  * Add AsStr property for sources (closes: #872391).
  * Update Vcs-Browser.

 -- Brendan O'Dea <email address hidden>  Sat, 19 Aug 2017 00:19:59 +1000
Superseded in artful-release on 2017-08-19
Deleted in artful-proposed on 2017-08-20 (Reason: moved to release)
libapt-pkg-perl (0.1.32build1) artful; urgency=medium

  * No-change rebuild for perl 5.26.0.

 -- Matthias Klose <email address hidden>  Wed, 26 Jul 2017 20:03:54 +0000

Available diffs

Superseded in artful-release on 2017-08-10
Deleted in artful-proposed on 2017-08-11 (Reason: moved to release)
libapt-pkg-perl (0.1.32) unstable; urgency=medium

  * Update copyright year.

 -- Brendan O'Dea <email address hidden>  Sun, 26 Mar 2017 20:47:23 +1100

Available diffs

Superseded in artful-release on 2017-04-30
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
libapt-pkg-perl (0.1.30) unstable; urgency=medium

  * Use dpkg-buildflags when building (closes: #841702).
  * Fix t/03_cache.t: status path in files may now be absolute.
  * AptPkg::Source now requires _system to be initialised.
  * Multi-Arch now uses "No" rather than "None".
  * Use FileSize rather than deprecated Size attribute (although the Perl
    API remains unchanged: the hash key is still "Size").
  * Remove use of deprecated Section attribute, taking the value from
    VersionList.
  * Include all included hashes, and stop using deprecated MD5Hash
    attribute.
  * Update XS version and copyright year.
  * Update debhelper compatibity to v9.
  * Remove some compiler warnings.

 -- Brendan O'Dea <email address hidden>  Sun, 23 Oct 2016 20:58:15 +1100
Superseded in zesty-release on 2016-11-01
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-01-06
Deleted in xenial-proposed (Reason: moved to release)
libapt-pkg-perl (0.1.29build7) xenial; urgency=medium

  * Rebuild for Perl 5.22.1.

 -- Colin Watson <email address hidden>  Thu, 17 Dec 2015 15:08:47 +0000

Available diffs

Superseded in xenial-release on 2016-01-06
Deleted in xenial-proposed on 2016-01-08 (Reason: moved to release)
libapt-pkg-perl (0.1.29build6) xenial; urgency=high

  * No change rebuild against libapt-pkg5.0 / libapt-inst2.0 on s390x.

 -- Dimitri John Ledkov <email address hidden>  Wed, 09 Dec 2015 17:12:37 +0000
Superseded in xenial-proposed on 2015-12-09
libapt-pkg-perl (0.1.29build5) xenial; urgency=medium

  * No-change rebuild against libapt-pkg5.0

 -- Michael Vogt <email address hidden>  Fri, 20 Nov 2015 12:22:02 +0100

Available diffs

Superseded in xenial-release on 2015-12-10
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
libapt-pkg-perl (0.1.29build4) wily; urgency=medium

  * No-change rebuild against libapt-pkg4.16

 -- Michael Vogt <email address hidden>  Mon, 05 Oct 2015 16:07:09 +0200

Available diffs

Superseded in wily-release on 2015-10-05
Deleted in wily-proposed on 2015-10-07 (Reason: moved to release)
libapt-pkg-perl (0.1.29build3) wily; urgency=medium

  * No-change rebuild against libapt-pkg4.16

 -- Steve Langasek <email address hidden>  Fri, 14 Aug 2015 17:56:15 +0000
Superseded in wily-release on 2015-08-16
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
libapt-pkg-perl (0.1.29build2) utopic; urgency=medium

  * Rebuild for Perl 5.20.0.
 -- Colin Watson <email address hidden>   Tue, 19 Aug 2014 17:48:24 +0100
Superseded in utopic-release on 2014-08-27
Published in trusty-release on 2013-10-24
Deleted in trusty-proposed (Reason: moved to release)
libapt-pkg-perl (0.1.29build1) devel; urgency=low

  * Rebuild for Perl 5.18.
 -- Colin Watson <email address hidden>   Sun, 20 Oct 2013 22:51:42 +0100

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libapt-pkg-perl (0.1.29) unstable; urgency=low


  * Update release years in debian/copyright.
  * Update Copyright to GPLv3.
  * Re-instate accidentally dropped Size and InstalledSize fields, and
    update test to ensure they exist.  Thanks to Kevin Ryde for reporting
    the issue and for spelunking the git repository to find the problem
    change (closes: #712613).

 -- Brendan O'Dea <email address hidden>  Wed, 19 Jun 2013 00:31:45 +1000

Available diffs

Superseded in saucy-release on 2013-06-19
Deleted in saucy-proposed on 2013-06-20 (Reason: moved to release)
libapt-pkg-perl (0.1.28) unstable; urgency=low


  * Whitespace cleanup.
  * More updates for multi-arch support:
    - Add is_multi_arch and native_arch methods to AptPkg::Cache.
    - Add FullName, ShortName and Arch fields to AptPkg::Cache::Package.
    - Change AptPkg::Cache::Iter to return FullName (including arch)
      rather than Name.
    - Update cache test to check for new fields.
    Thanks to Andrew Ayer for identifying the problem (closes: #707142).
  * Bump file versions.

 -- Brendan O'Dea <email address hidden>  Sat, 11 May 2013 00:25:16 +1000

Available diffs

Superseded in saucy-release on 2013-05-11
Deleted in saucy-proposed on 2013-05-12 (Reason: moved to release)
libapt-pkg-perl (0.1.27) unstable; urgency=low


  * Update test files with to include multi-arch, translations and inline
    signed Release files.
  * Remove very obsolete, rarely updated README file.
  * Add support for translated descriptions (closes: #701899).

 -- Brendan O'Dea <email address hidden>  Fri, 01 Mar 2013 15:28:53 +1100

Available diffs

Superseded in saucy-release on 2013-04-28
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libapt-pkg-perl (0.1.26) unstable; urgency=low


  * Update MANIFEST.
  * Switch to non-deprecated pkgCacheFile::Open method.
  * Remove old CVS keywords.
  * Drop Architecture from pkgCache::PkgFileIterator as this field is no
    longer populated by debListParser::LoadReleaseInfo().

 -- Brendan O'Dea <email address hidden>  Tue, 27 Mar 2012 22:41:35 +1100
Superseded in quantal-release on 2012-05-01
Published in precise-release on 2012-01-30
libapt-pkg-perl (0.1.25build2) precise; urgency=low

  * rebuild against the latest libapt
 -- Michael Vogt <email address hidden>   Mon, 30 Jan 2012 14:09:18 +0100

Available diffs

Superseded in precise-release on 2012-01-30
libapt-pkg-perl (0.1.25build1) precise; urgency=low

  * Rebuild for Perl 5.14.
 -- Colin Watson <email address hidden>   Tue, 15 Nov 2011 14:48:40 +0000

Available diffs

Superseded in precise-release on 2011-11-15
libapt-pkg-perl (0.1.25) unstable; urgency=low

  * Update Vcs-Git and Vcs-Browser fields.
  * Update standards-version to 3.9.2:
    - switch to debhelper v8, adding debian/compat
    - use dh_prep rather than dh_clean -k
    - add ${misc:Depends}
    - add build-arch and build-indep targets
    - conditionally "make realclean" rather than supressing errors
    - use DESTDIR, rather than PREFIX in install rules
    - switch to "3.0 (Native)" source format
  * Apply patch from Kevin Lyda to fix a number of misspellings in the
    comments and documentation.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  19 Oct 2011 09:19:45 +0000

Available diffs

Superseded in precise-release on 2011-10-19
Obsolete in oneiric-release on 2015-04-24
libapt-pkg-perl (0.1.24build3) oneiric; urgency=low

  * rebuild against latest libapt
 -- Michael Vogt <email address hidden>   Mon, 08 Aug 2011 12:09:06 +0200

Available diffs

Superseded in oneiric-release on 2011-08-08
libapt-pkg-perl (0.1.24build2) oneiric; urgency=low

  * Rebuild for Perl 5.12.
 -- Colin Watson <email address hidden>   Sat, 07 May 2011 01:12:04 +0100

Available diffs

Superseded in oneiric-release on 2011-05-07
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
libapt-pkg-perl (0.1.24build1) maverick; urgency=low

  * rebuild against latest libapt
 -- Michael Vogt <email address hidden>   Thu, 29 Jul 2010 13:10:42 +0200

Available diffs

Superseded in maverick-release on 2010-07-30
Obsolete in lucid-release on 2016-10-26
libapt-pkg-perl (0.1.24) unstable; urgency=low

  * Fix Vcs-Browser control field.
  * Create empty t/cache/etc/preferences.d directory to hush noisy test.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  05 Nov 2009 06:03:52 +0000

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
libapt-pkg-perl (0.1.23build1) karmic; urgency=low

  * rebuild against latest libapt

 -- Michael Vogt <email address hidden>   Fri, 25 Sep 2009 23:42:16 +0200

Available diffs

Superseded in karmic-release on 2009-09-28
Superseded in karmic-release on 2009-06-16
libapt-pkg-perl (0.1.23) unstable; urgency=low

  * Move repository to git://git.debian.org/users/bod/libapt-pkg-perl.git
  * Apply patch from Kevin Ryde to add Size/InstalledSize (closes: #522835).
  * Use pre-increment for iterator objects.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 00:16:36 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
libapt-pkg-perl (0.1.22build2) jaunty; urgency=low

  * rebuild against latest apt

 -- Michael Vogt <email address hidden>   Mon, 09 Feb 2009 16:05:24 +0100

Available diffs

Superseded in jaunty-release on 2009-02-10
Obsolete in intrepid-release on 2013-02-20
libapt-pkg-perl (0.1.22build1) intrepid; urgency=low

  * Rebuild against libapt-pkg-libc6.8-6-4.6 (LP: #243537).

 -- Luca Falavigna <email address hidden>   Sat, 28 Jun 2008 13:46:13 +0200

Available diffs

Superseded in intrepid-release on 2008-06-28
libapt-pkg-perl (0.1.22) unstable; urgency=low

  * Fix typo in AptPkg::Cache::Version DependsList docs (closes: #461553).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:12:23 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
libapt-pkg-perl (0.1.21build3) hardy; urgency=low

  * rebuild against the latest apt

 -- Michael Vogt <email address hidden>   Thu, 13 Dec 2007 16:51:38 +0100
Superseded in hardy-release on 2007-12-13
Obsolete in gutsy-release on 2011-09-16
libapt-pkg-perl (0.1.21build2) gutsy; urgency=low

  * rebuild against latest apt

 -- Michael Vogt <email address hidden>   Fri, 03 Aug 2007 22:13:21 +0200
Superseded in gutsy-release on 2007-08-03
libapt-pkg-perl (0.1.21build1) gutsy; urgency=low

  * Rebuild against libapt-pkg-libc6.6-6-4.4.

 -- Colin Watson <email address hidden>   Mon, 09 Jul 2007 11:29:10 +0100
Superseded in gutsy-release on 2007-07-09
libapt-pkg-perl (0.1.21) unstable; urgency=low

  * Remove obsolete _iter method from AptPkg/hash.pm .
  * Use typemap for methods returning objects rather than calling
    sv_setref_pv() manually.

  * Tidy up parented<> class handling.
  * Implement pkgPolicy interface as AptPkg::Policy (closes: #243125).

 -- Michael Bienia <email address hidden>   Fri,  29 Jun 2007 11:08:25 +0100
Superseded in gutsy-release on 2007-06-29
libapt-pkg-perl (0.1.20ubuntu5) gutsy; urgency=low

  * rebuild against the latest apt
  * bump build-depends

 -- Michael Vogt <email address hidden>   Tue, 19 Jun 2007 11:15:24 +0200
Superseded in gutsy-release on 2007-06-19
Obsolete in feisty-release on 2009-08-20
libapt-pkg-perl (0.1.20ubuntu4) feisty; urgency=low

  * rebuild against the latest apt

 -- Michael Vogt <email address hidden>   Mon, 26 Feb 2007 14:59:09 +0100
Superseded in feisty-release on 2007-02-26
libapt-pkg-perl (0.1.20ubuntu3) feisty; urgency=low

  * rebuild against the latest apt

 -- Michael Vogt <email address hidden>   Tue,  6 Feb 2007 18:55:43 +0100
Superseded in feisty-release on 2007-02-06
Obsolete in edgy-release on 2008-06-19
libapt-pkg-perl (0.1.20ubuntu2) edgy; urgency=low

  * Rebuild to remove libapt-pkg-libc6.4-6-3.50 dependancy.

 -- Anthony Mercatante <email address hidden>   Fri, 18 Aug 2006 15:33:43 +0200
Superseded in edgy-release on 2006-08-18
libapt-pkg-perl (0.1.20ubuntu1) edgy; urgency=low

  * Merge from debian unstable.
  * build-dep on latest apt

Superseded in edgy-release on 2006-07-04
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
libapt-pkg-perl (0.1.18ubuntu1) dapper; urgency=low


  * rebuild against latest apt

 -- Michael Vogt <email address hidden>  Fri, 25 Nov 2005 14:51:01 +0100
Obsolete in breezy-release on 2008-03-25
libapt-pkg-perl (0.1.15ubuntu2) breezy; urgency=low


  * rebuild against the latest apt

 -- Michael Vogt <email address hidden>  Mon, 15 Aug 2005 23:43:37 +0200
Obsolete in hoary-release on 2008-03-19
libapt-pkg-perl (0.1.13ubuntu3) hoary; urgency=low


  * rebuild against apt-0.6.31

 -- Michael Vogt <email address hidden>  Mon,  7 Feb 2005 13:26:14 +0100
Obsolete in warty-release on 2008-01-09
libapt-pkg-perl (0.1.12) unstable; urgency=low


  * Use enumerated constants in a numeric context for SelectedState,
    CurrentState and InstState.  Provide a string version for
    BuildDepends operators.  Closes: #227642.

 -- Brendan O'Dea <email address hidden>  Sun, 20 Jun 2004 22:19:46 +1000
146 of 46 results