libapt-pkg-perl 0.1.36 source package in Ubuntu

Changelog

libapt-pkg-perl (0.1.36) unstable; urgency=medium

  * Switch to range-based for loops.
  * Updates for apt 1.9.0, with thanks to Julian Andres Klode for the
    detailed report (closes: #930653).
    - Remove obsolete IsOk method from PkgFileIterator.
    - Remove obsolete GetMatch method from Policy.
    - Use string and vector from namespace std explicitly (previously
      picked up through a similar declaration in an apt-pkg header).
    - Remove obsolete GetPriority(Package) method from Policy.
    - Support old ABI for AptPkg::Source->find Files attribute.

 -- Brendan O'Dea <email address hidden>  Tue, 18 Jun 2019 13:14:33 +1000

Upload details

Uploaded by:
Brendan O'Dea on 2019-06-23
Uploaded to:
Sid
Original maintainer:
Brendan O'Dea
Architectures:
any
Section:
perl
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Eoan release on 2019-07-04 main perl

Downloads

File Size SHA-256 Checksum
libapt-pkg-perl_0.1.36.dsc 1.6 KiB 8ba34b7c33d363042a4c62a956e7403c81b92cfd3ab5e60cc8e30aa5a0b9de2e
libapt-pkg-perl_0.1.36.tar.xz 41.6 KiB 714aa468e1303e2460ea82062d50cc8bc301d4882b8f7091cb7566546ae1749b

No changes file available.

Binary packages built by this source

libapt-pkg-perl: Perl interface to libapt-pkg

 A Perl interface to APT's libapt-pkg which provides modules for configuration
 file/command line parsing, version comparison, inspection of the binary
 package cache and source package details.

libapt-pkg-perl-dbgsym: debug symbols for libapt-pkg-perl