libarchive 2.8.0-2ubuntu0.1 source package in Ubuntu

Changelog

libarchive (2.8.0-2ubuntu0.1) lucid-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via iso9660 overflows
    - debian/patches/CVE-2011-1777.patch: correctly fail on out of memory
      conditions in libarchive/archive_read_support_format_iso9660.c.
    - CVE-2011-1777
  * SECURITY UPDATE: arbitrary code execution via tar overflows
    - debian/patches/CVE-2011-1778.patch: correctly fail on out of memory
      conditions in libarchive/archive_read_support_format_tar.c
    - CVE-2011-1778
 -- Marc Deslauriers <email address hidden>   Fri, 09 Dec 2011 15:25:53 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2011-12-12
Uploaded to:
Lucid
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
libarchive_2.8.0.orig.tar.gz 1.4 MiB e5be324c94e885e449b8ffb30a843372d557966547efff3f1d5f69eb5a119769
libarchive_2.8.0-2ubuntu0.1.debian.tar.gz 13.7 KiB 55655ec63fe54fb9411bb2a4e352503c867c2b762e02016fe7cf10aab346a2a8
libarchive_2.8.0-2ubuntu0.1.dsc 2.1 KiB 25a146f192da9c0fede8715c8678ae79bf633f37b26c969f56a962aba2f955d9

View changes file

Binary packages built by this source

bsdcpio: No summary available for bsdcpio in ubuntu lucid.

No description available for bsdcpio in ubuntu lucid.

bsdtar: No summary available for bsdtar in ubuntu lucid.

No description available for bsdtar in ubuntu lucid.

libarchive-dev: No summary available for libarchive-dev in ubuntu lucid.

No description available for libarchive-dev in ubuntu lucid.

libarchive1: No summary available for libarchive1 in ubuntu lucid.

No description available for libarchive1 in ubuntu lucid.