libarchive 2.8.4-1ubuntu0.11.04.1 source package in Ubuntu

Changelog

libarchive (2.8.4-1ubuntu0.11.04.1) natty-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via iso9660 overflows
    - debian/patches/CVE-2011-1777.patch: correctly fail on out of memory
      conditions in libarchive/archive_read_support_format_iso9660.c.
    - CVE-2011-1777
  * SECURITY UPDATE: arbitrary code execution via tar overflows
    - debian/patches/CVE-2011-1778.patch: correctly fail on out of memory
      conditions in libarchive/archive_read_support_format_tar.c
    - CVE-2011-1778
 -- Marc Deslauriers <email address hidden>   Fri, 09 Dec 2011 15:22:52 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2011-12-12
Uploaded to:
Natty
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
libarchive_2.8.4.orig.tar.gz 1.4 MiB 83b237a542f27969a8d68ac217dc3796
libarchive_2.8.4-1ubuntu0.11.04.1.debian.tar.gz 15.7 KiB dda035c0e08810638dcc0388964a3c90
libarchive_2.8.4-1ubuntu0.11.04.1.dsc 2.1 KiB 5fab822cad76e1c3f67a3f66d77c08db

View changes file

Binary packages built by this source

bsdcpio: No summary available for bsdcpio in ubuntu natty.

No description available for bsdcpio in ubuntu natty.

bsdtar: No summary available for bsdtar in ubuntu natty.

No description available for bsdtar in ubuntu natty.

libarchive-dev: No summary available for libarchive-dev in ubuntu natty.

No description available for libarchive-dev in ubuntu natty.

libarchive1: No summary available for libarchive1 in ubuntu natty.

No description available for libarchive1 in ubuntu natty.