Change log for libconfig-inifiles-perl package in Ubuntu

130 of 30 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-01-19
Deleted in disco-proposed (Reason: moved to release)
libconfig-inifiles-perl (3.000001-1) unstable; urgency=medium

  [upstream]
  * New release.

  [ Peter Pentchev ]
  * Declare compliance with Debian Policy 4.3.0 with no changes.

 -- Peter Pentchev <email address hidden>  Wed, 16 Jan 2019 13:14:40 +0200

Available diffs

Superseded in disco-release on 2019-01-19
Deleted in disco-proposed on 2019-01-20 (Reason: moved to release)
libconfig-inifiles-perl (3.000000-1) unstable; urgency=medium

  [ upstream ]
  * New release.

  [ gregor herrmann ]
  * debian/*: update URLs from {search,www}.cpan.org to MetaCPAN.

  [ Peter Pentchev ]
  * Declare compliance with Policy 4.2.1.

  [ Jonas Smedegaard ]
  * Simplify rules:
    + Drop get-orig-source target: Use gbp import-orig --uscan.
    + Stop resolve build-dependencies in rules file.
    + Do copyright-check in maintainer script (not during build).
      Stop build-depend on licensecheck.
    + Use short-form dh sequencer (not cdbs).
      Stop build-depend on cdbs.
  * Wrap and sort control file.
  * Stop build-depend on dh-buildinfo.
  * Update git-buildpackage config: Filter any .gitignore file.
  * Update watch file:
    + Watch only MetaCPAN URL.
    + Mention gbp --uscan in usage comment.
    + Use substitution strings.
  * Drop obsolete lintian override regarding debhelper 9.
  * Tighten lintian overrides regarding License-Reference.
  * Fix avoid capitalize short description.
  * Update copyright info:
    + List issue tracker as preferred form of contact.
    + Add alternate source URLs.
    + Strip needless copyright signs.
    + Extend coverage of packaging.
    + Drop License field in header section.

 -- Jonas Smedegaard <email address hidden>  Sat, 03 Nov 2018 20:22:24 +0100

Available diffs

Superseded in disco-release on 2018-11-10
Published in cosmic-release on 2018-05-14
Deleted in cosmic-proposed (Reason: moved to release)
libconfig-inifiles-perl (2.98-1) unstable; urgency=medium

  [ Damyan Ivanov ]
  * change Priority from 'extra' to 'optional'

  [ Salvatore Bonaccorso ]
  * Update Vcs-* headers for switch to salsa.debian.org

  [ Peter Pentchev ]
  * Declare compliance with Policy 4.1.4 with no changes.
  * Drop trailing whitespace from old changelog entries.
  * Reflect the changes in debian/control.in.
  * Rules-Requires-Root: no
  * New upstream version:
    - reuse sessions in FETCH.  Closes: #849298
  * Use my Debian e-mail address.
  * Use the HTTPS scheme for the www.cpan.org URL.

 -- Peter Pentchev <email address hidden>  Mon, 14 May 2018 14:01:29 +0300

Available diffs

Superseded in cosmic-release on 2018-05-14
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
libconfig-inifiles-perl (2.94-1) unstable; urgency=medium

  * New upstream release:
    - drop the typos patch, integrated upstream
    - update the upstream repository location in the metadata file -
      moved to GitHub
  * Add myself to the list of uploaders.
  * Add a License line to the copyright file's header, too.

 -- Peter Pentchev <email address hidden>  Wed, 30 Nov 2016 11:04:04 +0200

Available diffs

Superseded in zesty-release on 2016-12-01
Deleted in zesty-proposed on 2016-12-02 (Reason: moved to release)
libconfig-inifiles-perl (2.93-1) unstable; urgency=medium

  * Team upload.

  [ gregor herrmann ]
  * Remove Jonathan Yu from Uploaders. Thanks for your work!

  [ Peter Pentchev ]
  * Catch up with the renamed Lintian override for the debhelper version.
  * Switch various upstream and Debian URLs to the HTTPS scheme.
  * Use MetaCPAN as the upstream homepage, remove the references to
    SourceForge.
  * Add the typos patch to correct some errors.
  * New upstream release:
    - update the upstream copyright information

 -- Peter Pentchev <email address hidden>  Sun, 27 Nov 2016 19:39:43 +0200

Available diffs

Superseded in zesty-release on 2016-11-30
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
libconfig-inifiles-perl (2.89-1) unstable; urgency=medium

  * Team upload

  * Add debian/upstream/metadata
  * Import upstream version 2.89 (Closes: #787079)
  * Declare compliance with Debian Policy 3.9.8
  * Mark package autopkgtest-able

 -- Florian Schlichting <email address hidden>  Tue, 03 May 2016 21:30:07 +0200

Available diffs

Superseded in yakkety-release on 2016-05-04
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
libconfig-inifiles-perl (2.88-1) unstable; urgency=medium

  [ upstream ]
  * New release.
    + Add a LICENSE file and section.
    + Minimum version is now perl-5.8.0.
    + Fix to properly update while using _write_config_with_a_made_fh.
    + Convert "Changes" to CPAN::Changes.
    + Add OLD-Changes.txt for the old changes' log.
    * Hopefully fix tests in perls less than 5.14.
    * Replace List::MoreUtils with List::Util-1.33-or-above.
    * Fix handle trailing comments which contain their delimiters twice.
    * Speedup.

  [ Salvatore Bonaccorso ]
  * Update Vcs-Browser URL to use cgit web frontend.

  [ Jonas Smedegaard ]
  * Bump debhelper compatibility level to 9.
  * Update copyright info:
    + Use License-Grant and License-Reference fields.
      Thanks to Ben Finney.
    + Extend coverage of packaging to include current year.
  * Declare compliance with Debian Policy 3.9.6.
  * Override lintian regarding license in License-Reference field.
    See bug#786450.
  * Override lintian regarding build-depending unversioned on debhelper.
  * Update package relations:
    + (Build-)depend on (recent perl or) recent
      libscalar-list-utils-perl (not recent liblist-moreutils-perl).

 -- Jonas Smedegaard <email address hidden>  Tue, 04 Aug 2015 14:24:30 +0200

Available diffs

Superseded in wily-release on 2015-08-04
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
libconfig-inifiles-perl (2.83-3) unstable; urgency=medium


  * Update copyright info:
    + Fix cover convenience code copy of Test::Run.
  * Fix build-depend explicitly on libmodule-build-perl.

 -- Jonas Smedegaard <email address hidden>  Wed, 02 Jul 2014 17:48:04 +0200

Available diffs

Superseded in utopic-release on 2014-07-02
Deleted in utopic-proposed on 2014-07-04 (Reason: moved to release)
libconfig-inifiles-perl (2.83-1) unstable; urgency=medium


  [ upstream ]
  * New release.
    + Add a LICENSE file and section.
    + Minimum version is now perl-5.8.0.

  [ Jonas Smedegaard ]
  * Bump to standards-version 3.9.5.
  * Fix use canonical Vcs-Git URL.
  * Update copyright info:
    + Add coverage year for main upstream authors, and update verbatim
      statement.
    + Extend coverage of packaging.
  * Update watch file to also use metacpan.org URL.

 -- Jonas Smedegaard <email address hidden>  Tue, 20 May 2014 15:27:52 +0200

Available diffs

Superseded in utopic-release on 2014-05-20
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
libconfig-inifiles-perl (2.82-1) unstable; urgency=low


  [ upstream ]
  * New release.
    + Add the RenameSection method to rename a section.
    + Add the CopySection method to copy a section.
    + Add t/style-trailing-space.t.
    + Remove trailing space.

  [ Jonas Smedegaard ]
  * Switch to cpan.org/authors URL for watch file and get-orig-source
    target, and simplify watch file.
  * Rewrap long description at 72 chars, and strip trailing whitespace.

 -- Jonas Smedegaard <email address hidden>  Fri, 19 Jul 2013 13:34:28 +0200

Available diffs

Superseded in saucy-release on 2013-07-19
Deleted in saucy-proposed on 2013-07-20 (Reason: moved to release)
libconfig-inifiles-perl (2.79-1) unstable; urgency=low


  [ upstream ]
  * New release.
    + Fix test failures with Pod-Simple-3.28.

  [ Salvatore Bonaccorso ]
  * Use canonical hostname (anonscm.debian.org) in Vcs-Git URL.

  [ Jonas Smedegaard ]
  * Update README.source to emphasize control.in file as *not* a
    show-stopper for contributions.
  * Bump policy compliance to standards-version 3.9.4.
  * Do copyright-check by default: Backports-friendly nowadays.
    Build-depend on devscripts.
  * Bump packaging license to GPL-3+, and extend coverage to include
    current year.
  * Bump dephelper compatibility level to 8.

 -- Jonas Smedegaard <email address hidden>  Thu, 09 May 2013 16:38:47 +0200

Available diffs

Superseded in saucy-release on 2013-05-10
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
libconfig-inifiles-perl (2.78-1) unstable; urgency=low


  * New upstream release.

  [ Jonas Smedegaard ]
  * Update package relations:
  * Tighten (build-)dependency on liblist-moreutils-perl: Needed since
    0.77.
    + Relax to build-depend unversioned on cdbs, and stop build-
      depending on (perl-modules with fallback on) libmodule-build-perl:
      Needed versions satisfied in stable, and oldstable no longer
      supported.
  * Update copyright file:
    + Fix use comment and license pseudo-sections to obey silly
      restrictions of copyright format 1.0.

 -- Jonas Smedegaard <email address hidden>  Fri, 02 Nov 2012 16:31:37 +0100

Available diffs

Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
libconfig-inifiles-perl (2.52-1ubuntu0.1) lucid-security; urgency=low

  * SECURITY UPDATE: insecure temporary file usage
    - adjust lib/Config/IniFiles.pm to use tempfile()
    - Patch backported from upstream a08fa26f4f59
    - CVE-2012-2451
 -- Jamie Strandboge <email address hidden>   Fri, 17 Aug 2012 08:17:18 -0500
Obsolete in natty-updates on 2013-06-04
Obsolete in natty-security on 2013-06-04
libconfig-inifiles-perl (2.58-1ubuntu0.1) natty-security; urgency=low

  * SECURITY UPDATE: insecure temporary file usage
    - debian/patches/CVE-2012-2451.patch: adjust to use tempfile()
    - CVE-2012-2451
 -- Jamie Strandboge <email address hidden>   Fri, 17 Aug 2012 08:11:55 -0500
Obsolete in oneiric-updates on 2015-04-24
Obsolete in oneiric-security on 2015-04-24
libconfig-inifiles-perl (2.68-1ubuntu0.11.10.1) oneiric-security; urgency=low

  * SECURITY UPDATE: insecure temporary file usage
    - debian/patches/CVE-2012-2451.patch: adjust to use tempfile()
    - CVE-2012-2451
 -- Jamie Strandboge <email address hidden>   Fri, 17 Aug 2012 07:47:21 -0500
Published in precise-updates on 2012-08-20
Published in precise-security on 2012-08-20
libconfig-inifiles-perl (2.68-1ubuntu0.12.04.1) precise-security; urgency=low

  * SECURITY UPDATE: insecure temporary file
    - debian/patches/CVE-2012-2451.patch: adjust to use tempfile()
    - CVE-2012-2451
 -- Jamie Strandboge <email address hidden>   Fri, 17 Aug 2012 07:47:21 -0500
Superseded in raring-release on 2012-11-03
Obsolete in quantal-release on 2015-04-24
libconfig-inifiles-perl (2.75-1) unstable; urgency=low


  * New upstream release.
    + Add utf8 encoding hint to POD file.

  * Extend/adjust copyright of Debian packaging.

 -- Jonas Smedegaard <email address hidden>  Tue, 05 Jun 2012 23:12:26 +0200

Available diffs

Superseded in quantal-release on 2012-06-08
libconfig-inifiles-perl (2.73-1) unstable; urgency=low


  * New upstream release:
    - fixes a regression in the error handling on tempfile creation, as noted
      by Adam D. Barrat in #671255 (RT#77039).

 -- gregor herrmann <email address hidden>  Mon, 14 May 2012 16:46:14 +0200

Available diffs

Superseded in quantal-release on 2012-05-24
libconfig-inifiles-perl (2.70-1) unstable; urgency=low


  * New upstream release.

  [ gregor herrmann ]
  * Remove debian/source/local-options; abort-on-upstream-changes and
    unapply-patches are default in dpkg-source since 1.16.1.

  [ Jonas Smedegaard ]
  * Bump standards-version to 3.9.3.
  * Use anonscm.debian.org for Vcs-Browser field.
  * Bump debhelper compat level to 7.
  * Update copyright file:
    + Fix double-indent in Copyright fields as per Policy ยง5.6.13.
    + Bump format to 1.0.
  * Update package relations:
    + Relax build-depend unversioned on debhelper: Needed version
      satisfied even in oldstable.

 -- Jonas Smedegaard <email address hidden>  Tue, 24 Apr 2012 13:37:12 -0400

Available diffs

Superseded in quantal-release on 2012-05-06
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
libconfig-inifiles-perl (2.68-1) unstable; urgency=low

  * New upstream release.
  * Update copyright file:
    + Add test, Expat licensed.
    + Update author: Shlomi Fish.
    + Quote licenses in License comments.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  27 Jun 2011 08:07:08 +0000

Available diffs

Superseded in oneiric-release on 2011-06-27
libconfig-inifiles-perl (2.66-2) unstable; urgency=low

  [ Salvatore Bonaccorso ]
  * Remove Salvatore Bonaccorso from Uploaders. 

Available diffs

Superseded in oneiric-release on 2011-05-09
Obsolete in natty-release on 2013-06-04
libconfig-inifiles-perl (2.58-1) unstable; urgency=low

  * New upstream release.
  * Stop using svn-upgrade in watch file.
  * Use source format 3.0 (quilt), and ease building with
    git-buildpackage: Git-ignore quilt .pc dir, and add source
    local-options.
  * Drop locally included CDBS snippets, and local implementation of
    DEB_MAINTAINER_MODE, all included in main cdbs now.
  * Ease backporting to Debian stable: Relax inclusion of CDBS snippets
    required only in DEB_MAINTAINER_MODE, and suppress related build-
    dependencies.
  * Extend copyright years in rules file, and refer to FSF website (not
    postal address).
  * Rewrite copyright file using draft rev135 of DEP5 format.
  * Bump Policy compliance to standards-version 3.9.1.
  * Shorten Vcs-* stanzas.
  * Update DEB_UPSTREAM_URL, to fix get-orig-source rule.
  * Build-depend on libtest-simple-perl.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  17 Oct 2010 01:20:03 +0000

Available diffs

Superseded in natty-release on 2010-10-17
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
libconfig-inifiles-perl (2.52-1) unstable; urgency=low

  [ Jonathan Yu ]
  * New upstream release
    + $config->exists() now pays attention to -nocase => 1. (RT#46721)
  * Added myself to Uploaders
  * Standards-Version 3.8.3 (no changes)
 
  [ Salvatore Bonaccorso ]
  * New upstream release

  [ Nathan Handler ]
  * debian/watch: Update to ignore development releases.

  [ Salvatore Bonaccorso ]
  * debian/control: Changed: Replace versioned (build-)dependency on
    perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
    permitted by Debian Policy 3.8.3).

  [ Jonas Smedegaard ]
  * Update CDBS snippets:
    + package-relations.mk: Cleanup unversioned+versioned dependency
      mix. Improve whitespace cleanup. Rewrite and silence applying
      dependencies.
    + Update URL to draft DEP5 format in copyright-check.mk output.
  * Drop no longer needed build-dependencies on quilt and patchutils,
    and make perl build-dependency unversioned (as per Debian Policy
    3.8.3). Both these changes thanks to cdbs automatic build-dependency
    resolving (DEB_MAINTAINER_MODE=1 fakeroot debian/rules clean).
  * Packaging moved to Git:
    + Update Vcs stanzas.
    + Add note on Git, git-buildpackage and pristine-tar to
      README.source, and drop not on Subversion.
    + Add git-buildpackage configfile, enabling signed tags and use of
      pristine-tar.
  * Update md5sum of new upstream release 2.52.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  05 Nov 2009 06:04:39 +0000

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
libconfig-inifiles-perl (2.49-1) unstable; urgency=low

  [ Jonas Smedegaard ]
  * Update copyright info:
    + Rewrite to use DEP5 r48 proposed machine-readable format
    + Add proper licensing header to rules file
    + Bump copyright years for debian/rules
  * Update CDBS snippets:
    + Extend package-relation.mk to handle debhelper 6 and 7.0.1, and to
      support non-build dependencies
  * Auto-update debian/control to tighten debhelper dependency, thanks
    to lintian.
  * Add README.source.  Drop custom CDBS hints.
  * Build-depend on quilt and recent patchutils.

  [ Salvatore Bonaccorso ]
  * New upstream release.
  * Add Salvatore Bonaccorso to Uploaders.
  * New upstream version (Changes in upstream version 2.48) fixes
    change in tie interfaces (Closes: #529616).
  * Bump Standards-Version to 3.8.1 
  * Add 1001-fix-POD-Config-IniFiles.patch to fix erroneous created
    manpage.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  01 Jun 2009 10:43:32 +0100

Available diffs

Superseded in karmic-release on 2009-06-01
libconfig-inifiles-perl (2.47-1) unstable; urgency=low

  [ Jonas Smedegaard ]
  * New upstream release. Closes: bug#430426, #380280.
  * Depend on ${misc:Depends}.
  * Fix Vcs-* fields to point to refer to correct package.
  * Update CDBS snippets:
    + Update copyright-check output to more closely match proposed new
      copyright file format
    + Simplify internal variables
    + Ignore no files by default in copyright-check.mk
    + Correct and update copyright hints of the snippets themselves
    + Move dependency cleanup to new local snippet package-relations.mk.
  * Update debian/copyright and copyright hints:
    + Rewrite debian/copyright using new file format, version 428
    + Add info on CDBS snippets (new owners, no new licenses)
  * Add DEB_MAINTAINER_MODE in debian/rules (thanks to Romain Beauxis).

  [ gregor herrmann ]
  * debian/watch: use dist-based URL.
  * debian/control: Changed: Switched Vcs-Browser field to ViewSVN
    (source stanza).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 00:17:02 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Superseded in intrepid-release on 2008-10-17
libconfig-inifiles-perl (2.39-5) unstable; urgency=medium

  * Set urgency=medium as 2.39-5 included a FTBFS bugfix (similar to
    bug#487066).

Available diffs

Superseded in intrepid-release on 2008-07-02
libconfig-inifiles-perl (2.39-3) unstable; urgency=low

  * Pass over maintenance of the package to the Perl group: Change Maintainer,
    and add myself to Uploaders.
  * Change debian/watch to use svn-upgrade (not uupdate).
  * Move Homepage to own field (from pseudo-field in long description).
  * Add Vcs-* fields.
  * Bump up standards-version to 3.7.3 (no changes needed).
  * Bump dephelper compatibility level to 5.
  * Fix build-depends-indep -> build-depends.
  * Update local cdbs tweaks:
    + Add new snippet update-tarball, implementing get-orig-source and more.
    + Major improvements to copyright-check, including new versioned
      build-dependency on devscripts.  Update debian/copyright_hints.
    + Drop auto-update.mk.  Set DEB_AUTO_UPDATE_DEBIAN_CONTROL directly
      instead when needed.
    + Add debian/README.cdbs-tweaks documenting local tweaks.
  * Fix double cdbs build-dependencies in debian/rules.
  * Semi-auto-update debian/control to apply changes contained in the above:
    DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:13:03 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
Superseded in feisty-release on 2007-04-10
libconfig-inifiles-perl (2.39-2) unstable; urgency=low

  * Strip bogus part of 2.39-1 changelog entry (due to cut'n'paste).

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
Obsolete in breezy-release on 2008-03-25
Obsolete in hoary-release on 2008-03-19
libconfig-inifiles-perl (2.38-3) unstable; urgency=high


  * Change unnecessary auto-generated dependency on perl to perl-base.
    Requested by Konstantinos Margaritis <email address hidden> to minimize
    dependencies for localization-config (and thus debian-installer
    netinst image).
  * Standards-Version: 3.6.1 (no changes needed).
  * Add usage note to watch file.
  * Mention "Debian GNU systems" in intro line if debian/copyright.
  * Correct location of Artistic license (to please lintian).
  * Shorten short description (all lib*-perl packages are modules...).
  * Use (and build-depend on) dh-buildinfo.
  * Set urgency=high as none of the above changes should cause any risk,
    and dropping perl dependency is important for debian-installer.

 -- Jonas Smedegaard <email address hidden>  Sat, 25 Sep 2004 21:38:04 +0200
Obsolete in warty-release on 2008-01-09
libconfig-inifiles-perl (2.38-2) unstable; urgency=low


  * Rebuild using newer cdbs (Closes: Bug#203617 - no need to tighten
    build-dependencies, as cdbs has not yet been included in any
    official release of Debian).
  * Standards-version 3.6.0.
  * Fix watch file to not include other related modules.
  * Change to section perl.
  * Remove info in debian/copyright included in debian/changelog.

 -- Jonas Smedegaard <email address hidden>  Thu, 31 Jul 2003 14:30:49 +0200
130 of 30 results