Change log for libdist-zilla-perl package in Ubuntu

147 of 47 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-08
Deleted in cosmic-proposed (Reason: moved to release)
libdist-zilla-perl (6.012-1) unstable; urgency=medium

  * Import upstream version 6.012.
  * Update (build) dependencies.

 -- gregor herrmann <email address hidden>  Mon, 07 May 2018 18:42:40 +0200

Available diffs

Superseded in cosmic-release on 2018-05-08
Deleted in cosmic-proposed on 2018-05-09 (Reason: moved to release)
libdist-zilla-perl (6.011-1) unstable; urgency=medium

  [ gregor herrmann ]
  * Drop debian/tests/pkg-perl/smoke-tests, handled by pkg-perl-
    autopkgtest now.

  [ Alex Muntada ]
  * Remove inactive pkg-perl members from Uploaders.

  [ Damyan Ivanov ]
  * declare conformance with Policy 4.1.3 (no changes needed)

  [ Salvatore Bonaccorso ]
  * Update Vcs-* headers for switch to salsa.debian.org

  [ gregor herrmann ]
  * Import upstream version 6.011.
  * Refresh SOURCE_DATE_EPOCH_support.patch (offset).
  * Update years of upstream and packaging copyright.
  * Declare compliance with Debian Policy 4.1.4.

 -- gregor herrmann <email address hidden>  Mon, 16 Apr 2018 20:49:42 +0200

Available diffs

Superseded in cosmic-release on 2018-05-05
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-07-16
Deleted in artful-proposed (Reason: moved to release)
libdist-zilla-perl (6.010-1) unstable; urgency=medium

  * Import upstream version 6.010.
  * Update years of packaging copyright.
  * autopkgtest: skip t/tester-local-plugins.t for now which fails due to
    the dot-in-@INC removal. This can be reverted once the upstream issue
    is solved. (Closes: #837132)

 -- gregor herrmann <email address hidden>  Tue, 11 Jul 2017 21:17:41 +0200

Available diffs

Superseded in artful-proposed on 2017-07-13
libdist-zilla-perl (6.009-1) unstable; urgency=low

  * Import upstream version 6.009.
  * Declare compliance with Debian Policy 4.0.0. (No changes needed.)
  * Bump debhelper compatibility to 10.
    + Update versioned debhelper build-dependency accordingly.

 -- Axel Beckert <email address hidden>  Mon, 19 Jun 2017 01:54:23 +0200

Available diffs

Superseded in artful-proposed on 2017-06-19
Deleted in zesty-proposed on 2017-06-21 (Reason: Moved to artful-proposed)
libdist-zilla-perl (6.008-1) unstable; urgency=medium

  * Remove Jonathan Yu from Uploaders. Thanks for your work!
  * Import upstream version 6.008.
  * Update years of packaging copyright.
  * Drop unneeded version constraints in debian/control.
  * Drop unversioned 'libmodule-corelist-perl' from Recommends.
    It's provided by perl anyway.
  * autopkgtest: enable more smoke tests.

 -- gregor herrmann <email address hidden>  Sat, 29 Oct 2016 19:49:38 +0200
Superseded in artful-release on 2017-07-16
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-06-22 (Reason: moved to release)
libdist-zilla-perl (6.007-1) unstable; urgency=low

  * Import upstream version 6.007.

 -- Axel Beckert <email address hidden>  Tue, 09 Aug 2016 22:00:31 +0200

Available diffs

Superseded in yakkety-release on 2016-10-06
Deleted in yakkety-proposed on 2016-10-07 (Reason: moved to release)
libdist-zilla-perl (6.005-2) unstable; urgency=low

  * Also list directory "t" in debian/tests/pkg-perl/smoke-files to
    actually run the test suite.
    + List t/compile.t in debian/tests/pkg-perl/smoke-skip since it tries
      to find Perl modules in build directory and its functionality is
      covered by pkg-perl-autopkgtest's default tests anyways

 -- Axel Beckert <email address hidden>  Thu, 26 May 2016 00:41:06 +0200

Available diffs

Superseded in yakkety-release on 2016-06-03
Deleted in yakkety-proposed on 2016-06-04 (Reason: moved to release)
libdist-zilla-perl (5.047-2) unstable; urgency=medium

  * Update build and runtime dependencies, add a Recommends.
    Thanks to autopkgtest.

 -- gregor herrmann <email address hidden>  Sun, 08 May 2016 18:43:11 +0200

Available diffs

Superseded in yakkety-proposed on 2016-05-08
libdist-zilla-perl (5.047-1) unstable; urgency=low

  [ Salvatore Bonaccorso ]
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI

  [ Axel Beckert ]
  * Import upstream version 5.047
    + Add new b-d on libscalar-list-utils-perl ≥ 1.45 and libterm-ui-perl.
    + Remove b-d on liblist-moreutils-perl.
  * Add patch to support SOURCE_DATE_EPOCH e.g. for dh-dist-zilla →
    Dist::Zilla::Plugin::PodWeaver → Pod::Weaver generated
    documentation. Should make at least librun-parts-perl reproducible.
  * Declare compliance with Debian Policy 3.9.8. (No changes needed.)

 -- Axel Beckert <email address hidden>  Sun, 08 May 2016 01:19:19 +0200
Superseded in yakkety-release on 2016-05-09
Published in xenial-release on 2016-01-22
Deleted in xenial-proposed (Reason: moved to release)
libdist-zilla-perl (5.043-1) unstable; urgency=low

  [ Salvatore Bonaccorso ]
  * Update Vcs-Browser URL to cgit web frontend

  [ gregor herrmann ]
  * Add debian/upstream/metadata
  * Import upstream version 5.021
    + Update (build) dependencies.
  * Declare compliance with Debian Policy 3.9.6.

  [ Axel Beckert ]
  * Import upstream versions 5.039 and 5.043
    + Update versioned (build) dependencies on libapp-cmd-perl and
      libconfig-mvp-reader-ini-perl.
    + Add new build-dependency on libcpan-meta-check-perl.
    + Run test suite with TZ=UTC being set to avoid timezone related test
      suite failures. See https://github.com/rjbs/Dist-Zilla/issues/497
  * Bump debhelper compatibility to 9 as recommended.
  * Add myself to uploaders.
  * Add lintian override for being in the perl section and shipping
    /usr/bin/dzil.
  * Extend long package description a bit.
  * Make package autopkgtestable.
    + Add "Testsuite: autopkgtest-pkg-perl" header
    + Add directory "corpus" to debian/tests/pkg-perl/smoke-files.
  * Remove obsolete conffile /etc/bash_completion.d/dzil. Thanks adequate!

 -- Axel Beckert <email address hidden>  Fri, 22 Jan 2016 00:36:56 +0100

Available diffs

Superseded in xenial-release on 2016-01-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
libdist-zilla-perl (5.020-2) unstable; urgency=medium

  * Run tests with TEST_VERBOSE=0.
    Verbose tests, as enabled in debhelper by now, still seem to break two
    tests (or "tests in tests").
    (Closes: #785659)
  * Declare compliance with Debian Policy 3.9.6.

 -- gregor herrmann <email address hidden>  Tue, 19 May 2015 19:18:23 +0200

Available diffs

Superseded in wily-release on 2015-05-20
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
libdist-zilla-perl (5.020-1) unstable; urgency=medium


  * New upstream release.

 -- gregor herrmann <email address hidden>  Thu, 31 Jul 2014 18:45:13 +0200

Available diffs

Superseded in utopic-release on 2014-07-31
Deleted in utopic-proposed on 2014-08-02 (Reason: moved to release)
libdist-zilla-perl (5.019-1) unstable; urgency=medium


  * Team upload

  * Imported Upstream version 5.019
  * add (>= 0.06) to libfile-sharedir-install-perl (build-)dependency

 -- Damyan Ivanov <email address hidden>  Wed, 21 May 2014 12:12:47 +0300

Available diffs

Superseded in utopic-release on 2014-05-21
Deleted in utopic-proposed on 2014-05-23 (Reason: moved to release)
libdist-zilla-perl (5.016-1) unstable; urgency=medium


  * New upstream release.
  * Strip trailing slash from metacpan URLs.
  * Install more examples.

 -- gregor herrmann <email address hidden>  Sun, 11 May 2014 17:48:37 +0200

Available diffs

Superseded in utopic-release on 2014-05-11
Deleted in utopic-proposed on 2014-05-13 (Reason: moved to release)
libdist-zilla-perl (5.013-1) unstable; urgency=medium


  * New upstream release.
  * Update years of upstream copyright.

 -- gregor herrmann <email address hidden>  Sun, 16 Feb 2014 16:28:41 +0100

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-01-02
Deleted in trusty-proposed (Reason: moved to release)
libdist-zilla-perl (5.008-1) unstable; urgency=medium


  * New upstream release.
  * Update years of packaging copyright.

 -- gregor herrmann <email address hidden>  Wed, 01 Jan 2014 22:52:35 +0100

Available diffs

Superseded in trusty-release on 2014-01-02
Deleted in trusty-proposed on 2014-01-03 (Reason: moved to release)
libdist-zilla-perl (5.006-1) unstable; urgency=low


  * Team upload

  * Import Upstream version 5.006
  * Add "break your build" changes to debian/NEWS
  * Update (build-)dependencies
  * Declare compliance with Debian Policy 3.9.5

 -- Florian Schlichting <email address hidden>  Tue, 26 Nov 2013 21:55:34 +0100

Available diffs

Superseded in trusty-release on 2013-11-27
Deleted in trusty-proposed on 2013-11-28 (Reason: moved to release)
libdist-zilla-perl (4.300039-1) unstable; urgency=low


  * New upstream release.
  * Update years of packaging copyright.
  * Switch order of alternative (build) dependencies.

 -- gregor herrmann <email address hidden>  Sat, 21 Sep 2013 19:49:13 +0200

Available diffs

Superseded in trusty-release on 2013-10-25
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libdist-zilla-perl (4.300034-1) unstable; urgency=low


  * New upstream release
  * Add versioned (Build-)Depends on libcpan-uploader-perl

 -- Alessandro Ghedini <email address hidden>  Fri, 26 Apr 2013 00:20:37 +0200

Available diffs

Superseded in saucy-release on 2013-04-29
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
libdist-zilla-perl (4.300030-1) unstable; urgency=low


  [ Salvatore Bonaccorso ]
  * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * Change search.cpan.org based URIs to metacpan.org based URIs

  [ Alessandro Ghedini ]
  * New upstream release
  * Update upstream copyright years

 -- Alessandro Ghedini <email address hidden>  Tue, 12 Feb 2013 13:00:08 +0100

Available diffs

Superseded in raring-release on 2013-02-12
Deleted in raring-proposed on 2013-02-13 (Reason: moved to release)
libdist-zilla-perl (4.300028-1) unstable; urgency=low


  * New upstream release
  * (Build) depend on liblist-allutils-perl

 -- Alessandro Ghedini <email address hidden>  Wed, 07 Nov 2012 19:21:01 +0100

Available diffs

Superseded in raring-release on 2012-11-08
Deleted in raring-proposed on 2012-11-09 (Reason: moved to release)
libdist-zilla-perl (4.300025-1) unstable; urgency=low


  * New upstream release
  * Bump Standards-Version to 3.9.4 (no changes needed)

 -- Alessandro Ghedini <email address hidden>  Mon, 08 Oct 2012 09:36:43 +0200

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
libdist-zilla-perl (4.300020-1) unstable; urgency=low


  * New upstream release
  * Build depend on libtest-file-sharedir-perl

 -- Alessandro Ghedini <email address hidden>  Thu, 28 Jun 2012 12:59:25 +0200

Available diffs

Superseded in quantal-release on 2012-06-29
libdist-zilla-perl (4.300018-1) unstable; urgency=low


  * New upstream release

 -- Alessandro Ghedini <email address hidden>  Fri, 08 Jun 2012 11:52:48 +0200

Available diffs

Superseded in quantal-release on 2012-06-09
libdist-zilla-perl (4.300017-2) unstable; urgency=low


  * Team upload.
  * Use writable $HOME during build to fix FTBFS (Closes: #676047)

 -- Salvatore Bonaccorso <email address hidden>  Tue, 05 Jun 2012 17:33:02 +0200

Available diffs

Superseded in quantal-release on 2012-06-08
libdist-zilla-perl (4.300017-1) unstable; urgency=low


  * New upstream release

 -- Alessandro Ghedini <email address hidden>  Thu, 31 May 2012 21:30:18 +0200

Available diffs

Superseded in quantal-release on 2012-06-01
libdist-zilla-perl (4.300016-1) unstable; urgency=low


  * New upstream release.

 -- gregor herrmann <email address hidden>  Mon, 07 May 2012 18:25:05 +0200

Available diffs

Superseded in quantal-release on 2012-05-19
libdist-zilla-perl (4.300015-1) unstable; urgency=low


  * New upstream release
  * (Build) depends on libcpan-meta-requirements-perl

 -- Alessandro Ghedini <email address hidden>  Tue, 24 Apr 2012 22:43:58 +0200

Available diffs

Superseded in quantal-release on 2012-05-06
libdist-zilla-perl (4.300014-1) unstable; urgency=low


  * New upstream release.
  * Update years of packaging copyright.

 -- gregor herrmann <email address hidden>  Sat, 07 Apr 2012 15:36:39 +0200
Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-12-26
libdist-zilla-perl (4.300005-1) unstable; urgency=low

  * New upstream release.
  * Add (build) dependency on libclass-load-perl.
  * Update years of packaging copyright.
  * Add perl 5.13.4 as an alternative build dependency for
    Test::More 0.96.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  26 Dec 2011 17:49:14 +0000

Available diffs

Superseded in precise-release on 2011-12-26
libdist-zilla-perl (4.300003-1) unstable; urgency=low

  * New upstream release
  * Add libtext-glob-perl to (B-)D(-I)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  13 Nov 2011 01:31:32 +0000

Available diffs

Superseded in precise-release on 2011-11-13
libdist-zilla-perl (4.300002-1) unstable; urgency=low

  * New upstream release

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
libdist-zilla-perl (4.200009-1) unstable; urgency=low
  * New upstream release -- Alessandro Ghedini <email address hidden>  Thu, 07 Jul 2011 18:21:14 +0200
Superseded in oneiric-release on 2011-07-27
libdist-zilla-perl (4.200008-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  24 Jun 2011 09:07:26 +0000

Available diffs

Superseded in oneiric-release on 2011-06-24
libdist-zilla-perl (4.200007-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  03 Jun 2011 10:24:07 +0000

Available diffs

Superseded in oneiric-release on 2011-06-03
libdist-zilla-perl (4.200006-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  01 May 2011 08:01:31 +0000

Available diffs

Superseded in oneiric-release on 2011-05-01
libdist-zilla-perl (4.200005-1) unstable; urgency=low

  * New upstream release
  * Bump Standards-Version to 3.9.2
  * Remove versioned dependencies on libsoftware-license-perl,
    libstring-rewriteprefix-perl, libstring-formatter-perl,
    libcpan-uploader-perl, libcpan-meta-perl, libconfig-mvp-reader-ini-perl

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
libdist-zilla-perl (4.200000-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  17 Dec 2010 11:01:21 +0000

Available diffs

Superseded in natty-release on 2010-12-17
libdist-zilla-perl (4.102345-1) unstable; urgency=low

  [ Ansgar Burchardt ]
  * New upstream release 4.102343.
  * Bump build-dep on libtest-simple-perl to >= 0.96.
  * Add build-dep on libtest-fatal-perl.
  * Update my email address.

  [ gregor herrmann ]
  * New upstream release 4.102344.
  * Make (build) dependency on libapp-cmd-perl versioned.

  * New upstream release 4.102345.
  * Add (build) dependency on perl (>= 5.10.1) | libparent-perl.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  22 Nov 2010 10:15:47 +0000

Available diffs

Superseded in natty-release on 2010-11-22
libdist-zilla-perl (4.102342-1) unstable; urgency=low

  * New upstream release.
  * Update my email address.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  18 Oct 2010 08:38:32 +0000

Available diffs

Superseded in natty-release on 2010-10-18
libdist-zilla-perl (4.102341-2) unstable; urgency=low

  * debian/control: added myself to uploaded, added libfile-copy-recursive-perl 
    in Depends. Re-ordered list of dependencies

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
libdist-zilla-perl (4.101612-1) unstable; urgency=low

  * New upstream release.
    + INCOMPATIBLE CHANGES: Has a new global config system.
      See NEWS or the upstream changelog for details.
  * Add dependency on libtry-tiny-perl (was just build-dep before).
  * Bump (build-)dep on
    - libconfig-mvp-perl to >= 2.101540,
    - libcpan-meta-perl to >= 2.101550,
    - libcpan-uploader-perl to >= 0.101550.
  * Add (build-)dep on libfile-sharedir-perl, libmoosex-lazyrequire-perl,
    libmoosex-setonce-perl.
  * Add build-dep on libtest-deep-perl.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  20 Jun 2010 03:01:52 +0100

Available diffs

Superseded in maverick-release on 2010-06-20
libdist-zilla-perl (3.101520-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  04 Jun 2010 15:13:27 +0100

Available diffs

Superseded in maverick-release on 2010-06-04
libdist-zilla-perl (3.101461-1) unstable; urgency=low

  [ Ansgar Burchardt ]
  * New upstream release.
    + Passes tests again. (Closes: #583467)
  * Make (build-)dep on liblog-dispatchouli-perl, libstring-formatter-perl,
    libstring-rewriteprefix-perl versioned.
  * Drop (build-)dep on libmixin-extrafields-perl.
  * Bump (build-)dep on libconfig-mvp-perl to >= 2.101460.
  * Replace (build-)dep on libconfig-ini-mvp-perl with
    libconfig-mvp-reader-ini-perl (>= 2.101460).
  * Bump (build-)dep on libsoftware-license-perl to >= 0.101370.
  * Add (build-)dep on libcpan-meta-perl, libmoosex-types-perl-perl.

  [ gregor herrmann ]
  * Note incompatible changes in debian/NEWS.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  31 May 2010 10:30:55 +0100

Available diffs

Superseded in maverick-release on 2010-05-31
libdist-zilla-perl (2.101040-1) unstable; urgency=low

  * New upstream release.

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
libdist-zilla-perl (1.100160-1) unstable; urgency=low

  [ Jonathan Yu ]
  * New upstream release
  * Add myself to Uploaders and Copyright
  * Require perl 5.10 instead of 5.9.3
  * Package now requires libfile-sharedir-install-perl

  [ gregor herrmann ]
  * Update year of upstream copyright.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  04 Feb 2010 17:26:21 +0000

Available diffs

Superseded in lucid-release on 2010-02-04
libdist-zilla-perl (1.093400-1) unstable; urgency=low

  * Initial release (closes: #562102).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  04 Jan 2010 21:31:27 +0000
147 of 47 results