Change log for libetpan package in Ubuntu

144 of 44 results
Published in groovy-release on 2020-04-24
Published in focal-release on 2020-02-25
Deleted in focal-proposed (Reason: moved to Release)
libetpan (1.9.4-2) unstable; urgency=medium

  * Upload new upstream version to unstable
  * Update Standards-Version to 4.5.0, no other changes

 -- Ricardo Mones <email address hidden>  Mon, 24 Feb 2020 15:45:02 +0100

Available diffs

Superseded in focal-release on 2020-02-25
Published in eoan-release on 2019-05-07
Deleted in eoan-proposed (Reason: moved to release)
libetpan (1.9.3-2) unstable; urgency=high

  * debian/patches/90_fix_tls_timeout.diff
  - Add upstream patch to fix TLS timeout (Closes: #927709)
  * Raised changelog urgency because of serious bug

 -- Ricardo Mones <email address hidden>  Mon, 06 May 2019 23:27:54 +0200

Available diffs

Superseded in eoan-release on 2019-05-07
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-07-14 (Reason: moved to release)
libetpan (1.9.3-1) unstable; urgency=medium

  * New upstream version 1.9.3
  * debian/libetpan20.symbols
  - Add new symbols in this version
  * debian/control
  - Update Standards-Version to 4.3.0
  * Remove cruft from old debug package

 -- Ricardo Mones <email address hidden>  Sat, 26 Jan 2019 20:49:11 +0100

Available diffs

Superseded in disco-release on 2019-01-28
Deleted in disco-proposed on 2019-01-29 (Reason: moved to release)
libetpan (1.9.2-1) unstable; urgency=medium

  * New upstream version 1.9.2
  - Drop patch included in new release
  * debian/libetpan-doc.links, debian/libetpan-doc.dirs
  - Fix directory name and symlink (Closes: #911051)
  * debian/rules
  - Use dpkg's pkg-info for getting upstream version
  * debian/libetpan20.symbols
  - Update new symbols in this release
  - Add Build-Depends-Package to symbols file
  * debian/watch
  - Fix watch file

 -- Ricardo Mones <email address hidden>  Tue, 18 Dec 2018 16:06:14 +0100

Available diffs

Superseded in disco-release on 2019-01-08
Deleted in disco-proposed on 2019-01-10 (Reason: moved to release)
libetpan (1.9.1-2) unstable; urgency=high

  * Add patch to fix FTBFS with curl 7.62.0.
    Thanks to Po-Chuan Hsieh and Hoà V. DINH (Closes: #913383)

 -- Ricardo Mones <email address hidden>  Wed, 28 Nov 2018 20:16:29 +0100

Available diffs

Superseded in disco-release on 2018-11-29
Deleted in disco-proposed on 2018-11-30 (Reason: moved to release)
libetpan (1.9.1-1) unstable; urgency=medium

  * New upstream version 1.9.1
  * debian/control
  - Remove unnecessary dh argument
  - Remove duplicated Priority field
  * Remove trailing whitespaces from changelog

 -- Ricardo Mones <email address hidden>  Thu, 04 Oct 2018 00:45:19 +0200

Available diffs

Superseded in disco-release on 2018-11-09
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed (Reason: moved to release)
libetpan (1.8.0-1) unstable; urgency=medium

  * New upstream version
  * get-upstream-tarball
  - Add an optional arg for specifying tarball version when it
    doesn't match the git tag (e.g.: '1.8' tag for '1.8.0' version)
  * patches/fix-CVE-2017-8825.diff, patches/series
  - Remove patch already in this version
  * control, libetpan17.* → libetpan20.*
  - Update soname: binary package is now libetpan20
  * copyright
  - Update date, fix expressions matching no files (thanks lintian!)

 -- Ricardo Mones <email address hidden>  Sun, 02 Jul 2017 13:11:54 +0200

Available diffs

Superseded in artful-release on 2017-07-15
Deleted in artful-proposed on 2017-07-18 (Reason: moved to release)
libetpan (1.6-3) unstable; urgency=high

  * patches/fix-CVE-2017-8825.diff, patches/series
  - Add upstream patch to fix CVE-2017-8825 (Closes: #862151)
  * control
  - Homepage: point to library's own page

 -- Ricardo Mones <email address hidden>  Tue, 30 May 2017 10:16:19 +0200

Available diffs

Superseded in artful-release on 2017-05-31
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
libetpan (1.6-2) unstable; urgency=medium

  * control
  - Build-Depends: replace jade with openjade (Closes: #840485)
  - Build-Depends-Indep: moved here from Build-Depends
  - Standards-Version: update to 3.9.8 (no other changes required)
  - Vcs-*: update all URLs to use https
  * patches/11_use_openjade.diff, patches/series
  - Add patch to use openjade instead of jade

 -- Ricardo Mones <email address hidden>  Wed, 12 Oct 2016 23:35:06 +0200

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-02-22
Deleted in xenial-proposed (Reason: moved to release)
libetpan (1.6-1build1) xenial; urgency=medium

  * No-change rebuild for gnutls transition.

 -- Matthias Klose <email address hidden>  Wed, 17 Feb 2016 22:26:05 +0000

Available diffs

Superseded in xenial-release on 2016-02-22
Deleted in xenial-proposed on 2016-02-23 (Reason: moved to release)
libetpan (1.6-1) unstable; urgency=medium

  * New upstream release in response to CVE-2014-3566 (POODLE)
  - SSLv3 is not forced anymore in SSL connections
  * patches/10*.diff, patches/series, get-upstream-tarball
  - Update patch, which was partially applied in github commit
    1e2008cb6abdfe629f11ca2c1f21d399c52579a9, but it's now required
    to generate the upstream tarball from the git tag. Removed from
    series file but used now by get-upstream-tarball scriptlet.
  * debian/libetpan17.symbols
  - Update symbols file: 10 added, 0 removed
  * debian/control
  - Update Standards-Version to 3.9.6 (no other changes)

 -- Ricardo Mones <email address hidden>  Thu, 03 Sep 2015 16:48:32 +0200

Available diffs

Superseded in xenial-release on 2015-10-25
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
libetpan (1.5-2) unstable; urgency=high


  [ Vincent Cheng ]
  * Fix unhandled symlink to directory conversion. (Closes: #773036)

  [ Ricardo Mones ]
  * Change Vincent's patch versions and changelog entry to make it a
    regular upload and thank him very much for the patch! :)
  * Raise urgency because of RC bug.

 -- Ricardo Mones <email address hidden>  Wed, 07 Jan 2015 14:10:56 +0100

Available diffs

Superseded in vivid-release on 2015-01-08
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
libetpan (1.5-1) unstable; urgency=medium


  * New upstream release: not really, identical to 1.4.1 but version
    bumped because “1.4.1 is not allowed as version number.” (sic.)
  - Builds in hurd-i386 since previous release (Closes: #686103)
  * debian/control
  - Update Depends of -dev to libgnutls28-dev (Closes: #751269)
  - Remove “Multi-Arch: same” for -dev (Closes: #751154)

 -- Ricardo Mones <email address hidden>  Wed, 11 Jun 2014 18:24:25 +0200

Available diffs

Superseded in utopic-proposed on 2014-06-11
libetpan (1.4.1-2) unstable; urgency=medium


  * debian/copyright
  - Update format and content for unstable (Closes: #750176)

 -- Ricardo Mones <email address hidden>  Mon, 09 Jun 2014 22:50:24 +0200

Available diffs

Superseded in utopic-release on 2014-07-29
Deleted in utopic-proposed on 2014-07-30 (Reason: moved to release)
libetpan (1.1-3) unstable; urgency=medium


  [ Hideki Yamane ]
  * debian/patches
    - add add-db5.3.patch (Closes: #740506)
  * debian/rules
    - use autoreconf to apply above patch
  * debian/control
    - add "Build-Depends: dh-autoreconf" to use autoreconf
      (Maybe it's overkill but it's okay since make it DH7 style in
       a near future)

  [ Ricardo Mones ]
  * debian/control
    - Upload to unstable. Has been time enough in experimental, it's
      time to push it forward.
    - Upgrade Standards-Version to 3.9.5 (no other changes)
    - Fix Vcs-* URLs to use the canonical hostname
    - Improve descriptions a bit and rewrap some long lines.
  * debian/rules
    - Use dh-autoreconf properly (Closes: #727405)
  * Fix some changelog typos too.

 -- Ricardo Mones <email address hidden>  Mon, 17 Mar 2014 02:39:05 +0100

Available diffs

Superseded in utopic-release on 2014-05-27
Published in trusty-release on 2014-01-30
Deleted in trusty-proposed (Reason: moved to release)
libetpan (1.0-5ubuntu3) trusty; urgency=low

  * Use dh-autoreconf for newer arches.
 -- Daniel T Chen <email address hidden>   Thu, 30 Jan 2014 14:40:31 -0500

Available diffs

Superseded in trusty-release on 2014-01-30
Deleted in trusty-proposed on 2014-02-01 (Reason: moved to release)
libetpan (1.0-5ubuntu2) trusty; urgency=low

  * Add db5.3 to configure scripts.
 -- Dmitrijs Ledkovs <email address hidden>   Sat, 02 Nov 2013 20:51:54 +0000

Available diffs

Superseded in trusty-release on 2013-11-02
Deleted in trusty-proposed on 2013-11-04 (Reason: moved to release)
libetpan (1.0-5ubuntu1) trusty; urgency=low

  * Use the autotools-dev dh addon to update config.guess/config.sub for
    arm64 (closes: #727405).
 -- Colin Watson <email address hidden>   Thu, 24 Oct 2013 13:38:32 +0100

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-18
libetpan (1.0-5) unstable; urgency=low

  * Update build-windows/libetpan_version.h by a debian patch, not by
    configure script. Closes: #643185.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  18 Oct 2011 10:03:34 +0000

Available diffs

Superseded in precise-release on 2011-10-18
Obsolete in oneiric-release on 2015-04-24
libetpan (1.0-4) unstable; urgency=low

  * Calculate libetpan-dev dependency on libdb based on what libetpan.so
    is actually, linked against, and not based on what libdb-dev depends on.
    Closes: #618965.
  * Patch configure to detect libdb-5.1.

Available diffs

Superseded in oneiric-release on 2011-05-04
Obsolete in natty-release on 2013-06-04
libetpan (0.58-1ubuntu1) natty; urgency=low

  * Rebuild to pick up multiarch changes.
  * Clean .la files.
 -- Evan Broder <email address hidden>   Fri, 01 Apr 2011 13:23:12 -0700

Available diffs

Superseded in natty-release on 2011-04-01
Obsolete in maverick-release on 2013-03-05
libetpan (0.58-1build1) maverick; urgency=low

  * Rebuild to fix libdb-dev dependency issues (LP: 616474).
 -- Reed Loden <email address hidden>   Wed, 11 Aug 2010 14:56:31 -0500

Available diffs

Superseded in maverick-release on 2010-08-11
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
libetpan (0.58-1) unstable; urgency=low

  * New Upstream Version.
  * Move libetpan-dbg to new section 'debug'.
  * Update Standards-Version to 3.8.2. 

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Jun 2009 10:37:12 +0100

Available diffs

Obsolete in dapper-updates on 2011-09-06
Obsolete in dapper-security on 2011-09-06
libetpan (0.48-2~dapper2) dapper-security; urgency=low

  * No change rebuild from backports for use with ClamAV 0.94

 -- Jamie Strandboge <email address hidden>   Thu, 30 Apr 2009 18:28:55 -0500
Superseded in karmic-release on 2009-06-23
libetpan (0.57-2) unstable; urgency=low

  * Add a hack to compute proper libdb-dev dependency for libetpan-dev
    package, depending on what libdb-dev was used at package build time.
  * Reference /usr/share/doc/dpatch/README.source.gz in debian/README.source
    instead of citing it. 
  * Added Vcs-Git and Vcs-Browser control fields pointing to my packaging
    repository. 
  * [lintian] use sf.net redirector in debian/watch. 
  * Upload to unstable.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 12:00:40 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
libetpan (0.57-1) experimental; urgency=low

  * New upstream release. Closes: #502007.
    - Removed patch 01-fix-498790 - included upstream.

Available diffs

Superseded in jaunty-release on 2008-12-10
Obsolete in intrepid-release on 2013-02-20
libetpan (0.54-4ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - change patch 01-configure-find-db4.6 to add db4.7.
    - change unversioned dependency on libdb-dev to versioned:
      libetpan and claws packages have to be in sync.

Available diffs

Superseded in intrepid-release on 2008-09-28
libetpan (0.54-3ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - change patch 01-configure-find-db4.6 to add db4.7.
    - change unversioned dependency on libdb-dev to versioned:
      libetpan and claws packages have to be in sync.
    - modify Maintainer value to match the DebianMaintainerField
      specification.

Available diffs

Superseded in intrepid-release on 2008-07-17
libetpan (0.54-1ubuntu1) intrepid; urgency=low

  [Cesare Tirabassi]

  * Rebuild due to libdb-dev transition to libdb4.7-dev.
  * Change patch 01-configure-find-db4.6 to add db4.7.
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

  [Scott Kitterman]

  * Change unversioned dependency on libdb-dev to versioned:
    libetpan and claws packages have to be in sync.

 -- Cesare Tirabassi <email address hidden>   Sat, 12 Jul 2008 16:30:55 +0200

Available diffs

Superseded in intrepid-release on 2008-07-12
libetpan (0.54-1) unstable; urgency=low

  * New upstream release.
  * Upstream changed library soname; rename library package to libetpan13.
  * Made shlibs file more backporting-friendly (closes one half of 467297).
  * Added symbols file for the library.
  * Recoded debian/copyright to utf-8.
  * Fixed a typo in libetpan-config manpage (thanks lintian).
  * (Build-)Depend on libdb-dev, not libdb4.x-dev.
  * Added a patch to that helps configure to find libdb4.6.
  * Bumped Standards-Version to 3.7.3.

 -- Scott Kitterman <email address hidden>   Sun,  2 Mar 2008 00:22:04 +0300
Superseded in intrepid-release on 2008-05-15
Obsolete in hardy-release on 2015-04-24
libetpan (0.52-1ubuntu1) hardy; urgency=low

  * Build using db-4.6.

 -- Matthias Klose <email address hidden>   Fri, 25 Jan 2008 16:28:01 +0000
Superseded in dapper-updates on 2009-05-04
Obsolete in dapper-backports on 2011-09-06
libetpan (0.48-2~dapper1) dapper-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in hardy-release on 2008-01-25
libetpan (0.52-1) unstable; urgency=low

  * New upstream release.
  * Increased version in shlibs file, because of a new function in API.
  * Add libexpat1-dev and libcurl4-gnutls-dev (>= 7.16.4-5) to Build-Depends
    and to Depends of libetpan-dev package.
    Versioned dependency on libcurl4-gnutls-dev is because of #439317.
  * Updates in handling documentastion:
    - upstream tarball no longer provides txt documentation, only html,
      so no longer install API.txt.gz,
    - don't install README file since it does not contain useful information,
      only installation instructions,
    - don't install compiled tests into libetpan-doc package, which is
      Architecture: all,
    - install doc/depend.dot and doc/layer.fig files.
  * Fixes suggested by lintian:
    - -$(MAKE) distclean => $(MAKE) distclean
    - ${Source-Version} => ${binary:Version}

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
libetpan (0.49-3) unstable; urgency=low

  * REALLY upload to unstable.

Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
libetpan (0.48-2) unstable; urgency=low

  * Apply patch from Colin Leroy <email address hidden> to fix crash when imap
    server returns errors. Closes: #398382.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  12 Dec 2006 10:58:01 +0000
Superseded in feisty-release on 2006-12-12
libetpan (0.48-1) unstable; urgency=low

  * New upstream release.
  * Upstream changed library soname; rename library package to libetpan10.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  08 Nov 2006 17:15:30 +0000
Superseded in feisty-release on 2006-11-08
libetpan (0.47-1) unstable; urgency=low

  * New upstream release.
    - Removed patches included upstream.
    - Did not increase library version in shlibs file, because looks like
      no change was done in the library ABI (although a new header was
      exported)

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
libetpan (0.46-2) unstable; urgency=low

  * Configure with --without-openssl, to force usage of gnutls if both
    openssl and gnutls are available in build environment.

Superseded in edgy-release on 2006-09-19
libetpan (0.45-4) unstable; urgency=low

  * Avoid attempts to run autotools at build time (Closes: #375611).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  29 Jun 2006 10:54:01 +0100
Superseded in edgy-release on 2006-06-29
libetpan (0.45-3) unstable; urgency=low

  * Build against libdb-4.4 (Closes: #367853). Per discussion in that bug,
    this should be safe.
  * Increased version number in shlibs file because of libdb version change.
  * Updated Standards-Version to 3.7.2, no changes required.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 14:37:07 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
libetpan (0.45-2) unstable; urgency=low

  * Add patch by Colin Leroy <email address hidden>, already in upstream CVS,
    that shoud fix #356325, #362747 and #358882.
  * Rebuild against libgnutls13. Will they ever stabialize their API?

Superseded in dapper-release on 2006-05-03
Superseded in dapper-release on 2006-02-03
libetpan (0.40-1ubuntu1) dapper; urgency=low


  * Resynchronise with Debian.

 -- Loic Pefferkorn <email address hidden>  Sat, 26 Nov 2005 09:42:59 +0100
Obsolete in breezy-release on 2008-03-25
libetpan (0.38-2ubuntu1) breezy; urgency=low


  * Swap lignutls-dev build-dep for libgnutls11-dev, as we don't have
    gnutls12 in breezy.  This can be overwritten in a sync in dapper.

 -- Adam Conrad <email address hidden>  Tue, 27 Sep 2005 13:31:17 +1000
Obsolete in hoary-release on 2008-03-19
libetpan (0.35-1) unstable; urgency=low


  * New upstream release:
    - has patch for gcc-4.0 applied (Closes: #287387),
    - has proper version in configure.in, so 02-fix-version.dpatch is not
      needed,
    - has 01-lockfile.dpatch applied.
  * Added debian/watch file.
  * Increased version in shlibs file, since new API calls have been added.
  * Added copyright information for libetpan-config.1 manpage.
  * Fixed libetpan-doc.doc-base to point to new index page (book1.htm) of
    API documentation.

 -- Nikita V. Youshchenko <email address hidden>  Sun,  2 Jan 2005 23:05:15 +0300
144 of 44 results