Change log for libfreenect package in Ubuntu

111 of 11 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-04
Deleted in bionic-proposed (Reason: moved to release)
libfreenect (1:0.5.3-1build1) bionic; urgency=high

  * No change rebuild to pick up -fPIE compiler default

 -- Balint Reczey <email address hidden>  Tue, 03 Apr 2018 12:32:05 +0000
Superseded in bionic-release on 2018-04-04
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-01-04
Deleted in xenial-proposed (Reason: moved to release)
libfreenect (1:0.5.3-1) unstable; urgency=medium

  * Recent upstream bugfix release
  * debian/{patches/deb_python_versions,rules}
    - adjusted to not use generic FindPython* helpers since shown to be
      not robust and in our case we need just a single version ATM
      (Closes: #809582)
  * debian/patches/up_donot_leak_fnusb_claim_camera_into_API
    to avoid leaking fnusb_claim_camera() into public library

 -- Yaroslav Halchenko <email address hidden>  Fri, 01 Jan 2016 22:26:32 -0500
Superseded in xenial-release on 2016-01-04
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
libfreenect (1:0.5.2+git6-g5455843+dfsg-1) unstable; urgency=medium

  * New upstream snapshot from v0.5.2-6-g5455843 with few fixes
  * Upload to unstable
  * Added 3 new missing symbols to .symbols file
  * debian/control
    - boosted policy compliance to 3.9.6

 -- Yaroslav Halchenko <email address hidden>  Wed, 29 Apr 2015 09:15:43 -0400
Superseded in wily-release on 2015-05-18
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-11-27
Deleted in trusty-proposed (Reason: moved to release)
libfreenect (1:0.2.0+dfsg-2) unstable; urgency=low


  * debian/patches
    - correct-libusb-path.patch - "reintroduced" to fix a single left-out
      versioned include of libusb.h . Should resolve FTBFS on kfreeebsd
      (Closes: #728483)

 -- Yaroslav Halchenko <email address hidden>  Fri, 01 Nov 2013 14:44:18 -0400
Superseded in trusty-proposed on 2013-11-02
libfreenect (1:0.2.0+dfsg-1) unstable; urgency=low


  * Fresh upstream release
    - support of newer Kinect models (Closes: #723939). Thanks Andrew Harvey
      for the report
    - packaged is actually v0.2.0-1-g5eed1f0 (i.e. 1 commit after release tag)
      to have correct version specified to cmake
    - public library API dropped some functions (retained in the source but
      marked as 'hidden'), SOVERSION boosted to 0.2
  * debian/patches
    - add-missing-libs.patch and modify-fakenect-install.patch -- updated
    - removed (absorbed upstream):
      build-on-big-endian-systems-again.patch
      cameras-memcpy-structs-into-aligned-buffer.patch
      correct-libusb-search-and-include.patch
      remove-libusb-include-from-exported-header.patch
  * debian/copyright
    - updated to include wrappers/ruby/ffi-libfreenect copyright/license
      (Thanks Paul Tagliamonte for the review/report)

 -- Yaroslav Halchenko <email address hidden>  Sun, 27 Oct 2013 09:42:41 -0400
Superseded in trusty-release on 2013-11-27
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libfreenect (1:0.1.2+dfsg-6) unstable; urgency=low


  [ Nicolas Bourdaud ]
  * Make build system compatible with multiarch:
    - dont-postfix-to-install-libdir.patch becomes use-standard-libdir.patch
  * Bump debhelper compatibility level to 9.
  * Add multiarch support.
  * Remove useless section fields from debian/control.
  * Use dh_python2 instead of dh_pysupport.
  * Update manpages with keyboard shortcuts. (Closes: #663869)

 -- Yaroslav Halchenko <email address hidden>  Tue, 22 May 2012 12:55:02 -0400

Available diffs

Superseded in quantal-release on 2012-05-24
libfreenect (1:0.1.2+dfsg-5) unstable; urgency=low


  [ Nicolas Bourdaud ]
  * Execute dh_numpy for python-freenect to fix lintian error
  * Bump policy version to 3.9.3 -- no changes
  * Update remove-libusb-include-from-exported-header.patch to fix warnings
    about undeclared struct timeval when using libfreenect.h

 -- Yaroslav Halchenko <email address hidden>  Sun, 04 Mar 2012 21:42:06 -0500
Obsolete in oneiric-updates on 2015-04-24
Deleted in oneiric-proposed on 2015-04-26 (Reason: moved to -updates)
libfreenect (1:0.0.1+20101211+2-2ubuntu1) oneiric-proposed; urgency=low

  * Changed libglut3 dependency to freeglut3 (LP: #861338)
 -- Daniel Patrick Johnson <email address hidden>   Tue, 17 Jan 2012 11:32:56 -0800
Superseded in quantal-release on 2012-04-30
Published in precise-release on 2012-01-18
libfreenect (1:0.0.1+20101211+2-3) unstable; urgency=low


  [ Nicolas Bourdaud ]
  * [03039eb] Remove useless explicit dependencies (e.g. libglut3) of
    binary packages (Closes: #616525)

  [ Yaroslav Halchenko]
  * Moved GPL-2 license stud to a separate paragraph
  * Boosted policy compliance to 3.9.2 -- no changes
  * Moved numpy into Depends from Suggests (Closes: #641792)
  * Added Build-Depends on python-support and call to dh_pysupport in
    binary-install (Closes: #632062)

 -- Yaroslav Halchenko <email address hidden>  Mon, 16 Jan 2012 22:24:06 -0500
Superseded in precise-release on 2012-01-18
Obsolete in oneiric-release on 2015-04-24
libfreenect (1:0.0.1+20101211+2-2) unstable; urgency=low

  * Added freeglut3-dev as a leading alternative to libglut3-dev
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  28 Jun 2011 10:02:05 +0000
Superseded in oneiric-release on 2011-06-28
libfreenect (1:0.0.1+20101211+2-1) unstable; urgency=low

  * Initial release for Debian (Closes: #606831)
  * Cherry-picked (into .orig.tar.gz) from upstream to resolve licensing
    issues:
    - [9cdc713] Removed old, unused kinect protocol documentation, as all
      info now exists on wiki and should be exported from there as needed
    - [3390f9b] Added BSD license into libusb-1.0 finder for compliance
    - [0a165cf] Carry pre-generated CONTRIB to be distributed/installed
      under /u/s/doc/*freenect* to fulfill upstream license requirement
  * [64cb9a2] debian/copyright: migrated to DEP5 format
    - added missing statement for cmake_modules/Findlibusb-1.0.cmake
  * [f34b2ea] added debian/blends and injected into the debian-science
    task files
  * [17eb497] pruning done debian/TODO items

111 of 11 results