libgdamm5.0 4.99.6-0ubuntu2 source package in Ubuntu

Changelog

libgdamm5.0 (4.99.6-0ubuntu2) precise; urgency=low

  * 3.0 Quilt format.
  * Rename binary package to libgdamm-5.0-13.

libgdamm5.0 (4.99.6-0ubuntu1openismus1) oneiric; urgency=low

  * New upstream release

libgdamm5.0 (4.99.5-0ubuntu1openismus1) oneiric; urgency=low

  * New upstream release

libgdamm5.0 (4.99.4-0ubuntu1openismus1) oneiric; urgency=low

  * Packaging libgdamm-5.0

libgdamm4.0 (4.1.2-0ubuntu1) oneiric; urgency=low

  * New upstream release
  * debian/control.in: updated glibmm requirement.
  * Updated SONAME from 12 to 13.

libgdamm4.0 (4.1.1-0ubuntu1) natty; urgency=low

  * New upstream release.
  * debian/control:
   - Bump libgda-4.0-dev build-dep to 4.1.7.
   - Bump lib package name to match SONAME.
   - Conflict/Replace on libgdamm4.0-11 which unfortunately
     actually provided libgdamm-4.0.so.12.
  * debian/rules: Update SHVER.

libgdamm4.0 (3.99.17-0ubuntu1) karmic; urgency=low

  * New upstream release:
    - Support new flag added in latest libgda4.
  * debian/control:
    - Bump libgda-4.0-dev build-dep to 4.0.3
  * debian/rules:
    - Update SHVER.

libgdamm4.0 (3.99.16-0ubuntu3) karmic; urgency=low

  * debian/control:
    - Update libgdamm4.0-dev dependencies with the correct libgda-4.0-dev
      package name too.

libgdamm4.0 (3.99.16-0ubuntu2) karmic; urgency=low

  * debian/control:
    - Updated libgda4 build-depend to pick up new package names.

libgdamm4.0 (3.99.16-0ubuntu1) karmic; urgency=low

  * New upstream version.
    - Based on libgda v4.
  * debian/control:
    - Change libgda3-dev build-dep to libgda4-dev.
    - Rename libgdamm3.0* -> libgdamm4.0*.
    - Remove obsolete conflicts/replaces.
  * debian/libgdamm4.0-dev.install:
    - Update for new version.
  * debian/libgdamm4.0-doc.doc-base.libgdamm4.0-reference:
    - Update for new version.
  * debian/rules:
    - Update SHVER.
    - Don't include /usr/share/cdbs/1/rules/simple-patchsys.mk - there
      are currently no patches.
  * Dropped obsolete 01_unused_parameter_warning.patch.

libgdamm3.0 (3.0.1-1) unstable; urgency=low

  [ Deng Xiyue ]
  * Add dpkg-dev >= 1.14.16 to Build-Depends for DM usage.
  * Remove doc-base from Build-Depends as it's not b-deped on.
  * Add ${shlibs:Depends} to all Depends fields as recommended.
  * Use machine-interpretable format for debian/copyright.
  * New upstream stable release.
  * Update Standard-Version to 3.8.0.  No change needed.
  * Add 01_unused_parameter_warning.patch from Norbert Kiesel
    <email address hidden> to silence a g++ warning.  Thanks Norbert.
    (Closes: #472834)

  [ Loic Minier ]
  * Properly anchor package name regexp.

libgdamm3.0 (3.0.0-2) unstable; urgency=low

  * Drop Conflicts/Replaces from shared library package.  They should be
    able to install in parallel.
  * Add `DM-Upload-Allowed: yes' field.  Thanks Loïc for advocacy.

libgdamm3.0 (3.0.0-1) unstable; urgency=low

  * New upstream release.
    + Bump soversion to 10 to match upstream changes.
    + Add proper Conflicts/Replaces to prepare for sync from Ubuntu.
  * Add Debian GNOME Team as uploader.
  * Refine debian/rules to be consistent with other GNOME Packages:
    + Use gnome-pkg-tools, and set GNOME_MODULE := libgdamm
    + Set shlibs version to 3.0.0 due to new API.
    + Set proper exclude rules.
    + Use chrpath hack to get rid of rpath on 64bit system.
    + Bump compat level to 6, and b-dep on debhelper >= 6, cdbs >= 0.4.51.
  * Refine debian/control*:
    + Add chrpath, gnome-pkg-tools to Build-depends.
    + Wrap fields for easier patch.
    + Add ${misc:Depends} and ${shlibs:Depends} to Depends.
  * Add libgdamm-3.0-doc.doc-base.libgdamm3.0-reference.
  * Add libgdamm-3.0-doc.examples to ship examples.
  * Refine libgdamm-3.0-doc.docs install path to retain original directory
    hierarchy.
  * Refine watch file.

libgdamm3.0 (2.9.81-1) unstable; urgency=low

  * Import Ubuntu package in Debian
  * New upstream version.
  * Change Maintainer address to point at me
  * Update Standars-Version to 3.7.3. No changes needed.
  * Change how binary packages are named, from libgdamm-3.0 to libgdamm3.0
  * Change package descriptions to made them more similar to the ones included
  in libgdamm1.3 package.

libgdamm3.0 (2.9.8-0ubuntu1) gutsy; urgency=low

  * New upstream release:
    - Rename set(GType) to set_g_type(GType).
    - set(Glib::Date): Correct the GValue initialization.

  * debian/watch:
    - Added
  * debian/control:
    - Modified Maintainer to Desktop Team
    - Updated soname
  * debian/libgdamm-3.0-7.install:
    - renamed to libgdamm-3.0-8.install

libgdamm3.0 (2.9.7-0ubuntu3) gutsy; urgency=low

  * Rebuild against glib, now that the fix is actually applied.

libgdamm3.0 (2.9.7-0ubuntu2) gutsy; urgency=low

  * Rebuild for glib ABI change.

libgdamm3.0 (2.9.7-0ubuntu1) gutsy; urgency=low

  * New upstream release:
    - DictConstraint: pkey_set_fields(), pkey_get_fields(),
      fkey_set_fields(), fkey_set_actions(), fkey_get_actions(),
      unique_set_fields(), unique_get_fields(): Use SListHandle, so the
      application coder can use standard C++ containers.

libgdamm3.0 (2.9.6-0ubuntu1) gutsy; urgency=low

  * New upstream release:
    - Config: get_provider_by_name(), get_providers(), get_value_string():
      Fix memory problems, fixing crashes.

libgdamm3.0 (2.9.5-0ubuntu1) gutsy; urgency=low

  * Initial release.
 -- Daniel Holbach <email address hidden>   Tue, 07 Feb 2012 16:44:36 +0100

Upload details

Uploaded by:
Daniel Holbach on 2012-02-22
Uploaded to:
Precise
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
devel
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Precise release on 2012-02-28 universe devel

Downloads

File Size SHA-256 Checksum
libgdamm5.0_4.99.6.orig.tar.gz 2.3 MiB e3c03264183e93e8e9b0734b6b7e5735bb6a4edd527c8b3348f9e77d4c10bf37
libgdamm5.0_4.99.6-0ubuntu2.debian.tar.gz 4.6 KiB 89710fb6ea787c11dafb0693f1ff3c118c1eb29ca6a1bcc4088c25869bca407f
libgdamm5.0_4.99.6-0ubuntu2.dsc 1.7 KiB ccb3a8714eec78aada70bffc1198c00ba4c97c710298d4920b719b57a75bed9c

View changes file

Binary packages built by this source

libgdamm-5.0-13: No summary available for libgdamm-5.0-13 in ubuntu quantal.

No description available for libgdamm-5.0-13 in ubuntu quantal.

libgdamm5.0-dev: C++ wrappers for libgda3 (library headers)

 libgdamm is a set of C++ bindings for the libgda database API.
 libgda is the GNU Data Access library.
 .
 This package contains the library headers.

libgdamm5.0-doc: No summary available for libgdamm5.0-doc in ubuntu saucy.

No description available for libgdamm5.0-doc in ubuntu saucy.