Change log for libgoogle-gson-java package in Ubuntu

111 of 11 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-06-03
Deleted in groovy-proposed (Reason: moved to Release)
libgoogle-gson-java (2.8.6-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version updated to 4.5.0
  * Switch to debhelper level 12

 -- Emmanuel Bourg <email address hidden>  Sun, 31 May 2020 22:32:55 +0200

Available diffs

Obsolete in cosmic-updates on 2020-07-13
Published in bionic-updates on 2019-04-16
Obsolete in cosmic-security on 2020-07-13
Published in bionic-security on 2019-04-16
Deleted in cosmic-proposed (Reason: moved to -updates)
Deleted in bionic-proposed (Reason: moved to -updates)
libgoogle-gson-java (2.8.5-3~18.04) bionic; urgency=medium

  * Build for bionic. LP: #1816528.

 -- Matthias Klose <email address hidden>  Sun, 03 Feb 2019 13:57:47 +0100
Superseded in groovy-release on 2020-06-03
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-04-18
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed (Reason: moved to release)
libgoogle-gson-java (2.8.5-3) unstable; urgency=medium

  * Team upload.
  * Remove the OpenIDE-Module entry again but sync the Manifest file with all
    the information from the previous 2.7.0 version.

 -- Markus Koschany <email address hidden>  Fri, 25 Jan 2019 11:54:04 +0100

Available diffs

Superseded in disco-release on 2019-01-25
Deleted in disco-proposed on 2019-01-29 (Reason: moved to release)
libgoogle-gson-java (2.8.5-2) unstable; urgency=medium

  * Team upload.
  * Add OpenIDE-Module entry to MANIFEST file to fix an error in Netbeans 10.
  * Declare compliance with Debian Policy 4.3.0.

 -- Markus Koschany <email address hidden>  Sun, 13 Jan 2019 23:39:43 +0100

Available diffs

Superseded in disco-release on 2019-01-14
Deleted in disco-proposed on 2019-01-15 (Reason: moved to release)
libgoogle-gson-java (2.8.5-1) unstable; urgency=medium

  * New upstream release
    - Removed the Java 9 patches (fixed upstream)
    - Replaced templating-maven-plugin with sed
  * Ignore the broken tests to work around the build failure with Java 11
    (Closes: #912433)
  * Restored the parent of gson/pom.xml to inherit the build settings
  * Updated the watch file for the recent releases
  * Standards-Version updated to 4.2.1
  * Exclude the Gradle wrapper from the upstream tarball
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <email address hidden>  Thu, 08 Nov 2018 12:04:52 +0100

Available diffs

Superseded in disco-release on 2018-11-09
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2018-04-21
Deleted in bionic-proposed (Reason: moved to release)
libgoogle-gson-java (2.8.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 2.8.2.
    - Fix FTBFS with Java 9. (Closes: #893238)
  * Drop maven.cleanIgnoreRules and maven.publishedRules because they do
    nothing.
  * Use compat level 11.
  * Declare compliance with Debian Policy 4.1.3.
  * Install the MANIFEST file with javahelper since the bnd-maven-plugin is not
    available.

 -- Markus Koschany <email address hidden>  Sun, 08 Apr 2018 19:51:28 +0200

Available diffs

Superseded in bionic-release on 2018-04-21
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed on 2020-07-10 (Reason: moved to release)
libgoogle-gson-java (2.4-2) unstable; urgency=medium

  * Team upload.
  * Build with the DH sequencer instead of CDBS
  * Added the missing build dependency on junit4
  * Standards-Version updated to 4.1.0
  * Switch to debhelper level 10

 -- Emmanuel Bourg <email address hidden>  Sat, 16 Sep 2017 22:20:53 +0200

Available diffs

Superseded in artful-release on 2017-09-17
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-11-04
Deleted in xenial-proposed (Reason: moved to release)
libgoogle-gson-java (2.4-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Adapted the build to the new project layout
  * debian/control:
    - Standards-Version updated to 3.9.6 (no changes)
    - Updated the Homepage field
  * debian/watch: Watch the release tags on Github
  * Switch to debhelper level 9

 -- Emmanuel Bourg <email address hidden>  Tue, 03 Nov 2015 22:50:32 +0100

Available diffs

Superseded in xenial-release on 2015-11-04
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-22
Deleted in trusty-proposed (Reason: moved to release)
libgoogle-gson-java (2.2.4-1) unstable; urgency=low


  * New upstream release
  * debian/control:
    - Use canonical URLs for the Vcs-* fields
    - Updated Standards-Version to 3.9.4 (no changes)
    - Removed the build dependency on libmaven-cobertura-plugin-java
    - Removed the build dependency on libmaven-assembly-plugin-java
    - Removed the explicit build dependency on libmaven-compiler-plugin-java
    - Removed the explicit build dependency on maven-repo-helper
    - Removed the unused build dependency on javahelper
  * Removed custom-build.patch and use Maven rules to ignore
    the unused dependencies
  * Register the Javadoc with doc-base
  * debian/rules: Added a get-orig-source target
  * debian/copyright: Updated the Format URI to 1.0
  * Added debian/orig-tar.sh to build the tarball
    from the upstream SVN repository and documented the process
    in debian/README.source

 -- Emmanuel Bourg <email address hidden>  Tue, 27 Aug 2013 15:30:05 +0200

Available diffs

Superseded in trusty-release on 2013-10-22
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libgoogle-gson-java (2.1-2) unstable; urgency=low


  * Team upload.
  * Modify d/poms file for m-d-h behavior change. (Closes: #670658)
  * Bump Standards-Version to 3.9.3 (no changes).

 -- tony mancill <email address hidden>  Fri, 27 Apr 2012 13:55:49 -0700

Available diffs

Superseded in quantal-release on 2012-05-09
libgoogle-gson-java (2.1-1) unstable; urgency=low


  * Initial release. (Closes: #654949)

 -- Jakub Adam <email address hidden>  Thu, 05 Jan 2012 23:13:41 +0100
111 of 11 results