Change log for libgssglue package in Ubuntu

119 of 19 results
Published in groovy-release on 2020-04-24
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-09-01
Deleted in eoan-proposed (Reason: moved to release)
libgssglue (0.4-2ubuntu2) eoan; urgency=medium

  * No-change rebuild to drop multiarch-support dependency.

 -- Matthias Klose <email address hidden>  Sun, 01 Sep 2019 03:41:09 +0000

Available diffs

Superseded in eoan-release on 2019-09-01
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-12-19
Deleted in trusty-proposed (Reason: moved to release)
libgssglue (0.4-2ubuntu1) trusty; urgency=medium

  * Use dh-autoreconf to update libtool macros for new ports.
 -- Colin Watson <email address hidden>   Wed, 18 Dec 2013 22:17:19 +0000

Available diffs

Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
libgssglue (0.1-4ubuntu0.1) lucid-security; urgency=low

  * SECURITY UPDATE: Privilege escalation via malicious environment variable
    - debian/patches/07-CVE_2011_2709.patch: Only read the GSSAPI_MECH_CONF
      environment variable in non-setuid situations. Based on upstream patch.
    - CVE-2011-2709
 -- Tyler Hicks <email address hidden>   Thu, 27 Sep 2012 21:13:08 -0700
Obsolete in natty-updates on 2013-06-04
Obsolete in natty-security on 2013-06-04
libgssglue (0.1-4ubuntu1.1) natty-security; urgency=low

  * SECURITY UPDATE: Privilege escalation via malicious environment variable
    - debian/patches/07-CVE_2011_2709.patch: Only read the GSSAPI_MECH_CONF
      environment variable in non-setuid situations. Based on upstream patch.
    - CVE-2011-2709
 -- Tyler Hicks <email address hidden>   Thu, 27 Sep 2012 21:13:08 -0700
Obsolete in oneiric-updates on 2015-04-24
Obsolete in oneiric-security on 2015-04-24
libgssglue (0.3-1ubuntu1.1) oneiric-security; urgency=low

  * SECURITY UPDATE: Privilege escalation via malicious environment variable
    - debian/patches/07-CVE_2011_2709.patch: Only read the GSSAPI_MECH_CONF
      environment variable in non-setuid situations. Based on upstream patch.
    - CVE-2011-2709
 -- Tyler Hicks <email address hidden>   Thu, 27 Sep 2012 21:13:08 -0700
Published in precise-updates on 2012-10-15
Published in precise-security on 2012-10-15
libgssglue (0.3-4ubuntu0.1) precise-security; urgency=low

  * SECURITY UPDATE: Privilege escalation via malicious environment variable
    - debian/patches/07-CVE_2011_2709.patch: Only read the GSSAPI_MECH_CONF
      environment variable in non-setuid situations. Based on upstream patch.
    - CVE-2011-2709
 -- Tyler Hicks <email address hidden>   Thu, 27 Sep 2012 21:13:08 -0700
Superseded in trusty-release on 2013-12-19
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libgssglue (0.4-2) unstable; urgency=low


  * Add multiarch support
  * Use hardening options

 -- Anibal Monsalve Salazar <email address hidden>  Fri, 08 Jun 2012 14:50:06 +1000

Available diffs

Superseded in quantal-release on 2012-06-08
libgssglue (0.4-1) unstable; urgency=high


  * New upstream version 0.4
    Changes since libgssglue-0.3:
    - Fix for CVE-2011-2709
      Patch from Marcus Meissner
      Note: Although https://bugzilla.novell.com/show_bug.cgi?id=694598
      mentions mount.nfs, libgssglue is not used by mount.nfs.
  * Fix out-of-date-standards-version
  * DH compatibility level is 9

 -- Anibal Monsalve Salazar <email address hidden>  Thu, 10 May 2012 10:08:08 +1000

Available diffs

Superseded in quantal-release on 2012-05-14
Published in precise-release on 2011-12-16
libgssglue (0.3-4) unstable; urgency=low

  * DH compatibility level is 8
  * Update debian/copyright
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  16 Dec 2011 16:26:35 +0000

Available diffs

Superseded in precise-release on 2011-12-16
libgssglue (0.3-3.1) unstable; urgency=emergency


  * Non-maintainer upload.
  * Don't use bzip2 compression for the debs (closes: 643950).
    No thanks, Anibal.

 -- Julien Cristau <email address hidden>  Fri, 07 Oct 2011 21:33:03 +0200
Superseded in precise-release on 2011-10-18
Obsolete in oneiric-release on 2015-04-24
libgssglue (0.3-1ubuntu1) oneiric; urgency=low

  * Move library to /lib, since this is used by rpcbind in /sbin.
 -- Steve Langasek <email address hidden>   Wed, 31 Aug 2011 20:45:13 +0000

Available diffs

Superseded in oneiric-release on 2011-09-01
libgssglue (0.3-1) unstable; urgency=low

  * New upstream
    Changes since libgssglue-0.2:
    + Add new typedefs defined in RFC 5587 and used in newer versions
      of MIT Kerberos.
    + Fixes a compile error in nfs-utils which uses gssapi.h from this
      package and other gss headers from the Kerberos distribution.
  * Merged upstream:
    debian/patches/07-629553-gssapi.h.in.patch
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  23 Jun 2011 10:34:07 +0000

Available diffs

Superseded in oneiric-release on 2011-06-23
libgssglue (0.2-3) unstable; urgency=medium

  * Fix incompatibility with krb5 1.9
    Add debian/patches/07-629553-gssapi.h.in.patch from upstream
    Closes: 629553, 629692
  * Fix unneeded-build-dep-on-quilt
  * Fix out-of-date-standards-version
  * Fix debian-rules-missing-recommended-target
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  17 Jun 2011 07:49:25 +0000

Available diffs

Superseded in oneiric-release on 2011-06-17
libgssglue (0.2-2) unstable; urgency=low

  [ Steve Langasek ]
  * debian/patches/01-370825-gssapi_mech.conf.patch: update for multiarch;
    look up our gssapi mechs using the default search path instead of an
    absolute path since the absolute path won't be the same on all archs (or
    the same before and after multiarch).
    Closes: 619559

  [ Anibal Monsalve Salazar ]
  * Remove debian/patches/debian-changes-0.2-1
    Closes: 619052

Available diffs

Superseded in oneiric-release on 2011-06-03
Obsolete in natty-release on 2013-06-04
libgssglue (0.1-4ubuntu1) natty; urgency=low

  * debian/patches/01-370825-gssapi_mech.conf.patch: update for multiarch;
    look up our gssapi mechs using the default search path instead of an
    absolute path since the absolute path won't be the same on all archs (or
    the same before and after multiarch).
 -- Steve Langasek <email address hidden>   Thu, 24 Mar 2011 20:51:05 -0700

Available diffs

Superseded in natty-release on 2011-03-25
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
libgssglue (0.1-4) unstable; urgency=low

  * Removing myself from uploaders.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  05 Nov 2009 06:05:50 +0000

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
libgssglue (0.1-3) unstable; urgency=low

  * Build on GNU/kFreeBSD. Closes: #531986
  * Fix resource leak. Closes: #512730
  * Fix wrong #if statments. Closes: 400185
  * Build depend on quilt
  * Standards Version is 3.8.1
  * DH compat is 7
  * Run dh_prep instead of dh_clean -k

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  08 Jun 2009 11:00:01 +0100

Available diffs

Superseded in karmic-release on 2009-06-08
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
libgssglue (0.1-2) unstable; urgency=low

  * Repackage debian source
  * Don't ship libgssglue.la. Closes: #473344
  * Update debian/watch file 
  * Fix the following lintian issues:
    W: libgssglue source: out-of-date-standards-version 3.7.2 (current is
       3.7.3)
    W: libgssglue1: description-contains-homepage
    W: libgssglue-dev: description-contains-homepage

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:14:11 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
Superseded in hardy-release on 2007-11-15
libgssglue (0.1-1) unstable; urgency=medium

  * debian/control:
    - Removed libgssapi-dev & libgssapi2 from Provides list.
      Closes: #441864.

119 of 19 results