Change log for libio-socket-ip-perl package in Ubuntu

117 of 17 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-11-12
Deleted in bionic-proposed (Reason: moved to release)
libio-socket-ip-perl (0.39-1) unstable; urgency=medium

  * Team upload.
  * Import upstream version 0.39
  * Drop old requirements for Socket version.
    The required version is satisfied in the oldstable distribution (jessie)
    now already.
  * Update copyright years for debian/* packaging files
  * Update copyright years for upstream files
  * Declare compliance with Debian policy 4.1.1
  * Cleanup trailing whitespaces in debian/changelog file

 -- Salvatore Bonaccorso <email address hidden>  Sun, 12 Nov 2017 14:32:56 +0100

Available diffs

Superseded in bionic-release on 2017-11-12
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
libio-socket-ip-perl (0.38-1) unstable; urgency=medium

  [ Salvatore Bonaccorso ]
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI

  [ gregor herrmann ]
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
  * New upstream release.
  * Update years of upstream and packaging copyright.
  * Declare compliance with Debian Policy 3.9.8.
  * Bump debhelper compatibility level to 9.

 -- gregor herrmann <email address hidden>  Sun, 30 Oct 2016 15:24:33 +0100

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
libio-socket-ip-perl (0.37-1) unstable; urgency=medium

  * Team upload

  * Imported Upstream version 0.37
    Closes: #788259 -- uninstallable with perl 5.22
  * Bump years of upstream copyright
  * Declare conformance with Policy 3.9.6
  * Add Testsuite control header

 -- Damyan Ivanov <email address hidden>  Fri, 12 Jun 2015 08:46:27 +0000

Available diffs

Superseded in wily-release on 2015-06-13
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
libio-socket-ip-perl (0.32-1) unstable; urgency=low


  * Team upload.
  * Update Vcs-Browser URL to cgit web frontend
  * Imported Upstream version 0.32
  * Add libmodule-build-perl to Build-Depends
  * Move perl to Build-Depends-Indep

 -- Salvatore Bonaccorso <email address hidden>  Sun, 14 Sep 2014 15:34:30 +0200

Available diffs

Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
libio-socket-ip-perl (0.31-1) unstable; urgency=low


  * Team upload.
  * Imported Upstream version 0.30 and 0.31
    - IO::Socket::IP should not call $self->connect when retrying connect
      (Closes: #749212)

 -- Salvatore Bonaccorso <email address hidden>  Sun, 13 Jul 2014 19:52:33 +0200

Available diffs

Superseded in utopic-release on 2014-07-17
Deleted in utopic-proposed on 2014-07-18 (Reason: moved to release)
libio-socket-ip-perl (0.29-3) unstable; urgency=low


  * Team upload.
  * Revert "Add 749212.patch patch"
    This reverts commit 3c530918ff9a2626dfe536fca267a285fcb6ed5c.
    Patch reverted as it seems to introduce regressions, e.g. in bts from
    devscripts. bts show -m $bugnumber fails to download bugreport.

 -- Salvatore Bonaccorso <email address hidden>  Mon, 09 Jun 2014 17:26:40 +0200

Available diffs

Superseded in utopic-release on 2014-06-10
Deleted in utopic-proposed on 2014-06-11 (Reason: moved to release)
libio-socket-ip-perl (0.29-2) unstable; urgency=low


  * Team upload.
  * Add 749212.patch patch.
    IO::Socket::IP should not call $self->connect when retrying connect.
    Thanks to Jakub Wilk <email address hidden> for the original report.
    (Closes: #749212)

 -- Salvatore Bonaccorso <email address hidden>  Mon, 09 Jun 2014 06:50:16 +0200

Available diffs

Superseded in utopic-release on 2014-06-09
Deleted in utopic-proposed on 2014-06-10 (Reason: moved to release)
libio-socket-ip-perl (0.29-1) unstable; urgency=medium


  [ gregor herrmann ]
  * Strip trailing slash from metacpan URLs.

  [ Xavier Guimard ]
  * Imported Upstream version 0.29

 -- Xavier Guimard <email address hidden>  Thu, 06 Mar 2014 07:06:42 +0100

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-01-19
Deleted in trusty-proposed (Reason: moved to release)
libio-socket-ip-perl (0.25-3) unstable; urgency=medium


  * Really effect the above change by changing the dh_perl invocation
    (Closes: #735925). Thanks to Niko Tyni for pointing out the problem.

 -- Dominic Hargreaves <email address hidden>  Sun, 19 Jan 2014 17:38:43 +0000

Available diffs

Superseded in trusty-release on 2014-01-19
Deleted in trusty-proposed on 2014-01-21 (Reason: moved to release)
libio-socket-ip-perl (0.25-2) unstable; urgency=medium


  * Switch Depends from perl to perl-base as a special case, for a
    module which is likely to become part of perl-base in 5.20
    (Closes: #735925)

 -- Dominic Hargreaves <email address hidden>  Sun, 19 Jan 2014 11:58:14 +0000

Available diffs

Superseded in trusty-release on 2014-01-19
Deleted in trusty-proposed on 2014-01-20 (Reason: moved to release)
libio-socket-ip-perl (0.25-1) unstable; urgency=medium


  * Team upload.
  * Imported Upstream version 0.25
  * Update copyright years for upstream files
  * Declare compliance with Debian policy 3.9.5

 -- Salvatore Bonaccorso <email address hidden>  Sun, 12 Jan 2014 09:33:27 +0100

Available diffs

Superseded in trusty-release on 2014-01-12
Deleted in trusty-proposed on 2014-01-13 (Reason: moved to release)
libio-socket-ip-perl (0.24-1) unstable; urgency=low


  * New upstream release.
  * Update years of packaging copyright.

 -- gregor herrmann <email address hidden>  Fri, 18 Oct 2013 19:14:46 +0200

Available diffs

Superseded in trusty-release on 2013-10-22
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libio-socket-ip-perl (0.21-1) unstable; urgency=low


  [ gregor herrmann ]
  * debian/control: update {versioned,alternative} (build) dependencies.

  [ Xavier Guimard ]
  * Bump Standards-Version to 3.9.4

  [ Salvatore Bonaccorso ]
  * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * Change search.cpan.org based URIs to metacpan.org based URIs

  [ Dominique Dumont ]
  * Imported Upstream version 0.21
  * copyright: updated years, added /me in debian/*
  * control:
    + added /me in uploaders
    * put back versioned dependencies of libsocket-perl, to avoid
      pbuilder issues
  * added patch to skip test that connect to internet

 -- Dominique Dumont <email address hidden>  Tue, 07 May 2013 14:14:25 +0200
Superseded in saucy-release on 2013-05-12
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libio-socket-ip-perl (0.16-2ubuntu1) quantal; urgency=low

  * Drop alternate build-dependency on perl (>= 5.15.6) to work around
    a bug in Launchpad's sbuild that keeps it in the dep-wait state.
 -- Felix Geyer <email address hidden>   Wed, 08 Aug 2012 19:27:26 +0200

Available diffs

Superseded in quantal-release on 2012-08-08
libio-socket-ip-perl (0.16-2) unstable; urgency=low


  * Team upload.
  * Re-order alternative build-deps to something suitable
    for current testing/sid buildds (Closes: #680809).

 -- intrigeri <email address hidden>  Sun, 08 Jul 2012 14:43:50 -0600

Available diffs

Superseded in quantal-release on 2012-07-22
libio-socket-ip-perl (0.16-1) unstable; urgency=low


  * Team upload.

  [ Ansgar Burchardt ]
  * debian/control: Convert Vcs-* fields to Git.

  [ Salvatore Bonaccorso ]
  * debian/copyright: Replace DEP5 Format-Specification URL from
    svn.debian.org to anonscm.debian.org URL.

  [ gregor herrmann ]
  * New upstream releases 0.08, 0.09, 0.11, 0.12.
  * Update years of upstream and packaging copyright.
  * debian/copyright: update to Copyright-Format 1.0.
  * Remove spelling patch, applied upstream.
  * Remove (build) dependency on libsocket-getaddrinfo-perl, add (build)
    dependency on Socket 1.97.
  * Bump Standards-Version to 3.9.3 (no changes).

  [ intrigeri ]
  * New upstream releases 0.14, 0.15 and 0.16.

 -- intrigeri <email address hidden>  Thu, 28 Jun 2012 16:47:05 +0200

Available diffs

Superseded in quantal-release on 2012-06-29
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
libio-socket-ip-perl (0.07-1) unstable; urgency=low

  * Team upload.
  * New upstream release
  * debian/copyright: Update copyright years for upstream.
  * Bump Debhelper compat level to 8.
  * debian/control:
    - Bump versioned Build-Depends on debhelper to (>= 8).
    - Move perl to Build-Depends as with Debhelper compat level 8 we use
      Build.PL by default. 
    - Add (Build-)Depends(-Indep) on netbase.
  * Add fix-spelling-error-in-manpage.patch to fix spelling error in
    manpage.

117 of 17 results