Change log for libmad package in Ubuntu

119 of 19 results
Published in xenial-updates on 2018-10-25
Published in xenial-security on 2018-10-25
libmad (0.15.1b-9ubuntu16.04.1) xenial-security; urgency=medium

  * Merge from Debian testing, remaining changes:
    - Disable architecture specific optimisations on ARM, as there is a bug in
      this codepath which causes segfaults, and the assembler is very old
      (likely bitrotted). (LP: #989846)

 -- Mike Salvatore <email address hidden>  Thu, 25 Oct 2018 10:47:07 -0400
Published in bionic-updates on 2018-10-25
Published in bionic-security on 2018-10-25
libmad (0.15.1b-9ubuntu18.04.1) bionic-security; urgency=medium

  * Merge from Debian testing, remaining changes:
    - Disable architecture specific optimisations on ARM, as there is a bug in
      this codepath which causes segfaults, and the assembler is very old
      (likely bitrotted). (LP: #989846)

 -- Mike Salvatore <email address hidden>  Thu, 25 Oct 2018 10:47:07 -0400
Published in disco-release on 2018-10-31
Deleted in disco-proposed (Reason: moved to release)
Published in cosmic-updates on 2018-10-25
Published in cosmic-security on 2018-10-25
libmad (0.15.1b-9ubuntu18.10.1) cosmic-security; urgency=medium

  * Merge from Debian testing, remaining changes:
    - Disable architecture specific optimisations on ARM, as there is a bug in
      this codepath which causes segfaults, and the assembler is very old
      (likely bitrotted). (LP: #989846)

 -- Mike Salvatore <email address hidden>  Thu, 25 Oct 2018 10:47:07 -0400
Published in trusty-updates on 2018-10-25
Published in trusty-security on 2018-10-25
libmad (0.15.1b-9ubuntu14.04.1) trusty-security; urgency=medium

  * Merge from Debian testing, remaining changes:
    - Disable architecture specific optimisations on ARM, as there is a bug in
      this codepath which causes segfaults, and the assembler is very old
      (likely bitrotted). (LP: #989846)

 -- Mike Salvatore <email address hidden>  Thu, 25 Oct 2018 10:47:07 -0400
Superseded in disco-release on 2018-10-31
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-25
Deleted in trusty-proposed (Reason: moved to release)
libmad (0.15.1b-8ubuntu1) trusty; urgency=low

  * Merge from Debian testing, remaining changes:
    - Disable architecture specific optimisations on ARM, as there is a bug in
      this codepath which causes segfaults, and the assembler is very old
      (likely bitrotted). (LP: #989846)

Superseded in trusty-release on 2013-10-25
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
libmad (0.15.1b-7ubuntu2) raring; urgency=low

  * Disable architecture specific optimisations on ARM, as there is a bug in
    this codepath which causes segfaults, and the assembler is very old
    (likely bitrotted). (LP: #989846)
 -- Iain Lane <email address hidden>   Wed, 12 Dec 2012 12:10:33 +0000
Superseded in raring-release on 2012-12-13
Obsolete in quantal-release on 2015-04-24
Superseded in quantal-release on 2012-06-15
Published in precise-release on 2012-02-06
libmad (0.15.1b-7ubuntu1) precise; urgency=low

  * Merge from Debian testing, remaining changes:
    - Build for multiarch.
    - Drop libmad.la, no longer needed.
    - Drop redundant build target in debian/rules that ignores all the cdbs
      autotools handling.
 -- Steve Langasek <email address hidden>   Mon, 06 Feb 2012 12:19:01 -0800
Superseded in precise-release on 2012-02-06
libmad (0.15.1b-6ubuntu1) precise; urgency=low

  * Build for multiarch.
  * Drop libmad.la, no longer needed.
  * Drop redundant build target in debian/rules that ignores all the cdbs
    autotools handling.
 -- Steve Langasek <email address hidden>   Thu, 29 Dec 2011 22:46:46 -0800
Superseded in precise-release on 2011-12-30
libmad (0.15.1b-6) unstable; urgency=low
  [ Konstantinos Margaritis ]  * Add support for armhf (Closes: #596936)    - libmad.thumb.diff: use "adr" instead of "add" to make code ready for      thumb2    - Provide-Thumb-2-alternative-code-for-MAD_F_MLN.diff: fix another      ftbfs with thumb2 as "rsc" doesnt exist anymore - thanks to Dave      Martin for this patch -- Kurt Roeckx <email address hidden>  Tue, 29 Mar 2011 22:26:22 +0200
Superseded in precise-release on 2011-12-30
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
libmad (0.15.1b-5ubuntu1) natty; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - libmad.thumb.diff: use "adr" instead of "add" to make code ready for
      thumb2
    - Provide-Thumb-2-alternative-code-for-MAD_F_MLN.diff: fix another
      ftbfs with thumb2 as "rsc" doesnt exist anymore - thanks to Dave
      Martin for this patch (LP: #534287).
  * Update Provide-Thumb-2-alternative-code-for-MAD_F_MLN.diff according
    to LP: bug #587632 and drop -marm

Superseded in natty-release on 2010-11-24
Obsolete in maverick-release on 2013-03-05
libmad (0.15.1b-4ubuntu2) maverick; urgency=low

  * build with -marm on armel (LP: #587632)
 -- Oliver Grawert <email address hidden>   Tue, 14 Sep 2010 14:37:42 +0200
Superseded in maverick-release on 2010-09-14
Obsolete in lucid-release on 2016-10-26
libmad (0.15.1b-4ubuntu1) lucid; urgency=low

  * libmad.thumb.diff: use "adr" instead of "add" to make code ready for
    thumb2 (LP: #513734)
  * Provide-Thumb-2-alternative-code-for-MAD_F_MLN.diff: fix another
    ftbfs with thumb2 as "rsc" doesnt exist anymore - thanks to Dave
    Martin for this patch (LP: #534287).
 -- Alexander Sack <email address hidden>   Fri, 19 Mar 2010 13:09:26 +0100
Superseded in lucid-release on 2010-03-19
libmad (0.15.1b-4build1) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Sat, 06 Mar 2010 13:35:17 +0100

Available diffs

Superseded in lucid-release on 2010-03-06
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
libmad (0.15.1b-4) unstable; urgency=low

  * On an invalid mpeg file we can go past the end of the buffer.
    (Closes: #508133)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  24 Dec 2008 22:36:24 +0000

Available diffs

Superseded in jaunty-release on 2008-12-24
Obsolete in intrepid-release on 2013-02-20
libmad (0.15.1b-3) unstable; urgency=low

  * Acknowledge NMU
  * Use DEB_DH_MAKESHLIBS_ARGS_libmad0 instead to set shlibs.
  * Update Clément Stenac's email address to use <email address hidden>
  * Add build dependency on autotools-dev, quilt
  * Don't use -O plus some other -f options, just use -O2.  (Closes: #415279)
  * Use the 64bit fixed point math on amd64 to have a higher quality
    output than the default.  (Closes: #465438)
  * Bump shlibs since it changes the size of mad_build on amd64.
  * Add compat file, level 5.  Change build dependency of debhelper to 5.
  * Don't set -lm in the mad.pc file.  libmad doesn't use any math function.
  * Remove libmad0 Depends on pkg-config.
  * Change to Standards-Version 3.7.3:
    - Change ${Source-Version} into ${binary:Version}

 -- Matthias Klose <email address hidden>   Sun,  22 Jun 2008 00:02:38 +0100

Available diffs

Superseded in intrepid-release on 2008-06-22
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
libmad (0.15.1b-2.1ubuntu1) gutsy; urgency=low

  * Don't build with -fforce-mem (deprecated since GCC 4.1).
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Mon, 10 Sep 2007 13:24:41 +0200
Superseded in gutsy-release on 2007-09-10
libmad (0.15.1b-2.1build1) gutsy; urgency=low

  * No-change upload to include stack protector.

 -- Kees Cook <email address hidden>   Tue, 31 Jul 2007 10:44:27 -0700
Superseded in gutsy-release on 2007-07-31
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
Obsolete in breezy-release on 2008-03-25
libmad (0.15.1b-2.1) unstable; urgency=high


  * Non-maintainer upload, not targetted for Sarge.
  * Urgency high because this is generating uploads with broken depends
    that may be propagating to testing (see #311488).
  * debian/rules: set DEB_DH_MAKESHLIBS_ARGS_ALL = -V 'libmad0 (>= 0.15.1b)'
    to restore the updated shlibs lost in the switch to CDBS
    (closes: #310311).

 -- Jordi Mallach <email address hidden>  Wed,  1 Jun 2005 17:12:24 +0200
Obsolete in hoary-release on 2008-03-19
Obsolete in warty-release on 2008-01-09
libmad (0.15.1b-1) unstable; urgency=low


  * New upstream version. (closes: #252902)
  * Removed TODO from installed documentation.
  * Added minimad.c to the libmad0-dev documentation. Thanks to
    Mario Lang for the patch. (closes: #249067)

 -- Kyle McMartin <email address hidden>  Sat, 5 Jun 2004 18:52:00 -0400
119 of 19 results