Change log for libmongo-client package in Ubuntu

116 of 16 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-11-09
Deleted in disco-proposed (Reason: moved to release)
libmongo-client (0.1.8-4) unstable; urgency=medium

  * Change to my new email address.
  * Use the automatic debug symbol packages:
    - Remove libmongo-client0-dbg section from debian/control.
    - Remove override_dh_strip from debian/rules.
    - Remove debian/libmongo-client0-dbg.maintscript.
  * Migrate to debhelper 11:
    - Change debian/compat to 11.
    - Bump minimum debhelper version in debian/control to >= 11.
  * Declare compliance with Debian Policy 4.2.1 (No changes needed).
  * New debian/patches/0001-hardening.patch to fix hardening.
  * Replace outdated README.source to explain the branching model used.
  * debian/control:
    - Change VCS-* to point to the new repository.
    - Replace Priority extra with optional.
    - Remove trailing whitespaces.
  * debian/libmongo-client-doc.install:
    - Change directory to usr/share/doc/libmongo-client-doc.
  * debian/copyright:
    - Use secure copyright format URI.
    - Bump year for debian/* to 2018.
  * debian/rules:
    - Add code to remove unused .md5 files from documentation.
    - Use /usr/share/dpkg/pkg-info.mk to get Upstream version.
    - Remove now useless code.
    - Fix tests.

 -- Jörg Frings-Fürst <email address hidden>  Mon, 01 Oct 2018 14:32:40 +0200

Available diffs

Superseded in disco-release on 2018-11-09
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-30
Deleted in artful-proposed (Reason: moved to release)
libmongo-client (0.1.8-3.1) unstable; urgency=medium

  * Non-maintainer upload.
  * fix symlink_to_dir calls for libmongo-client0-dbg
      and libmongo-client-dev (Closes: #860115).

 -- Ivo De Decker <email address hidden>  Wed, 12 Apr 2017 21:46:46 +0200

Available diffs

Superseded in artful-release on 2017-04-30
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
libmongo-client (0.1.8-2) unstable; urgency=medium

  * New Maintainer (Closes: #770801).
  * debian/contol:
    - Set myself as maintainer.
    - Bump Standards-Version to 3.9.6 (no changes required).
    - Change Vcs-* to collab-maint since old Vcs is not longer available.
  * debian/copyright:
    - Add missing license for tests/tools/*.
    - Add myself to the list of authors for debian/*.
    - Change upstream email address to <email address hidden>.
    - Change source to github.
  * debian/rules:
    - Remove useless override_dh_builddeb: xz is now standard.
    - Remove oldstyle debhelper parts.
    - Add override_dh_makeshlibs to build symbols on every build.
    - Add missing LDFLAGS.
  * debian/watch:
    - Change source to github.
  * Remove debian/source/options because xz is now standard.
  * New debian/patches/0100-gcc5.patch:
    - Cheery-picked upstream commit 7ccdf08e81aa51a1b54eb4c574e6e4fc5f2e2d54
      to make the library fit for gcc-5 (Closes: #777959).

 -- Jörg Frings-Fürst <email address hidden>  Wed, 08 Jul 2015 14:42:01 +0200

Available diffs

Superseded in wily-release on 2015-07-08
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
libmongo-client (0.1.8-1) unstable; urgency=medium


  * New upstream release.
  * debian/symbols updated with the new LMC_0.1.8 version tag.
  * debian/copyright updated to include 2014 in copyright years.
  * debian/rules updated to drop --with-versioned-symbols: it is
    automatically enabled now, if supported.

 -- Gergely Nagy <email address hidden>  Thu, 22 May 2014 13:05:18 +0200

Available diffs

Superseded in utopic-release on 2014-05-22
Deleted in utopic-proposed on 2014-05-24 (Reason: moved to release)
libmongo-client (0.1.7.1-1) unstable; urgency=medium


  * New upstream release.
    + Improves the roboustness of safe mode.

 -- Gergely Nagy <email address hidden>  Fri, 14 Mar 2014 11:04:43 +0100

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2013-12-16
Deleted in trusty-proposed (Reason: moved to release)
libmongo-client (0.1.7-1) unstable; urgency=low


  * New upstream release.
    + Automatic re-authentication support, even when using automatic
      failover with replicasets.
  * debian/symbols updated with the new LMC_0.1.7 version tag.

 -- Gergely Nagy <email address hidden>  Sun, 15 Dec 2013 11:37:03 +0100

Available diffs

Superseded in trusty-release on 2013-12-16
Deleted in trusty-proposed on 2013-12-17 (Reason: moved to release)
libmongo-client (0.1.6.3-2) unstable; urgency=low


  * debian/copyright: Point to /usr/share/common-licenses/Apache-2.0 for
    the full text of the license. (Thanks, lintian!)
  * Bumped Standards-Version to 3.9.5, no changed necessary.

 -- Gergely Nagy <email address hidden>  Tue, 05 Nov 2013 10:38:33 +0100

Available diffs

Superseded in trusty-release on 2013-11-05
Deleted in trusty-proposed on 2013-11-06 (Reason: moved to release)
libmongo-client (0.1.6.3-1) unstable; urgency=low


  * New upstream release.
    + Fixed chunked GridFS file retrieval, to keep the chunk order.
    + Fixed a crash that happened when verification in safe-mode failed.
  * Bumped Standards-Version to 3.9.4, no changes necessary.
  * debian/copyright: Updated the copyright years.

 -- Gergely Nagy <email address hidden>  Tue, 27 Aug 2013 10:10:37 +0200

Available diffs

Superseded in trusty-release on 2013-10-23
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
libmongo-client (0.1.6.2-1) unstable; urgency=low


  * New upstream release.
    + Minor memory leak fix in the GridFS code
    + Support for the obsolete Binary subtype in GridFS files
    + Documentation improvements
  * Don't muck with m4/ during build, it is included upstream now.

 -- Gergely Nagy <email address hidden>  Fri, 21 Dec 2012 12:35:43 +0100

Available diffs

Superseded in raring-release on 2012-12-21
Deleted in raring-proposed on 2012-12-22 (Reason: moved to release)
libmongo-client (0.1.6.1-3) unstable; urgency=low


  * Make libmongo-client-dev depend on libglib2.0-dev. Thanks Michael
    Biebl. (Closes: #690992)

 -- Gergely Nagy <email address hidden>  Sat, 20 Oct 2012 08:30:09 +0200

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
libmongo-client (0.1.5-1) unstable; urgency=low


  * New upstream bugfix release.
    + Fixes build on s390x, sparc64 and ppc64.
  * Bump debhelper build-dependency to >= 9~
  * Update debian/copyright to copyright-format-1.0.
  * Bump Standards-Version to 3.9.3 (no other changes necessary)

 -- Gergely Nagy <email address hidden>  Fri, 13 Apr 2012 18:37:21 +0200

Available diffs

Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-10-17
libmongo-client (0.1.4-3) unstable; urgency=low

  * Build-Depend on debhelper (>= 8.9.7~) for -arch/-indep override
    support.
  * Move doxygen & graphviz to Build-Depends-Indep, and only build docs
    when building -indep. This'll save quite a bit of disk space on
    buildds. Thanks Laszlo Boszormenyi <email address hidden> for the suggestion.

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
libmongo-client (0.1.4-1) unstable; urgency=low

  * New upstream release.
 -- Gergely Nagy <email address hidden>   Sun,  28 Aug 2011 18:04:31 +0000

Available diffs

Superseded in oneiric-release on 2011-08-28
libmongo-client (0.1.3-1) unstable; urgency=low
  * New upstream release. -- Gergely Nagy <email address hidden>  Tue, 19 Jul 2011 19:48:33 +0200
Superseded in oneiric-release on 2011-07-27
libmongo-client (0.1.1-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  16 Jun 2011 22:57:32 +0000

Available diffs

Superseded in oneiric-release on 2011-06-16
libmongo-client (0.1.0-1) unstable; urgency=low

  * Initial release (Closes: #626969)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  06 Jun 2011 12:21:53 +0000
116 of 16 results