libndp 1.4-2ubuntu0.15.10.1 source package in Ubuntu

Changelog

libndp (1.4-2ubuntu0.15.10.1) wily-security; urgency=medium

  * SECURITY UPDATE: denial of service via RA messages from sources outside
    the local network
    - d/p/0001-libndp-validate-the-IPv6-hop-limit.patch: validate hop limit
      in libndp/libndp.c.
    - d/p/0002-libndb-reject-redirect-and-router-advertisements-fro.patch:
      reject redirect and router advertisements from non-link-local in
      libndp/libndp.c.
    - d/p/0001-fixup-libndp-validate-the-IPv6-hop-limit.patch: allocate
      space for the hop limit in libndp/libndp.c.
    - CVE-2016-3698

 -- Marc Deslauriers <email address hidden>  Mon, 16 May 2016 11:18:28 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2016-05-16
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
linux-any kfreebsd-any
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
libndp_1.4.orig.tar.gz 329.9 KiB 3a0be247ec024bd72fe5b40ea9491519c4023c7faf078311196fab817b2fd55f
libndp_1.4-2ubuntu0.15.10.1.debian.tar.xz 6.3 KiB 758379f7215fd2d8abdc57f0a087383532869300a6c96354932bed8098b6aadb
libndp_1.4-2ubuntu0.15.10.1.dsc 2.1 KiB cfc98029f776952eef7de454c20f8f3dbfed926492b1a19ec748fd01285a0a7c

View changes file

Binary packages built by this source

libndp-dbg: No summary available for libndp-dbg in ubuntu wily.

No description available for libndp-dbg in ubuntu wily.

libndp-dev: No summary available for libndp-dev in ubuntu wily.

No description available for libndp-dev in ubuntu wily.

libndp-dev-dbgsym: No summary available for libndp-dev-dbgsym in ubuntu wily.

No description available for libndp-dev-dbgsym in ubuntu wily.

libndp-tools: No summary available for libndp-tools in ubuntu wily.

No description available for libndp-tools in ubuntu wily.

libndp-tools-dbgsym: No summary available for libndp-tools-dbgsym in ubuntu wily.

No description available for libndp-tools-dbgsym in ubuntu wily.

libndp0: No summary available for libndp0 in ubuntu wily.

No description available for libndp0 in ubuntu wily.

libndp0-dbgsym: No summary available for libndp0-dbgsym in ubuntu wily.

No description available for libndp0-dbgsym in ubuntu wily.