Change log for libnet-pcap-perl package in Ubuntu

120 of 20 results
Published in hirsute-proposed on 2020-11-09
libnet-pcap-perl (0.18-3build2) hirsute; urgency=medium

  * No-change rebuild for the perl update.

 -- Matthias Klose <email address hidden>  Mon, 09 Nov 2020 12:44:40 +0100

Available diffs

Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-24
Published in focal-release on 2019-10-24
Deleted in focal-proposed (Reason: moved to Release)
libnet-pcap-perl (0.18-3build1) focal; urgency=medium

  * No-change rebuild for the perl update.

 -- Matthias Klose <email address hidden>  Fri, 18 Oct 2019 19:33:37 +0000

Available diffs

Superseded in focal-release on 2019-10-24
Published in eoan-release on 2019-07-20
Deleted in eoan-proposed (Reason: moved to release)
libnet-pcap-perl (0.18-3) unstable; urgency=medium

  [ Alex Muntada ]
  * Remove inactive pkg-perl members from Uploaders.

  [ Salvatore Bonaccorso ]
  * Update Vcs-* headers for switch to salsa.debian.org

  [ Xavier Guimard ]
  * Email change: Xavier Guimard -> <email address hidden>

  [ gregor herrmann ]
  * Add patch from Fedora for libpcap 1.9.0 compatibility.
    (Closes: #932282)
  * Update years of packaging copyright.
  * Annotate test-only build dependencies with <!nocheck>.
  * Declare compliance with Debian Policy 4.4.0.
  * Bump debhelper-compat to 12.
  * debian/watch: use uscan version 4.
  * Remove trailing whitespace from debian/*.

 -- gregor herrmann <email address hidden>  Fri, 19 Jul 2019 16:53:15 -0300
Superseded in eoan-release on 2019-07-20
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-07-14 (Reason: moved to release)
libnet-pcap-perl (0.18-2build2) disco; urgency=medium

  * No-change rebuild for the perl 5.28 transition.

 -- Adam Conrad <email address hidden>  Fri, 02 Nov 2018 18:12:19 -0600

Available diffs

Superseded in disco-release on 2018-11-08
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed (Reason: moved to release)
libnet-pcap-perl (0.18-2build1) artful; urgency=medium

  * No-change rebuild for perl 5.26.0.

 -- Matthias Klose <email address hidden>  Wed, 26 Jul 2017 20:08:12 +0000

Available diffs

Superseded in artful-release on 2017-08-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
libnet-pcap-perl (0.18-2) unstable; urgency=medium

  * Add patch from CPAN RT for libpcap 1.8 compatibility.
    (Closes: #843704)
  * Add build dependency on libtest-exception-perl to enable more tests.
  * Add a patch to fix spelling mistakes in the POD.

 -- gregor herrmann <email address hidden>  Sat, 12 Nov 2016 17:46:36 +0100
Superseded in zesty-release on 2016-11-14
Deleted in zesty-proposed on 2016-11-16 (Reason: moved to release)
libnet-pcap-perl (0.18-1build1) zesty; urgency=medium

  * No-change rebuild for perl 5.24 transition

 -- Iain Lane <email address hidden>  Mon, 24 Oct 2016 10:25:23 +0100

Available diffs

Superseded in zesty-release on 2016-11-01
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
libnet-pcap-perl (0.18-1) unstable; urgency=medium

  * Team upload.

  [ gregor herrmann ]
  * Strip trailing slash from metacpan URLs.

  [ Salvatore Bonaccorso ]
  * Update Vcs-Browser URL to cgit web frontend
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI

  [ gregor herrmann ]
  * Change bugtracker URL(s) to HTTPS.
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.

  [ Salvatore Bonaccorso ]
  * Add debian/upstream/metadata
  * Import upstream version 0.18
  * Drop patches:
    - 0001-Append-CCFLAGS-to-Config-ccflags-instead-of-overridi.patch
    - spelling-errors.patch
    - fail-without-libpcap.patch
  * Update copyright years for upstream files
  * Declare compliance with Debian policy 3.9.8
  * debian/rules: Enable the bindnow hardening flag
  * Declare package as autopkgtestable

 -- Salvatore Bonaccorso <email address hidden>  Sun, 22 May 2016 14:18:32 +0200
Superseded in yakkety-release on 2016-05-23
Published in xenial-release on 2016-01-06
Deleted in xenial-proposed (Reason: moved to release)
libnet-pcap-perl (0.17-1build3) xenial; urgency=medium

  * Rebuild for Perl 5.22.1.

 -- Colin Watson <email address hidden>  Thu, 17 Dec 2015 15:53:36 +0000
Superseded in xenial-release on 2016-01-06
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
libnet-pcap-perl (0.17-1build2) utopic; urgency=medium

  * Rebuild for Perl 5.20.0.
 -- Colin Watson <email address hidden>   Wed, 20 Aug 2014 12:43:19 +0100
Superseded in utopic-release on 2014-08-27
Published in trusty-release on 2013-10-24
Deleted in trusty-proposed (Reason: moved to release)
libnet-pcap-perl (0.17-1build1) trusty; urgency=low

  * Rebuild for Perl 5.18.
 -- Colin Watson <email address hidden>   Mon, 21 Oct 2013 10:26:35 +0100

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libnet-pcap-perl (0.17-1) unstable; urgency=low


  [ Ansgar Burchardt ]
  * debian/control: Convert Vcs-* fields to Git.

  [ Salvatore Bonaccorso ]
  * Change search.cpan.org based URIs to metacpan.org based URIs

  [ Xavier Guimard ]
  * Imported Upstream version 0.17
  * Update debian/copyright (years and format)
  * Bump Standards-Version to 3.9.4
  * Bump debhelper compatibility to 9 to get hardening flags
  * Remove safe_signals patch now included in upstream
  * Add spelling patch (reported to RT)
  * Refresh ccflags patch

  [ gregor herrmann ]
  * Add a patch to make Makefile.PL die if libpcap isn't found.
    (Closes: #633414)

 -- Xavier Guimard <email address hidden>  Sat, 25 May 2013 08:23:59 +0200

Available diffs

Superseded in precise-release on 2011-11-16
libnet-pcap-perl (0.16-2build2) precise; urgency=low

  * Rebuild for Perl 5.14.
 -- Colin Watson <email address hidden>   Tue, 15 Nov 2011 20:06:22 +0000

Available diffs

Superseded in saucy-release on 2013-05-26
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-11-16
libnet-pcap-perl (0.16-3) unstable; urgency=low
  [ Franck Joncourt ]  * Minimized debian/rules:    + Refreshed debian/rules    + Updated BD versions on debhelper and quilt to be able to use     dh --with quilt  [ gregor herrmann ]  * debian/control: improve long description, thanks to Peter Pentchev for    spotting.  [ Nathan Handler ]  * debian/watch: Update to ignore development releases.  [ gregor herrmann ]  * Add patch by Niko Tyni to work with perl 5.14 (closes: #629302).  * Switch to source format 3.0 (quilt); drop quilt framework.  * Bump debhelper compatibility level to 8.  * Set Standards-Version to 3.9.2, drop version from perl build dependency.  * debian/copyright: refresh formatting. -- gregor herrmann <email address hidden>  Sun, 10 Jul 2011 21:39:19 +0200
Superseded in precise-release on 2011-11-15
Obsolete in oneiric-release on 2015-04-24
libnet-pcap-perl (0.16-2build1) oneiric; urgency=low

  * Rebuild for Perl 5.12.
 -- Colin Watson <email address hidden>   Sun, 08 May 2011 13:20:57 +0100

Available diffs

Superseded in oneiric-release on 2011-05-08
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
libnet-pcap-perl (0.16-2) unstable; urgency=low

  [ gregor herrmann ]
  * debian/control: Added: ${misc:Depends} to Depends: field.
  
  [ Franck Joncourt ]
  * Do not allow the pcap loop function to be interrupted by signals.
    It happens this causes segfault. (Closes: #508432)
      - Documented the usage of quilt through README.source.
      - Added Build-dependency on quilt in d.control
      - Updated d.rules
      - Added safe_signal.patch.
    This patch makes Net::Pcap behave the same way as its previous release.
  * Set Standards-Version to 3.8.1 (no changes).
  * Removed the created const-xs.inc and const-c.inc during clean.
  * d.copyright: add © symbol for Debian copyright holders.
  * d.control:
    - Add /me to Uploaders.
    - Refresh both short and long descriptions

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  30 Apr 2009 08:51:35 +0100

Available diffs

Superseded in karmic-release on 2009-04-30
Obsolete in jaunty-release on 2013-02-28
libnet-pcap-perl (0.16-1) unstable; urgency=low

  * Take over for the Debian Perl Group on maintainer's request
    (http://lists.debian.org/debian-perl/2008/11/msg00047.html).
  * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
    field (source stanza); Homepage field (source stanza). Changed:
    Maintainer set to Debian Perl Group <pkg-perl-
    <email address hidden>> (was: Ola Lundqvist
    <email address hidden>); Ola Lundqvist <email address hidden> moved to
    Uploaders.
  * debian/watch: use dist-based URL.

  * New upstream release (closes: #329635). Includes fixes for
    - "pcap_setnonblock and pcap_getnonblocl implementation" (closes: #270942)
    - "Example/test 07-stats.t fails" (closes: #272869)
  * Remove README.Debian, which just points to a manpage.
  * Don't install README anymore, just a text version of the POD
    documentation.
  * Install "real" examples instead of test scripts.
  * Set debhelper compatibility level to 7; adapt
    debian/{control,compat,rules}.
  * Set Standards-Version to 3.8.0 (no changes).
  * debian/copyright: switch to new format.
  * Remove the created funcs.txt during clean.
  * debian/control:
    - build depend on libpcap0.8-dev instead of (transitional) libpcap-dev
    - mention module name in long description
    - add /me to Uploaders
    - add build dependency on libtest-pod-perl to enable an additional test
      (various other tests depend on not existing packages or are not
      functional)
    - change Section to perl

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  14 Nov 2008 11:46:36 +0000

Available diffs

Superseded in jaunty-release on 2008-11-14
Obsolete in intrepid-release on 2013-02-20
libnet-pcap-perl (0.04-3build1) intrepid; urgency=low

  * Rebuild for the perl 5.10 transition.

 -- Michael Bienia <email address hidden>   Sat, 24 May 2008 12:18:19 +0200
Superseded in intrepid-release on 2008-05-24
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
Obsolete in breezy-release on 2008-03-25
Obsolete in hoary-release on 2008-03-19
libnet-pcap-perl (0.04-3) unstable; urgency=low


  * Added directory t from sources to examples directory, closes:
    #203294.
  * Updated standards version to 3.6.1.

 -- Ola Lundqvist <email address hidden>  Sat, 14 Aug 2004 22:46:37 +0200
Obsolete in warty-release on 2008-01-09
libnet-pcap-perl (0.04-2) unstable; urgency=low


  * Updated standards version from 3.5.2 to 3.5.8.
  * Fixed description line.
  * Maintainer keepup, closes: #158964.
  * Rebuilt using latest libpcap-dev, closes: #156213.

 -- Ola Lundqvist <email address hidden>  Fri, 18 Jul 2003 13:54:15 +0200
120 of 20 results