Change log for libopenmpt package in Ubuntu

126 of 26 results
Published in eoan-release on 2019-08-11
Deleted in eoan-proposed (Reason: moved to release)
libopenmpt (0.4.6-1) unstable; urgency=medium

  [ James Cowgill ]
  * New upstream release.

  [ Ondřej Nový ]
  * d/control: Bump Standards-Version to 4.4.0.

 -- James Cowgill <email address hidden>  Sun, 11 Aug 2019 11:17:18 +0100

Available diffs

Superseded in eoan-release on 2019-08-11
Deleted in eoan-proposed on 2019-08-13 (Reason: moved to release)
libopenmpt (0.4.5-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Mon, 15 Jul 2019 23:46:33 +0100

Available diffs

Superseded in eoan-release on 2019-07-16
Published in disco-release on 2019-02-16
Deleted in disco-proposed (Reason: moved to release)
libopenmpt (0.4.3-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Fri, 15 Feb 2019 09:30:30 +0000

Available diffs

Superseded in disco-release on 2019-02-16
Deleted in disco-proposed on 2019-02-17 (Reason: moved to release)
libopenmpt (0.4.2-1) unstable; urgency=medium

  * New upstream release.

  * d/control: Bump debhelper compat to 12.
  * d/not-installed: Add file and pass --fail-missing to dh_missing.

 -- James Cowgill <email address hidden>  Wed, 23 Jan 2019 09:26:13 +0000

Available diffs

Superseded in disco-release on 2019-01-24
Deleted in disco-proposed on 2019-01-25 (Reason: moved to release)
libopenmpt (0.4.1-1) unstable; urgency=medium

  * New upstream release.

  * d/patches:
    - Drop patches related to CSoundFile API compatibility - fixed
      upstream.

 -- James Cowgill <email address hidden>  Mon, 07 Jan 2019 19:11:44 +0000

Available diffs

Superseded in disco-release on 2019-01-08
Deleted in disco-proposed on 2019-01-09 (Reason: moved to release)
libopenmpt (0.4.0-1) unstable; urgency=medium

  * New upstream release.

  * d/copyright: Update for 0.4.0 and sort paragraphs.
  * d/control: Bump standards to 4.3.0.
  * d/patches:
    - Refresh 01_libmodplug_symver.patch.
    - Add patch to fix CSoundFile API compatibility.
  * d/libopenmpt0.symbols: Adjust weak symbols

 -- James Cowgill <email address hidden>  Mon, 24 Dec 2018 21:43:58 +0000

Available diffs

Superseded in disco-release on 2018-12-25
Deleted in disco-proposed on 2018-12-26 (Reason: moved to release)
libopenmpt (0.3.13-1) unstable; urgency=medium

  * New upstream release.
    - Fixes out of bound read in malformed MED files. (Closes: #911584)

 -- James Cowgill <email address hidden>  Mon, 22 Oct 2018 09:46:13 +0100

Available diffs

Superseded in disco-release on 2018-11-11
Published in cosmic-release on 2018-07-29
Deleted in cosmic-proposed (Reason: moved to release)
libopenmpt (0.3.11-1) unstable; urgency=medium

  * New upstream release.
    - Fix crash with some malformed custom tunings in MPTM files.
      (Closes: #904874)

 -- James Cowgill <email address hidden>  Sun, 29 Jul 2018 13:29:16 +0800

Available diffs

Superseded in cosmic-release on 2018-07-29
Deleted in cosmic-proposed on 2018-07-30 (Reason: moved to release)
libopenmpt (0.3.10-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Sun, 17 Jun 2018 10:08:38 +0100

Available diffs

Superseded in cosmic-release on 2018-06-17
Deleted in cosmic-proposed on 2018-06-19 (Reason: moved to release)
libopenmpt (0.3.9-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Mon, 07 May 2018 17:39:24 +0100

Available diffs

Superseded in cosmic-release on 2018-05-08
Deleted in cosmic-proposed on 2018-05-09 (Reason: moved to release)
libopenmpt (0.3.8-1) unstable; urgency=medium

  * New upstream release.
    - Fixes CVE-2018-10017 (Closes: #895406).

  * debian/control:
    - Bump standards version to 4.1.4.

 -- James Cowgill <email address hidden>  Wed, 11 Apr 2018 12:19:51 +0100

Available diffs

Superseded in cosmic-release on 2018-05-06
Published in bionic-release on 2018-02-05
Deleted in bionic-proposed (Reason: moved to release)
libopenmpt (0.3.6-1) unstable; urgency=medium

  * New upstream release.
    - Fixes CVE-2018-6611 (Closes: #889545).

  * debian/copyright:
    - Update dates.
  * debian/compat:
    - Use debhelper 11.
  * debian/control:
    - Set Maintainer to <email address hidden>.
    - Switch Vcs URLs to salsa.debian.org.
    - Bump standards version to 4.1.3.
  * debian/rules:
    - Revert workaround implementing build targets manually now that debhelper
      has been fixed.

 -- James Cowgill <email address hidden>  Sun, 04 Feb 2018 23:09:22 +0000

Available diffs

Superseded in bionic-release on 2018-02-05
Deleted in bionic-proposed on 2018-02-06 (Reason: moved to release)
libopenmpt (0.3.4-1) unstable; urgency=medium

  * New upstream release.

  * debian/control:
    - Bump standards to 4.1.2.

 -- James Cowgill <email address hidden>  Mon, 18 Dec 2017 14:55:44 +0000

Available diffs

Superseded in bionic-release on 2017-12-19
Deleted in bionic-proposed on 2017-12-20 (Reason: moved to release)
libopenmpt (0.3.3-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Tue, 21 Nov 2017 08:54:21 +0000

Available diffs

Superseded in bionic-release on 2017-11-25
Deleted in bionic-proposed on 2017-11-26 (Reason: moved to release)
libopenmpt (0.3.2-1) unstable; urgency=medium

  * New upstream release.

  * debian/control:
    - Set Rules-Requires-Root: no.
  * debian/rules:
    - Remove unused variables.
    - Implement build targets manually to workaround dh not playing well
      with a "build" directory in the upstream source.

 -- James Cowgill <email address hidden>  Wed, 08 Nov 2017 23:31:31 +0000

Available diffs

Superseded in bionic-release on 2017-11-12
Deleted in bionic-proposed on 2017-11-13 (Reason: moved to release)
libopenmpt (0.3.1-1) unstable; urgency=medium

  * New upstream release.

  * debian/control:
    - Remove unnecessary testsuite autopkgtest header.
    - Bump standards to 4.1.1 (no changes).
  * debian/copyright:
    - Update copyright including some modifications from decopy.
  * debian/libopenmpt-dev.install:
    - Install libopenmpt_ext.* headers which are now stable.
  * debian/libopenmpt0.symbols:
    - Add new symbols foudn in 0.3.0.
  * debian/patches:
    - Refresh patches.
  * debian/rules:
    - Build doxygen documentation again and update install path.
  * debian/tests:
    - Use openmpt_module_create2 in autopkgtests.
  * debian/watch:
    - Update for new versioning scheme.

 -- James Cowgill <email address hidden>  Mon, 02 Oct 2017 23:47:01 +0100

Available diffs

Superseded in bionic-release on 2017-11-07
Published in artful-release on 2017-08-17
Deleted in artful-proposed (Reason: moved to release)
libopenmpt (0.2.8760~beta27-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Wed, 16 Aug 2017 11:31:38 +0100
Superseded in artful-release on 2017-08-17
Deleted in artful-proposed on 2017-08-18 (Reason: moved to release)
libopenmpt (0.2.8461~beta26-1) unstable; urgency=medium

  * New upstream release.
    - Fixes CVE-2017-11311: arbitrary code execution via a crafted PSM File.
      (Closes: #867579)

 -- James Cowgill <email address hidden>  Fri, 14 Jul 2017 17:21:59 +0100
Superseded in artful-release on 2017-07-16
Deleted in artful-proposed on 2017-07-17 (Reason: moved to release)
libopenmpt (0.2.8414~beta25-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Wed, 05 Jul 2017 18:36:10 +0100
Superseded in artful-release on 2017-07-06
Deleted in artful-proposed on 2017-07-08 (Reason: moved to release)
libopenmpt (0.2.8190~beta24-1) unstable; urgency=medium

  * New upstream release.
    - Fixes various local denial-of-service security bugs. (Closes: #864195)
  * Upload to unstable.

  * debian/control:
    - Bump standards to 4.0.0 (no changes required).

 -- James Cowgill <email address hidden>  Mon, 19 Jun 2017 18:53:10 +0100
Superseded in artful-release on 2017-06-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
libopenmpt (0.2.7386~beta20.3-3) unstable; urgency=medium

  * debian/tests:
    - Depend on build-essential in all autopkgtests. This should fix the
      recent autopkgtest failures.

 -- James Cowgill <email address hidden>  Thu, 12 Jan 2017 17:17:13 +0000
Superseded in zesty-proposed on 2017-01-12
libopenmpt (0.2.7386~beta20.3-2) unstable; urgency=medium

  * Enable libmodplug compatibility layer.
    - Add libopenmpt-modplug-dev and libopenmpt-modplug1.
    - Add autopkgtest for libmodplug compat layer.
    - Add ELF symbol versioning to all the symbols exported by the
      compatibility layer.

  * debian/control:
    - Build-Conflicts against autoconf-archive.
    - Drop "decoding" from the short description to make more room.
  * debian/rules:
    - Disable static library in configure invocation.

 -- James Cowgill <email address hidden>  Sun, 08 Jan 2017 10:38:40 +0000
Superseded in zesty-release on 2017-01-13
Deleted in zesty-proposed on 2017-01-14 (Reason: moved to release)
libopenmpt (0.2.7386~beta20.3-1) unstable; urgency=medium

  * New upstream release.

 -- James Cowgill <email address hidden>  Fri, 25 Nov 2016 09:42:47 +0000
Superseded in zesty-release on 2016-11-25
Deleted in zesty-proposed on 2016-11-27 (Reason: moved to release)
libopenmpt (0.2.7299~beta20.2-2) unstable; urgency=medium

  * debian/control:
    - Add extra dependencies to libopenmpt-dev to satisfy pkg-config. Should
      fix autopkgtest failures.
  * debian/libopenmpt-dev.install:
    - Drop static library.
  * debian/watch:
    - Remove hyphen before @ANY_VERSION@ in watch file.

 -- James Cowgill <email address hidden>  Sat, 12 Nov 2016 15:31:14 +0000
Superseded in zesty-release on 2016-11-13
Deleted in zesty-proposed on 2016-11-15 (Reason: moved to release)
libopenmpt (0.2.7299~beta20.2-1) unstable; urgency=medium

  * New upstream release.

  * debian/patches:
    - Drop 01_openmpt123-whatis.patch - applied upstream.
  * debian/rules:
    - Use dh_autoreconf --as-needed.
    - Install libopenmpt/dox/changelog.md as the upstream changelog.
  * debian/tests:
    - Add pkg-config to autopkgtest dependencies.

 -- James Cowgill <email address hidden>  Wed, 09 Nov 2016 15:55:27 +0000
Superseded in zesty-release on 2016-11-10
Deleted in zesty-proposed on 2016-11-11 (Reason: moved to release)
libopenmpt (0.2.7025~beta20.1-1) unstable; urgency=medium

  * Initial release. (Closes: #839185)

 -- James Cowgill <email address hidden>  Mon, 03 Oct 2016 10:04:29 +0100
126 of 26 results