Change log for liboro-java package in Ubuntu

121 of 21 results
Published in focal-release on 2019-10-26
Deleted in focal-proposed (Reason: moved to Release)
liboro-java (2.0.8a-14) unstable; urgency=medium

  * Generate Java 8 compatible bytecode
  * Standards-Version updated to 4.4.0

 -- Emmanuel Bourg <email address hidden>  Sun, 08 Sep 2019 14:41:28 +0200

Available diffs

Superseded in focal-release on 2019-10-26
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-11-09
Deleted in disco-proposed (Reason: moved to release)
liboro-java (2.0.8a-13) unstable; urgency=medium

  * Build with the DH sequencer instead of CDBS
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11
  * Moved the package to Git

 -- Emmanuel Bourg <email address hidden>  Tue, 23 Oct 2018 17:28:48 +0200

Available diffs

Superseded in disco-release on 2018-11-09
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
liboro-java (2.0.8a-12) unstable; urgency=medium

  * Build reproducibility:
    - Set the encoding to UTF-8 when generating the Javadoc
  * Moved the package to Git
  * Standards-Version updated to 3.9.8
  * Updated debian/copyright to the Copyright Format 1.0

 -- Emmanuel Bourg <email address hidden>  Wed, 27 Jul 2016 15:10:43 +0200

Available diffs

Superseded in yakkety-release on 2016-07-28
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
liboro-java (2.0.8a-11) unstable; urgency=medium

  * Build reproducibility:
    - Set the locale to en_US when generating the Javadoc

 -- Emmanuel Bourg <email address hidden>  Mon, 29 Jun 2015 13:55:44 +0200

Available diffs

Superseded in wily-release on 2015-06-29
Deleted in wily-proposed on 2015-07-01 (Reason: moved to release)
liboro-java (2.0.8a-10) unstable; urgency=low

  [ Emmanuel Bourg ]
  * Build reproducibility:
    - Replaced the date in the manifest with the date from debian/changelog
    - Removed the timestamps from the Javadoc
  * debian/rules: Improved the clean target
  * Removed the obsolete information in debian/README.debian
  * Use canonical URLs for the Vcs-* fields
  * Switch to debhelper level 9

  [ tony mancill ]
  * Bump Standards-Version to 3.9.6.
  * Remove Niels Thykier from Uploaders. (Closes: #770561)

 -- Emmanuel Bourg <email address hidden>  Thu, 28 May 2015 13:11:09 +0200

Available diffs

Superseded in wily-release on 2015-05-29
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
liboro-java (2.0.8a-9) unstable; urgency=low


  * Team upload.
  * d/watch: Changed the URL to point to the Apache archive
  * Updated Standards-Version to 3.9.4
  * Removed Michael Koch from uploaders list  (Closes: #654088)

 -- Emmanuel Bourg <email address hidden>  Fri, 29 Mar 2013 00:47:36 +0100
Superseded in saucy-release on 2013-04-28
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
liboro-java (2.0.8a-8build1) quantal; urgency=low

  * No-change rebuild with openjdk-7 as default-jdk.
 -- James Page <email address hidden>   Fri, 18 May 2012 11:44:26 +0100

Available diffs

Superseded in quantal-release on 2012-05-18
Published in precise-release on 2011-10-17
liboro-java (2.0.8a-8) unstable; urgency=low

  * Team upload.
  * Remove Java runtime from Depends.
  * Remove Arnaud from Uploaders list.
  * Update Standards-Version: 3.9.1.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 11:09:42 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
liboro-java (2.0.8a-7) unstable; urgency=low

  [ Michael Koch ]
  * Updated Standards-Version to 3.8.4.

  [ Niels Thykier ]
  * Added myself to Uploaders.
  * Merged B-D-I and B-D; it does not make sense to have both
    when all packages are arch all.
  * Downgraded java source and target version from 1.4 to 1.3 and 1.2
    respectively.
  * Updated depedencies on java-runtimes to fit the built class version.
  * Made patch quilt-compatible and added a short description.
  * Bumped debhelper compat to 7.
  * Added OSGi metadata.
  * Converted source format to 3.0 (quilt).
  * Modified the -doc synopsis to clarify it is a documentation package.
  * Added Homepage and Vcs-* fields.
 -- Onkar Shinde <email address hidden>   Mon,  22 Mar 2010 18:47:06 +0000

Available diffs

Superseded in lucid-release on 2010-03-22
Obsolete in karmic-release on 2013-03-04
liboro-java (2.0.8a-6) unstable; urgency=low

  * Upload to unstable.

Available diffs

Superseded in karmic-release on 2009-10-19
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
liboro-java (2.0.8a-4ubuntu2) intrepid; urgency=low

  * Set java source version to 1.4. LP: #264808.

 -- Matthias Klose <email address hidden>   Mon, 20 Oct 2008 13:37:24 +0000

Available diffs

Superseded in intrepid-release on 2008-10-20
liboro-java (2.0.8a-4ubuntu1) intrepid; urgency=low

  * (Build-)depend on default-jre/-jdk.
  * Drop dependency on java-common.

 -- Matthias Klose <email address hidden>   Wed, 30 Jul 2008 18:31:08 +0000

Available diffs

Superseded in intrepid-release on 2008-07-30
liboro-java (2.0.8a-4) unstable; urgency=low

  * Updated watch file to match upstream correctly.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:16:04 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
liboro-java (2.0.8a-3) unstable; urgency=low

  * Build-Depend on java-gcj-compat-dev instead of java-gcj-compat.
    Closes: #429474.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  20 Jun 2007 10:03:53 +0100
Superseded in gutsy-release on 2007-06-20
liboro-java (2.0.8a-2) unstable; urgency=low

  * Use java-gcj-compat instead of kaffe.
  * Addd java-gcj-compat | java1-runtime | java2-runtime to Depends.
  * Moved Build-Depends-Indep to Build-Depends.
  * Updated Standards-Version.

 -- Martin Pitt <email address hidden>   Mon,  18 Jun 2007 07:32:58 +0100
Superseded in gutsy-release on 2007-06-18
Obsolete in feisty-release on 2009-08-20
liboro-java (2.0.8a-1ubuntu2) feisty; urgency=low

  * debian/control: Update maintainer fields according to debian-
    maintainer-field spec.

 -- Martin Pitt <email address hidden>   Tue, 27 Feb 2007 10:26:08 +0000
Superseded in feisty-release on 2007-02-27
Obsolete in edgy-release on 2008-06-19
liboro-java (2.0.8a-1ubuntu1) edgy; urgency=low

  * Merge from debian unstable.

Superseded in edgy-release on 2006-07-07
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
liboro-java (2.0.8-4ubuntu1) dapper; urgency=low


  * Resync with debian 

 -- Charles Majola <email address hidden>  Thu,  1 Dec 2005 07:41:45 +0000
Obsolete in breezy-release on 2008-03-25
liboro-java (2.0.8-3ubuntu3) breezy; urgency=low


  * Change build-deps from java-runtime{1,2} to java{1,2}-runtime

 -- Brandon Hale <email address hidden>  Sat,  8 Oct 2005 19:05:44 -0400
Obsolete in hoary-release on 2008-03-19
liboro-java (2.0.8-1.1ubuntu1) hoary; urgency=low


  * Converted to java-gcj-compat.
  * Cleaned up dependencies a bit.

 -- Jerry Haltom <email address hidden>  Tue, 22 Mar 2005 20:54:32 -0600
Obsolete in warty-release on 2008-01-09
liboro-java (2.0.8-1.1) unstable; urgency=low


  * Non-maintainer upload.
  * debian/control: Added cdbs to Build-Depends. Thanks to Daniel for the
    report. Closes: #233181

 -- Marc 'HE' Brockschmidt <email address hidden>  Sat, 20 Mar 2004 01:31:53 +0100
121 of 21 results