libpam-krb5 4.8-2ubuntu0.1 source package in Ubuntu

Changelog

libpam-krb5 (4.8-2ubuntu0.1) eoan-security; urgency=medium

  * SECURITY UPDATE: One-byte buffer overflow
    - debian/patches/CVE-2020-10595.patch: checks prompts[i].reply->length
      boundaries in prompting.c.
    - CVE-2020-10595

 -- <email address hidden> (Leonidas S. Barbosa)  Tue, 24 Mar 2020 09:31:05 -0300

Upload details

Uploaded by:
Leonidas S. Barbosa on 2020-03-24
Uploaded to:
Eoan
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
admin
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Eoan updates on 2020-03-31 main net
Eoan security on 2020-03-31 main net

Downloads

File Size SHA-256 Checksum
libpam-krb5_4.8.orig.tar.xz 402.2 KiB cbb59f6f72ad6207c8376b14af89badadd62fbfc7f661ca779e7afa4434457e2
libpam-krb5_4.8.orig.tar.xz.asc 488 bytes 24c528863dd7d2b40a43e72529dc8fe5d9bb534c6c2a33c5f8a4a5cf0acffec3
libpam-krb5_4.8-2ubuntu0.1.debian.tar.xz 25.3 KiB cd6415a6c02d3276184d4b5fc396ab765f2c8fb5d4acfa2a345c9ef2262457a6
libpam-krb5_4.8-2ubuntu0.1.dsc 2.3 KiB b76795b609f81c156c23b67df06d9c48d21e11d41982d478ef1376ab383723fd

Available diffs

View changes file

Binary packages built by this source

libpam-heimdal: PAM module for Heimdal Kerberos

 A Kerberos PAM module build against the Heimdal libraries. It supports
 authenticating against a Kerberos KDC, obtaining tickets and populating
 an initial ticket cache, authorizing users via a ~/.k5login file, and
 changing Kerberos passwords.

libpam-heimdal-dbgsym: debug symbols for libpam-heimdal
libpam-krb5: PAM module for MIT Kerberos

 A Kerberos PAM module build against the MIT Kerberos libraries. It
 supports authenticating against a Kerberos KDC, obtaining tickets and
 populating an initial ticket cache, authorizing users via a ~/.k5login
 file, and changing Kerberos passwords.

libpam-krb5-dbgsym: debug symbols for libpam-krb5