Ubuntu

“libproxy” 0.4.7-0ubuntu4.1 source package in Ubuntu

Changelog

libproxy (0.4.7-0ubuntu4.1) precise-security; urgency=low

  * SECURITY UPDATE: possible remote code execution via buffer overflow
    - debian/patches/CVE-2012-4504.patch: move length check to proper
      location in libproxy/url.cpp.
    - CVE-2012-4504
 -- Marc Deslauriers <email address hidden>   Tue, 06 Nov 2012 09:43:52 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2012-11-06
Uploaded to:
Precise
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any all
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Precise updates on 2012-11-12 main libs
Precise security on 2012-11-12 main libs

Downloads

File Size MD5 Checksum
libproxy_0.4.7.orig.tar.gz 89.0 KiB 509e03a488a61cd62bfbaf3ab6a2a7a5
libproxy_0.4.7-0ubuntu4.1.debian.tar.gz 7.2 KiB 4b69cebe546aa812d3ebe83418792359
libproxy_0.4.7-0ubuntu4.1.dsc 2.9 KiB b2817261068a3de9529c1e8b1fc0c3f3

Binary packages built by this source

libproxy-cil-dev: automatic proxy configuration management library (CLI devel)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains development files for the CLI bindings, and should be
 used for compilation.

libproxy-dev: automatic proxy configuration management library (devel)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the development files including vala bindings.

libproxy-tools: automatic proxy configuration management library (tools)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains a program to interact with libproxy from the
 command line.

libproxy0.4-cil: automatic proxy configuration management library (CLI)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the CLI bindings.

libproxy1: automatic proxy configuration management library (shared)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the shared library.

libproxy1-plugin-gsettings: automatic proxy configuration management library (GSettings plugin)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the plugin to allow libproxy to read proxy settings from
 GSettings (GNOME 3)

libproxy1-plugin-kconfig: automatic proxy configuration management library (KConfig plugin)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the plugin to allow libproxy to read proxy settings from
 KConfig (KDE 4)

libproxy1-plugin-networkmanager: automatic proxy configuration management library (Network Manager plugin)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the plugin to allow libproxy to read information from
 Network Manager.

libproxy1-plugin-webkit: automatic proxy configuration management library (Webkit plugin)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the plugin to allow libproxy to interpret PAC files
 using Webkit

python-libproxy: automatic proxy configuration management library (python)

 libproxy is a lightweight library which makes it easy to develop
 applications proxy-aware with a simple and stable API.
 .
 This package contains the Python bindings.