librabbitmq 0.9.0-0.2ubuntu0.19.04.1 source package in Ubuntu

Changelog

librabbitmq (0.9.0-0.2ubuntu0.19.04.1) disco-security; urgency=medium

  * SECURITY UPDATE: Integer overflow
    - debian/patches/CVE-2019-18609.patch: check frame_size is >= INT32_MAX
      in librabbitmq/amqp_connection.c.
    - CVE-2019-18609

 -- <email address hidden> (Leonidas S. Barbosa)  Thu, 05 Dec 2019 09:19:41 -0300

Upload details

Uploaded by:
Leonidas S. Barbosa on 2019-12-05
Uploaded to:
Disco
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Disco updates on 2019-12-05 main libs
Disco security on 2019-12-05 main libs

Downloads

File Size SHA-256 Checksum
librabbitmq_0.9.0.orig.tar.gz 141.3 KiB 316c0d156452b488124806911a62e0c2aa8a546d38fc8324719cd29aaa493024
librabbitmq_0.9.0-0.2ubuntu0.19.04.1.debian.tar.xz 10.1 KiB 89779effa41a52fbfb603635cfa052a1958fa7714ad2ac096a7d3e1c813c7493
librabbitmq_0.9.0-0.2ubuntu0.19.04.1.dsc 2.1 KiB d62faeae4ff15126fb78fe2ba462287cff9fddf7f037eb46854e23154f0fe65b

View changes file

Binary packages built by this source

amqp-tools: Command-line utilities for interacting with AMQP servers

 RabbitMQ provides robust messaging for applications. It is easy to use, fit
 for purpose at cloud scale and supported on all major operating systems and
 developer platforms. librabbitmq is a C-language AMQP client library for use
 with AMQP servers such as RabbitMQ speaking protocol versions 0-9-1.
 .
 This package includes command line utilities.

amqp-tools-dbgsym: debug symbols for amqp-tools
librabbitmq-dev: AMQP client library written in C - Dev Files

 RabbitMQ provides robust messaging for applications. It is easy to use, fit
 for purpose at cloud scale and supported on all major operating systems and
 developer platforms. librabbitmq is a C-language AMQP client library for use
 with AMQP servers such as RabbitMQ speaking protocol versions 0-9-1.
 .
 This package provides the files needed for development.

librabbitmq4: AMQP client library written in C

 RabbitMQ provides robust messaging for applications. It is easy to use, fit
 for purpose at cloud scale and supported on all major operating systems and
 developer platforms. librabbitmq is a C-language AMQP client library for use
 with AMQP servers such as RabbitMQ speaking protocol versions 0-9-1.
 .
 This package includes the library itself.

librabbitmq4-dbgsym: debug symbols for librabbitmq4