libreoffice 1:5.0.1-0ubuntu1 source package in Ubuntu

Changelog

libreoffice (1:5.0.1-0ubuntu1) wily; urgency=medium

  * new final upstream release
  * changes vs. vivid:
    - use cpp-5 (thanks Rico)
    - use internal libwps, opencollada, collada2gltf, libcmis, cppunit

libreoffice (1:5.0.0-0ubuntu1~wily1) wily; urgency=medium

  * LibreOffice 5.0.0 final release (identical to rc5)
  * merge from Debian:
    - debian/patches/disable-tiledrendering-test.diff: temporarily disable test
    - rulees: bump build-depends on libgltf, *collada*, cppunit, liborcus, libcmis to
      build-depend on their gcc 5 rebuilds. Bump boost build-dep to >= 1.58
      (closes: #794717)
    - rules:fix SYSTEM_GCC_CHECK for gcc 5; remove obsolete >= 4.7 check for Qt to get
      correct build-dep
    - temporarily disable -evolution until libebook1.2-dev is installable again
    - debian/control.in: suggest breeze-icon-theme in -style-breeze (like the
      other ones do for oxygen/tango)
  * reduce diff to Debian: use Enhances in styles consistently
  * depend from leaf themes like -style-sifr on -style-galaxy for now

libreoffice (1:5.0.1~rc1-3) UNRELEASED; urgency=medium

  * debian/patches/gtk3-rtl.diff: backport GTk3 RTL fixes (arrows, checkboxes)
    from libreoffice-5-0

  * debian/rules:
    - bump libmysqlcppconn-dev and libclucene-dev build-deps to their
      gcc 5 versions
    - add explicit dh-python build-dependency
    - temporarily disable -kde (KDE uninstallable in sid right now
      anyway) and coinmp

  * merge from Ubuntu:
    - autopkgtest updates/fixes

libreoffice (1:5.0.1~rc1-2) unstable; urgency=medium

  * debian/patches/series: (re-)enable disable-tiledrendering-test.diff;
    still fails...

libreoffice (1:5.0.1~rc1-1) unstable; urgency=medium

  * New upstream release candidate

  * upload to unstable

  * debian/rules:
    - bump build-depends on libgltf, *collada*, cppunit, liborcus, libcmis to
      build-depend on their gcc 5 rebuilds. Bump boost build-dep to >= 1.58
      (closes: #794717)
    - rules:fix SYSTEM_GCC_CHECK for gcc 5; remove obsolete >= 4.7 check for Qt to get
      correct build-dep
    - temporarily disable -evolution until libebook1.2-dev is installable again
    - debian/control.in: suggest breeze-icon-theme in -style-breeze (like the
      other ones do for oxygen/tango)
  * debian/control.in: suggest breeze-icon-theme in -style-breeze (like the
    other ones do for oxygen/tango)

libreoffice (1:5.0.0~rc5-1) experimental; urgency=medium

  * New upstream release candidate

  * debian/rules:
    - ENABLE_MERGELIBS=n on kfreebsd-* for now ("Argument list too long")
    - ENABLE_COLLADA=y (for i386/amd64) now that the libs finally are in
      Debian
    - KDE_ICONSET_DEP=libreoffice-style-breeze (closes: #794318)
  * debian/control.in:
     - update -l10n conflicts in -common, remove 3.5/3.6, add 4.3/4.4
       (closes: #794024)

libreoffice (1:5.0.0~rc4-1) experimental; urgency=medium

  * New upstream release candidate

  * debian/rules:
   - ENABLE_MERGELIBS=y as it's now upstream default

libreoffice (1:5.0.0~rc3-1) experimental; urgency=medium

  * New upstream release candidate

  * debian/rules:
    - re-enable CVE tests on all platforms again now that the infinite loop with
      unsigned char-default is supposedly fixed

libreoffice (1:5.0.0~rc2-1) experimental; urgency=medium

  * New upstream release candidate

  * debian/control.in:
    - s/cliipart/clipart/ (closes: #787660 again)
  * debian/rules:
    - move libunoidllo.so from ure into uno-libs3, too, as
      libcppuhelpergcc3.so.3 is (now) linked to it

  * debian/rules:
    - move gnome-open-url (back) to -gnome

libreoffice (1:5.0.0~rc1-1) experimental; urgency=medium

  * New upstream release candidate
    - fixes "Can't use a hash as a reference" deprecation warning/error in
      lo-xlate-lang (closes: #788613)

  * debian/patches/liborcus.diff: backport build fixes for using liborcus
    0.9.1 from master

  * debian/rules:
    - readd lost move of sal.py/cppu.py and libuno*.so.3-gdb.py
      into uno-libs3-dbg (closes: #788848)
    - build-depend on liborcus >= 0.9.0

  * debian/control.in:
    - make -gnome depend on -gtk3 now that it's enabled upstream if desktop
      is gnome3 (closes: #681180)

libreoffice (1:5.0.0~beta3-1) experimental; urgency=medium

  * New upstream beta release

  * debian/patches/rsc-no-error-about-unknown-switch.diff: don't error out
    CPPFLAGS (e.g. -Wdate-time) to not FTBFS with the patched reproducible
    builds toolchain

  * debian/rules:
    - remove left-over dh_installxmlcatalogs call...
    - temporarily disable junit tests

  * debian/control{,.in}:
    - suggest openclipart2-libreoffice | openclipart-libreoffice
      (closes: #787660)

  * debian/copyright:
    - remove long gone dmake (closes: #788311)

libreoffice (1:5.0.0~beta1-1) experimental; urgency=medium

  * New upstream beta release

  * debian/control{,.lokit.in}, debian/rules, debian/libreofficekit-dev.*:
    initial LibreOfficeKit packaging
  * debian/control{,.in}, debian/rules, debian/*xmlcatalogs.in: drop packaging
    openoffice.org-dtd-officedocument1.0; we've kept this DTD for a obsolete
    format for too long already

  * debian/rules:
    - add conditional for system-collada2gltf
    - oops, also add old openoffice(.org) changelogs to fonts-opensymbol, it
      already existed in OOO 3.2.1 times (squeeze)
    - enable l10n again

libreoffice (1:5.0.0~alpha1-1) experimental; urgency=medium

  * new upstream snapshot

  * debian/rules:
    - adapt for ure folded into /usr/lib/libreoffice/program directly
    - build only en-US for now
  * debian/uno-libs3.symbols: update
  * debian/control.in, debian/rules: disable crystal icons (KDE3); enable
    breeze (KDE 5)

 -- Bjoern Michaelsen <email address hidden>  Mon, 31 Aug 2015 20:32:35 +0200

Upload details

Uploaded by:
Björn Michaelsen on 2015-09-10
Sponsored by:
Mathieu Trudel-Lapierre
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
alpha amd64 armel armhf hppa i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc powerpcspe ppc64 s390 s390x sparc all
Section:
editors
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
libreoffice_5.0.1.orig-src.tar.xz 172.4 MiB c9d8b1d00429dfa86e07b2f78a3157e2bcb154ebce7f4e706428b06e4bb586e0
libreoffice_5.0.1.orig-translations.tar.xz 123.9 MiB 04c4f8d167cbe97f4f0f2d1e5a133347fb742e975a4041cac335ffb591120fe6
libreoffice_5.0.1.orig.tar.xz 140.0 MiB ae7213b711d139a9baec56bceae2c3a6ffe30caf0be06358d39db914d6bcae87
libreoffice_5.0.1-0ubuntu1.debian.tar.xz 2.0 MiB 2dec7c5e3de45c581856ee129d7c522e4ee73b6801324933e0286fd4599960a5
libreoffice_5.0.1-0ubuntu1.dsc 13.5 KiB b3b8171a7ba8b3254211a26934ea7bc1c2259f8d725cab7c2d94d19fcc12af0e

View changes file

Binary packages built by this source

fonts-opensymbol: No summary available for fonts-opensymbol in ubuntu wily.

No description available for fonts-opensymbol in ubuntu wily.

libreoffice: No summary available for libreoffice in ubuntu wily.

No description available for libreoffice in ubuntu wily.

libreoffice-avmedia-backend-gstreamer: No summary available for libreoffice-avmedia-backend-gstreamer in ubuntu wily.

No description available for libreoffice-avmedia-backend-gstreamer in ubuntu wily.

libreoffice-avmedia-backend-gstreamer-dbgsym: No summary available for libreoffice-avmedia-backend-gstreamer-dbgsym in ubuntu wily.

No description available for libreoffice-avmedia-backend-gstreamer-dbgsym in ubuntu wily.

libreoffice-base: No summary available for libreoffice-base in ubuntu wily.

No description available for libreoffice-base in ubuntu wily.

libreoffice-base-core: No summary available for libreoffice-base-core in ubuntu wily.

No description available for libreoffice-base-core in ubuntu wily.

libreoffice-base-core-dbgsym: No summary available for libreoffice-base-core-dbgsym in ubuntu wily.

No description available for libreoffice-base-core-dbgsym in ubuntu wily.

libreoffice-base-dbgsym: No summary available for libreoffice-base-dbgsym in ubuntu wily.

No description available for libreoffice-base-dbgsym in ubuntu wily.

libreoffice-base-drivers: No summary available for libreoffice-base-drivers in ubuntu wily.

No description available for libreoffice-base-drivers in ubuntu wily.

libreoffice-base-drivers-dbgsym: No summary available for libreoffice-base-drivers-dbgsym in ubuntu wily.

No description available for libreoffice-base-drivers-dbgsym in ubuntu wily.

libreoffice-calc: No summary available for libreoffice-calc in ubuntu wily.

No description available for libreoffice-calc in ubuntu wily.

libreoffice-calc-dbgsym: No summary available for libreoffice-calc-dbgsym in ubuntu wily.

No description available for libreoffice-calc-dbgsym in ubuntu wily.

libreoffice-common: No summary available for libreoffice-common in ubuntu wily.

No description available for libreoffice-common in ubuntu wily.

libreoffice-core: No summary available for libreoffice-core in ubuntu wily.

No description available for libreoffice-core in ubuntu wily.

libreoffice-core-dbgsym: No summary available for libreoffice-core-dbgsym in ubuntu wily.

No description available for libreoffice-core-dbgsym in ubuntu wily.

libreoffice-dbg: No summary available for libreoffice-dbg in ubuntu wily.

No description available for libreoffice-dbg in ubuntu wily.

libreoffice-dbgsym: No summary available for libreoffice-dbgsym in ubuntu wily.

No description available for libreoffice-dbgsym in ubuntu wily.

libreoffice-dev: No summary available for libreoffice-dev in ubuntu wily.

No description available for libreoffice-dev in ubuntu wily.

libreoffice-dev-dbgsym: No summary available for libreoffice-dev-dbgsym in ubuntu wily.

No description available for libreoffice-dev-dbgsym in ubuntu wily.

libreoffice-dev-doc: No summary available for libreoffice-dev-doc in ubuntu wily.

No description available for libreoffice-dev-doc in ubuntu wily.

libreoffice-draw: No summary available for libreoffice-draw in ubuntu wily.

No description available for libreoffice-draw in ubuntu wily.

libreoffice-draw-dbgsym: No summary available for libreoffice-draw-dbgsym in ubuntu wily.

No description available for libreoffice-draw-dbgsym in ubuntu wily.

libreoffice-gnome: No summary available for libreoffice-gnome in ubuntu wily.

No description available for libreoffice-gnome in ubuntu wily.

libreoffice-gnome-dbgsym: No summary available for libreoffice-gnome-dbgsym in ubuntu wily.

No description available for libreoffice-gnome-dbgsym in ubuntu wily.

libreoffice-gtk: No summary available for libreoffice-gtk in ubuntu wily.

No description available for libreoffice-gtk in ubuntu wily.

libreoffice-gtk-dbgsym: No summary available for libreoffice-gtk-dbgsym in ubuntu wily.

No description available for libreoffice-gtk-dbgsym in ubuntu wily.

libreoffice-gtk3: No summary available for libreoffice-gtk3 in ubuntu wily.

No description available for libreoffice-gtk3 in ubuntu wily.

libreoffice-gtk3-dbgsym: No summary available for libreoffice-gtk3-dbgsym in ubuntu wily.

No description available for libreoffice-gtk3-dbgsym in ubuntu wily.

libreoffice-impress: No summary available for libreoffice-impress in ubuntu wily.

No description available for libreoffice-impress in ubuntu wily.

libreoffice-impress-dbgsym: No summary available for libreoffice-impress-dbgsym in ubuntu wily.

No description available for libreoffice-impress-dbgsym in ubuntu wily.

libreoffice-java-common: No summary available for libreoffice-java-common in ubuntu wily.

No description available for libreoffice-java-common in ubuntu wily.

libreoffice-kde: No summary available for libreoffice-kde in ubuntu wily.

No description available for libreoffice-kde in ubuntu wily.

libreoffice-kde-dbgsym: No summary available for libreoffice-kde-dbgsym in ubuntu wily.

No description available for libreoffice-kde-dbgsym in ubuntu wily.

libreoffice-l10n-in: No summary available for libreoffice-l10n-in in ubuntu wily.

No description available for libreoffice-l10n-in in ubuntu wily.

libreoffice-l10n-za: No summary available for libreoffice-l10n-za in ubuntu wily.

No description available for libreoffice-l10n-za in ubuntu wily.

libreoffice-librelogo: No summary available for libreoffice-librelogo in ubuntu wily.

No description available for libreoffice-librelogo in ubuntu wily.

libreoffice-math: No summary available for libreoffice-math in ubuntu wily.

No description available for libreoffice-math in ubuntu wily.

libreoffice-math-dbgsym: No summary available for libreoffice-math-dbgsym in ubuntu wily.

No description available for libreoffice-math-dbgsym in ubuntu wily.

libreoffice-mysql-connector: No summary available for libreoffice-mysql-connector in ubuntu wily.

No description available for libreoffice-mysql-connector in ubuntu wily.

libreoffice-mysql-connector-dbgsym: No summary available for libreoffice-mysql-connector-dbgsym in ubuntu wily.

No description available for libreoffice-mysql-connector-dbgsym in ubuntu wily.

libreoffice-officebean: No summary available for libreoffice-officebean in ubuntu wily.

No description available for libreoffice-officebean in ubuntu wily.

libreoffice-officebean-dbgsym: No summary available for libreoffice-officebean-dbgsym in ubuntu wily.

No description available for libreoffice-officebean-dbgsym in ubuntu wily.

libreoffice-ogltrans: No summary available for libreoffice-ogltrans in ubuntu wily.

No description available for libreoffice-ogltrans in ubuntu wily.

libreoffice-ogltrans-dbgsym: No summary available for libreoffice-ogltrans-dbgsym in ubuntu wily.

No description available for libreoffice-ogltrans-dbgsym in ubuntu wily.

libreoffice-pdfimport: No summary available for libreoffice-pdfimport in ubuntu wily.

No description available for libreoffice-pdfimport in ubuntu wily.

libreoffice-pdfimport-dbgsym: No summary available for libreoffice-pdfimport-dbgsym in ubuntu wily.

No description available for libreoffice-pdfimport-dbgsym in ubuntu wily.

libreoffice-report-builder: No summary available for libreoffice-report-builder in ubuntu wily.

No description available for libreoffice-report-builder in ubuntu wily.

libreoffice-report-builder-bin: No summary available for libreoffice-report-builder-bin in ubuntu wily.

No description available for libreoffice-report-builder-bin in ubuntu wily.

libreoffice-report-builder-bin-dbgsym: No summary available for libreoffice-report-builder-bin-dbgsym in ubuntu wily.

No description available for libreoffice-report-builder-bin-dbgsym in ubuntu wily.

libreoffice-script-provider-bsh: No summary available for libreoffice-script-provider-bsh in ubuntu wily.

No description available for libreoffice-script-provider-bsh in ubuntu wily.

libreoffice-script-provider-js: No summary available for libreoffice-script-provider-js in ubuntu wily.

No description available for libreoffice-script-provider-js in ubuntu wily.

libreoffice-script-provider-python: No summary available for libreoffice-script-provider-python in ubuntu wily.

No description available for libreoffice-script-provider-python in ubuntu wily.

libreoffice-sdbc-firebird: No summary available for libreoffice-sdbc-firebird in ubuntu wily.

No description available for libreoffice-sdbc-firebird in ubuntu wily.

libreoffice-sdbc-firebird-dbgsym: No summary available for libreoffice-sdbc-firebird-dbgsym in ubuntu wily.

No description available for libreoffice-sdbc-firebird-dbgsym in ubuntu wily.

libreoffice-sdbc-hsqldb: No summary available for libreoffice-sdbc-hsqldb in ubuntu wily.

No description available for libreoffice-sdbc-hsqldb in ubuntu wily.

libreoffice-sdbc-hsqldb-dbgsym: No summary available for libreoffice-sdbc-hsqldb-dbgsym in ubuntu wily.

No description available for libreoffice-sdbc-hsqldb-dbgsym in ubuntu wily.

libreoffice-sdbc-postgresql: No summary available for libreoffice-sdbc-postgresql in ubuntu wily.

No description available for libreoffice-sdbc-postgresql in ubuntu wily.

libreoffice-sdbc-postgresql-dbgsym: No summary available for libreoffice-sdbc-postgresql-dbgsym in ubuntu wily.

No description available for libreoffice-sdbc-postgresql-dbgsym in ubuntu wily.

libreoffice-style-breeze: No summary available for libreoffice-style-breeze in ubuntu wily.

No description available for libreoffice-style-breeze in ubuntu wily.

libreoffice-style-galaxy: No summary available for libreoffice-style-galaxy in ubuntu wily.

No description available for libreoffice-style-galaxy in ubuntu wily.

libreoffice-style-hicontrast: No summary available for libreoffice-style-hicontrast in ubuntu wily.

No description available for libreoffice-style-hicontrast in ubuntu wily.

libreoffice-style-human: No summary available for libreoffice-style-human in ubuntu wily.

No description available for libreoffice-style-human in ubuntu wily.

libreoffice-style-oxygen: No summary available for libreoffice-style-oxygen in ubuntu wily.

No description available for libreoffice-style-oxygen in ubuntu wily.

libreoffice-style-sifr: No summary available for libreoffice-style-sifr in ubuntu wily.

No description available for libreoffice-style-sifr in ubuntu wily.

libreoffice-style-tango: No summary available for libreoffice-style-tango in ubuntu wily.

No description available for libreoffice-style-tango in ubuntu wily.

libreoffice-subsequentcheckbase: No summary available for libreoffice-subsequentcheckbase in ubuntu wily.

No description available for libreoffice-subsequentcheckbase in ubuntu wily.

libreoffice-wiki-publisher: No summary available for libreoffice-wiki-publisher in ubuntu wily.

No description available for libreoffice-wiki-publisher in ubuntu wily.

libreoffice-writer: No summary available for libreoffice-writer in ubuntu wily.

No description available for libreoffice-writer in ubuntu wily.

libreoffice-writer-dbgsym: No summary available for libreoffice-writer-dbgsym in ubuntu wily.

No description available for libreoffice-writer-dbgsym in ubuntu wily.

libreofficekit-dev: No summary available for libreofficekit-dev in ubuntu wily.

No description available for libreofficekit-dev in ubuntu wily.

python3-uno: No summary available for python3-uno in ubuntu wily.

No description available for python3-uno in ubuntu wily.

python3-uno-dbgsym: No summary available for python3-uno-dbgsym in ubuntu wily.

No description available for python3-uno-dbgsym in ubuntu wily.

uno-libs3: No summary available for uno-libs3 in ubuntu wily.

No description available for uno-libs3 in ubuntu wily.

uno-libs3-dbg: No summary available for uno-libs3-dbg in ubuntu wily.

No description available for uno-libs3-dbg in ubuntu wily.

uno-libs3-dbgsym: No summary available for uno-libs3-dbgsym in ubuntu wily.

No description available for uno-libs3-dbgsym in ubuntu wily.

ure: No summary available for ure in ubuntu wily.

No description available for ure in ubuntu wily.

ure-dbg: No summary available for ure-dbg in ubuntu wily.

No description available for ure-dbg in ubuntu wily.

ure-dbgsym: No summary available for ure-dbgsym in ubuntu wily.

No description available for ure-dbgsym in ubuntu wily.