Change log for libsdl1.2 package in Ubuntu

153 of 53 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-11-11
Deleted in disco-proposed (Reason: moved to release)
libsdl1.2 (1.2.15+dfsg2-4) unstable; urgency=medium

  * d/rules: Add @ in 'tar --mtime="@$(SOURCE_DATE_EPOCH)"', otherwise the
    date is not valid

 -- Manuel A. Fernandez Montecelo <email address hidden>  Thu, 25 Oct 2018 01:47:02 +0200

Available diffs

Superseded in disco-release on 2018-11-11
Published in cosmic-release on 2018-09-15
Deleted in cosmic-proposed (Reason: moved to release)
libsdl1.2 (1.2.15+dfsg2-2) unstable; urgency=medium

  [ Gianfranco Costamagna ]
  * Team upload

  [ Ryan C. Gordon (icculus) ]
  * Disable --disable-loadso switch, it was useless and it is wrong
    in many cases (see LP: #1740517 for discussion)

 -- Gianfranco Costamagna <email address hidden>  Fri, 14 Sep 2018 19:52:34 +0200

Available diffs

Superseded in cosmic-release on 2018-09-15
Superseded in cosmic-release on 2018-07-20
Deleted in cosmic-proposed on 2018-09-16 (Reason: moved to release)
libsdl1.2 (1.2.15+dfsg2-1) unstable; urgency=medium

  * Team upload
  * Ack previous NMU, thanks
  * debian/patches/SDL-1.2.15-vec_perm-ppc64le.patch:
    - fix test failures on ppc64el, by fixing a wrong ordering on BE
      systems. Thanks Frédéric Bonnard for the patch!

 -- Gianfranco Costamagna <email address hidden>  Wed, 30 May 2018 15:27:49 +0200
Superseded in cosmic-release on 2018-05-31
Deleted in cosmic-proposed on 2018-06-01 (Reason: moved to release)
libsdl1.2 (1.2.15+dfsg2-1~build1) cosmic; urgency=medium

  * Team upload
  * Ack previous NMU, thanks
  * debian/patches/SDL-1.2.15-vec_perm-ppc64le.patch:
    - fix test failures on ppc64el, by fixing a wrong ordering on BE
      systems. Thanks Frédéric Bonnard for the patch!

 -- Gianfranco Costamagna <email address hidden>  Wed, 30 May 2018 15:27:49 +0200
Superseded in cosmic-release on 2018-05-30
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-07-25
Deleted in artful-proposed (Reason: moved to release)
libsdl1.2 (1.2.15+dfsg2-0.1) unstable; urgency=medium

  * Non-maintainer upload.

  [ Manuel A. Fernandez Montecelo ]
  * Do not build-depend on libaudiofile, unused.
    Closes: #857670

  [ Jonas Smedegaard ]
  * Add script to check copyright and licensing of source.
  * Update copyright info:
    + Rewrite copyright file in machine-readable format.
    + Fix cover many secondary copyright holders and licenses.
  * Repackage upstream source to exclude more potentially non-DFSG code,
    and add patch to avoid missing code.
    Closes: Bug#834204.
  * Update watch file:
    + Bump to version 4.
    + Add usage comment.
    + Set repacksuffix.
  * Drop repackaging hints from git-buildpackage config: Handled by
    uscan + machine-readable copyright file.
  * Add lintian overrides regarding license in License-Reference field.
    See bug#786450.
  * Add lintian overrides regarding license name used both alone an in
    composition.

 -- Jonas Smedegaard <email address hidden>  Tue, 18 Jul 2017 13:46:21 +0200
Superseded in artful-release on 2017-07-25
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-06-22 (Reason: moved to release)
libsdl1.2 (1.2.15+dfsg1-4) unstable; urgency=high

  * Urgency "high" to fix problems with migration of -dbg package.  Thanks
    Yann Dirson.
  * Ensure proper migration from -dbg package using "dh_strip
    --dbgsym-migration"
  * Bump debhelper dependency for --dbgsym-migration
  * Fix for reproducible builds:
    - sort files by name when creating "examples.tar.gz"

 -- Manuel A. Fernandez Montecelo <email address hidden>  Thu, 17 Mar 2016 12:15:31 +0000

Available diffs

Superseded in yakkety-release on 2016-05-05
Published in xenial-release on 2016-03-13
Deleted in xenial-proposed (Reason: moved to release)
libsdl1.2 (1.2.15+dfsg1-3) unstable; urgency=medium

  * Disable suppot for DirectFB (Closes: #816125)
  * d/control: Update Vcs-* URLs, use https
  * Fixes for reproducible builds:
    - timestamps_in_tarball, use --clamp-mtime with changelog as date
    - timestamps_in_gzip_headers, export GZIP="-9n"
  * Drop -dbg package

 -- Manuel A. Fernandez Montecelo <email address hidden>  Sat, 12 Mar 2016 00:36:47 +0000
Superseded in xenial-release on 2016-03-13
Deleted in xenial-proposed on 2016-03-15 (Reason: moved to release)
libsdl1.2 (1.2.15-12ubuntu1) xenial; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Drop directfb support.

Superseded in xenial-release on 2015-11-01
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
libsdl1.2 (1.2.15-11ubuntu1) wily; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - Drop directfb support.

Published in precise-updates on 2015-04-13
Published in precise-security on 2015-04-13
libsdl1.2 (1.2.14-6.4ubuntu3.1) precise-security; urgency=medium

  * SECURITY UPDATE: buffer overflow in MakeBigReq (LP: #1441381)
    - debian/control: change Build-Depends to libx11 security update
    - CVE-2013-7439
 -- Marc Deslauriers <email address hidden>   Mon, 13 Apr 2015 08:17:25 -0400
Superseded in wily-release on 2015-08-12
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
libsdl1.2 (1.2.15-10ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - Drop directfb support. This is the only package which still pulls the
      rather sizable directfb into a standard installation, and we never
      actually used/supported it anyway.
  * Dropped changes, included in Debian:
    - Drop tslib support which is in universe.
    - debian/patches/sdl-check-for-SDL_VIDEO_X11_BACKINGSTORE.patch:
      Restore old backingstore behavior to prevent tearing.

Published in trusty-updates on 2014-05-19
Deleted in trusty-proposed (Reason: moved to -updates)
libsdl1.2 (1.2.15-8ubuntu1.1) trusty; urgency=medium

  * debian/patches/sdl-check-for-SDL_VIDEO_X11_BACKINGSTORE.patch:
    - Restore old backingstore behavior to prevent tearing
      (LP: #1280665)
 -- Timo Jyrinki <email address hidden>   Sat, 19 Apr 2014 23:22:43 +0300
Superseded in utopic-release on 2014-07-02
Deleted in utopic-proposed on 2014-07-03 (Reason: moved to release)
libsdl1.2 (1.2.15-9ubuntu2) utopic; urgency=medium

  * Restore accidentally-clobbered changes from 1.2.15-8ubuntu2.

  [ Timo Jyrinki ]
  * debian/patches/sdl-check-for-SDL_VIDEO_X11_BACKINGSTORE.patch:
    - Restore old backingstore behavior to prevent tearing
      (LP: #1280665)
 -- Steve Langasek <email address hidden>   Tue, 06 May 2014 10:04:08 -0700

Available diffs

Superseded in utopic-release on 2014-05-06
Deleted in utopic-proposed on 2014-05-07 (Reason: moved to release)
libsdl1.2 (1.2.15-9ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - Drop directfb support. This is the only package which still pulls the
      rather sizable directfb into a standard installation, and we never
      actually used/supported it anyway.
    - Drop tslib support which is in universe.
  * Dropped changes, included in Debian:
    - fix dh_autoreconf handling.

Superseded in utopic-release on 2014-05-01
Deleted in utopic-proposed on 2014-05-03 (Reason: moved to release)
libsdl1.2 (1.2.15-8ubuntu2) utopic; urgency=medium

  * debian/patches/sdl-check-for-SDL_VIDEO_X11_BACKINGSTORE.patch:
    - Restore old backingstore behavior to prevent tearing
      (LP: #1280665)
 -- Timo Jyrinki <email address hidden>   Sat, 19 Apr 2014 23:22:43 +0300

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-01-14
Deleted in trusty-proposed (Reason: moved to release)
libsdl1.2 (1.2.15-8ubuntu1) trusty; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - Drop directfb support. This is the only package which still pulls the
      rather sizable directfb into a standard installation, and we never
      actually used/supported it anyway.
      --enable-video-directfb from confflags.
    - Drop tslib support which is in universe.
    - debian/rules, debian/patches/proper-autotools.patch: Fix wrong
      handling of dh_autoreconf that fails to ever re-libtoolize the
      package.  Bypass calling autoheader, since configure.in isn't
      compatible with current version of autoheader.
  * Dropped changes, merged in Debian:
    - drop the unused libsdl1.2debian-udeb package
    - Use dh_autotools-dev to update config.{sub,guess} for new ports.

Superseded in trusty-release on 2014-01-14
Deleted in trusty-proposed on 2014-01-15 (Reason: moved to release)
libsdl1.2 (1.2.15-5ubuntu3) trusty; urgency=medium

  * debian/rules, debian/patches/proper-autotools.patch: Fix wrong handling
    of dh_autoreconf that fails to ever re-libtoolize the package.  Bypass
    calling autoheader, since configure.in isn't compatible with current
    version of autoheader.
 -- Steve Langasek <email address hidden>   Sun, 15 Dec 2013 19:53:07 -0800
Superseded in trusty-release on 2013-12-16
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libsdl1.2 (1.2.15-5ubuntu2) saucy; urgency=low

  * Use dh_autotools-dev to update config.{sub,guess} for new ports.
 -- Adam Conrad <email address hidden>   Tue, 08 Oct 2013 19:22:04 -0600

Available diffs

Superseded in saucy-release on 2013-10-09
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libsdl1.2 (1.2.15-5ubuntu1) quantal; urgency=low

  * Merge from Debian unstable (LP: #1030782), remaining changes:
    - Drop directfb support. This is the only package which still pulls the
      rather sizable directfb into a standard installation, and we never
      actually used/supported it anyway. Drop directfb build/binary dependencies
      and libsdl1.2debian-udeb package; don't build udeb flavour and drop
      --enable-video-directfb from confflags.
  * Drop tslib support which is in universe.

Superseded in quantal-release on 2012-08-01
Published in precise-release on 2012-01-27
libsdl1.2 (1.2.14-6.4ubuntu3) precise; urgency=low

  * Rebuild to pick new audiofile's shlibs (LP: #922036)
 -- Alessio Treglia <email address hidden>   Fri, 27 Jan 2012 12:43:59 +0100
Superseded in precise-release on 2012-01-27
libsdl1.2 (1.2.14-6.4ubuntu2) precise; urgency=low

  * Pull from Debian git to get multiarch support in:

  [ Felix Geyer ]
  * Remove all patches that were disabled.
  * Switch to source format 3.0 (quilt).
  * Simplify debian/rules by using dh(1).
  * Drop ancient Conflicts/Replaces.
  * Disable the PlayStation 3 Cell driver on ppc64. (Closes: #644908)
  * Update Vcs control fields to the new git repository. (Closes: #615902)
  * Drop sequence numbers from the patch filenames.
  * Fix: SDL_BlitCopyOverlap() copies data between overlapping bitmaps.
    (Closes: #626048)
    - Add sdlblit_memcpy_fix.diff, cherry-picked from upstream.
  * Set _NET_WM_PID property in X11 windows which is used by GNOME Shell and the
    Unity desktop.
    - Add x11_add_support_NET_WM_PID.diff from Ubuntu / Marco Trevisan.
  * Bump Standards-Version to 3.9.2, no further changes necessary.
  * Override package-name-doesnt-match-sonames lintian warning.
  * Add a debug package. (Closes: #600292)
  * Add myself as uploader.
  * Switch to debhelper compat level v9.
    - Convert to multiarch. (Closes: #636605)
    - Exports hardening build flags.
  * Remove the .la file.

  [ Dominique Dumont ]
  * control: replaced XC-Package-Type with Package-Type tag
 -- Steve Langasek <email address hidden>   Thu, 29 Dec 2011 17:55:26 -0800
Superseded in precise-release on 2011-12-30
libsdl1.2 (1.2.14-6.4ubuntu1) precise; urgency=low

  * Merge from Debian testing (LP: #898147), remaining changes:
    - Drop directfb support. This is the only package which still pulls the
      rather sizable directfb into a standard installation, and we never
      actually used/supported it anyway. Drop directfb build/binary dependencies
      and libsdl1.2debian-udeb package; don't build udeb flavour and drop
      --enable-video-directfb from confflags.
    - Disable PlayStation 3 Cell driver on ppc64 as well as on powerpc.
    - Replace memcpy by memmove in SDL_blit.c, as per SDL bug 1090
      see http://hg.libsdl.org/SDL/rev/d898ee5431f5
    - Add 321_x11_add_support_to__NET_WM_PID.diff to support pid exportation
      in each x11 SDL window, needed mostly by pygame and BAMF.

Superseded in precise-release on 2011-12-05
libsdl1.2 (1.2.14-6.1ubuntu5) precise; urgency=low

  * No-change rebuild to drop spurious libsfgcc1 dependency on armhf.
 -- Adam Conrad <email address hidden>   Fri, 02 Dec 2011 17:34:37 -0700
Superseded in precise-release on 2011-12-03
Obsolete in oneiric-release on 2015-04-24
libsdl1.2 (1.2.14-6.1ubuntu4) oneiric; urgency=low

  * Added 321_x11_add_support_to__NET_WM_PID.diff to support pid exportation
    in each x11 SDL window, needed mostly by pygame and BAMF (LP: #777417).
 -- Marco Trevisan (Trevino) <mail@3v1n0.net>   Wed, 06 Jul 2011 15:07:19 +0200
Superseded in oneiric-release on 2011-07-06
Obsolete in natty-release on 2013-06-04
libsdl1.2 (1.2.14-6.1ubuntu3) natty; urgency=low

  * Replace memcpy by memmove in SDL_blit.c, as per SDL bug 1090
    see http://hg.libsdl.org/SDL/rev/d898ee5431f5
    (LP: #725044).
 -- <email address hidden> (Dr. David Alan Gilbert)   Sun, 13 Mar 2011 01:05:52 +0000
Superseded in natty-release on 2011-04-01
libsdl1.2 (1.2.14-6.1ubuntu2) natty; urgency=low

  * Disable PlayStation 3 Cell driver on ppc64 as well as on powerpc.
 -- Colin Watson <email address hidden>   Tue, 15 Feb 2011 12:57:15 +0000
Superseded in natty-release on 2011-02-15
libsdl1.2 (1.2.14-6.1ubuntu1) natty; urgency=low

  [ Ubuntu Merge-o-Matic ]
  * Merge from Debian unstable.  Remaining changes:
    - Drop aRts support: drop libarts1-dev and libartsc0-dev build-deps,
      deps, drop libsdl1.2debian-arts package from control, drop alternate dep
      of libsdl1.2-debian on libsdl1.2debian-arts, pass --enable-arts=no in
      confflags, drop arts from FLAVOURS in rules.
    - Drop svgalib support: drop build-dep and deps on libsvga1-dev, drop
      mention of "svga" driver in libsdl1.2debian's description.
    - Drop directfb support. This is the only package which still pulls the
      rather sizable directfb into a standard installation, and we never
      actually used/supported it anyway. Drop directfb build/binary dependencies and
      libsdl1.2debian-udeb package; don't build udeb flavour and drop
      --enable-video-directfb from all_confflags.

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
libsdl1.2 (1.2.14-6ubuntu3) maverick; urgency=low

  * Drop directfb support. This is the only package which still pulls
    the rather sizable directfb into a standard installation, and we never
    actually used/supported it anyway.
    - debian/control: Drop directfb build/binary dependencies and
      libsdl1.2debian-udeb package.
    - debian/rules: Don't build udeb flavour and drop --enable-video-directfb
      from all_confflags
 -- Martin Pitt <email address hidden>   Wed, 30 Jun 2010 10:58:00 +0200
Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
libsdl1.2 (1.2.14-4ubuntu1.1) lucid-proposed; urgency=low

  * Add 320_disappearingcursor.diff & 310_fixmouseclicks from Debian
    revisions 1.2.14-5 & 1.2.14-6 to fix problems with the mouse button
    clicks not being detected in windowed mode (LP: #528957)
 -- Andrew Mitchell <email address hidden>   Mon, 03 May 2010 22:57:25 +1200
Superseded in maverick-release on 2010-07-02
libsdl1.2 (1.2.14-6ubuntu2) maverick; urgency=low

  * Rebuild for directfb 1.2.10 transition. (LP: #585992)
 -- Felix Geyer <email address hidden>   Wed, 26 May 2010 20:21:01 +0200

Available diffs

Superseded in maverick-release on 2010-05-27
libsdl1.2 (1.2.14-6ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes:
    * Drop aRts support: drop libarts1-dev and libartsc0-dev build-deps,
      deps, drop libsdl1.2debian-arts package from control, drop alternate dep
      of libsdl1.2-debian on libsdl1.2debian-arts, pass --enable-arts=no in
      confflags, drop arts from FLAVOURS in rules.
    * Drop svgalib support: drop build-dep and deps on libsvga1-dev, drop
      mention of "svga" driver in libsdl1.2debian's description.
 -- Andrew Mitchell <email address hidden>   Wed, 19 May 2010 16:37:00 +1200
Superseded in maverick-release on 2010-05-19
Obsolete in lucid-release on 2016-10-26
libsdl1.2 (1.2.14-4ubuntu1) lucid; urgency=low

  * Drop explicit -Wl,-Bsymbolic-functions LDFLAGS since that's the default in
    Ubuntu anyway.
  * Re-add --disable-audio-arts to udeb_confflags, no need to diverge from
    Debian here since we don't have aRts anyway.
  * Merge from Debian unstable, remaining changes:
    * Drop aRts support: drop libarts1-dev and libartsc0-dev build-deps,
      deps, drop libsdl1.2debian-arts package from control, drop alternate dep
      of libsdl1.2-debian on libsdl1.2debian-arts, pass --enable-arts=no in
      confflags, drop arts from FLAVOURS in rules.
    * Drop svgalib support: drop build-dep and deps on libsvga1-dev, drop
      mention of "svga" driver in libsdl1.2debian's description.
 -- Loic Minier <email address hidden>   Fri, 26 Feb 2010 15:19:15 +0100
Superseded in lucid-release on 2010-02-26
libsdl1.2 (1.2.14-1ubuntu2) lucid; urgency=low

  * In debian/rules, Don't use PlayStation 3 Cell driver on powerpc
    --enable-video-ps3=no (fixes FTBFS)
    - Thanks to Gentoo Bug 290450 for the fix
 -- Scott Kitterman <email address hidden>   Tue, 29 Dec 2009 01:00:25 -0500

Available diffs

Superseded in lucid-release on 2009-12-29
libsdl1.2 (1.2.14-1ubuntu1) lucid; urgency=low

  * Merge from Debian experimental, remaining changes:
    + debian/control:
      + add libglu1-mesa-dev as a build dependency, so SDL gets built
        with OpenGL support (LP: #328932)
      - dropped build-depends on libarts1-dev, libartsc0-dev. These
        packages will disappear as part of the arts removal
        (LP: #320915)
      - Removed Package: libsdl1.2debian-arts section entirely
      - dropped depends on libsdl1.2debian-arts (= ${binary:Version})
        for libsdl1.2-debian
      - dropped recommends on libartsc0-dev for libsdl1.2-dev
      - Remove svgalib support.
    + debian/rules:
      + set --enable-arts-shared=no and --enable-arts=no in confflags
      - removed --disable-audio-arts from udeb_confflags
      - dropped arts from FLAVOURS=
      + Link using -Wl,-Bsymbolic-functions.

Superseded in lucid-release on 2009-12-11
Obsolete in karmic-release on 2013-03-04
libsdl1.2 (1.2.13-4ubuntu4) karmic; urgency=low

  * Rebuild against directfb 1.2.

 -- Colin Watson <email address hidden>   Fri, 17 Jul 2009 10:50:14 +0100

Available diffs

Superseded in karmic-release on 2009-07-17
Obsolete in jaunty-release on 2013-02-28
libsdl1.2 (1.2.13-4ubuntu3) jaunty; urgency=low

  * debian/control:
    - add libglu1-mesa-dev as a build dependency, so SDL gets built with
      OpenGL support (LP: #328932)
    - Fix typo in svn URL (LP: #330457)

 -- Luke Yelavich <email address hidden>   Fri, 20 Feb 2009 13:15:42 +1100

Available diffs

Superseded in jaunty-release on 2009-02-20
libsdl1.2 (1.2.13-4ubuntu2) jaunty; urgency=low

  * Rebuild without aRts support. (LP: #320915)
  * Multiple changes in debian/control
    - dropped build-depends on libarts1-dev, libartsc0-dev. These
      packages will disappear as part of the arts removal.
    - Removed Package: libsdl1.2debian-arts section entirely
    - dropped depends on libsdl1.2debian-arts (= ${binary:Version}) for
      libsdl1.2-debian
    - dropped depends on  libartsc0-dev for libsdl1.2-dev
  * Multiple changes in debian/rules
    - set --enable-arts-shared=no and --enable-arts=no in confflags
    - removed --disable-audio-arts from udeb_confflags
    - dropped arts from FLAVOURS=

 -- Richard Birnie <email address hidden>   Sun, 25 Jan 2009 13:41:45 +0000
Superseded in jaunty-release on 2009-02-12
libsdl1.2 (1.2.13-4ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes:
    - Remove svgalib support.
    - Build for lpia as for i386.
    - Link using -Wl,-Bsymbolic-functions.

Available diffs

Superseded in jaunty-release on 2008-11-04
Obsolete in intrepid-release on 2013-02-20
libsdl1.2 (1.2.13-2ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - Remove svgalib support.
    - Prefer libgl1-mesa-dev build-dependency over xlibmesa-gl-dev.
    - Build for lpia as for i386.
    - Link using -Wl,-Bsymbolic-functions.
    - Munge Maintainer field as per spec.
  * Patch from Lennart Poettering to fix up buffering issues in the pulseaudio
    output driver, and remove references to unused PASERVER and PADEVICE
    environment variables.

Superseded in intrepid-release on 2008-05-08
Obsolete in hardy-release on 2015-04-24
libsdl1.2 (1.2.13-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable.
  * Remaining Ubuntu changes:
    - Remove svgalib support.
    - Prefer libgl1-mesa-dev build-dependency over xlibmesa-gl-dev.
    - Build for lpia as for i386.
    - Link using -Wl,-Bsymbolic-functions.
    - Munge Maintainer field as per spec.

Superseded in hardy-release on 2008-01-05
libsdl1.2 (1.2.12-1ubuntu2) hardy; urgency=low

  * Rebuild for libdirectfb-0.9-25 -> libdirectfb-1.0-0 transition.

 -- Steve Kowalik <email address hidden>   Tue, 25 Dec 2007 15:45:54 +1100
Superseded in hardy-release on 2007-12-25
libsdl1.2 (1.2.12-1ubuntu1) hardy; urgency=low

  * Merge with Debian; remaining changes:
    - Remove svgalib support.
    - Prefer libgl1-mesa-dev build-dependency over xlibmesa-gl-dev.
    - Build for lpia as for i386.
  * Link using -Wl,-Bsymbolic-functions.

Superseded in hardy-release on 2007-12-05
Obsolete in gutsy-release on 2011-09-16
libsdl1.2 (1.2.11-9ubuntu2) gutsy; urgency=low

  * Build for lpia as for i386.

 -- Matthias Klose <email address hidden>   Fri, 10 Aug 2007 13:57:08 +0000
Superseded in gutsy-release on 2007-08-10
libsdl1.2 (1.2.11-9ubuntu1) gutsy; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Remove svgalib support.
    - Prefer libgl1-mesa-dev build-dependency over xlibmesa-gl-dev.
    - Extend debian/patches/216_page_size.diff to avoid use of <asm/page.h>
      altogether.

Superseded in gutsy-release on 2007-06-11
libsdl1.2 (1.2.11-8ubuntu1) gutsy; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Remove svgalib support.
    - Prefer libgl1-mesa-dev build-dependency over xlibmesa-gl-dev.
    - Extend debian/patches/216_page_size.diff to avoid use of <asm/page.h>
      altogether.
  * Set Ubuntu maintainer address.

Superseded in gutsy-release on 2007-05-15
Obsolete in feisty-release on 2009-08-20
libsdl1.2 (1.2.11-7ubuntu1) feisty; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Remove svgalib support.
    - Extend debian/patches/216_page_size.diff to avoid use of <asm/page.h>
      altogether.
  * Adjust method of removing svgalib support to make future merges easier.

Superseded in feisty-release on 2006-12-19
Obsolete in edgy-release on 2008-06-19
libsdl1.2 (1.2.10-3ubuntu2) edgy; urgency=low

  * Add 099_page_size.diff, to prevent usage of page.h and PAGE_SIZE, use
    sysconf(_SC_PAGESIZE) instead, and resolve FTBFS on powerpc and ia64.

 -- Adam Conrad <email address hidden>   Sat, 21 Oct 2006 13:04:26 +1000
Superseded in edgy-release on 2006-10-21
libsdl1.2 (1.2.10-3ubuntu1) edgy; urgency=low

  * Merge from debian unstable. Remaining Ubuntu changes:
    - debian/control: Drop libsvga1-dev build dependency and dependencies,
      adapt package descriptions.

Superseded in edgy-release on 2006-07-03
Obsolete in dapper-release on 2011-09-06
libsdl1.2 (1.2.9-0.0ubuntu2) dapper; urgency=low

  * No-change upload to fix dependencies to prefer libesd-alsa.

 -- Martin Pitt <email address hidden>   Mon, 27 Mar 2006 09:03:08 +0000
Superseded in dapper-release on 2006-03-27
Superseded in dapper-release on 2006-02-03
libsdl1.2 (1.2.9-0.0ubuntu1) dapper; urgency=low


  * Resynchronise with Debian.

 -- Martin Pitt <email address hidden>  Thu, 17 Nov 2005 15:28:57 +0100
Obsolete in breezy-release on 2008-03-25
libsdl1.2 (1.2.7+1.2.8cvs20041007-5.3ubuntu2) breezy; urgency=low


  * Update {build-,}depends for the xorg -> mesa transition.

 -- Adam Conrad <email address hidden>  Fri, 19 Aug 2005 02:41:04 +1000
Obsolete in hoary-release on 2008-03-19
libsdl1.2 (1.2.7+1.2.8cvs20041007-3ubuntu4) hoary; urgency=low


  * Apply patch from Debian BTS which makes libsdl1.2 build on amd64
    again.  (ubuntu: #5031)

 -- Tollef Fog Heen <email address hidden>  Mon, 17 Jan 2005 21:47:56 +0100
Obsolete in warty-release on 2008-01-09
libsdl1.2 (1.2.7-7) unstable; urgency=low


  * Updates from CVS:
    - joystick ioctl error checking, and "logical joystick" enhancement.
    - Don't crash if SoftStretch used on hardware surface.
    - Fix DirectFB crash on exit.
    - Free X11 mouse cursor pixmaps properly in FreeWMCursor.
    - Fix for gcc-3.4.0 / PIC; and cpuinfo detects more extensions now.
    - Don't allow video modes larger than maximum size.
    - Properly set error when OpenGL init fails.
  * De-multilined Build-Depends and Uploaders field.
  * Converted changelog to UTF-8.

 -- Matthew Danish <email address hidden>  Fri, 11 Jun 2004 22:30:47 -0400
153 of 53 results