libseccomp 2.4.2-2ubuntu1 source package in Ubuntu

Changelog

libseccomp (2.4.2-2ubuntu1) focal; urgency=medium

  * Merge with Debian unstable (LP: 1849785). Remaining changes:
    * Add autopkgtests
  * Dropped changes (in upstream now):
    - db-properly-reset-attribute-state.patch
    - Updated to new upstream 2.4.1 version to fix security issue.
    - add-log-action.patch: Minimal backport to support the
      SECCOMP_RET_LOG action that was released in Linux kernel version
      4.14.
  * Dropped changes (in Debian now):
    - debian/tests/testsuite-live:
      - build utils with -pthread
      - build tools/scmp_api_level
    - debian/control: add valgrind to Build-Depends to get more unit tests.
    - debian/*.install: change python paths.
    - debian/libseccomp2.symbols: added new symbols.
    - debian/rules: add dh_auto_configure before dh_auto_install to pick up
      all the python versions.
    - debian/patches/*: removed, all included in new version.

libseccomp (2.4.2-2) unstable; urgency=medium

  [ Christian Ehrhardt ]
  * d/rules: fix potential FTFBS after full python3 switch
  * d/t/control: drop python2 test following the removal of the package

  [ Felix Geyer ]
  * Remove build-dependency on valgrind for mips64el as it's broken there.
  * Backport patch to define __SNR_ppoll again.
    - Add api_define__SNR_ppoll_again.patch
  * Replace custom patch for cython3 with the upstream fix.

libseccomp (2.4.2-1) unstable; urgency=medium

  [ Christian Ehrhardt ]
  * New upstream release 2.4.2 for compatibility with newer kernels and
    fixing FTBFS (LP: #1849785).
    - drop d/p/python_install_dir.patch (now upstream)
    - d/rules: adapt to python 3.8 lacking the m modifier on includes
      see https://wiki.debian.org/Python/Python3.8
    - d/p/tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-sysc.patch: fix
      build time test on arm64

  [ Felix Geyer ]
  * Drop Python 2 bindings. (Closes: #936917)
    - Add cython3.patch to use the Python 3 cython variant.

libseccomp (2.4.1-2) unstable; urgency=medium

  * Remove build-dependency on valgrind for mipsel and x32 as it's broken
    on those archs.
  * Set Rules-Requires-Root: no.

libseccomp (2.4.1-1) unstable; urgency=medium

  * New upstream release.
    - Addresses CVE-2019-9893 (Closes: #924646)
  * Drop all patches for parisc arch support, merged upstream.
  * Build-depend on valgrind to run more unit tests.
  * Run dh_auto_configure for every python 3 version to install the extension
    in the correct path.
  * Update the symbols file.
  * Adapt autopkgtest to new upstream version:
    - Build against pthread
    - Build scmp_api_level tool
  * Upgrade to debhelper compat level 12.
    - Add d/not-installed file
  * Fix install path of the python module.
    - Add python_install_dir.patch
  * Add autopkgtest for python packages.

 -- Christian Ehrhardt <email address hidden>  Wed, 13 Nov 2019 08:41:54 +0100

Upload details

Uploaded by:
Christian Ehrhardt  on 2019-11-19
Uploaded to:
Focal
Original maintainer:
Ubuntu Developers
Architectures:
linux-any
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Focal proposed on 2019-11-19 main libs

Downloads

File Size SHA-256 Checksum
libseccomp_2.4.2.orig.tar.gz 586.9 KiB b54f27b53884caacc932e75e6b44304ac83586e2abe7a83eca6daecc5440585b
libseccomp_2.4.2-2ubuntu1.debian.tar.xz 13.2 KiB 8b7a245da4cd67a988fa20cc3bcf151d10979766150f291092b13b6a2e947ff4
libseccomp_2.4.2-2ubuntu1.dsc 2.5 KiB f7424363ba71dda432935c36542fc2dff2842e4b8d82c7f13f0532786c6b40b9

View changes file

Binary packages built by this source

libseccomp-dev: high level interface to Linux seccomp filter (development files)

 This library provides a high level interface to constructing, analyzing
 and installing seccomp filters via a BPF passed to the Linux Kernel's
 prctl() syscall.
 .
 This package contains the development files.

libseccomp2: high level interface to Linux seccomp filter

 This library provides a high level interface to constructing, analyzing
 and installing seccomp filters via a BPF passed to the Linux Kernel's
 prctl() syscall.

libseccomp2-dbgsym: debug symbols for libseccomp2
python3-seccomp: high level interface to Linux seccomp filter (Python 3 bindings)

 This library provides a high level interface to constructing, analyzing
 and installing seccomp filters via a BPF passed to the Linux Kernel's
 prctl() syscall.

python3-seccomp-dbgsym: debug symbols for python3-seccomp
seccomp: helper tools for high level interface to Linux seccomp filter

 Provides helper tools for interacting with libseccomp. Currently, only
 a single tool exists, providing a way to easily enumerate syscalls across
 the supported architectures.

seccomp-dbgsym: debug symbols for seccomp