Change log for libsub-exporter-perl package in Ubuntu

111 of 11 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-01-01
Deleted in bionic-proposed (Reason: moved to release)
libsub-exporter-perl (0.987-1) unstable; urgency=medium

  [ gregor herrmann ]
  * New upstream release.
  * Strip trailing slash from metacpan URLs.

  [ Salvatore Bonaccorso ]
  * Update Vcs-Browser URL to cgit web frontend
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI

  [ gregor herrmann ]
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.

  [ Alex Muntada ]
  * Remove inactive pkg-perl members from Uploaders.

  [ Damyan Ivanov ]
  * bump debhelper compatibility version to 10
  * add Testsuite header
  * declare conformance with Policy 4.1.3 (no changes needed)

 -- Damyan Ivanov <email address hidden>  Mon, 01 Jan 2018 09:04:15 +0000

Available diffs

Superseded in bionic-release on 2018-01-01
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Superseded in yakkety-release on 2016-09-14
Superseded in yakkety-release on 2016-09-08
Superseded in yakkety-release on 2016-09-01
Superseded in yakkety-release on 2016-08-30
Superseded in yakkety-release on 2016-08-22
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-21
Deleted in trusty-proposed (Reason: moved to release)
libsub-exporter-perl (0.986-1) unstable; urgency=low


  [ Salvatore Bonaccorso ]
  * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * Change search.cpan.org based URIs to metacpan.org based URIs

  [ gregor herrmann ]
  * New upstream release.
  * Drop spelling.patch, merged upstream.
  * Update years of packaging copyright.
  * Declare compliance with Debian Policy 3.9.4.

 -- gregor herrmann <email address hidden>  Fri, 11 Oct 2013 22:44:12 +0200

Available diffs

Superseded in trusty-release on 2013-10-21
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libsub-exporter-perl (0.984-1) unstable; urgency=low


  [ Ansgar Burchardt ]
  * Email change: Ansgar Burchardt -> <email address hidden>
  * debian/control: Convert Vcs-* fields to Git.

  [ gregor herrmann ]
  * New upstream release.
  * debian/rules: remove override_dh_auto_test (test variable does not
    apply anymore).
  * Refresh and forward spelling patch.
  * debian/copyright: update to Copyright-Format 1.0.
  * debian/copyright: remove third-party info, update years of copyright
    and license stanzas.
  * Remove build dependencies that are not needed anymore.
  * Remove version from libdata-optlist-perl (build) dependency.
  * Bump Standards-Version to 3.9.3 (no changes).
  * Set debhelper compatibility level to 8.

 -- gregor herrmann <email address hidden>  Sat, 09 Jun 2012 00:06:10 +0200

Available diffs

Superseded in quantal-release on 2012-06-09
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Superseded in natty-release on 2010-12-06
Obsolete in maverick-release on 2013-03-05
libsub-exporter-perl (0.982-1) unstable; urgency=low

  [ gregor herrmann ]
  * debian/control: Changed: Switched Vcs-Browser field to ViewSVN
    (source stanza).

  [ Nathan Handler ]
  * debian/watch: Update to ignore development releases.

  [ gregor herrmann ]
  * Convert to source format 3.0 (quilt).
  * Minimize debian/rules.
  * Add /me to Uploaders.
  * Set Standards-Version to 3.8.4; remove version from perl build dependency.
  * debian/copyright: refresh formatting.
  * Add a patch to fix a spelling mistake.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  28 May 2010 11:23:05 +0100

Available diffs

Superseded in maverick-release on 2010-05-28
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
libsub-exporter-perl (0.981-1) unstable; urgency=low

  * New upstream release.

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
libsub-exporter-perl (0.979-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  06 May 2008 11:28:07 +0100
Superseded in intrepid-release on 2008-05-06
libsub-exporter-perl (0.978-2) unstable; urgency=low

  [ gregor herrmann ]
  * debian/rules: delete /usr/lib/perl5 only if it exists.

  [ Rene Mayorga ]
  * Prepare for Perl 5.10 update
  * debian/control:
    + Raise debhelper version to 6
    + Add libtest-perl-critic-perl to B-D-I
  * debian/compat: set level to 6
  * debian/rules
    + use $@ for touch -stamp files
    + Don't Install README
    + Add PERL_TEST_CRITIC=1 to enable more tests

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
libsub-exporter-perl (0.976-1) unstable; urgency=low

  * New upstream release
  * debian/rules
    + move test suite from install to build target
    + drop unneeded OPTIMIZE parameter to $(MAKE)
    + drop unneeded dh_strip and dh_link calls
  * Added libtest-pod(-coverage)?-perl to Build-Depends for more testing
  * Added myself to Uploaders:
  * Improved debian/copyright
    + Use generic download URL
    + Corrected years of copyright

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
libsub-exporter-perl (0.974-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 Apr 2007 00:30:48 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
libsub-exporter-perl (0.972-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  12 Dec 2006 10:58:43 +0000
Superseded in feisty-release on 2006-12-12
libsub-exporter-perl (0.97.0-1) unstable; urgency=low

  * New upstream release (closes: #370695)

111 of 11 results