Ubuntu

Change log for “libswingx-java” package in Ubuntu

18 of 8 results
Published in trusty-release on 2013-10-18
Published in saucy-release on 2013-04-25
Published in raring-release on 2012-10-18
Published in quantal-release on 2012-04-26
Published in precise-release on 2011-10-13
Published in oneiric-release on 2011-04-30
libswingx-java (1:1.6.2-1) unstable; urgency=low

  * New upstream release.
  * Switch to maven as build system:
    - d/control: drop ant, add maven-debian-helper
    - d/rules: use maven.mk
  * d/patches/pom.diff: drop, uneeded since upstream fixed its dependencies.
  * d/watch: update to use java.net directly.
  * d/rules: force debian version for JARs (Closes: #603495).
  * d/copyright: Update to lastest DEP-5 r166.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  30 Apr 2011 13:11:04 +0000

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
libswingx-java (1:1.6.1-1) unstable; urgency=low

  * New upstream release.
  * Switch to 3.0 (quilt) format.
  * Bump Standards-Version to 3.9.1: no changes needed.
  * Drop Depends on JRE: not requested anymore by new Java Policy.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 09:42:13 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
Published in lucid-release on 2010-01-18
libswingx-java (1:1.6-1) unstable; urgency=low

  * New upstream release.
    - remove debian/patches/swingworker.diff (merged upstream)
    - update debian/patches/pom.diff
  * Depends on java6-runtime-headless as we build java6 bytecode
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  18 Jan 2010 07:31:35 +0000

Available diffs

Superseded in lucid-release on 2010-01-18
libswingx-java (1:1.0-1) unstable; urgency=low

  * New upstream release.
  * New "libswingx-java-doc" package:
    - contains API javadoc documentation
  * Bump Standards-Version to 3.8.3
    - Change section to "java"
    - Rename debian/README.Debian-source to debian/README.source
    - Describe quilt patch system in debian/README.source
  * Bump debhelper version to >= 7
  * Remove unused Depends on ${shlibs:Depends}
  * Default JRE:
    - Build-Depends on default-jdk
    - Use /usr/lib/jvm/default-java as JAVA_HOME
  * Add myself to Uploaders
  * Use DEP5 format for debian/copyright
  * Maven POMs:
    - Add a Build-Depends-Indep dependency on maven-repo-helper
    - Use mh_installpoms and mh_installjar to install the POM and the jar to the
      Maven repository
    - Remove unneeded dependencies in pom.diff patch
  * Maven ant helper (build system):
    - Add a Build-Depends dependency on maven-ant-helper
    - Update debian/build.xml to use /usr/share/maven-ant-helper/maven-build.xml
    - Build classpath is now defined in debian/build.properties
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  30 Nov 2009 23:45:53 +0000

Available diffs

Superseded in lucid-release on 2009-12-01
Obsolete in karmic-release on 2013-03-04
Superseded in karmic-release on 2009-06-30
libswingx-java (1:0.9.5-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in karmic-release on 2009-05-11
Obsolete in jaunty-release on 2013-02-28
libswingx-java (1:0.9.3-2ubuntu1) jaunty; urgency=low

  * Copy some packaging changes from Debian.
  * Build with source=target=1.5 and change Depends accordingly.

 -- Onkar Shinde <email address hidden>   Sun, 05 Apr 2009 20:25:29 +0530

Available diffs

Superseded in jaunty-release on 2009-04-05
libswingx-java (1:0.9.3-2) unstable; urgency=low

  * Switch to OpenJDK for building the package.

Available diffs

Superseded in jaunty-release on 2008-11-10
Obsolete in intrepid-release on 2013-02-20
libswingx-java (1:0.9.2-1) unstable; urgency=low

  * new upstream release

18 of 8 results