libupnp4 1.8.0~svn20100507-1.1ubuntu0.12.04.1 source package in Ubuntu

Changelog

libupnp4 (1.8.0~svn20100507-1.1ubuntu0.12.04.1) precise-security; urgency=low

  * SECURITY UPDATE: patch from Debian
    - debian/patches/0001-Security-fix-for-CERT-issue-VU-922681: fix various
      stack-based buffer overflows in service_unique_name() function
    - CVE-2012-5958
    - CVE-2012-5959
    - CVE-2012-5960
    - CVE-2012-5961
    - CVE-2012-5962
    - CVE-2012-5963
    - CVE-2012-5964
    - CVE-2012-5965
 -- Jamie Strandboge <email address hidden>   Wed, 13 Feb 2013 14:37:12 -0600

Upload details

Uploaded by:
Jamie Strandboge on 2013-02-13
Uploaded to:
Precise
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
net
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Precise updates on 2013-02-14 universe net
Precise security on 2013-02-14 universe net

Downloads

File Size SHA-256 Checksum
libupnp4_1.8.0~svn20100507.orig.tar.gz 1.3 MiB 02a27bb68c5e6b30fec9a0eb69d73b3c667637c7156f7aa641cdbc244ed156ab
libupnp4_1.8.0~svn20100507-1.1ubuntu0.12.04.1.diff.gz 27.3 KiB 0baf6ea77e2bfadd3b42e5d05abf4ffecef5771ee79c4b52906e7c0169a0974e
libupnp4_1.8.0~svn20100507-1.1ubuntu0.12.04.1.dsc 2.1 KiB b4d09755d7e3dae36c0c0faf486f870b3a06e0a2aca47dd54b9d0d9dcdecbce4

View changes file

Binary packages built by this source

libupnp4: Portable SDK for UPnP Devices, version 1.8 (shared libraries)

 The Portable SDK for UPnP Devices (libupnp) provides developers with an
 API and open source code for building control points, devices, and
 bridges that are compliant with Version 1.0 of the Universal Plug and
 Play Device Architecture Specification - see http://www.upnp.org/ for
 specifications.
 .
 The libupnp4 package contains the runtime libraries for libupnp
 version 1.8.

libupnp4-dbg: debugging symbols for libupnp4

 The Portable SDK for UPnP Devices (libupnp) provides developers with an
 API and open source code for building control points, devices, and
 bridges that are compliant with Version 1.0 of the Universal Plug and
 Play Device Architecture Specification - see http://www.upnp.org/ for
 specifications.
 .
 This package contains the debugging symbols associated with libupnp4.
 They will automatically be used by gdb for debugging libupnp-related
 issues.
 .
 Most people will not need this package.

libupnp4-dev: Portable SDK for UPnP Devices, version 1.8 (development files)

 The Portable SDK for UPnP Devices (libupnp) provides developers with an
 API and open source code for building control points, devices, and
 bridges that are compliant with Version 1.0 of the Universal Plug and
 Play Device Architecture Specification - see http://www.upnp.org/ for
 specifications.
 .
 The libupnp4-dev package contains the header files, documentation and
 debug versions of libraries needed for development of programs using
 libupnp version 1.8.

libupnp4-doc: Documentation for the Portable SDK for UPnP Devices, version 1.8

 The Portable SDK for UPnP Devices (libupnp) provides developers with an
 API and open source code for building control points, devices, and
 bridges that are compliant with Version 1.0 of the Universal Plug and
 Play Device Architecture Specification - see http://www.upnp.org/ for
 specifications.
 .
 This package contains the HTML documentation for the libupnp4 library
 in /usr/share/doc/libupnp4-doc/