Change log for libwx-perl package in Ubuntu

146 of 46 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-11-08
Deleted in disco-proposed (Reason: moved to release)
libwx-perl (1:0.9932-5build1) disco; urgency=medium

  * No-change rebuild for the perl 5.28 transition.

 -- Adam Conrad <email address hidden>  Fri, 02 Nov 2018 19:47:43 -0600
Superseded in disco-release on 2018-11-08
Published in cosmic-release on 2018-07-06
Deleted in cosmic-proposed (Reason: moved to release)
libwx-perl (1:0.9932-5) unstable; urgency=medium

  * Replace reproducible_output.patch with 5 patches from openSUSE.
    Thanks to Stefan BrĂ¼ns for the bug report with the pointer.
    (Closes: #901544)
  * Declare compliance with Debian Policy 4.1.4.
  * Bump debhelper compatibility level to 10.
  * Remove '--parallel' from default target in debian/rules as it's the
    default now for debhelper.
  * Fix typo in description in fix-fake-pod.patch.

 -- gregor herrmann <email address hidden>  Wed, 27 Jun 2018 20:51:40 +0200

Available diffs

Superseded in cosmic-release on 2018-07-06
Published in bionic-release on 2018-04-14
Deleted in bionic-proposed (Reason: moved to release)
libwx-perl (1:0.9932-4) unstable; urgency=medium

  * Team upload.
  * Fix autopkgtest failures with xvfb configuration (Closes: #895189)
  * Break older (GTK2) versions of libwx-scintilla-perl and
    libwx-glcanvas-perl. (Closes: #895134)

 -- Niko Tyni <email address hidden>  Fri, 13 Apr 2018 19:46:18 +0300

Available diffs

Superseded in bionic-proposed on 2018-04-04
libwx-perl (1:0.9932-2build2) bionic; urgency=medium

  * No-change rebuild against wxperl-gtk-3-0-4-uni-gcc-3-4

 -- Steve Langasek <email address hidden>  Wed, 04 Apr 2018 19:03:13 +0000
Superseded in bionic-release on 2018-04-14
Deleted in bionic-proposed on 2018-04-15 (Reason: moved to release)
libwx-perl (1:0.9932-3) unstable; urgency=medium

  [ Alex Muntada ]
  * Remove inactive pkg-perl members from Uploaders.

  [ Damyan Ivanov ]
  * declare conformance with Policy 4.1.3 (no changes needed)

  [ Salvatore Bonaccorso ]
  * Update Vcs-* headers for switch to salsa.debian.org

  [ Olly Betts ]
  * Update version on libalien-wxwidgets-perl dependency and build-dependency
    to ensure GTK3 flavour of wxWidgets is used in both cases.
  * Tell xvfb to use a 16-bit colour display for running tests - the default
    8-bit colour causes some tests to fail.

 -- Olly Betts <email address hidden>  Wed, 04 Apr 2018 10:41:11 +1200
Superseded in bionic-release on 2018-04-05
Deleted in bionic-proposed on 2018-04-06 (Reason: moved to release)
libwx-perl (1:0.9932-2build1) bionic; urgency=medium

  * No-change rebuild against latest wxwidgets3.0 (Closes: #893923)

 -- Jeremy Bicha <email address hidden>  Sun, 25 Mar 2018 17:53:17 -0400
Superseded in bionic-release on 2018-03-26
Published in artful-release on 2017-08-10
Deleted in artful-proposed (Reason: moved to release)
libwx-perl (1:0.9932-2) unstable; urgency=medium

  * Team upload.
  * Try harder to make the package build reproducibly, by sorting EXPORT_OK
    in Wx_Exp.pm.

 -- intrigeri <email address hidden>  Sun, 06 Aug 2017 22:15:25 +0000
Superseded in artful-proposed on 2017-08-07
libwx-perl (1:0.9932-1build2) artful; urgency=medium

  * No-change rebuild for perl 5.26.0.

 -- Matthias Klose <email address hidden>  Wed, 26 Jul 2017 20:28:59 +0000
Superseded in artful-release on 2017-08-10
Deleted in artful-proposed on 2017-08-11 (Reason: moved to release)
libwx-perl (1:0.9932-1build1) artful; urgency=medium

  * Rebuild against new wxwidgets3.0 3.0.3.1+dfsg-1.

 -- Gianfranco Costamagna <email address hidden>  Wed, 26 Jul 2017 12:01:48 +0200
Superseded in artful-release on 2017-07-26
Deleted in artful-proposed on 2017-07-27 (Reason: moved to release)
libwx-perl (1:0.9932-1) unstable; urgency=medium

  * New upstream version 0.9932.
  * Refresh reproducible_output.patch (offset).
  * Drop encoding-pragma.patch, unescaped_left_brace.patch.
    Both fixed upstream.
  * Drop unneeded version constraint from build dependency.
  * Use HTTPS for some URLs in debian/{copyright,upstream/metadata}.
    Thanks to duck.
  * Add more fixes to spelling.patch.
  * Set bindnow linker flag in debian/rules.
  * Declare compliance with Debian Policy 4.0.0.

 -- gregor herrmann <email address hidden>  Fri, 23 Jun 2017 21:13:00 +0200

Available diffs

Superseded in artful-release on 2017-06-26
Deleted in artful-proposed on 2017-06-28 (Reason: moved to release)
libwx-perl (1:0.9928-3) unstable; urgency=medium

  * Add patch encoding-pragma.patch to disable "use encoding" which is a
    fatal error since Perl 5.25.x. (Closes: #826452)

 -- gregor herrmann <email address hidden>  Sat, 20 May 2017 13:47:09 +0200
Superseded in artful-release on 2017-05-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
libwx-perl (1:0.9928-1build1) zesty; urgency=medium

  * No-change rebuild for perl 5.24 transition

 -- Iain Lane <email address hidden>  Mon, 24 Oct 2016 17:10:19 +0100
Superseded in zesty-release on 2016-11-01
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
libwx-perl (1:0.9928-1) unstable; urgency=medium

  * Team upload.

  [ Reiner Herrmann ]
  * Add patch to produce sorted output to get reproducible results.
    (Closes: #787265)

  [ Axel Beckert ]
  * Add ext/webview/Makefile to debian/clean.
  * Add debian/upstream/metadata
  * Import upstream version 0.9927
  * Add lintian overrides for the two pkg-perl specific lintian warnings
    library-package-name-for-application + application-in-library-section.

  [ gregor herrmann ]
  * debian/copyright: fix a path to (a) file(s).
  * Rename autopkgtest configuration file(s) as per new pkg-perl-
    autopkgtest schema.
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
  * debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.

  [ Salvatore Bonaccorso ]
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI

  [ intrigeri ]
  * Declare compliance with Standards-Version 3.9.8.
  * Imported upstream version 0.9928.

 -- intrigeri <email address hidden>  Mon, 27 Jun 2016 15:11:25 +0000
Superseded in yakkety-release on 2016-06-28
Published in xenial-release on 2016-01-06
Deleted in xenial-proposed (Reason: moved to release)
libwx-perl (1:0.9923-4build3) xenial; urgency=medium

  * Rebuild for Perl 5.22.1.

 -- Colin Watson <email address hidden>  Fri, 18 Dec 2015 18:05:14 +0000
Superseded in xenial-release on 2016-01-06
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
libwx-perl (1:0.9923-4build2) wily; urgency=medium

  * No-change rebuild against libwx*-0v5

 -- Martin Pitt <email address hidden>  Mon, 10 Aug 2015 12:05:08 +0200
Superseded in wily-release on 2015-08-16
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
libwx-perl (1:0.9923-4build1) vivid; urgency=medium

  * Rebuild for new libalien-wxwidgets-perl Provides (ignore the version bump,
    it's just to depwait)
 -- Iain Lane <email address hidden>   Mon, 03 Nov 2014 10:18:04 +0000
Superseded in vivid-proposed on 2014-11-03
libwx-perl (1:0.9923-4) unstable; urgency=medium


  * Team upload.
  * Remove arm* workarounds now that the gcc-4.9 issues are fixed.
    (Closes: #758497)
  * Make the package autopkgtestable.
  * Upgrade to Standards-Version 3.9.6 (no changes).

 -- Niko Tyni <email address hidden>  Fri, 10 Oct 2014 22:40:41 +0300
Superseded in vivid-release on 2014-11-03
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
libwx-perl (1:0.9923-3) unstable; urgency=high


  [ gregor herrmann ]
  * Add patches from Niko Tyni to handle missing wxwidgets3.0 symbol on
    arm{el,hf}:
    - Wx.xs: return 0 if wxPluginManager::LoadLibrary fails
    - t/01_load.t: skip failing tests
    - ext/propgrid/Makefile.PL: skip tests
    Closes: #758127
    High urgency to help the perl 5.20 transition

  [ Salvatore Bonaccorso ]
  * Update Vcs-Browser URL to cgit web frontend

  [ Damyan Ivanov ]
  * adapt lintian overrides with new vendorarch (m-a aware and
    version-dependent)

 -- Damyan Ivanov <email address hidden>  Sun, 17 Aug 2014 19:46:33 +0000

Available diffs

Superseded in utopic-release on 2014-08-27
Deleted in utopic-proposed on 2014-08-28 (Reason: moved to release)
libwx-perl (1:0.9923-1) unstable; urgency=medium


  * Strip trailing slash from metacpan URLs.

  * New upstream release.
  * (Build-) depend on newer libalien-wxwidgets-perl to get dependency on
    wxwidgets3.0. (Closes: #743280)
  * Add a lintian override for a spelling mistake in a variable name.
  * debian/copyright: fix URL of original wxWindows Library Licence.
  * Declare compliance with Debian Policy 3.9.5.

 -- gregor herrmann <email address hidden>  Tue, 01 Apr 2014 19:36:23 +0200

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2013-10-24
Deleted in trusty-proposed (Reason: moved to release)
libwx-perl (1:0.9922-2) unstable; urgency=low


  * Make (build) dependency on libalien-wxwidgets-perl versioned.
    (Closes: #719380)
  * Update and forward fix-man-spelling patch.

 -- gregor herrmann <email address hidden>  Mon, 19 Aug 2013 14:20:49 +0200

Available diffs

Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libwx-perl (1:0.9922-1) unstable; urgency=low


  [ Salvatore Bonaccorso ]
  * Change Vcs-Git to canonical URI (git://anonscm.debian.org)
  * Change search.cpan.org based URIs to metacpan.org based URIs

  [ Dominique Dumont ]
  * Imported Upstream version 0.9922
  * added patch to fix Wx man page spelling errors
  * copyright: updated year
  * control:
    * refreshed with cme
    * cleaned up versioned dependencies
    * bumped Standards-Version: 3.9.4
    + added /me in uploader
    - removed ryan

 -- Dominique Dumont <email address hidden>  Thu, 02 May 2013 20:43:23 +0200

Available diffs

Superseded in saucy-release on 2013-05-03
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
libwx-perl (1:0.9911-1) unstable; urgency=low


  * New upstream release

 -- Alessandro Ghedini <email address hidden>  Sun, 02 Sep 2012 17:06:37 +0200

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
libwx-perl (1:0.9909-1) unstable; urgency=low


  * New upstream release

 -- Alessandro Ghedini <email address hidden>  Thu, 31 May 2012 21:48:06 +0200

Available diffs

Superseded in quantal-release on 2012-06-01
libwx-perl (1:0.9908-1) unstable; urgency=low


  * New upstream release

 -- Alessandro Ghedini <email address hidden>  Sun, 27 May 2012 15:05:58 +0200

Available diffs

Superseded in quantal-release on 2012-05-28
libwx-perl (1:0.9906-1) unstable; urgency=low


  * New upstream release
  * Email change: Alessandro Ghedini -> <email address hidden>
  * Update copyright file with new files

 -- Alessandro Ghedini <email address hidden>  Tue, 08 May 2012 13:05:34 +0200

Available diffs

Superseded in quantal-release on 2012-05-19
libwx-perl (1:0.9905-1) unstable; urgency=low


  * New upstream release
  * Update debhelper versioned build depend to get more hardening flags
  * Update upstream copyright years
  * Add interface/wx/treelist.h to copyright

 -- Alessandro Ghedini <email address hidden>  Mon, 19 Mar 2012 15:40:27 +0100

Available diffs

Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-11-18
libwx-perl (1:0.9903-1) unstable; urgency=low


  [ Alessandro Ghedini ]
  * New upstream release

  [ Dominic Hargreaves ]
  * Swap libextutils-parsexs-perl/perl alternate build-dependency around
    following migration of perl 5.14 to unstable so that it can be
    autobuilt

 -- Dominic Hargreaves <email address hidden>  Thu, 17 Nov 2011 21:25:07 +0000
Superseded in precise-release on 2011-11-18
libwx-perl (1:0.9902-1build1) precise; urgency=low

  * Rebuild for Perl 5.14.
 -- Colin Watson <email address hidden>   Tue, 15 Nov 2011 20:22:02 +0000

Available diffs

Superseded in precise-release on 2011-11-15
libwx-perl (1:0.9902-1) unstable; urgency=low

  * Team upload
  * New upstream release
  * Refresh patches
  * Update debian/copyright
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  26 Oct 2011 07:46:32 +0000

Available diffs

Superseded in precise-release on 2011-10-26
libwx-perl (1:0.9901-3) unstable; urgency=low

  * point to GPL-1 for "version 1 or later". Thanks to Salvatore.

Available diffs

Obsolete in natty-updates on 2013-06-04
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
libwx-perl (1:0.98-1build0.1) natty-proposed; urgency=low

  *  No change rebuild to pick up newer wx lib symbols (LP: #754513)
 -- SevenMachines <email address hidden>   Fri, 03 Jun 2011 09:19:12 -0700

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
libwx-perl (1:0.98-1build1) oneiric; urgency=low

  * Rebuild for Perl 5.12.
 -- Colin Watson <email address hidden>   Sun, 08 May 2011 13:37:44 +0100

Available diffs

Superseded in oneiric-release on 2011-05-08
Obsolete in natty-release on 2013-06-04
libwx-perl (1:0.98-1) unstable; urgency=low

  * New upstream release
    - add epoch, to compensate for upstream going from 0.9702 -> 0.98
  * Standards-Version: 3.9.1 (no changes required)
 -- Bhavani Shankar <email address hidden>   Tue, 18 Jan 2011 17:17:01 -0500

Available diffs

Obsolete in maverick-updates on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
libwx-perl (0.9702-1build0.1) maverick-proposed; urgency=medium

  * No-change rebuild for unexpected ABI breakage (LP: #680140)
 -- <email address hidden> (Malte S. Stretz)   Sat, 11 Dec 2010 10:30:30 +0200

Available diffs

Superseded in natty-release on 2011-01-25
libwx-perl (0.9702-1build1) natty; urgency=medium

  * No-change rebuild for unexpected ABI breakage (LP: #680140)
 -- <email address hidden> (Malte S. Stretz)   Sat, 11 Dec 2010 10:33:43 +0200

Available diffs

Superseded in natty-release on 2010-12-11
Obsolete in maverick-release on 2013-03-05
libwx-perl (0.9702-1) unstable; urgency=low

  * New upstream release
    - now requires at least ExtUtils::ParseXS version 2.2202 and
      ExtUtils:XSpp 0.11

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
libwx-perl (0.96-1build1) lucid; urgency=low

  * Rebuld to pick the right Wx symbols. (LP: #495012)
 -- Damyan Ivanov <email address hidden>   Sun, 18 Apr 2010 21:02:33 +0300

Available diffs

Superseded in lucid-release on 2010-04-18
libwx-perl (0.96-1) unstable; urgency=low

  * require alien-wxwidgets version 0.48
  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  08 Feb 2010 11:03:31 +0000

Available diffs

Superseded in lucid-release on 2010-02-08
libwx-perl (0.94-1) unstable; urgency=low

  [ Roberto C. Sanchez ]
  * New upstream release

  [ Ryan Niebur ]
  * remove wrap_get_raw_keycode.patch, applied upstream
  * skip the failing tests (Closes: #499740)

Available diffs

Superseded in lucid-release on 2010-01-05
Obsolete in karmic-release on 2013-03-04
libwx-perl (0.91-1) unstable; urgency=low

  [ Jonathan Yu ]
  * New upstream release

  [ Damyan Ivanov ]
  * convert to debhelper7 and clean-up
    + bump debhelper and quilt build-dependencies due to usage of overrides
      and "--with quilt"
    + move removal of build cruft to debian/clean
    + install examples using debian/examples
    + install README.txt using debian/docs
    + drop dropping of build:: from the beginning of some manual pages (there
      are no more man pages starting with build::
    + make chown of module files in /usr/lib/perl5 verbose. ditto for
      Wx::build::MakeMaker::Win32_MSVC.3pm removal
    + mode of examples/README.txt fixed with an override
  * describe hashbang.patch
  * drop kill_bogus_test.patch, it is skipped anyway
  * add a sentence to long description
  * Standards-Version: 3.8.1 (no changes)
  * bump years in debian/copyright and add two additional upstream copyright
    holders

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  01 Jun 2009 10:44:08 +0100

Available diffs

Superseded in karmic-release on 2009-06-01
Obsolete in jaunty-release on 2013-02-28
libwx-perl (0.89-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  15 Dec 2008 10:20:42 +0000

Available diffs

Superseded in jaunty-release on 2008-12-15
libwx-perl (0.88-1) unstable; urgency=low

  [ Roberto C. Sanchez]
  * New upstream release (Closes: #499740)

  [ gregor herrmann]
  * debian/control: Changed: Switched Vcs-Browser field to ViewSVN
    (source stanza).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  22 Nov 2008 23:54:31 +0000

Available diffs

Superseded in jaunty-release on 2008-11-23
libwx-perl (0.86-2) unstable; urgency=medium

  * debian/rules: run tests with -j1; this disables parallel make during tests
    even if the build target was invoked with -jN (N>1).
    Closes: #499740 -- FTBFS: Failed 2/4 test scripts. 6/9 subtests failed.

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
libwx-perl (0.84-1) unstable; urgency=low

  * New upstream release
  * Update to Standards-Version 3.8.0 (no changes)
  * Change from Build-Depends on the obsolete xbase-clients to x11-xkb-utils

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  02 Jul 2008 12:19:26 +0100

Available diffs

Superseded in intrepid-release on 2008-07-02
libwx-perl (0.83-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  22 May 2008 08:19:51 +0100
Superseded in intrepid-release on 2008-05-22
libwx-perl (0.82-2) unstable; urgency=low

  * Build-Depend and Depend on libalien-wxwidgets-perl (>= 0.33-3), which can
    properly recognize g++ >= 4.3.

146 of 46 results