Change log for libxalan2-java package in Ubuntu

127 of 27 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-12
Deleted in cosmic-proposed (Reason: moved to release)
libxalan2-java (2.7.2-2) unstable; urgency=medium

  * Team upload.
  * Switch to compat level 11.
  * Declare compliance with Debian Policy 4.1.4.
  * Use source/target 1.7.
  * Add java10.patch and fix FTBFS with Java 9 and Java 10. The bootclasspath
    option was removed upstream. (Closes: #893295)

 -- Markus Koschany <email address hidden>  Fri, 11 May 2018 18:28:08 +0200

Available diffs

Superseded in cosmic-release on 2018-05-12
Published in bionic-release on 2017-11-18
Deleted in bionic-proposed (Reason: moved to release)
libxalan2-java (2.7.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Removed CVE-2014-0107.patch (fixed upstream)
    - Refreshed the Maven poms
  * Simplified debian/patches/build.patch
  * Build with the DH sequencer instead of CDBS
  * Added the missing --has-package-version flag
  * Moved the package to Git
  * Use XZ compression for the upstream tarball
  * Updated debian/watch
  * Use secure Vcs-* URLs
  * Switch to debhelper level 10
  * Standards-Version updated to 4.1.1
  * Converted debian/copyright to the Copyright Format 1.0

 -- Emmanuel Bourg <email address hidden>  Fri, 13 Oct 2017 17:17:35 +0200

Available diffs

Published in precise-updates on 2014-05-21
Published in precise-security on 2014-05-21
libxalan2-java (2.7.1-7ubuntu0.1) precise-security; urgency=medium

  * SECURITY UPDATE: information disclosure or arbitrary code execution via
    crafted XSLT programs
    - debian/patches/CVE-2014-0107.patch: disable external general
      entities, foreign attributes and access to the system properties in
      src/org/apache/xalan/transformer/TransformerImpl.java,
      src/org/apache/xalan/processor/XSLTElementProcessor.java,
      src/org/apache/xalan/processor/TransformerFactoryImpl.java,
      src/org/apache/xpath/functions/FuncSystemProperty.java.
    - CVE-2014-0107
 -- Marc Deslauriers <email address hidden>   Mon, 31 Mar 2014 13:19:53 -0400
Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
libxalan2-java (2.7.1-5ubuntu1.1) lucid-security; urgency=medium

  * SECURITY UPDATE: information disclosure or arbitrary code execution via
    crafted XSLT programs
    - debian/patches/CVE-2014-0107.patch: disable external general
      entities, foreign attributes and access to the system properties in
      src/org/apache/xalan/transformer/TransformerImpl.java,
      src/org/apache/xalan/processor/XSLTElementProcessor.java,
      src/org/apache/xalan/processor/TransformerFactoryImpl.java,
      src/org/apache/xpath/functions/FuncSystemProperty.java.
    - CVE-2014-0107
 -- Marc Deslauriers <email address hidden>   Mon, 31 Mar 2014 13:20:32 -0400
Obsolete in saucy-updates on 2015-04-24
Obsolete in saucy-security on 2015-04-24
libxalan2-java (2.7.1-8ubuntu0.1) saucy-security; urgency=medium

  * SECURITY UPDATE: information disclosure or arbitrary code execution via
    crafted XSLT programs
    - debian/patches/CVE-2014-0107.patch: disable external general
      entities, foreign attributes and access to the system properties in
      src/org/apache/xalan/transformer/TransformerImpl.java,
      src/org/apache/xalan/processor/XSLTElementProcessor.java,
      src/org/apache/xalan/processor/TransformerFactoryImpl.java,
      src/org/apache/xpath/functions/FuncSystemProperty.java.
    - CVE-2014-0107
 -- Marc Deslauriers <email address hidden>   Mon, 31 Mar 2014 13:12:34 -0400
Superseded in bionic-release on 2017-11-18
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Superseded in yakkety-release on 2016-10-06
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-03-31
Deleted in trusty-proposed (Reason: moved to release)
libxalan2-java (2.7.1-9) unstable; urgency=high


  * Team upload.
  * Fix CVE-2014-0107: Strengthen the secure processing mode by disabling
    external general entities, foreign attributes and access to the system
    properties. This could be exploited to execute arbitrary code remotely.
    (Closes: #742577)
  * debian/control:
    - Standards-Version updated to 3.9.5 (no changes)
    - Use canonical URLs for the Vcs-* fields
    - Updated the Homepage field
    - Removed the duplicate Section fields
  * Switch to debhelper level 9
  * debian/rules: Improved the clean target

 -- Emmanuel Bourg <email address hidden>  Tue, 25 Mar 2014 15:22:35 +0100

Available diffs

Superseded in trusty-release on 2014-03-31
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libxalan2-java (2.7.1-8) unstable; urgency=low


  [ Miguel Landaeta ]
  * Team upload.
  * Remove Michael Koch from Uploaders list.
    Thanks for the work on this package. (Closes: #654100).
  * Ensure backwards compatible bytecode is build (LP: #1049794):
    - d/ant.properties: Specify source/target = 1.5 when compiling
      Java source code. Thanks to James Page for the patch. (Closes: #688208).

  [ tony mancill ]
  * Bump Standards-Version to 3.9.4. No changes were required.

 -- tony mancill <email address hidden>  Wed, 29 May 2013 20:57:50 -0700
Superseded in saucy-release on 2013-06-03
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libxalan2-java (2.7.1-7ubuntu1) quantal; urgency=low

  * Ensure backwards compatible bytecode is build (LP: #1049794):
    - d/ant.properties: Specify source/target = 1.5 when compiling
      Java source code.
 -- James Page <email address hidden>   Thu, 20 Sep 2012 10:58:42 +0100

Available diffs

Superseded in quantal-release on 2012-09-20
libxalan2-java (2.7.1-7build1) quantal; urgency=low

  * No-change rebuild with openjdk-7 as default-jdk.
 -- James Page <email address hidden>   Fri, 18 May 2012 11:44:58 +0100
Superseded in quantal-release on 2012-05-18
Published in precise-release on 2011-12-07
libxalan2-java (2.7.1-7) unstable; urgency=low


  [Jakub Adam]
  * Add OSGi metadata to jar manifest
  * Add javahelper to Build-Depends
  * Add Jakub Adam to Uploaders.
  * Require libstylebook-java (>> 1.0~b3~svn20061109-4) in Build-Depends
    because of FTBFS with this version.

  [tony mancill]
  * Drop recommends on -gcj packages.  (Closes: #651047)
    - Thanks to Martin Pitt.
  * Update Vcs-Svn URL.
  * Bump standards version to 3.9.2 (no changes).

 -- Jakub Adam <email address hidden>  Sat, 26 Nov 2011 21:10:08 +0100
Superseded in precise-release on 2011-12-07
libxalan2-java (2.7.1-6ubuntu1) precise; urgency=low

  * Synchronize with Debian unstable. Remaining Ubuntu changes:
    - debian/control: Drop leftover Recommends: to the dropped -gcj packages.
      (Debian #651047)

Available diffs

Superseded in precise-release on 2011-12-05
libxalan2-java (2.7.1-5ubuntu2) precise; urgency=low

  * No-change rebuild to drop spurious libsfgcc1 dependency on armhf.
 -- Adam Conrad <email address hidden>   Fri, 02 Dec 2011 17:39:52 -0700

Available diffs

Superseded in precise-release on 2011-12-03
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
libxalan2-java (2.7.1-5ubuntu1) karmic; urgency=low

  * Merge with Debian; remaining changes:
    - debian/control: Only suggest libxalan2-java-gcj on selected architectures,
      and libxalan2-java architecture "any" to have it work (LP: #386307).

Available diffs

Superseded in karmic-release on 2009-10-19
libxalan2-java (2.7.1-2ubuntu1) karmic; urgency=low

  * debian/control: Only suggest libxalan2-java-gcj on selected architectures,
    and libxalan2-java architecture "any" to have it work (LP: #386307)

 -- Thierry Carrez <email address hidden>   Fri, 14 Aug 2009 13:48:55 +0200

Available diffs

Superseded in karmic-release on 2009-08-14
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
libxalan2-java (2.7.1-2) unstable; urgency=low

  * Build-Depends on default-jdk-builddep. Closes: #477893
  * Clarified debian/copyright.
  * Don't use '-1' in Build-Depends.
  * Updated watch file to match upstream correctly.

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
libxalan2-java (2.7.0-5) unstable; urgency=low

  * debian/control: removed Stefan Gybas, Wolfgang Baer and Jeroen van
    Wolffelaar from uploaders.
  * generate the doc with stylebook (closes: #402556).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 17:31:08 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
libxalan2-java (2.7.0-4) unstable; urgency=medium

  * libxalan2-java-gcj: Depend on libjaxp1.3-java. Closes: #408729.

Superseded in gutsy-release on 2007-05-23
Obsolete in feisty-release on 2009-08-20
libxalan2-java (2.7.0-1ubuntu3) feisty; urgency=low

  * libxalan2-java-gcj: Fix typo in dependencies.

 -- Matthias Klose <email address hidden>   Tue,  6 Feb 2007 11:04:52 +0100
Superseded in feisty-release on 2007-02-06
libxalan2-java (2.7.0-1ubuntu2) feisty; urgency=low

  * Move build-indep dependencies to build dependencies.

 -- Matthias Klose <email address hidden>   Wed,  3 Jan 2007 11:00:44 +0000
Superseded in feisty-release on 2007-01-03
libxalan2-java (2.7.0-1ubuntu1) feisty; urgency=low

  * Merge with Debian unstable; remaining changes:
    - build -gcj packages.

Superseded in feisty-release on 2006-12-06
Obsolete in edgy-release on 2008-06-19
libxalan2-java (2.6.0-6ubuntu4) edgy; urgency=low

  * Change Build-Depend-Indep to Build-Depends.

 -- Matthias Klose <email address hidden>   Tue,  3 Oct 2006 11:49:20 +0000
Superseded in edgy-release on 2006-10-03
libxalan2-java (2.6.0-6ubuntu3) edgy; urgency=low

  * Fix binary-arch only build.

 -- Matthias Klose <email address hidden>   Sun,  1 Oct 2006 16:48:28 +0000
Superseded in edgy-release on 2006-10-01
libxalan2-java (2.6.0-6ubuntu1) edgy; urgency=low

  * Merge from debian unstable.

Superseded in edgy-release on 2006-07-07
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
libxalan2-java (2.6.0-5ubuntu2) dapper; urgency=low


  * Fix docs install missing folder failure
    - remove debian/libxalan2-java-docs.docs (debian rules does this) 

 -- Charles Majola <email address hidden>  Wed,  7 Dec 2005 18:39:47 +0000
Obsolete in breezy-release on 2008-03-25
libxalan2-java (2.6.0-3ubuntu1) breezy; urgency=low


  * Synchronize with unstable.
  * Fix FTBFS, build-depend on java-gcj-compat-dev.

 -- Matthias Klose <email address hidden>  Fri, 12 Aug 2005 00:40:04 +0200
Obsolete in hoary-release on 2008-03-19
libxalan2-java (2.6.0-1ubuntu1) hoary; urgency=low


  * Building with java-gcj-compat.
  * Disabled dependency on bsf for initial bootstrap.
  * Patched build file to avoid copying .class files from dependent Jars.

 -- Jerry Haltom <email address hidden>  Mon, 21 Mar 2005 20:33:39 -0600
Obsolete in warty-release on 2008-01-09
libxalan2-java (2.6.0-1) unstable; urgency=low


  * New upstream release
  * Don't ship xml-apis.jar any longer since its contents are equal to
    xmlParserAPIs.jar from libxerces2-java
  * Use Xerces 2.0 Ant 1.6 during build
  * Don't install versioned JARs in /usr/share/java since this package has
    no API itself

 -- Stefan Gybas <email address hidden>  Sun, 14 Mar 2004 18:35:28 +0100
127 of 27 results