Change log for libxml-security-java package in Ubuntu

117 of 17 results
Published in bionic-updates on 2019-04-16
Published in bionic-security on 2019-04-16
Deleted in bionic-proposed (Reason: moved to -updates)
libxml-security-java (2.0.10-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1814133.

Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-10-10
Deleted in cosmic-proposed (Reason: moved to release)
libxml-security-java (2.0.10-2) unstable; urgency=medium

  * Team upload.

  [ Jochen Sprickerhof ]
  * Add patch for old API used by libitext5-java (Closes: #906375)

  [ Emmanuel Bourg ]
  * Standards-Version updated to 4.2.1

 -- Emmanuel Bourg <email address hidden>  Mon, 24 Sep 2018 12:06:50 +0200

Available diffs

Superseded in cosmic-release on 2018-10-10
Deleted in cosmic-proposed on 2018-10-11 (Reason: moved to release)
libxml-security-java (2.0.10-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - New build dependency on libmaven-jaxb2-plugin-java
    - New dependency on libwoodstox-java
  * Build with Java 8 compatibility
  * Standards-Version updated to 4.1.5
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs
  * Use a secure URL in debian/watch and debian/orig-tar.sh

 -- Emmanuel Bourg <email address hidden>  Wed, 25 Jul 2018 10:46:30 +0200

Available diffs

Superseded in cosmic-release on 2018-07-28
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
libxml-security-java (1.5.8-2) unstable; urgency=medium

  * Team upload.
  * maven.properties: Skip the tests to prevent build failure on amd64.
    (Closes: #852930)
  * libxml-security-java: Improve the short description. (Closes: #756642)

 -- Markus Koschany <email address hidden>  Mon, 06 Feb 2017 12:47:14 +0100

Available diffs

Superseded in zesty-release on 2017-02-06
Deleted in zesty-proposed on 2017-02-08 (Reason: moved to release)
libxml-security-java (1.5.8-1) unstable; urgency=medium

  * New upstream release
  * Build with the DH sequencer instead of CDBS
  * Enabled the OSGi metadata
  * Moved the package to Git
  * Removed Niels Thykier from the uploaders (Closes: #770585)
  * Updated debian/watch to track the latest releases
  * Removed the non-free RFC3161 from the upstream tarball
  * Use XZ compression for the upstream tarball
  * Standards-Version updated to 3.9.8 (no changes)
  * Switch to debhelper level 10

 -- Emmanuel Bourg <email address hidden>  Wed, 16 Nov 2016 16:39:56 +0100

Available diffs

Published in precise-updates on 2015-05-15
Published in precise-security on 2015-05-15
libxml-security-java (1.4.5-1+deb7u1build0.12.04.1) precise-security; urgency=medium

  * fake sync from Debian

Superseded in zesty-release on 2016-11-17
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-02-02
Deleted in trusty-proposed (Reason: moved to release)
libxml-security-java (1.5.6-1) unstable; urgency=medium


  * Team upload.
  * New upstream release.
    - Addresses CVE-2013-4517 (Closes: #733938)
  * Freshen pom.xml patch for new version.

 -- tony mancill <email address hidden>  Sun, 02 Feb 2014 10:14:47 -0800

Available diffs

Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
libxml-security-java (1.4.3-2ubuntu0.1) lucid-security; urgency=low

  * SECURITY UPDATE: XML signature spoofing via CanonicalizationMethod
    parameter
    - src/org/jcp/xml/dsig/internal/dom/DOMCanonicalizationMethod.java:
      don't allow non-standard c14n method.
    - http://svn.apache.org/viewvc?view=revision&revision=1493772
    - CVE-2013-2172
 -- Marc Deslauriers <email address hidden>   Tue, 10 Sep 2013 11:44:34 -0400
Superseded in trusty-release on 2014-02-02
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libxml-security-java (1.5.5-2) unstable; urgency=low


  * Upload to unstable
  * Release 1.5.5 fixes CVE-2013-2172 (Closes: #720375)
  * Added the Classpath attribute in the jar manifest

 -- Emmanuel Bourg <email address hidden>  Mon, 26 Aug 2013 19:56:57 +0200

Available diffs

Superseded in saucy-release on 2013-08-29
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-16
libxml-security-java (1.4.5-1) unstable; urgency=low


  * New upstream release
  * Update debian/watch to point to new SVN repo.
  * Update Standards-Version: 3.9.1.
  * Switch to source format 3.0.
  * Use Maven to build the package. Ignore test failures.
  * Update Description.
  * Add a documentation package.
  * Update Homepage field.

 -- Torsten Werner <email address hidden>  Tue, 30 Aug 2011 14:07:46 +0200
Superseded in precise-release on 2011-10-16
Obsolete in oneiric-release on 2015-04-24
Superseded in oneiric-release on 2011-08-18
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
libxml-security-java (1.4.3-2fakesync1) lucid; urgency=low

  * Fake sync due to mismatching tarball (LP: #511448).
 -- Artur Rona <email address hidden>   Sun, 14 Feb 2010 12:40:14 +0100
Superseded in lucid-release on 2010-02-16
libxml-security-java (1.4.3-1ubuntu1) lucid; urgency=low

  * Merge from debian testing, remaining changes:
    - debian/build.xml: Build Java2 code to match runtime dependency
    - debian/build.xml: Fix the jar packaging to include resources
    - debian/control: Depend on JRE /and/ shlibs:Depends, rather than /or/

Available diffs

Superseded in lucid-release on 2009-11-13
Obsolete in karmic-release on 2013-03-04
Superseded in karmic-release on 2009-08-26
libxml-security-java (1.4.3-0ubuntu1) karmic; urgency=low

  * New upstream release, fixes CVE-2009-0217 (LP: #416802)
  * debian/build.xml: target 1.4 code to be java2-compatible

 -- Thierry Carrez <email address hidden>   Fri, 21 Aug 2009 10:34:59 +0200

Available diffs

Superseded in karmic-release on 2009-08-21
libxml-security-java (1.4.2-1ubuntu2) karmic; urgency=low

  * debian/control: Set libxml-security-java runtime dependency on
    "default-jre-headless | java2-runtime-headless" (LP: #387884)
  * debian/control, debian/rules: Build-depend on default-jdk

 -- Thierry Carrez <email address hidden>   Thu, 18 Jun 2009 14:37:56 +0200

Available diffs

Superseded in karmic-release on 2009-06-18
Obsolete in jaunty-release on 2013-02-28
libxml-security-java (1.4.2-1ubuntu1) jaunty; urgency=low

  [ chris grzegorczyk ]
  * Fix the jar packaging to include resources (LP: #328329)

 -- Thierry Carrez <email address hidden>   Thu, 12 Feb 2009 08:17:32 +0000

Available diffs

Superseded in jaunty-release on 2009-02-12
libxml-security-java (1.4.2-1) unstable; urgency=low

  * New upstream release
  * Bump Standards-Version to 3.8.0
  * debian/copyright: remove the full text of Apache 2.0 license, as now
    is included in common licenses

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  05 Nov 2008 10:38:19 +0000

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
libxml-security-java (1.4.1-1) unstable; urgency=low

  * Initial release (Closes: #450611)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  07 May 2008 10:38:44 +0100
117 of 17 results