Change log for libxtst package in Ubuntu

124 of 24 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
libxtst (2:1.2.3-1) unstable; urgency=low

  [ Andreas Boll ]
  * New upstream release.
    - Fixes CVE-2016-7951 and CVE-2016-7952 (Closes: #840444).
  * Bump libx11-dev build-dep to 2:1.6.0 per configure.ac.
  * Let uscan verify tarball signatures.
  * Remove Cyril from Uploaders.
  * Update a bunch of URLs in packaging to https.
  * Fix lintian error: pre-depends-directly-on-multiarch-support.

  [ Julien Cristau ]
  * Bump debhelper build-dep to 8.1.3 for ${misc:Pre-Depends}.

  [ Emilio Pozuelo Monfort ]
  * Bump debhelper compat to 10.
  * Switch from xsfbs to dh.
  * Switch to -dbgsym packages.
  * Bump Standards-Version to 3.9.8, no changes.
  * Drop automake and libtool build-dependencies, debhelper takes care
    of that now.
  * Drop unneeded override for dh_installchangelogs, it already installs
    the upstream ChangeLog automatically.

 -- Emilio Pozuelo Monfort <email address hidden>  Tue, 06 Dec 2016 01:38:08 +0100

Available diffs

Superseded in zesty-release on 2016-12-10
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
libxtst (2:1.2.2-1) unstable; urgency=low


  * New upstream release.
  * debian/copyright: add copyright notices and licenses from the manpages and
    specs.  Thanks, Ansgar!
  * Bump debhelper compat level to 7.
  * Use dpkg-buildflags.
  * Disable silent build rules.
  * Use dh_prep instead of dh_clean -k.

 -- Julien Cristau <email address hidden>  Mon, 12 Aug 2013 20:33:03 +0200

Available diffs

Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
libxtst (2:1.1.0-2ubuntu0.1) lucid-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-2063.patch: fix multiple overflows.
    - CVE-2013-2063
 -- Marc Deslauriers <email address hidden>   Tue, 28 May 2013 13:45:53 -0400
Obsolete in quantal-updates on 2015-04-24
Obsolete in quantal-security on 2015-04-24
libxtst (2:1.2.1-1ubuntu0.12.10.1) quantal-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-2063.patch: fix multiple overflows.
    - CVE-2013-2063
 -- Marc Deslauriers <email address hidden>   Tue, 28 May 2013 13:41:34 -0400
Published in precise-updates on 2013-06-05
Published in precise-security on 2013-06-05
libxtst (2:1.2.0-4ubuntu0.1) precise-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-2063.patch: fix multiple overflows.
    - CVE-2013-2063
 -- Marc Deslauriers <email address hidden>   Tue, 28 May 2013 13:43:10 -0400
Obsolete in raring-updates on 2015-04-24
Obsolete in raring-security on 2015-04-24
libxtst (2:1.2.1-1ubuntu0.13.04.1) raring-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-2063.patch: fix multiple overflows.
    - CVE-2013-2063
 -- Marc Deslauriers <email address hidden>   Tue, 28 May 2013 13:38:56 -0400
Superseded in saucy-release on 2013-08-16
Deleted in saucy-proposed on 2013-08-17 (Reason: moved to release)
libxtst (2:1.2.1-1+deb7u1) wheezy-security; urgency=high


  * integer overflow in XRecordGetContext() [CVE-2013-2063]

 -- Julien Cristau <email address hidden>  Tue, 14 May 2013 20:12:48 +0200

Available diffs

Superseded in saucy-release on 2013-05-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libxtst (2:1.2.1-1) unstable; urgency=low


  * New upstream release.
  * Split documentation to a separate package.  Mark libxtst-dev Multi-Arch:
    same.
  * Don't build the documentation from the build-arch target.
  * Bump build-deps on xutils-dev, xmlto and xorg-sgml-doctools per
    configure.ac.

 -- Julien Cristau <email address hidden>  Mon, 23 Apr 2012 22:55:46 +0200

Available diffs

Superseded in quantal-release on 2012-05-09
Published in precise-release on 2011-10-25
libxtst (2:1.2.0-4) unstable; urgency=low

  [ Julien Cristau ]
  * Build for multiarch (closes: #639348).  Thanks, Peter Samuelson!
  * Don't use dh_testroot in clean.

  [ Steve Langasek ]
  * Don't mark libxtst-dev Multi-Arch: same, because its documentation isn't
    identical across architectures.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  24 Oct 2011 23:32:40 +0000
Superseded in precise-release on 2011-10-25
Obsolete in oneiric-release on 2015-04-24
libxtst (2:1.2.0-3) unstable; urgency=low
  * Upload to unstable. -- Cyril Brulebois <email address hidden>  Wed, 20 Jul 2011 23:10:53 +0200
Superseded in oneiric-release on 2011-07-27
Obsolete in natty-release on 2013-06-04
libxtst (2:1.2.0-1) unstable; urgency=low

  * New upstream release.
  * Bump xutils-dev build-dep for new macros.
  * Update debian/copyright from upstream COPYING.
  * Add xmlto, xorg-sgml-doctools, and w3m build-dep for the doc.
  * Pass --with-xmlto and --without-fop (we want html and txt only).
  * Pass --docdir=/usr/share/doc/libxtst-dev and add this directory to
    the libxtst-dev.install file.
  * Switch from --list-missing to --fail-missing for additional safety.
  * Exclude libXtst.la from dh_install accordingly.
  * Add myself to Uploaders.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  20 Nov 2010 11:15:48 +0000

Available diffs

Superseded in natty-release on 2010-11-20
Obsolete in maverick-release on 2013-03-05
libxtst (2:1.1.0-3) unstable; urgency=low

  [ Julien Cristau ]
  * Rename the build directory to not include DEB_BUILD_GNU_TYPE for no
    good reason.  Thanks, Colin Watson!

  [ Brice Goglin ]
  * Fix short description, thanks Nick Shaforostoff, closes: #565234.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  24 Jun 2010 17:27:43 +0100

Available diffs

Superseded in maverick-release on 2010-06-24
Obsolete in lucid-release on 2016-10-26
libxtst (2:1.1.0-2) unstable; urgency=low

  * Upload to unstable.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  18 Jan 2010 07:31:46 +0000

Available diffs

Superseded in lucid-release on 2010-01-18
libxtst (2:1.1.0-1) experimental; urgency=low

  [ Timo Aaltonen ]
  * New upstream release.
  * Bump the build-dep on xutils-dev (>= 1:7.5~1).
  * Bump the build-dep on libxext-dev (>= 1:1.0.99.4).

Available diffs

Superseded in lucid-release on 2009-12-04
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
libxtst (2:1.0.3-1ubuntu2) jaunty; urgency=low

  * debian/control: make libxtst-dev depend on libxi-dev. The "right fix"
    would be to make x11proto-xext-dev Depends on libxi-dev, but that would
    introduce a circular dependency.
    .
    A number of packages FTBFS because of this (#include XTest.h, but no
    XInput.h available). All occurences I could find using a very
    unscientific method are fixed by this workaround.

 -- Daniel Holbach <email address hidden>   Mon, 23 Mar 2009 13:17:51 +0100
Superseded in jaunty-release on 2009-03-27
libxtst (2:1.0.3-1ubuntu1) jaunty; urgency=low

  * Add missing libxi-dev to Build-Depends (fixes FTBFS) (lp: #346841).

 -- Michael Bienia <email address hidden>   Sun, 22 Mar 2009 17:18:54 +0100

Available diffs

Superseded in jaunty-release on 2009-03-23
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
libxtst (2:1.0.3-1) unstable; urgency=low

  [ Julien Cristau ]
  * Sync package sections with the override.
  * Bump epoch so Ubuntu can sync this package.

  [ Brice Goglin ]
  * New upstream release.
  * Add myself to Uploaders, and remove Branden and Fabio with their
    permission.
  * Add upstream URL to debian/copyright.
  * Update 01_build_manpages.diff since its first half has been merged
    upstream, and rename it to 01_fix_date_in_manpages.diff to match
    the remaining part.

 -- Timo Aaltonen <email address hidden>   Wed,  14 Nov 2007 10:06:20 +0000
Superseded in hardy-release on 2007-11-14
Obsolete in gutsy-release on 2011-09-16
libxtst (2:1.0.2-1ubuntu1) gutsy; urgency=low

  * Merge with debian.  Remaining Ubuntu changes:
    - Bump epoch

Superseded in gutsy-release on 2007-08-03
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
libxtst (2:1.0.1-3build1) edgy; urgency=low

  * Fakesync from Debian.  Different orig.tar.gz and different epoch.

Superseded in edgy-release on 2006-07-07
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
libxtst (2:1.0.1-0ubuntu2) dapper; urgency=low


  * Change dependency on x-common to x11-common.

 -- Daniel Stone <email address hidden>  Thu, 19 Jan 2006 18:34:40 +1100
Superseded in dapper-release on 2006-01-31
libxtst (2:1.0.1-0ubuntu1) dapper; urgency=low


  * New upstream release.

 -- Daniel Stone <email address hidden>  Thu,  5 Jan 2006 13:56:22 +1100
Superseded in dapper-release on 2006-01-31
libxtst (2:0.99.3-0ubuntu1) dapper; urgency=low


  * New upstream release.

 -- Daniel Stone <email address hidden>  Mon, 12 Dec 2005 16:13:25 +1100
Superseded in dapper-release on 2006-01-31
libxtst (2:1.0.0-0ubuntu1) dapper; urgency=low


  * New upstream release.

 -- Daniel Stone <email address hidden>  Wed, 21 Dec 2005 13:40:58 +1100
Obsolete in breezy-release on 2008-03-25
libxtst (1:1.13.0-2) breezy; urgency=low


  * Bump Build-Deps on libx11-dev and libxext-dev to avoid _XOPEN_SOURCE.

 -- Daniel Stone <email address hidden>  Sat, 23 Jul 2005 00:49:26 +1000
124 of 24 results