Change log for libzip package in Ubuntu

118 of 18 results
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-12-11
Deleted in disco-proposed (Reason: moved to release)
libzip (1.5.1-0ubuntu1) disco; urgency=medium

  * New upstream release (LP: #1674057) (Closes: #894813)
    - Removes custom AES implementation in favour of using standard crypto libs
  * Build with cmake, autotools support was dropped.
  * Bump debhelper to compat 11
  * debian/control
    - Add Build-dep on libssl-dev and libbz2-dev
  * debian/libzip5.symbols: Update with new symbols
  * debian/rules:
    - Clean up Multi-arch support
    - set dh_missing to --fail-missing
    - Drop flags obsolete with dh 11
    - Strip -Bsymbolic-functions link flag as it causes test failures
  * debian/libzip-dev.install: don't install static lib, its not built now
  * debian/libzip5.lintian-overrides:
    -  override possible-gpl-code-linked-with-openssl, libzip is BSD licensed
       only the debian packaging is licensed under GPLv3
  * debian/copyright: Update to reflect removed code

 -- Tim Lunn <email address hidden>  Tue, 27 Nov 2018 10:51:36 +1000
Superseded in disco-proposed on 2018-11-27
libzip (1.3.2-1) experimental; urgency=medium

  * Update to upstream version 1.3.2 (Closes: #881877)
  * Updated symbols file
  * Updated libzip-dev.install and rules to cover the new path of zipconf.h
  * Changed rules file to fix sets-dpkg-architecture-variable lintian warning

 -- Stefan Schörghofer <amd1212@4md.gr>  Mon, 20 Nov 2017 21:39:26 +0100
Superseded in disco-release on 2018-12-11
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
libzip (1.1.2-1.1) unstable; urgency=medium

  [ Hans-Christoph Steiner ]
  * Imported Upstream version 1.1.1
  * New upstream version (Closes: #662083)

  [ Ondřej Surý ]
  * Non-maintainer upload.
  * Imported Upstream version 1.1.2
  * Install NEWS as upstream changelog, README and TODO is no more

 -- Ondřej Surý <email address hidden>  Tue, 10 May 2016 12:09:23 +0200
Superseded in yakkety-release on 2016-05-20
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
Superseded in wily-proposed on 2015-09-12
libzip (1.0.1-0ubuntu1) wily; urgency=medium

  * New upstream version.
  * libzip soname change (libzip2 -> libzip4).
  * Update symbols file.
  * Stop building the libtorrent package; removed upstream.
  * Mark libzip-dev and libzip4 as Multi-Arch: same.
  * Bump standards version.

 -- Matthias Klose <email address hidden>  Sat, 12 Sep 2015 02:51:54 +0200
Superseded in wily-release on 2015-09-13
Superseded in wily-release on 2015-09-12
Superseded in wily-release on 2015-09-12
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
libzip (0.11.2-1.2) unstable; urgency=high


  * Non-maintainer upload.
  * Add CVE-2015-2331.patch patch.
    CVE-2015-2331: ZIP integer overflow leads to writing past heap boundary.
    (Closes: #780756)

 -- Salvatore Bonaccorso <email address hidden>  Fri, 20 Mar 2015 20:17:45 +0100

Available diffs

Superseded in vivid-release on 2015-03-27
Obsolete in utopic-release on 2016-11-03
Superseded in utopic-release on 2014-10-23
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
libzip (0.11.2-1.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Put a symlink to zipconf.h on the default search path, so that
    packages that do not use pkg-config to locate libzip will not FTBFS.
    Thanks to Simon McVittie (Closes: #739308).

 -- John Paul Adrian Glaubitz <email address hidden>  Wed, 06 Aug 2014 15:38:27 +0200

Available diffs

Superseded in utopic-release on 2014-08-07
Deleted in utopic-proposed on 2014-08-08 (Reason: moved to release)
libzip (0.11.2-1) unstable; urgency=medium


  * New upstream release (Closes: #734388).
  * Remove patches:
    - fix_open_nonarchive_test.patch - fixed upstream
    - fix_zipconf_path.patch - fixed upstream
    - fix_broken_decrypt.patch - fixed upstream
    - fix_autotools_tests.diff - stolen upstream
  * Update debian/control:
    - add unzip to Build-Depends.
    - bump compat to 9
  * Update *.install: multiarch paths.
  * Update libzip2 symbols file.

 -- Fathi Boudra <email address hidden>  Sun, 09 Feb 2014 13:24:18 +0200

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2013-11-06
Deleted in trusty-proposed (Reason: moved to release)
libzip (0.10.1-1.2) unstable; urgency=low


  * Non-maintainer upload.
  * Fix "FTBFS: dh_auto_test: make -j1 check returned exit code 2":
    add patch fix_autotools_tests.diff (autotools test fix, backported from
    upstream 0.11.1), taken from Ubuntu package. Thanks, Bjoern Michaelsen.
    (Closes: #713393, LP: #1197023)

 -- gregor herrmann <email address hidden>  Sun, 03 Nov 2013 15:27:06 +0100
Superseded in trusty-release on 2013-11-06
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libzip (0.10.1-1.1ubuntu1) saucy; urgency=low

  * backport changes from upstream 0.11.1 to make autotools happy
    (LP: #1197023)
 -- Bjoern Michaelsen <email address hidden>   Tue, 02 Jul 2013 21:44:05 +0200
Superseded in saucy-release on 2013-07-03
Superseded in saucy-release on 2013-07-03
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libzip (0.10.1-1.1) unstable; urgency=low


  * Non-maintainer upload.
  * Re-enable tests
  * Fix broken decrypt on amd64 (Closes: 665225).

 -- Luk Claes <email address hidden>  Sat, 07 Jul 2012 02:03:46 +0000

Available diffs

Superseded in quantal-release on 2012-07-20
Superseded in quantal-release on 2012-06-15
libzip (0.10.1-1) unstable; urgency=low


  * New upstream release: fix CVE-2012-1162 and CVE-2012-1163
    Incorrect loop construct and numeric overflow. (Closes: #664990, #665957)

 -- Fathi Boudra <email address hidden>  Mon, 21 May 2012 15:16:11 +0300
Superseded in quantal-release on 2012-05-24
Published in precise-release on 2012-03-29
libzip (0.10-1ubuntu1) precise; urgency=low

  * SECURITY UPDATE: arbitrary code execution or information leak via
    heap overflow and numeric overflow.
    - debian/patches/CVE-2012-116x.patch: fix overflow and loop in
      lib/zip_open.c.
    - CVE-2012-1162
    - CVE-2012-1163
 -- Marc Deslauriers <email address hidden>   Wed, 28 Mar 2012 15:05:00 -0400
Superseded in precise-release on 2012-03-29
libzip (0.10-1) unstable; urgency=low


  * New upstream release. (Closes: #647131)
  * Add patches:
    - fix_open_nonarchive_test.patch
    - fix_zipconf_path.patch
  * Update debian/compat: bump to 8.
  * Update debian/rules:
    - build depends on dh-autoreconf.
    - bump debhelper build dependency to 8.0.0.
    - bump Standards-Version to 3.9.0 - no changes needed.
    - rename libzip1 to libzip2 (bump soname).
  * Update debian/rules:
    - use dh with autoreconf.
    - drop override_dh_auto_test.
  * Update debian/*.install files.

 -- Fathi Boudra <email address hidden>  Sat, 31 Dec 2011 14:39:13 +0200

Available diffs

Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
libzip (0.9-3ubuntu0.1) lucid-proposed; urgency=low

  * Fix memory leaks in zip_close. (LP: #623846)
 -- Firas Kraiem <email address hidden>   Sun, 19 Sep 2010 16:47:51 +0200

Available diffs

Superseded in precise-release on 2012-03-19
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
libzip (0.9.3-1) unstable; urgency=low

  * New upstream release. (Closes: #567769)
  * Drop patch to support archives with 64k entries - stolen upstream.
  * Add libzip1 symbols file.
  * Switch to dpkg-source 3.0 (quilt) format:
    - drop quilt build dependency.
  * Switch to dh:
    - drop cdbs build dependency.
    - bump debhelper build dependency version to 7.4.15.
    - enable parallel build (pass --parallel option to dh).
  * Bump Standards-Version to 3.8.4 (no changes needed).
  * Update debian/copyright file:
    - upstream contact e-mail, years and explicit GPL version.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:56:36 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
libzip (0.9-3) unstable; urgency=low

  * Add patch to support archives with 64k entries (Closes: #536215)
    Thanks to Dieter Baron

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Superseded in intrepid-release on 2008-08-22
Obsolete in hardy-release on 2015-04-24
libzip (0.8-1) unstable; urgency=low

  * Initial release. (Closes: #446583)

 -- Brandon Holtsclaw <email address hidden>   Mon,  05 Nov 2007 17:11:55 +0000
Superseded in hardy-release on 2007-11-05
Obsolete in gutsy-release on 2011-09-16
Superseded in gutsy-release on 2007-10-15
libzip (0.8-0ubuntu1) gutsy; urgency=low

  * Initial package

 -- Jonathan Riddell <email address hidden>   Fri, 12 Oct 2007 20:27:26 +0100
118 of 18 results