Change log for liggghts package in Ubuntu

150 of 50 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-01-23
Deleted in disco-proposed (Reason: moved to release)
liggghts (3.8.0+repack1-4) unstable; urgency=medium

  * [b42dedf] Update CMakeListst. (Closes: 917500)

 -- Anton Gladky <email address hidden>  Tue, 22 Jan 2019 20:40:32 +0100
Superseded in disco-release on 2019-01-23
Deleted in disco-proposed on 2019-01-24 (Reason: moved to release)
liggghts (3.8.0+repack1-3) unstable; urgency=medium

  * [5cb8750] Set LC_ALL=C in d/rules. (Closes: #917500)

 -- Anton Gladky <email address hidden>  Mon, 21 Jan 2019 23:56:07 +0100

Available diffs

Superseded in disco-release on 2019-01-22
Deleted in disco-proposed on 2019-01-23 (Reason: moved to release)
liggghts (3.8.0+repack1-2) unstable; urgency=medium

  * [8bc3eb8] Remove qt4-framework from deps. (Closes: #875028)
  * [5ae1881] Update standards-version to 4.3.0

 -- Anton Gladky <email address hidden>  Sat, 19 Jan 2019 15:42:41 +0100

Available diffs

Superseded in disco-release on 2019-01-20
Deleted in disco-proposed on 2019-01-21 (Reason: moved to release)
liggghts (3.8.0+repack1-1) unstable; urgency=medium

  * [77bb37d] Update patches
  * [9c9888d] Apply cme fix dpkg
  * [2a69e72] Add allow-run-as-root option
  * [a0fb4a3] Remove unneeded fields in d/control and d/rules
  * [211b0af] Use packaged version of the js-libs
  * [4ecc15e] Fix typo in d/changelog
  * [b9e4366] Update d/watch
  * [15fd630] New upstream version 3.8.0+repack1

 -- Anton Gladky <email address hidden>  Sun, 23 Dec 2018 20:53:10 +0100
Superseded in disco-release on 2018-12-24
Published in cosmic-release on 2018-09-19
Deleted in cosmic-proposed (Reason: moved to release)
liggghts (3.7.0+repack1-1.1ubuntu3) cosmic; urgency=medium

  * Add i386 to ignore list, and ignore i386/armhf tests, they hang.
    (See Debian bug: #907267)

 -- Gianfranco Costamagna <email address hidden>  Mon, 17 Sep 2018 17:43:15 +0200
Superseded in cosmic-proposed on 2018-09-19
liggghts (3.7.0+repack1-1.1ubuntu2) cosmic; urgency=medium

  * Add i386 to ignore list, and ignore i386 tests, they hang.
    (See Debian bug: #907267)

 -- Gianfranco Costamagna <email address hidden>  Mon, 17 Sep 2018 17:43:15 +0200
Superseded in cosmic-proposed on 2018-09-18
liggghts (3.7.0+repack1-1.1ubuntu1) cosmic; urgency=medium

  * Add i386 to ignore list, and ignore i386 tests, they hang.
    (See Debian bug: #907267)

 -- Gianfranco Costamagna <email address hidden>  Mon, 17 Sep 2018 17:43:15 +0200
Superseded in cosmic-proposed on 2018-09-17
liggghts (3.7.0+repack1-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix FTBFS on 32bit archs with gcc 8 by building with -g1.
  * Fix FTBFS on mips/mipsel by building with -g0. (Closes: #866097)
  * Add more architectures to disable_auto_test_archs_*.

 -- Adrian Bunk <email address hidden>  Tue, 14 Aug 2018 12:03:22 +0300
Superseded in cosmic-release on 2018-09-19
Deleted in cosmic-proposed on 2018-09-20 (Reason: moved to release)
liggghts (3.7.0+repack1-1build1) cosmic; urgency=medium

  * No-change rebuild against openmpi 3

 -- Graham Inggs <email address hidden>  Mon, 14 May 2018 10:37:30 +0000
Superseded in cosmic-release on 2018-07-06
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-07-19
Deleted in artful-proposed (Reason: moved to release)
liggghts (3.7.0+repack1-1) unstable; urgency=medium

  * [56c1d27] Drop windows-files from the source.
  * [a769922] Filter some js-files from the source.
  * [e042cd2] New upstream version 3.7.0+repack1
  * [d14defe] Refresh patches, remove uneeded ones.
  * [8812f5f] Set maximal hardening level.

 -- Anton Gladky <email address hidden>  Tue, 18 Jul 2017 00:15:56 +0200
Superseded in artful-release on 2017-07-19
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
liggghts (3.5.0+repack1-10) unstable; urgency=medium

  * [e2a6253] Better fix for the bug, fixed in previous upload.
              Thanks, Graham

 -- Anton Gladky <email address hidden>  Thu, 19 Jan 2017 18:58:57 +0100

Available diffs

Superseded in zesty-release on 2017-01-20
Deleted in zesty-proposed on 2017-01-21 (Reason: moved to release)
liggghts (3.5.0+repack1-9) unstable; urgency=medium

  * [a879ac6] Do not fail on mpi-errors. (Closes: #851726)

 -- Anton Gladky <email address hidden>  Wed, 18 Jan 2017 22:46:29 +0100

Available diffs

Superseded in zesty-release on 2017-01-19
Deleted in zesty-proposed on 2017-01-20 (Reason: moved to release)
liggghts (3.5.0+repack1-8) unstable; urgency=medium

  * [2219bae] Fix variable name in d/rules.

 -- Anton Gladky <email address hidden>  Fri, 30 Dec 2016 08:26:31 +0100

Available diffs

Superseded in zesty-release on 2016-12-30
Deleted in zesty-proposed on 2016-12-31 (Reason: moved to release)
liggghts (3.5.0+repack1-7) unstable; urgency=medium

  * [6079250] Disable test on mips64el (unstable).

 -- Anton Gladky <email address hidden>  Fri, 30 Dec 2016 00:24:51 +0100

Available diffs

Superseded in zesty-release on 2016-12-30
Deleted in zesty-proposed on 2016-12-31 (Reason: moved to release)
liggghts (3.5.0+repack1-6) unstable; urgency=medium

  * [96fa01f] Add mips64el to disable_auto_test_archs_mpi in d/rules.

 -- Anton Gladky <email address hidden>  Thu, 29 Dec 2016 20:02:34 +0100

Available diffs

Superseded in zesty-release on 2016-12-30
Deleted in zesty-proposed on 2016-12-31 (Reason: moved to release)
liggghts (3.5.0+repack1-5) unstable; urgency=medium

  [ Graham Inggs ]
  * [fe1b4d7] Replace OMPI_MCA_orte_rsh_agent by OMPI_MCA_plm_rsh_agent
              for autopkgtests too
  * [5037eeb] Allow --oversubscribe for autopkgtests

 -- Anton Gladky <email address hidden>  Wed, 28 Dec 2016 19:01:44 +0100
Superseded in zesty-release on 2016-12-29
Deleted in zesty-proposed on 2016-12-30 (Reason: moved to release)
liggghts (3.5.0+repack1-4ubuntu1) zesty; urgency=medium

  * Replace deprecated OMPI_MCA_orte_rsh_agent with OMPI_MCA_plm_rsh_agent
  * Allow --oversubscribe for autopkgtests

 -- Graham Inggs <email address hidden>  Wed, 21 Dec 2016 14:00:28 +0200
Superseded in zesty-release on 2016-12-21
Deleted in zesty-proposed on 2016-12-22 (Reason: moved to release)
liggghts (3.5.0+repack1-4) unstable; urgency=medium

  [ Graham Inggs ]
  * Restrictions: allow-stderr on the tests, for compatibility with current
    openmpi.
  * Update autopkgtests with examples from 3.5.0.

  [ Anton Gladky ]
  * Use --parallel build again

 -- Anton Gladky <email address hidden>  Tue, 08 Nov 2016 20:25:41 +0100
Superseded in zesty-release on 2016-11-09
Deleted in zesty-proposed on 2016-11-10 (Reason: moved to release)
liggghts (3.5.0+repack1-2ubuntu1) zesty; urgency=medium

  * Merge with Debian unstable, remaining changes
    - Restrictions: allow-stderr on the tests, for compatibility with current
      openmpi.
    - Update autopkgtests with examples from 3.5.0.

Superseded in zesty-proposed on 2016-11-07
liggghts (3.5.0+repack1-2) unstable; urgency=medium

  * [8031b0e] Do not use parallel build. Fails on some platforms.
  * [6a2a7ed] Fix autotests.

 -- Anton Gladky <email address hidden>  Sat, 05 Nov 2016 15:46:43 +0100
Superseded in zesty-release on 2016-11-07
Deleted in zesty-proposed on 2016-11-08 (Reason: moved to release)
liggghts (3.5.0+repack1-1ubuntu2) zesty; urgency=medium

  * Fix autopkgtests by using examples from 3.5.0.

 -- Graham Inggs <email address hidden>  Wed, 02 Nov 2016 13:43:29 +0200
Superseded in zesty-proposed on 2016-11-02
liggghts (3.5.0+repack1-1ubuntu1) zesty; urgency=medium

  [ Steve Langasek]
  * Restrictions: allow-stderr on the tests, for compatibility with current
    openmpi.

 -- Gianfranco Costamagna <email address hidden>  Tue, 01 Nov 2016 21:54:15 +0100
Superseded in zesty-proposed on 2016-11-01
liggghts (3.5.0+repack1-1) unstable; urgency=medium

  * [784df99] New upstream version 3.5.0+repack1
  * [4101537] Refresh patches.

 -- Anton Gladky <email address hidden>  Thu, 27 Oct 2016 23:04:19 +0200
Superseded in zesty-release on 2016-11-05
Deleted in zesty-proposed on 2016-11-06 (Reason: moved to release)
liggghts (3.4.0+repack1-2ubuntu1) zesty; urgency=medium

  * Restrictions: allow-stderr on the tests, for compatibility with current
    openmpi.

 -- Steve Langasek <email address hidden>  Sat, 22 Oct 2016 15:06:24 -0700
Superseded in zesty-proposed on 2016-10-22
liggghts (3.4.0+repack1-2build1) zesty; urgency=medium

  * No-change rebuild against libopenmpi2

 -- Steve Langasek <email address hidden>  Sat, 22 Oct 2016 01:36:26 +0000
Superseded in zesty-release on 2016-10-27
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
liggghts (3.4.0+repack1-2) unstable; urgency=medium

  * [ead3d70] Disable mpi-test on powerpc.
  * [6492a8e] Apply cme fix dpkg.

 -- Anton Gladky <email address hidden>  Wed, 27 Jul 2016 00:44:20 +0200

Available diffs

Superseded in yakkety-release on 2016-07-28
Deleted in yakkety-proposed on 2016-07-29 (Reason: moved to release)
liggghts (3.4.0+repack1-1) unstable; urgency=medium

  * [6a5c2a8] Imported Upstream version 3.4.0+repack1
  * [157da23] Refresh patches.
  * [9a184e0] Apply cme fix dpkg.
  * [ea651a2] Update d/copyright.

 -- Anton Gladky <email address hidden>  Wed, 15 Jun 2016 22:12:40 +0200
Superseded in yakkety-release on 2016-06-16
Deleted in yakkety-proposed on 2016-06-17 (Reason: moved to release)
liggghts (3.3.1+repack1-1ubuntu4) yakkety; urgency=medium

  * Rebuild against libvtk6.3.

 -- Gianfranco Costamagna <email address hidden>  Mon, 30 May 2016 10:32:52 +0200
Superseded in yakkety-release on 2016-06-10
Published in xenial-release on 2016-02-15
Deleted in xenial-proposed (Reason: moved to release)
liggghts (3.3.1+repack1-1ubuntu3) xenial; urgency=medium

  * Add powerpc to disable_auto_test_archs_mpi and disable_auto_test_archs_simpl.

 -- Matthias Klose <email address hidden>  Fri, 12 Feb 2016 20:29:44 +0100
Superseded in xenial-proposed on 2016-02-12
liggghts (3.3.1+repack1-1ubuntu2) xenial; urgency=medium

  * debian/tests: Don't use deprecated mpi variable.
  * Allow stderr in the autopkg tests.

 -- Matthias Klose <email address hidden>  Thu, 11 Feb 2016 15:10:36 +0100
Superseded in xenial-proposed on 2016-02-11
liggghts (3.3.1+repack1-1ubuntu1) xenial; urgency=medium

  * debian/tests: Don't use deprecated mpi variable.

 -- Matthias Klose <email address hidden>  Thu, 11 Feb 2016 15:10:36 +0100
Superseded in xenial-proposed on 2016-02-11
liggghts (3.3.1+repack1-1build2) xenial; urgency=medium

  * No-change rebuild for openmpi on s390x.

 -- Matthias Klose <email address hidden>  Sat, 06 Feb 2016 19:49:42 +0000
Superseded in xenial-proposed on 2016-02-06
liggghts (3.3.1+repack1-1build1) xenial; urgency=medium

  * No-change rebuild for openmpi transition.

 -- Matthias Klose <email address hidden>  Mon, 01 Feb 2016 11:31:00 +0000
Superseded in xenial-release on 2016-02-15
Deleted in xenial-proposed on 2016-02-16 (Reason: moved to release)
liggghts (3.3.1+repack1-1) unstable; urgency=medium

  * [3697863] Imported Upstream version 3.3.1+repack1
  * [662e977] Refresh patches.
  * [df1a7e8] Remove dbg-file.

 -- Anton Gladky <email address hidden>  Sun, 17 Jan 2016 00:55:04 +0100
Superseded in xenial-release on 2016-01-17
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
liggghts (3.2.0+repack1-3) unstable; urgency=medium

  * [62739c0] Add support for VTK6.2. (Closes: #793605)

 -- Anton Gladky <email address hidden>  Tue, 04 Aug 2015 21:14:21 +0200
Superseded in wily-release on 2015-08-31
Deleted in wily-proposed on 2015-09-02 (Reason: moved to release)
liggghts (3.2.0+repack1-2ubuntu1) wily; urgency=medium

  * Rename library packages for g++5 ABI transition.

 -- Steve Langasek <email address hidden>  Tue, 04 Aug 2015 08:12:32 +0000
Superseded in wily-release on 2015-08-11
Deleted in wily-proposed on 2015-08-13 (Reason: moved to release)
liggghts (3.2.0+repack1-2) unstable; urgency=medium

  * [7db5a48] Update d/watch.
  * [ba29637] Update d/copyright.
  * [b81a33d] Refresh patches.
  * [9d49744] Imported Upstream version 3.2.0+repack1

 -- Anton Gladky <email address hidden>  Mon, 22 Jun 2015 18:17:22 +0200
Superseded in wily-release on 2015-06-23
Deleted in wily-proposed on 2015-06-24 (Reason: moved to release)
liggghts (3.1.0+repack1-1) unstable; urgency=medium

  * [6ac272b] Use cme fix dpkg-control.

 -- Anton Gladky <email address hidden>  Wed, 06 May 2015 22:16:12 +0200
Superseded in wily-release on 2015-05-08
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
liggghts (3.0.3+repack-2) unstable; urgency=medium


  * [57ea03a] Specify components for VTK. (Closes: #765106).
  * [a8da87d] Set Standards-Version: 3.9.6. No changes.

 -- Anton Gladky <email address hidden>  Tue, 14 Oct 2014 22:56:37 +0200

Available diffs

Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
liggghts (3.0.2+repack-1) unstable; urgency=medium


  * [ae36cd8] Add Files-Excluded to copyright-file.
  * [b745737] Exclude LAMMPS-examples.
  * [61a906b] Imported Upstream version 3.0.2+repack
  * [2566925] Set minimal vtk6 version to 6.1.0+dfsg-7.
  * [fb1a0c1] Add libxdmf-dev to BD.
  * [268930b] Remove .gitignore from examples.

 -- Anton Gladky <email address hidden>  Sun, 15 Jun 2014 19:49:34 +0200

Available diffs

Superseded in utopic-release on 2014-07-29
Deleted in utopic-proposed on 2014-07-30 (Reason: moved to release)
liggghts (3.0.1+repack-2) unstable; urgency=medium


  * [84cab80] Fix autopkgtest. (Closes: #747339)

 -- Anton Gladky <email address hidden>  Sat, 17 May 2014 22:53:31 +0200
Superseded in utopic-proposed on 2014-05-18
liggghts (3.0.1+repack-1build1) utopic; urgency=medium

  * No-change rebuild to drop mpich dependency on arm64.
 -- Logan Rosen <email address hidden>   Fri, 02 May 2014 10:44:50 -0400
Superseded in utopic-proposed on 2014-05-02
liggghts (3.0.1+repack-1) unstable; urgency=medium


  * [f333916] Imported Upstream version 3.0.1+repack
  * [ce0d980] Build against VTK6 instead of VTK5.
  * [f8e3515] Add autotest.
  * [833caea] Set Standards-Version: 3.9.5. No changes.

 -- Anton Gladky <email address hidden>  Wed, 23 Apr 2014 22:21:33 +0200
Superseded in utopic-release on 2014-05-22
Published in trusty-release on 2013-12-17
Deleted in trusty-proposed (Reason: moved to release)
liggghts (2.3.8-1build1) trusty; urgency=medium

  * No-change rebuild for libopenmpi1.3 -> libopenmpi1.6 transition.
 -- Logan Rosen <email address hidden>   Mon, 16 Dec 2013 00:07:01 -0500
Superseded in trusty-release on 2013-12-17
Deleted in trusty-proposed on 2013-12-19 (Reason: moved to release)
liggghts (2.3.8-1) unstable; urgency=low


  * [c18713f] Imported Upstream version 2.3.8
  * [8433776] Use wrap-and-sort.

 -- Anton Gladky <email address hidden>  Sun, 10 Nov 2013 20:25:20 +0100

Available diffs

Superseded in trusty-release on 2013-11-11
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
liggghts (2.3.6-1) unstable; urgency=low


  * [e358878] Add debian/watch.
  * [28595e2] Imported Upstream version 2.3.6
  * [a43057c] Ignore quilt dir

 -- Anton Gladky <email address hidden>  Sun, 07 Jul 2013 16:55:39 +0200

Available diffs

Superseded in saucy-release on 2013-07-08
Deleted in saucy-proposed on 2013-07-09 (Reason: moved to release)
liggghts (2.3.2-1) unstable; urgency=low


  * [adf4c2b] Imported Upstream version 2.3.2
  * [8fe04ee] Use cmake for building.
  * [e34c201] Split the package into libliggghts2, liggghts-doc, liggghts2-dbg.

 -- Anton Gladky <email address hidden>  Tue, 07 May 2013 22:47:51 +0200

Available diffs

Superseded in saucy-release on 2013-05-11
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
liggghts (1.5.3-1) unstable; urgency=low


  * [fb49bd6] Imported Upstream version 1.5.3
  * [cbfc470] Fix FTBFS due to gcc-4.7 (missing header).

 -- Anton Gladky <email address hidden>  Wed, 23 May 2012 22:44:20 +0200

Available diffs

Superseded in quantal-release on 2012-05-24
liggghts (1.5.2-3) unstable; urgency=low


  * [b5f1247] Fix wrong defined archs for auto_tests.

 -- Anton Gladky <email address hidden>  Thu, 15 Mar 2012 21:31:29 +0100

Available diffs

Superseded in quantal-release on 2012-05-01
Published in precise-release on 2012-01-09
liggghts (1.5-1) unstable; urgency=low


  * [9529b4b] Install a manpage.
  * [8d5c6d1] Imported Upstream version 1.5

 -- Anton Gladky <email address hidden>  Fri, 02 Dec 2011 21:40:31 +0100
150 of 50 results