lighttpd fails to restart during logrotate script

Bug #59269 reported by Nicholas Brand on 2006-09-06
4
Affects Status Importance Assigned to Milestone
lighttpd (Debian)
Fix Released
Unknown
lighttpd (Ubuntu)
Medium
Unassigned
Dapper
Medium
Lukas Fittl

Bug Description

I have been receiving the following error on an amd64 dapper server running lighttpd 1.4.11-3ubuntu3, the latest available version for dapper in universe:

-----
Cron <root@server> test -x /usr/sbin/anacron || run-parts --report /etc/cron.daily

/etc/cron.daily/logrotate:
invoke-rc.d: initscript lighttpd, action "reload" failed.
error: error running shared postrotate script for /var/log/lighttpd/*.log
run-parts: /etc/cron.daily/logrotate exited with return code 1
-----

Lighttpd stops running at the same time I get this error. Running /etc/init.d/lighttpd start brings it back up. Unfortunately, it does not occur every time logrotate is run. Average occurance is every two weeks, with the longest stretch being a month. Lighttpd is running a simple rails app.

It appears to be related to Debian bug #366366 ( http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=366366 )

Kurt Kraut (kurtkraut) wrote :

Hi,

I'm getting the same error. If I do sudo /etc/init.d/lighttpd restart, it fails. But if I stop it and restart it, it works.

Hampton (hcatlin) wrote :

I can confirm this.

I have had three ubuntu servers have lighttpd die because of this issue. They tend to die every few days... or, unfortunately, faster the more traffic I have.

Lukas Fittl (lfittl) on 2006-11-04
Changed in lighttpd:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
status: Confirmed → Fix Released
importance: Undecided → Medium
status: Unconfirmed → Confirmed
assignee: nobody → lfittl
Lukas Fittl (lfittl) wrote :
Lukas Fittl (lfittl) wrote :
Changed in lighttpd:
status: Confirmed → In Progress
Lukas Fittl (lfittl) wrote :

Bug #68401 will be fixed by this patch as well.

Lukas Fittl (lfittl) on 2006-11-05
Changed in lighttpd:
assignee: lfittl → motu-sru
status: In Progress → Unconfirmed
Reinhard Tartler (siretart) wrote :

please avoid changes to formatting when creating diffs.
+1 for dapper-proposed

Lukas Fittl (lfittl) wrote :

The formatting changes have been done by the Debian maintainers (I just copied the newer script as stated in the changelog), but I can revert the formatting changes if you want.

Daniel T Chen (crimsun) wrote :

+1 for dapper-proposed.

Changed in lighttpd:
status: Unknown → Fix Released
StefanPotyra (sistpoty) wrote :

+1 for dapper-proposed from me as well.

Lukas Fittl (lfittl) wrote :

Uploaded to dapper-proposed, as soon as this is built, please test it if possible.

Changed in lighttpd:
assignee: motu-sru → lfittl
status: Unconfirmed → In Progress
Colin Watson (cjwatson) wrote :

Accepted into dapper-proposed (although, in future, please provide a better description of the change in debian/changelog; a reasonable guideline is to concentrate more on the effects of the change than on the details of how you changed it). Please test, if possible via Simon Law and the QA team.

Kees Cook (kees) wrote :

Before taking to dapper-updates, please respin with security updates. Please see bug 107628 for details.

Kyle McMartin (kyle) wrote :

lighttpd_1.4.11-3ubuntu3.2.dsc accepted into dapper-proposed.

Changed in lighttpd:
status: In Progress → Fix Committed
Jonathan Riddell (jr) wrote :

accepted into dapper-updates

Changed in lighttpd:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.