lintian 2.16.0 source package in Ubuntu

Changelog

lintian (2.16.0) unstable; urgency=medium

  The "post-buster" release.

  * Summary of tag changes:
    + Added:
      - bin-sbin-mismatch
      - command-in-sbin-has-manpage-in-incorrect-section
      - directory-in-etc-sv-directory-without-executable-run-script
      - package-supports-alternative-init-but-no-init.d-script

  [ Chris Lamb ]
  * Add 4.4.0 as a known Standards-Version.
  * Post-buster changes:
    - Reflect the release, updating dates (etc.) of "oldstable" and so on.
    - Bump the recommended debhelper level to 12 (see #918809).
    - Bump the old and ancient version numbers for Python 3 checks (see
      #903399).
    - Drop the deprecated --fail-on-warnings option to help towards fixing
      Debian bug #709932.
    - Upgrade package-uses-vendor-specific-patch-series to "E:" level
      severity (see #904302).
  * Warn about files referencing /usr/bin/foo if the binary is actually
    installed under /usr/sbin/foo. (Closes: #930702)
  * Check that a package that ships a /etc/sv/foo directory then
    /etc/sv/foo/run exists and is executable. (Closes: #931426)
  * Support suppress-tags-from-file in Lintian configuration file.
    (Closes: #930700)
  * Don't emit pkg-js-tools-test-is-missing if the "dh" invocation uses
    variables in its arguments. (Closes: #928283)
  * Fix "mistake||correction" delimiter for a number of entries in
    data/spelling/corrections-case. (Closes: #931446)
  * Disable the duplicate word checker when analysing patch files.
    (Closes: #931183)
  * Override dh_dwz in a binaries-general test to avoid testsuite hanging.
    (Closes: #931632)
  * Don't emit latest-debian-changelog-entry-without-new-version for
    uploads to (eg.) buster-security to avoid false-positives when
    performing "no-change" uploads with a ~debXuY suffix.

  [ Felix Lechner ]
  * Bump the minimum perltidy version required to avoid test failures.
  * Add runtime dependency on liblist-compare-perl.
  * Reduce the complexity of code in Lintian::Unpacker.

  [ Dmitry Bogatov ]
  * Check for commands in /sbin or /usr/sbin with manpages in the
    incorrect section. (Closes: #570998)

  [ Adam D. Barratt ]
  * Lintian::Reporting::Util: Add missing import of Exporter::import.

  [ Axel Beckert ]
  * Fix typo in description of debian-watch-does-not-check-gpg-signature.

 -- Chris Lamb <email address hidden>  Mon, 08 Jul 2019 01:24:09 +0000

Upload details

Uploaded by:
Debian Lintian Maintainers on 2019-07-10
Uploaded to:
Sid
Original maintainer:
Debian Lintian Maintainers
Architectures:
all
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Eoan release on 2019-08-01 main devel

Builds

Eoan: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
lintian_2.16.0.dsc 3.8 KiB f5159f4227abd6348846ed02910ff4d5804759bbb60c45cf631a8f7c86280181
lintian_2.16.0.tar.xz 1.6 MiB 99b993a22cbf3ae5b8f8e647225642b7c494bc8a196d96d4f32c6d2409b6ba85

Available diffs

No changes file available.

Binary packages built by this source

lintian: Debian package checker

 Lintian dissects Debian packages and reports bugs and policy violations. It
 contains automated checks for many aspects of Debian policy as well as some
 checks for common errors.
 .
 This package is useful for all people who want to check Debian packages for
 compliance with Debian policy. Every Debian maintainer should check packages
 with this tool before uploading them to the archive.
 .
 This version of Lintian is calibrated for policy version 4.4.0.