linux-aws 5.4.0-1020.20 source package in Ubuntu

Changelog

linux-aws (5.4.0-1020.20) focal; urgency=medium

  * focal/linux-aws: 5.4.0-1020.20 -proposed tracker (LP: #1887058)

  [ Ubuntu: 5.4.0-42.46 ]

  * focal/linux: 5.4.0-42.46 -proposed tracker (LP: #1887069)
  * linux 4.15.0-109-generic network DoS regression vs -108 (LP: #1886668)
    - SAUCE: Revert "netprio_cgroup: Fix unlimited memory leak of v2 cgroups"

linux-aws (5.4.0-1019.19) focal; urgency=medium

  * focal/linux-aws: 5.4.0-1019.19 -proposed tracker (LP: #1885843)

  [ Ubuntu: 5.4.0-41.45 ]

  * focal/linux: 5.4.0-41.45 -proposed tracker (LP: #1885855)
  * Packaging resync (LP: #1786013)
    - update dkms package versions
  * CVE-2019-19642
    - kernel/relay.c: handle alloc_percpu returning NULL in relay_open
  * CVE-2019-16089
    - SAUCE: nbd_genl_status: null check for nla_nest_start
  * CVE-2020-11935
    - aufs: do not call i_readcount_inc()
  * ip_defrag.sh in net from ubuntu_kernel_selftests failed with 5.0 / 5.3 / 5.4
    kernel (LP: #1826848)
    - selftests: net: ip_defrag: ignore EPERM
  * Update lockdown patches (LP: #1884159)
    - SAUCE: acpi: disallow loading configfs acpi tables when locked down
  * seccomp_bpf fails on powerpc (LP: #1885757)
    - SAUCE: selftests/seccomp: fix ptrace tests on powerpc
  * Introduce the new NVIDIA 418-server and 440-server series, and update the
    current NVIDIA drivers (LP: #1881137)
    - [packaging] add signed modules for the 418-server and the 440-server
      flavours

 -- Khalid Elmously <email address hidden>  Fri, 10 Jul 2020 01:33:58 -0400

Upload details

Uploaded by:
Khaled El Mously on 2020-07-10
Uploaded to:
Focal
Original maintainer:
Ubuntu Kernel Team
Architectures:
all amd64 arm64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Focal: [FULLYBUILT] amd64 [FULLYBUILT] arm64

Downloads

File Size SHA-256 Checksum
linux-aws_5.4.0.orig.tar.gz 162.4 MiB 805f3ed93854317814c59caf2dbfd2097745685f95c8c18b509c9347dcc7d51f
linux-aws_5.4.0-1020.20.diff.gz 5.5 MiB 76e3a009134214bfde3bcd64895ba04942f07ad8ed88089cd288bdacbae844d9
linux-aws_5.4.0-1020.20.dsc 4.1 KiB 68acee7bfc80f6b1e0f792cccfbf3bbb73e869c68ad0f2efff6972905e8054b2

View changes file

Binary packages built by this source

linux-aws-cloud-tools-5.4.0-1020: Linux kernel version specific cloud tools for version 5.4.0-1020

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 5.4.0-1020 on
 ARMv8.
 You probably want to install linux-cloud-tools-5.4.0-1020-<flavour>.

linux-aws-headers-5.4.0-1020: No summary available for linux-aws-headers-5.4.0-1020 in ubuntu groovy.

No description available for linux-aws-headers-5.4.0-1020 in ubuntu groovy.

linux-aws-tools-5.4.0-1020: Linux kernel version specific tools for version 5.4.0-1020

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-1020 on
 ARMv8.
 You probably want to install linux-tools-5.4.0-1020-<flavour>.

linux-buildinfo-5.4.0-1020-aws: Linux kernel buildinfo for version 5.4.0 on ARMv8 SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 ARMv8 SMP.
 .
 You likely do not want to install this package.

linux-cloud-tools-5.4.0-1020-aws: Linux kernel version specific cloud tools for version 5.4.0-1020

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 5.4.0-1020 on
 ARMv8.

linux-headers-5.4.0-1020-aws: Linux kernel headers for version 5.4.0 on ARMv8 SMP

 This package provides kernel header files for version 5.4.0 on
 ARMv8 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-1020/debian.README.gz for details.

linux-image-5.4.0-1020-aws: No summary available for linux-image-5.4.0-1020-aws in ubuntu groovy.

No description available for linux-image-5.4.0-1020-aws in ubuntu groovy.

linux-image-5.4.0-1020-aws-dbgsym: No summary available for linux-image-5.4.0-1020-aws-dbgsym in ubuntu groovy.

No description available for linux-image-5.4.0-1020-aws-dbgsym in ubuntu groovy.

linux-modules-5.4.0-1020-aws: Linux kernel extra modules for version 5.4.0 on ARMv8 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports AWS processors.
 .
 Geared toward Amazon Web Services (AWS) systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-aws meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-5.4.0-1020-aws: No summary available for linux-modules-extra-5.4.0-1020-aws in ubuntu groovy.

No description available for linux-modules-extra-5.4.0-1020-aws in ubuntu groovy.

linux-tools-5.4.0-1020-aws: Linux kernel version specific tools for version 5.4.0-1020

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-1020 on
 ARMv8.