linux-gcp 4.18.0-1003.4 source package in Ubuntu

Changelog

linux-gcp (4.18.0-1003.4) cosmic; urgency=medium

  * linux-gcp: 4.18.0-1003.4 -proposed tracker (LP: #1799452)

  * Shared folders cannot be mounted in ubuntu/cosmic64 due to missing vbox
    modules (LP: #1796647)
    - [Config] gcp: CONFIG_VBOXGUEST=n

  [ Ubuntu: 4.18.0-11.12 ]

  * linux: 4.18.0-11.12 -proposed tracker (LP: #1799445)
  * arm64: snapdragon: WARNING: CPU: 0 PID: 1 arch/arm64/kernel/setup.c:271
    reserve_memblock_reserved_regions (LP: #1797139)
    - SAUCE: arm64: Fix /proc/iomem for reserved but not memory regions
  * arm64: snapdragon: WARNING: CPU: 0 PID: 1 at drivers/irqchip/irq-gic.c:1016
    gic_irq_domain_translate (LP: #1797143)
    - SAUCE: arm64: dts: msm8916: camms: fix gic_irq_domain_translate warnings
  * The front MIC can't work on the Lenovo M715 (LP: #1797292)
    - ALSA: hda/realtek - Fix the problem of the front MIC on the Lenovo M715
  * Provide mode where all vCPUs on a core must be the same VM (LP: #1792957)
    - KVM: PPC: Book3S HV: Provide mode where all vCPUs on a core must be the same
      VM
  * fscache: bad refcounting in fscache_op_complete leads to OOPS (LP: #1797314)
    - SAUCE: fscache: Fix race in decrementing refcount of op->npages
  * hns3: autoneg settings get lost on down/up (LP: #1797654)
    - net: hns3: Fix for information of phydev lost problem when down/up
  * not able to unwind the stack from within __kernel_clock_gettime in the Linux
    vDSO (LP: #1797963)
    - powerpc/vdso: Correct call frame information
  * Signal 7 error when running GPFS tracing in cluster (LP: #1792195)
    - powerpc/mm/books3s: Add new pte bit to mark pte temporarily invalid.
    - powerpc/mm/radix: Only need the Nest MMU workaround for R -> RW transition
  * Support Edge Gateway's WIFI LED (LP: #1798330)
    - SAUCE: mwifiex: Switch WiFi LED state according to the device status
  * Support Edge Gateway's Bluetooth LED (LP: #1798332)
    - SAUCE: Bluetooth: Support for LED on Edge Gateways
  * kvm doesn't work on 36 physical bits systems (LP: #1798427)
    - KVM: x86: fix L1TF's MMIO GFN calculation
  * CVE-2018-15471
    - xen-netback: fix input validation in xenvif_set_hash_mapping()
  * regression in 'ip --family bridge neigh' since linux v4.12 (LP: #1796748)
    - rtnetlink: fix rtnl_fdb_dump() for ndmsg header

  [ Ubuntu: 4.18.0-10.11 ]

  * linux: 4.18.0-10.11 -proposed tracker (LP: #1797379)
  * the machine of lenovo M715 with the AMD GPU (Radeon Vega 8 Mobile, rev ca,
    1002:15dd) often hangs randomly (LP: #1796789)
    - drm/amd: Add missing fields in atom_integrated_system_info_v1_11
  * Miscellaneous Ubuntu changes
    - [Config] CONFIG_VBOXGUEST=n
    - ubuntu: vbox -- update to 5.2.18-dfsg-2
    - ubuntu: enable vbox build

 -- Stefan Bader <email address hidden>  Wed, 24 Oct 2018 15:15:41 +0200

Upload details

Uploaded by:
Stefan Bader on 2018-10-24
Uploaded to:
Cosmic
Original maintainer:
Ubuntu Kernel Team
Architectures:
amd64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Cosmic: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
linux-gcp_4.18.0.orig.tar.gz 149.8 MiB fd5c4f5ab07d6dccf7ef79317e36c2754438fb3d79d750df1d9868bab0de9573
linux-gcp_4.18.0-1003.4.diff.gz 6.8 MiB dba317cc468c73d2f07e77e25098a191bf9cab4b9077a2032424e1aac6421193
linux-gcp_4.18.0-1003.4.dsc 3.5 KiB 5374edc1b06196c0b568c384ca46aa3a3e313855e8a14fb6539c7f46231de5e6

View changes file

Binary packages built by this source

linux-gcp-headers-4.18.0-1003: Header files related to Linux kernel version 4.18.0

 This package provides kernel header files for version 4.18.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-gcp-headers-4.18.0-1003/debian.README.gz for details

linux-gcp-tools-4.18.0-1003: No summary available for linux-gcp-tools-4.18.0-1003 in ubuntu disco.

No description available for linux-gcp-tools-4.18.0-1003 in ubuntu disco.

linux-gcp-tools-4.18.0-1003-dbgsym: No summary available for linux-gcp-tools-4.18.0-1003-dbgsym in ubuntu disco.

No description available for linux-gcp-tools-4.18.0-1003-dbgsym in ubuntu disco.

linux-headers-4.18.0-1003-gcp: Linux kernel headers for version 4.18.0 on 64 bit x86 SMP

 This package provides kernel header files for version 4.18.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.18.0-1003/debian.README.gz for details.

linux-image-unsigned-4.18.0-1003-gcp: No summary available for linux-image-unsigned-4.18.0-1003-gcp in ubuntu disco.

No description available for linux-image-unsigned-4.18.0-1003-gcp in ubuntu disco.

linux-image-unsigned-4.18.0-1003-gcp-dbgsym: No summary available for linux-image-unsigned-4.18.0-1003-gcp-dbgsym in ubuntu disco.

No description available for linux-image-unsigned-4.18.0-1003-gcp-dbgsym in ubuntu disco.

linux-modules-4.18.0-1003-gcp: Linux kernel extra modules for version 4.18.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-4.18.0-1003-gcp: Linux kernel extra modules for version 4.18.0 on 64 bit x86 SMP

 This package contains the Linux kernel extra modules for version 4.18.0 on
 64 bit x86 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-tools-4.18.0-1003-gcp: Linux kernel version specific tools for version 4.18.0-1003

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-1003 on
 64 bit x86.