linux-gcp 5.15.0-1008.12 source package in Ubuntu

Changelog

linux-gcp (5.15.0-1008.12) jammy; urgency=medium

  [ Ubuntu: 5.15.0-37.39 ]

  * netfilter newset OOB write (LP: #1976363)
    - netfilter: nf_tables: sanitize nft_set_desc_concat_parse()
  * CVE-2022-1966
    - netfilter: nf_tables: disallow non-stateful expression in sets earlier

 -- Thadeu Lima de Souza Cascardo <email address hidden>  Wed, 01 Jun 2022 15:57:41 -0300

Upload details

Uploaded by:
Thadeu Lima de Souza Cascardo
Uploaded to:
Jammy
Original maintainer:
Ubuntu Kernel Team
Architectures:
amd64 arm64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Jammy: [FULLYBUILT] amd64 [FULLYBUILT] arm64

Downloads

File Size SHA-256 Checksum
linux-gcp_5.15.0.orig.tar.gz 185.9 MiB 4d7908da75ad50a70a0141721e259c2589b7bdcc317f7bd885b80c2ffa689211
linux-gcp_5.15.0-1008.12.diff.gz 7.6 MiB b354a7c54b583c5529da4c08904eb771ad0d8b409d16c39c602ab581e32b48d6
linux-gcp_5.15.0-1008.12.dsc 3.7 KiB 8af64b9b6da1f7aebf9c17ff35a7ce9946d5ec38cc8c747d2aecb98aea01b1c1

View changes file

Binary packages built by this source

linux-buildinfo-5.15.0-1008-gcp: Linux kernel buildinfo for version 5.15.0 on ARMv8 SMP

 This package contains the Linux kernel buildinfo for version 5.15.0 on
 ARMv8 SMP.
 .
 You likely do not want to install this package.

linux-gcp-headers-5.15.0-1008: Header files related to Linux kernel version 5.15.0

 This package provides kernel header files for version 5.15.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-gcp-headers-5.15.0-1008/debian.README.gz for details

linux-gcp-tools-5.15.0-1008: Linux kernel version specific tools for version 5.15.0-1008

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.15.0-1008 on
 ARMv8.
 You probably want to install linux-tools-5.15.0-1008-<flavour>.

linux-headers-5.15.0-1008-gcp: Linux kernel headers for version 5.15.0 on ARMv8 SMP

 This package provides kernel header files for version 5.15.0 on
 ARMv8 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.15.0-1008/debian.README.gz for details.

linux-image-unsigned-5.15.0-1008-gcp: Linux kernel image for version 5.15.0 on ARMv8 SMP

 This package contains the unsigned Linux kernel image for version 5.15.0 on
 ARMv8 SMP.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-5.15.0-1008-gcp-dbgsym: Linux kernel debug image for version 5.15.0 on ARMv8 SMP

 This package provides the unsigned kernel debug image for version 5.15.0 on
 ARMv8 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-modules-5.15.0-1008-gcp: Linux kernel extra modules for version 5.15.0 on ARMv8 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-5.15.0-1008-gcp: Linux kernel extra modules for version 5.15.0 on ARMv8 SMP

 This package contains the Linux kernel extra modules for version 5.15.0 on
 ARMv8 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-tools-5.15.0-1008-gcp: Linux kernel version specific tools for version 5.15.0-1008

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.15.0-1008 on
 ARMv8.