linux-gcp 5.4.0-1055.59 source package in Ubuntu

Changelog

linux-gcp (5.4.0-1055.59) focal; urgency=medium

  * focal/linux-gcp: 5.4.0-1055.59 -proposed tracker (LP: #1947072)

  * NVME errors in confidential vms (LP: #1943902)
    - swiotlb: remove the tbl_dma_addr argument to swiotlb_tbl_map_single
    - driver core: add a min_align_mask field to struct device_dma_parameters
    - swiotlb: add a IO_TLB_SIZE define
    - swiotlb: factor out an io_tlb_offset helper
    - swiotlb: factor out a nr_slots helper
    - swiotlb: clean up swiotlb_tbl_unmap_single
    - swiotlb: refactor swiotlb_tbl_map_single
    - swiotlb: don't modify orig_addr in swiotlb_tbl_sync_single
    - swiotlb: respect min_align_mask
    - nvme-pci: set min_align_mask
    - swiotlb: move orig addr and size validation into swiotlb_bounce
    - swiotlb: Fix the type of index
    - swiotlb: manipulate orig_addr when tlb_addr has offset

 -- Khalid Elmously <email address hidden>  Wed, 13 Oct 2021 23:25:16 -0400

Upload details

Uploaded by:
Khaled El Mously
Uploaded to:
Focal
Original maintainer:
Ubuntu Kernel Team
Architectures:
amd64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Focal: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
linux-gcp_5.4.0.orig.tar.gz 162.4 MiB 805f3ed93854317814c59caf2dbfd2097745685f95c8c18b509c9347dcc7d51f
linux-gcp_5.4.0-1055.59.diff.gz 9.2 MiB 4094ba81803b6aa3f1dc39cb320613cdade573ef1c39b92ddf854b57d447435c
linux-gcp_5.4.0-1055.59.dsc 3.7 KiB 8b7b89279330099d45fdcfbab26995fb106cbf7631fea46d57994f24954e3479

View changes file

Binary packages built by this source

linux-buildinfo-5.4.0-1055-gcp: Linux kernel buildinfo for version 5.4.0 on 64 bit x86 SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 64 bit x86 SMP.
 .
 You likely do not want to install this package.

linux-gcp-headers-5.4.0-1055: Header files related to Linux kernel version 5.4.0

 This package provides kernel header files for version 5.4.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-gcp-headers-5.4.0-1055/debian.README.gz for details

linux-gcp-tools-5.4.0-1055: Linux kernel version specific tools for version 5.4.0-1055

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-1055 on
 64 bit x86.
 You probably want to install linux-tools-5.4.0-1055-<flavour>.

linux-headers-5.4.0-1055-gcp: Linux kernel headers for version 5.4.0 on 64 bit x86 SMP

 This package provides kernel header files for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-1055/debian.README.gz for details.

linux-image-unsigned-5.4.0-1055-gcp: Linux kernel image for version 5.4.0 on 64 bit x86 SMP

 This package contains the unsigned Linux kernel image for version 5.4.0 on
 64 bit x86 SMP.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-5.4.0-1055-gcp-dbgsym: Linux kernel debug image for version 5.4.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-modules-5.4.0-1055-gcp: Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-5.4.0-1055-gcp: Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP

 This package contains the Linux kernel extra modules for version 5.4.0 on
 64 bit x86 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 processors.
 .
 Geared toward GCP/GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gcp meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-tools-5.4.0-1055-gcp: Linux kernel version specific tools for version 5.4.0-1055

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-1055 on
 64 bit x86.