linux-gke-5.4 5.4.0-1074.79~18.04.1 source package in Ubuntu

Changelog

linux-gke-5.4 (5.4.0-1074.79~18.04.1) bionic; urgency=medium

  [ Ubuntu: 5.4.0-1074.79 ]

  * CVE-2022-1966
    - netfilter: nf_tables: add nft_set_elem_expr_alloc()
    - netfilter: nf_tables: disallow non-stateful expression in sets earlier

 -- Thadeu Lima de Souza Cascardo <email address hidden>  Fri, 03 Jun 2022 14:01:56 -0300

Upload details

Uploaded by:
Thadeu Lima de Souza Cascardo
Uploaded to:
Bionic
Original maintainer:
Ubuntu Kernel Team
Architectures:
amd64 arm64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Bionic: [FULLYBUILT] amd64 [FULLYBUILT] arm64

Downloads

File Size SHA-256 Checksum
linux-gke-5.4_5.4.0.orig.tar.gz 162.4 MiB 805f3ed93854317814c59caf2dbfd2097745685f95c8c18b509c9347dcc7d51f
linux-gke-5.4_5.4.0-1074.79~18.04.1.diff.gz 11.3 MiB 896071bf4b44f95a22fa02958a1423306dcaeb25441367fec7abbd11914684eb
linux-gke-5.4_5.4.0-1074.79~18.04.1.dsc 3.6 KiB 6bdfd90c0697c50dcc8188afcfbab2c29b0449fc74022eb297e761b5ca1e2516

View changes file

Binary packages built by this source

linux-buildinfo-5.4.0-1074-gke: Linux kernel buildinfo for version 5.4.0 on ARMv8 SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 ARMv8 SMP.
 .
 You likely do not want to install this package.

linux-gke-5.4-headers-5.4.0-1074: Header files related to Linux kernel version 5.4.0

 This package provides kernel header files for version 5.4.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-gke-5.4-headers-5.4.0-1074/debian.README.gz for details

linux-gke-5.4-tools-5.4.0-1074: Linux kernel version specific tools for version 5.4.0-1074

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-1074 on
 ARMv8.
 You probably want to install linux-tools-5.4.0-1074-<flavour>.

linux-headers-5.4.0-1074-gke: Linux kernel headers for version 5.4.0 on ARMv8 SMP

 This package provides kernel header files for version 5.4.0 on
 ARMv8 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-1074/debian.README.gz for details.

linux-image-unsigned-5.4.0-1074-gke: Linux kernel image for version 5.4.0 on ARMv8 SMP

 This package contains the unsigned Linux kernel image for version 5.4.0 on
 ARMv8 SMP.
 .
 Supports amd64 arm64 processors.
 .
 Geared toward GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gke meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-5.4.0-1074-gke-dbgsym: Linux kernel debug image for version 5.4.0 on ARMv8 SMP

 This package provides the unsigned kernel debug image for version 5.4.0 on
 ARMv8 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-modules-5.4.0-1074-gke: Linux kernel extra modules for version 5.4.0 on ARMv8 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 arm64 processors.
 .
 Geared toward GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gke meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-5.4.0-1074-gke: Linux kernel extra modules for version 5.4.0 on ARMv8 SMP

 This package contains the Linux kernel extra modules for version 5.4.0 on
 ARMv8 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports amd64 arm64 processors.
 .
 Geared toward GKE systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-gke meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-tools-5.4.0-1074-gke: Linux kernel version specific tools for version 5.4.0-1074

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-1074 on
 ARMv8.