in ntfsprogs symlink /sbin/mount.ntfs-fuse points to incorrect location

Bug #29865 reported by Mantas Kriaučiūnas on 2006-01-27
10
Affects Status Importance Assigned to Milestone
Baltix
High
Mantas Kriaučiūnas
linux-ntfs (Ubuntu)
Medium
Unassigned

Bug Description

in ntfsprogs package symlink /sbin/mount.ntfs-fuse points to incorrect location - /usr/sbin/ntfsmount, but ntfsmount file is in /usr/bin, not /usr/sbin.

Please fix this bug before Ubuntu 6.04 (dapper) will be released.

Btw, what you think about making read-write ntfs mount (filesystem type ntfs-fuse) as default in Ubuntu 6.04 ? It seems this is not diffucult:

mounting via fstab (in 1.12.1 and later)

If you are using ntfsprogs-1.12.1 or later, you only need to place something like this in /etc/fstab:

/dev/hda1 /mnt/c ntfs-fuse fmask=0111,dmask=0,succeed_chmod 0 0

(look at http://wiki.linux-ntfs.org/doku.php?id=ntfsmount )

Majority desktop computers have Windows 2000/XP with NTFS filesystem and now there is sort of interoperability problems with data on Windows partitions, because users can put/change or remove any data on these partitions. Should I report another bug about this ?

Mantas Kriaučiūnas (mantas) wrote :

NTFS write support should be implemented in Baltix 1.2 beta2 or release candidate.
I've heared, that Mandriva has NTFS write support, it would be wise to look at theyr implementation, do they use ntfs-fuse filesystem type in fstab or not.

David Jaša (dejv) wrote :

Fix is so simple (just changing one symlink) so it should be done ASAP...

Changed in linux-ntfs:
status: Unconfirmed → Confirmed
Dennis Kaarsemaker (dennis) wrote :

The developers determine their priorities...

LKRaider (paul-eipper) wrote :

Why there's no correction for this bug as of yet?!

> Why there's no correction for this bug as of yet?!

Because there are numerous more important bugs perhaps?

Someone please apply and upload

Barry deFreese (bddebian) wrote :

Sorry, this one is in main, I can't touch it.

There is a new upstream ntfsprogs version (1.13.0) available since 2006-02-27.

Release Notes (for full changelog look at http://sourceforge.net/project/shownotes.php?release_id=397070&group_id=13956 )
"The long awaited release. Lots of enhancements and fixes across the board.
See the changelog for details but a few notable changes are that mkntfs now creates NTFS 3.1 (Windows XP) volumes by default and that ntfsmount can deal with symbolic links and device files."

It seems you forgot to package ntfsprogs 1.13.0, so now you can move directly to 1.13.1 - it was released on 2006 June 16, look at

http://sourceforge.net/project/shownotes.php?release_id=426474&group_id=13956

Notes:
Time for another release. Many bug fixes and enhancements so update is strongly recommended.

Some important changes:
- Fix bug with renaming directories with names in DOS and WIN32 namespaces. (Yura)

Barry deFreese (bddebian) wrote :

This was fixed in the Edgy release.

Changed in linux-ntfs:
status: Confirmed → Fix Released
Przemek K. (azrael) on 2009-11-13
Changed in baltix:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints